09:00:03 <anteaya> #startmeeting nova-net-to-neutron-migration
09:00:04 <openstack> Meeting started Tue Feb 24 09:00:03 2015 UTC and is due to finish in 60 minutes.  The chair is anteaya. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:07 <openstack> The meeting name has been set to 'nova_net_to_neutron_migration'
09:00:12 <anteaya> hello folks
09:00:13 <mikal> Hi
09:00:14 <obondarev> o/
09:00:27 <anteaya> hey mikal obondarev
09:00:43 <anteaya> gus jlibosva ping
09:00:48 <anteaya> belmoreira: hello
09:00:48 <jlibosva> hi
09:00:51 <gus> hi
09:00:56 <anteaya> great
09:01:16 <anteaya> our agenda: https://wiki.openstack.org/wiki/Meetings/Nova-nettoNeutronMigration
09:01:39 <anteaya> let's get started
09:01:43 <anteaya> #topic the state of the Neutron spec (obondarev)
09:01:58 <obondarev> ok, this one will be short :)
09:01:58 <anteaya> I don't think anything has changed here from last week
09:02:01 <anteaya> :)
09:02:03 <obondarev> as there are no updates on the spec this week
09:02:07 <anteaya> great
09:02:23 <anteaya> anyone have anything on the spec?
09:02:38 <gus> nothing this week.
09:02:46 <anteaya> wonderful
09:02:48 <anteaya> next
09:02:52 <anteaya> #topic the state of implementation (obondarev)
09:03:06 <obondarev> ok
09:03:12 <obondarev> I saw new patchset on db migration from Jacub
09:03:20 <obondarev> didn't have a chance to review yet
09:03:27 <obondarev> jlibosva: can you please give an update?
09:03:30 <anteaya> #link https://review.openstack.org/#/c/148260/
09:03:47 <jlibosva> yep
09:04:01 <jlibosva> so I tested the simplest case of migrating flat network
09:04:11 <jlibosva> realized that flat manager doesn't support floating ips
09:04:24 <anteaya> is the patch in a state of non-crashing now?
09:04:28 <jlibosva> no
09:04:34 <anteaya> ah
09:04:39 <jlibosva> Should be able to migrate flat network
09:05:03 <jlibosva> I obtained a dataset from real nnet deployment with vlans
09:05:17 <jlibosva> so I'm gonna do some test/debugging for vlan managers
09:05:34 <anteaya> sorry I'm going to ask a stupid question
09:05:40 * anteaya displays her ignorance
09:05:47 <anteaya> is vlan a flat manager?
09:05:48 <obondarev> jlibosva: can you please add some test instructions to the patch (in a comment)
09:06:00 <jlibosva> obondarev: yeah, that would be good idea
09:06:05 <jlibosva> anteaya: vlan is a type of manager
09:06:10 <jlibosva> there are three in nova net
09:06:10 <anteaya> okay
09:06:13 <jlibosva> flat, flatdhcp and vlan
09:06:18 <anteaya> ah ha
09:06:27 <anteaya> okay so no vlan is not a flat manager
09:06:40 <anteaya> so how do we solve the flat manager situation
09:06:40 <jlibosva> right
09:06:53 <anteaya> as that is the simplest, yes?
09:06:56 <jlibosva> flat manager is the simplest case
09:07:00 <jlibosva> right
09:07:10 <jlibosva> so I'm not sure if anyone is really using this type of manager
09:07:17 <anteaya> so it sounds like we have solved that yet
09:07:21 <jlibosva> anyway this should be covered by script nowadays
09:07:23 <anteaya> haven't
09:07:24 <mikal> I would think its used in some private clouds
09:07:40 <anteaya> if it is the simplest to solve, let's solve it
09:07:49 <anteaya> so what do we need to solve it?
09:08:10 <jlibosva> well, as I said. I did some tests and it migrates successfully
09:08:19 <anteaya> oh I thought you said it didn't
09:08:22 <mikal> anteaya: this might be helpful by the way -- http://docs.openstack.org/admin-guide-cloud/content/section_networking-options.html
09:08:32 <jlibosva> did I? maybe typo
09:08:40 <anteaya> also how did it migrate, as you said the patch still crashes
09:08:43 <anteaya> mikal: thanks :)
09:09:10 <jlibosva> anyway, I except to break it once I start implementing the other two :) as we don't have any testing yet
09:09:26 <jlibosva> anteaya: aaah, sorry
09:09:28 <anteaya> we seem to hoping all over the place
09:09:33 <jlibosva> my bad, I read "is patch crashing?"
09:09:35 <anteaya> does this patchset cause a crash
09:09:41 <jlibosva> so no, the patch is not crashing
09:09:41 <anteaya> is the patch crashing?
09:09:47 <anteaya> okay thank you
09:09:52 <jlibosva> my apologies
09:10:02 <anteaya> and you have tested this patchset in a flat network migration?
09:10:09 <jlibosva> right, very small one
09:10:30 <anteaya> can you post any kind of artifact for others to see that it worked?
09:11:14 <obondarev> I think test instructions should be fine
09:11:17 <jlibosva> yes, I can push some results somewhere, maybe gist
09:11:26 <anteaya> jlibosva: that will do
09:11:33 <anteaya> just for someone else to take a look
09:11:50 <anteaya> and have you been in contact with spadhe?
09:11:59 <anteaya> has she had a chance to test your patch?
09:12:24 <jlibosva> no, I haven't reached her last week
09:12:33 <anteaya> can you try this week?
09:12:53 <anteaya> and you are away for a month starting the end of this week, yes/
09:12:53 <jlibosva> anteaya: do you have her email address?
09:13:03 <anteaya> I don't know, I will check
09:13:08 <jlibosva> maybe email correspondence will be more sufficient as we have 8 hrs TZ difference
09:13:12 <jlibosva> or 9
09:13:29 <jlibosva> right, I'll be gone since Friday till April
09:13:36 <anteaya> no, I don't, do you mikal she was at the nova meetup
09:14:01 <anteaya> okay so let's get this patchset in a state that it can be tested with flat networks for the month of march
09:14:20 <anteaya> so post some artifacts and any tests you can come up with
09:14:26 <jlibosva> will do
09:14:36 <anteaya> and then after you return we can work on getting it working with vlan
09:14:38 <anteaya> is that fair?
09:15:02 <mikal> anteaya: sorry, who are we after?
09:15:10 <jlibosva> ok, I was already working on vlan so I'll see what's missing after tests today. I got the dataset yesterday evening
09:15:16 <jlibosva> mikal: spandhe
09:15:16 <anteaya> mikal a yahoo dev named spadhe
09:15:18 <mikal> anteaya: do you know her real name, I can look her up
09:15:35 <anteaya> gus: do you still have a link to her github account?
09:15:51 <gus> (looking ..)
09:16:08 <anteaya> jlibosva: okay that is fine, I just want to make sure we are in a state where we can do something such as test while you are away
09:16:18 <jlibosva> I see
09:16:21 <mikal> No one by that name registered for the mid-cycle...
09:16:47 <anteaya> mikal: hmmm, I saw her there, shame she didn't register
09:16:54 <jlibosva> maybe https://launchpad.net/~shraddha-pandhe ?
09:17:01 <mikal> Oh wait, the eventbrite UI defeated me
09:17:02 <mikal> Please hold
09:17:08 <anteaya> jlibosva: I think that was it
09:17:17 * anteaya imagines hold music
09:17:34 <anteaya> okay so hoping to test the db migration while jlibosva is away
09:17:43 <anteaya> any more on the db migration patch?
09:17:43 <mikal> Nup, no one by that name
09:18:04 <anteaya> mikal: thanks for looking, markmcclain knows her so maybe he can help find her email
09:18:11 <anteaya> jlibosva: can you ask him?
09:18:24 <anteaya> so let's move onto obondarev's patch
09:18:25 <mikal> Yeah, we could also ask Mel Witt if she knows this person
09:18:31 <anteaya> that too
09:18:34 <obondarev> ok, moving to nova-net proxy
09:18:44 <jlibosva> anteaya: ack
09:18:47 <anteaya> #link https://review.openstack.org/#/c/150490/
09:18:50 <anteaya> jlibosva: thanks
09:18:56 <obondarev> we had an irc conversation with dansmith on it
09:19:11 <obondarev> I think we agreed that it won't be simpler and less messy to proxy at API level
09:19:22 <anteaya> was taht in the nova channel or neutron?
09:19:24 <obondarev> so his words were "I don't have any other suggestions other than "don't do it at all""
09:19:30 <anteaya> I could find the logs for it
09:19:31 <obondarev> anteaya: nova channel
09:19:39 <anteaya> thanks I'll look again
09:19:55 <anteaya> obondarev: don't do what at all, migrate?
09:20:09 <obondarev> anteaya: proxy
09:20:20 <obondarev> I guess he still has concerns regarding more complex cases with the approach I'm advocating
09:20:20 <anteaya> so if we don't proxy, what do we do?
09:20:39 <anteaya> and what day did this conversation take place?
09:20:39 <gus> Aha, found it (that took a while):
09:20:42 <gus> #link https://github.com/shraddha-pandhe/Tools/tree/master/NovaNetToNeutronMigration
09:20:51 <anteaya> gus: awesome thank you
09:21:04 <obondarev> anteaya: let me check..
09:21:11 <anteaya> obondarev: thanks
09:21:42 <anteaya> because I talked to dan at the nova meeting last week, so I am just trying to figure out who has the most recent information
09:22:05 <obondarev> anteaya: it was after out conversation
09:22:11 <obondarev> anteaya: I mean nova meeteng
09:22:16 <anteaya> oh okay
09:22:19 <obondarev> anteaya: I read the logs
09:22:24 <anteaya> well do finish your thought then
09:22:34 <anteaya> what do you want to do now?
09:22:35 <obondarev> anteaya: probably the day before nova meeting
09:22:40 <anteaya> okay thanks
09:22:48 <obondarev> and I'm working on allocate_for_instance case now
09:22:53 <obondarev> I think this is complex enough to serve some kind of proof
09:23:06 <obondarev> that the approach is working
09:23:10 <anteaya> when might you have something to offer to gerrit?
09:23:18 <obondarev> I'm going to get it ready this week
09:23:35 <obondarev> I'm sure I'll have much fun with testing :)
09:23:35 <jlibosva> obondarev: I think allocate_for_instance is being refactored, are you aware of that?
09:23:45 <anteaya> at the nova meeting, I learned you had talked to dan (thank you for that) and that dan said you were going to offer something this week
09:23:57 <obondarev> jlibosva: when did that happen?
09:24:00 <anteaya> which is great, so we agreed to look at what you offered and go from there
09:24:25 <jlibosva> obondarev: not sure, I talked with Brent ~2weeks ago and he said he was working on some refactoring
09:24:39 <jlibosva> maybe it will worth to sync with him
09:24:47 <obondarev> jlibosva: thanks for the info, will look
09:25:03 <anteaya> obondarev: might you have something by the end of today to look at on gerrit?
09:25:26 <obondarev> anteaya: I think no
09:25:49 <anteaya> we are slowing down in momentum, which is understandable since we are in k-3 and core reviewers are tied up with reviews on things that will get into this release
09:25:50 <obondarev> as it will be part of work, no real value to look and try it
09:26:03 <anteaya> well except to get feedback
09:26:18 <anteaya> if you want to continue on this route that is fine
09:26:37 <anteaya> just keep in mind that we soon need to make a decision if this is going to get into kilo or not
09:26:47 <anteaya> for other people to make decisions on things
09:26:57 <obondarev> anteaya: understood
09:27:05 <obondarev> I'm also going to try Jacub's patch as well as part of testing
09:27:07 <anteaya> right now it feels to me that it won't and we should just say so and focus on L
09:27:12 <anteaya> obondarev: good idea
09:27:22 <anteaya> are we ready as a group to say refocus on L?
09:27:46 <anteaya> it won't change what we are doing, we just need to communicate to others that care
09:27:47 <jlibosva> +1 for L
09:28:00 <obondarev> given that even db migration and proxy is only half of work I guess we can say so
09:28:13 <anteaya> gus: your thoughts?
09:28:55 <anteaya> he got pulled away
09:29:05 <anteaya> okay let's wait for him
09:29:07 <gus> agree with the above - it will be too much of a stretch to make it into K
09:29:13 <anteaya> okay L it is
09:29:25 <anteaya> mikal: you can help communicate that agreement?
09:29:36 <anteaya> #agreed we will refocus on L release
09:29:37 <mikal> Sure
09:29:40 <anteaya> thanks
09:29:47 <mikal> We can put that on the agenda for the next nova meeting
09:29:57 <anteaya> okay so obondarev when do you think you might have something to look at?
09:30:01 <anteaya> mikal: thanks
09:30:21 <obondarev> anteaya: by the next nova meeting?
09:30:40 <anteaya> obondarev: it would be nice to have something up prior to that
09:30:49 <obondarev> anteaya: sorry, when will it be?
09:30:53 <anteaya> so folks have had a chance to review before the meeting
09:31:05 <anteaya> thursday at 2100 I think
09:31:12 <anteaya> the later of the two times
09:31:18 <mikal> For nova, yeah
09:31:23 <mikal> Its the later version this week
09:32:09 <obondarev> anteaya: ok, I'll update patch by thursday
09:32:16 <anteaya> so obondarev please put something up as soon as you are able, so folks can look at it
09:32:19 <anteaya> okay thank you
09:32:26 <anteaya> anything more on implementation?
09:32:39 <obondarev> not from my side
09:32:51 <anteaya> okay next
09:32:57 <anteaya> #topic documentation (emagana)
09:33:08 <anteaya> edgar won't ever make the meetings
09:33:22 <anteaya> I'm still looking for a docs person to help edgar who will attend meetings
09:33:26 <anteaya> in the mean time
09:33:37 <anteaya> the doc patch that edgar has been working on
09:33:47 <anteaya> #link https://review.openstack.org/#/c/155947
09:33:52 <anteaya> has been put on hold
09:34:02 <anteaya> docs team is moving from xml to rst
09:34:19 <anteaya> and wonders if the patch has any use before the guide is published
09:34:41 <obondarev> and at least the spec is not finished yet
09:34:43 <anteaya> my main request was to have something for sdague to take to the ops mid-cycle
09:34:49 <obondarev> which I guess is a blocker as well
09:35:00 <anteaya> but he feels that he can use the spec which has been published so far
09:35:32 <anteaya> I do need to find out from edgar what the timing is on the guide publication
09:35:49 <anteaya> the migration section may not make it into the k release of the guide
09:35:58 <anteaya> which is fine since the migration code won't
09:36:10 <anteaya> so for now work on that patch is on hold
09:36:16 <anteaya> any questions or thoughts?
09:36:42 <anteaya> next topic
09:36:54 <anteaya> #topic testing
09:37:07 <anteaya> so we don't really have anything for this section
09:37:28 <anteaya> and that is okay
09:37:47 <anteaya> so we will work on getting folks to test jlibosva's patch with flat network managers
09:37:50 <obondarev> anteaya: but we now have db migration for flat to test ;)
09:37:57 <anteaya> anything else we have ready to test
09:38:01 <anteaya> obondarev: yes!
09:38:27 <anteaya> anything more for testing?
09:38:40 <anteaya> #topic Open Discussion
09:38:49 <anteaya> anyone have anything here?
09:39:02 <anteaya> okay
09:39:03 <jlibosva> nope
09:39:14 <anteaya> well thanks everyone for your attendance and participation
09:39:19 <anteaya> have a good holiday jlibosva
09:39:22 <jlibosva> thanks :)
09:39:25 <anteaya> see you when you return
09:39:33 <anteaya> see everyone else next week
09:39:33 <obondarev> thanks everyone
09:39:35 <anteaya> thank you
09:39:39 <anteaya> #endmeeting