17:00:34 <gibi_> #startmeeting nova notification
17:00:34 <openstack> Meeting started Tue Jul 12 17:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is gibi_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'nova_notification'
17:00:42 <gibi_> o/
17:01:27 * gibi_ double checks the date-time-room trio
17:01:29 <macsz> Hello
17:01:34 <rlrossit_> o/
17:01:35 <gibi_> macsz: hi!
17:01:42 * rlrossit_ had his internet cut out at 11:59
17:01:57 <gibi_> rlrossit_: lunchtime again? :)
17:02:08 <pumaranikar> hello
17:02:11 <rlrossit_> yeah, but I'm at home today, so no idea why that decided to cut out
17:02:35 <rlrossit_> just wonderful internet here in the US
17:02:39 <gibi_> :)
17:02:47 <gibi_> let's get started\
17:02:51 <gibi_> #topic outstanding reviews
17:03:05 <gibi_> so, things I know about
17:03:29 <gibi_> transformation patches that has +2 before the deadline got ffe
17:03:39 <gibi_> everythin is merged except
17:03:53 <gibi_> https://review.openstack.org/#/c/331972/
17:03:57 <gibi_> Transform instance.restore notifications
17:04:14 <gibi_> I had to press rebase on it again
17:04:27 <gibi_> I will push it through today / tomorrow
17:04:49 <gibi_> I think everybody did very good job with the transformation
17:05:11 <gibi_> all the still open once needs to be resurrected on Ocata base
17:05:19 <gibi_> s/once/ones/
17:05:32 <syjulian> What should be done to the ones with -2?
17:05:43 <gibi_> syjulian: those needs to wait until Ocata
17:06:02 <rlrossit_> those are just procedural -2's, not "this is a very bad thing" -2
17:06:04 <gibi_> as soon as master is open to Ocata you need a rebase and you have to ask the core to remove -2
17:06:15 <macsz> Can we create bp for ocata now?
17:06:26 <macsz> Or do we have to wait
17:06:44 <rlrossit_> I think you can open a bp whenever you want, though approval will probably wait until Ocata
17:06:53 <gibi_> rlrossit_: +!
17:06:55 <gibi_> rlrossit_: +1
17:06:56 <rlrossit_> like, no one will look at it until then
17:07:50 <gibi_> we have some follow up patches
17:08:12 <gibi_> rlrossit_ refactors the enum values
17:08:22 <gibi_> syjulian fixes some security issues
17:08:52 * rlrossit_ forgot he had that patch open
17:08:53 <gibi_> I had not time to start one until now, but will try harder
17:10:05 <gibi_> the basic patches of the json schema generation is merged in ovo
17:10:27 <gibi_> I think the next step there is to add schemam to the complex fields like ObjectField ListOf...Field
17:10:47 <gibi_> we need them as they are used in the payload classes
17:11:02 <gibi_> syjulian: are you planning to continue on this track?
17:11:21 <syjulian> Yes
17:11:28 <gibi_> syjulian: great, thanks
17:11:53 <syjulian> I also saw a follow up on the nova side
17:12:16 <gibi_> syjulian: which one?
17:12:33 <syjulian> "after the json schema patch is merged in ovo and a new ovo lib version is released we can add a tool to nova generate the json schemas for the versioned notifications"
17:12:38 <syjulian> this was on the wiki
17:12:53 <gibi_> syjulian: yeah, that is basically depends on the complex fields I mentione above
17:13:05 <syjulian> ah ok
17:13:48 <gibi_> these was the patches I'm aware of
17:14:11 <rlrossit_> though that tool won't get in until O
17:14:58 <rlrossit_> (but you can still work on it now)
17:15:04 <gibi_> rlrossit_: true, will state that on the wiki
17:16:17 <gibi_> anything else that is open and needs discussion?
17:17:09 <syjulian> can i get clarification on one of the follow up items?
17:17:32 <syjulian> this one "refactor the sample test to avoid booting a new instance for every sample test."
17:18:17 <gibi_> syjulian: sure. there was a suggestion in one of the merged review that now every sample action test boots up a new instance, execute the action, assert the notificatin
17:18:31 <gibi_> and this many instance boot might take time
17:18:45 <gibi_> I haven't timed the test yet to see how much time we are talking about
17:19:04 <gibi_> if it is significant then we can rearrange the tests to reuse a singel instance
17:20:31 <gibi_> we have ~40 instance actions all together
17:21:37 <gibi_> so if the boot an instance boot is under a sec in the test then it only adds a minute to the whole suite, I guess if it adds more than a minute that is a problem
17:22:25 <syjulian> oh ok. so the first thing is to find out the time increase
17:22:37 <gibi_> yes, that is the first step
17:24:25 <gibi_> anything else?
17:25:29 <gibi_> OK then
17:25:33 <gibi_> #topic open discussion
17:26:00 <gibi_> I have one question.
17:26:26 <gibi_> Do you want to decrease the frequency of the meeting to biweekly as it was during Mitaka?
17:26:39 <rlrossit_> +1
17:27:18 <syjulian> i'm good with that
17:28:10 <gibi_> OK, then lets, decrease it
17:28:40 <gibi_> #action: gibi to change the meeting to biweekly
17:29:05 <gibi_> anything else to discuss?
17:31:16 <gibi_> OK, let's close it
17:31:32 <gibi_> thanks for showing up. I will send a mail to the ML with the new meeting schedule
17:31:49 <gibi_> \o
17:31:59 <rlrossit_> \o
17:32:01 <gibi_> #endmeeting