17:00:31 <gibi> #startmeeting nova notification
17:00:32 <openstack> Meeting started Tue Mar 14 17:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:35 <openstack> The meeting name has been set to 'nova_notification'
17:00:41 <gibi> hello1
17:00:46 <mriedem> o/
17:01:46 <gibi> let's wait a minute or two. maybe others will show up
17:02:59 <gibi> I guess this will be a short one
17:03:21 <gibi> mriedem: do you want to go throgh every items or just discuss the things you are interested in?
17:03:48 <gibi> I don't want to steal your time :)
17:04:28 <mriedem> umm
17:04:33 <mriedem> i didn't have an agenda
17:04:41 <mriedem> so whatever works for you
17:05:01 <gibi> OK then I will raise thing what I think might be interesting
17:05:14 <gibi> so finally I made a draft about the BDM in InstancePayload
17:05:21 <gibi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/113850.html
17:05:33 <gibi> It would be good to get feedback about it
17:05:52 <gibi> aunnam promised to start the implementation when the direction is clear
17:06:09 <mriedem> ok, i saw the email but haven't digested it yet
17:07:10 <gibi> the difference between the two options are the amount of data. do we want to have minimal data or we want to be future proof with the data in the notification
17:07:32 <mriedem> w/o reading the details, i generally think we start small with what we need,
17:07:32 <gibi> at least that is my main dilemma
17:07:35 <mriedem> and add later as necessary
17:07:45 <aunnam> gibi, saw the mail and waiting for reply, thanks for the mail
17:07:56 <mriedem> i tend to avoid future proofing things, because if the future doesn't come to use those things we have technical debt
17:08:09 <gibi> make sense
17:08:34 <gibi> I think the aunnam can put up the implementation with the Option A (minimal data)
17:08:39 <gibi> s/the/then/
17:08:51 <mriedem> ok
17:08:56 <gibi> and we can discuss the details in the code review
17:09:13 <gibi> #agreed BDM in InstancePayload will use minimal data for now
17:09:21 <aunnam> gibi, ok then will start working on that tomorrow
17:09:40 <gibi> aunnam: thanks a lot to pick this up
17:10:39 <gibi> anything else on the searchlight integration we need to discuss?
17:11:11 <mriedem> i haven't gone through the latest comments in the spec since last week,
17:11:14 <mriedem> so nothing from me there
17:11:25 <mriedem> except i'm not sure if anyone is signed up to work on the searchlight side of things
17:11:31 <mriedem> i.e. adding support for versioned notifications
17:11:48 <mriedem> oh also,
17:12:11 <mriedem> macsz expressed interest in helping out with getting the CI pieces together to test nova + searchlight in a dsvm job
17:13:06 <gibi> I will try follow the patches at least giving reviews
17:14:46 <gibi> also I will try to join the searchlight weekly meeting to see If I can help with the versioned notification work in their side
17:14:58 <gibi> s/in/on./
17:15:34 <gibi> mriedem: what happens if it turns out that making searchlight versioned notification compatible does not fit Pike?
17:15:55 <gibi> will nova delay the searchlight integration?
17:16:05 <mriedem> yes i think we'd have to, it's a dependency for that to work
17:16:23 <mriedem> if you're not using searchlight, the nova-api will have to fall back to a merge sort
17:16:51 <mriedem> which will be slow, but that's what we'll have for now, and that's really only for multiple cells which we don't support yet anyway
17:17:08 <gibi> ohh, OK
17:17:18 <mriedem> dan is working on the multi-cell support though
17:17:21 <mriedem> so that should happen in pike
17:17:46 * gibi making notes to follow the whole thing called nova :)
17:18:12 <gibi> anyhow I will try to help on the searchlight side If I can
17:18:29 <gibi> that would give me feedback about the usability of the versioned notification interface anyhoqw
17:18:42 <mriedem> yeah
17:18:56 <gibi> a have only one thing besides searchlight integration for today
17:19:22 <gibi> oslo messaging 5.19 has been released
17:19:39 <gibi> with the improvement about checking if a notifier is enabled
17:19:50 <gibi> so I proposed the depenedncy bump
17:20:01 <gibi> #link https://review.openstack.org/#/c/445452/
17:20:17 <gibi> and I will finish up the nova patch about short circuiting
17:20:41 <mriedem> ok, i'll review the reqs patch
17:20:48 <gibi> thanks
17:21:01 <gibi> I have nothing else important
17:21:05 <gibi> right now
17:21:18 <mriedem> ok, me neither.
17:21:22 <gibi> tomorrow is notional holiday here so I will be out
17:21:32 <mriedem> ok. i've got a pile of todos.
17:21:39 <mriedem> so just ping me when you need me to focus on something
17:21:43 <mriedem> since i'm easily distracted right now
17:21:45 <gibi> mriedem: thank for the help
17:21:50 <gibi> mriedem: I will ping you :)
17:22:05 <gibi> aunnam: do you have anyithing else to discuss?
17:22:08 <mriedem> nope
17:22:22 <aunnam> nothing from my side
17:22:26 <gibi> greate
17:22:33 <gibi> thenk let's close this meeting
17:22:41 <gibi> see you on Thursday
17:22:48 <gibi> #endmeeting