17:00:04 <gibi> #startmeeting nova notification
17:00:05 <openstack> Meeting started Tue Oct 31 17:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <openstack> The meeting name has been set to 'nova_notification'
17:00:15 <mriedem> o/
17:00:18 <gibi> o/
17:00:48 <gibi> I think no need to wait for others. Let's get started
17:01:20 <gibi> You mentioned in one of the transformation patches you +Wd recently that we might need reno about these
17:01:41 <mriedem> i'm pretty sure we did renos in the past
17:01:43 <gibi> I shortly checked and we did not wrote a reno in Pike about the transformed notifications
17:01:47 <gibi> exactly
17:01:52 <mriedem> maybe it was ocata
17:02:10 <gibi> anyhow I can make sure we will have one in Queens
17:02:12 <gibi> at the end
17:02:16 <gibi> summarizing what was done
17:02:19 <mriedem> i don't want one reno per patch, but we could summarize the various changes in queens into a single release note at the end (if we remember), or start one now and amend it per patch
17:02:35 <gibi> I can start that patch
17:02:43 <gibi> keeping it open makes sense
17:03:05 <gibi> #action gibi start a notification transformation reno patch for Queens
17:03:50 <gibi> other notification related features was handled with separate reno in the past so we keep that tradition
17:04:33 <gibi> lets move to the next item
17:05:10 <gibi> obj_make_compatible methods in payload classes
17:05:19 <gibi> only FlavorPayload has that today
17:05:25 <mriedem> i was going to bring that up :)
17:05:28 <mriedem> let's wrangle dansmith
17:05:32 <gibi> OK
17:05:39 <mriedem> #link https://review.openstack.org/#/c/514943/
17:05:49 <mriedem> i had assumed he'd just appear
17:06:26 <gibi> So we have that only in FlavorPayload and not in the other payload classes
17:06:41 <gibi> we did not add them in the past as it is not used today
17:06:47 <mriedem> and we have no sort of schema-based tooling to handle backporting these things
17:06:54 <gibi> yes
17:07:27 <mriedem> i don't want to generate a bunch of work to add compat methods to the other payload classes for something that isn't used
17:07:29 <gibi> inconsistency is bad so I'd like to have a solution that is consistent across payload classes
17:07:53 <gibi> but I can accept both end, adding the everywhere or removing from FlavorPayload
17:08:02 <mriedem> yeah i guess for now your patch is ok, and if we needed to support compat later we can use the version change log to do that
17:08:28 <mriedem> i wanted to ask dansmith because we had a similar discussion recently about os-vif
17:09:06 <gibi> OK
17:09:22 <gibi> we can move forward and go back if he shows up or ask him later
17:09:39 <mriedem> i +2ed your change
17:09:49 <gibi> OK, thanks
17:10:28 <gibi> moving forward
17:10:44 <gibi> finally I managed to add override support for the jsonref in https://review.openstack.org/#/q/topic:refactor-notification-samples
17:10:55 <gibi> it seems jaypipes likes it
17:11:22 <gibi> takashi had some additional comments but those feels to me as out of scope
17:11:32 <gibi> #link https://review.openstack.org/#/c/452820/
17:11:53 <gibi> basically the original samples have some weired power_state values
17:12:07 <gibi> but it is because the FakeDriver used in the functional test is too simple
17:12:10 <mriedem> yeah, so speaking of that....
17:12:20 <gibi> it don't handle power state of the instance properly
17:12:25 <mriedem> https://review.openstack.org/#/c/509935/
17:12:34 <mriedem> i just need to update the samples :)
17:12:39 <mriedem> but was already working on that for unrelated reason
17:12:51 <gibi> soo cool
17:13:07 <gibi> I will point takashi to your patch
17:13:57 <gibi> as the driver is soo simple I expect other inconsistencies to pop up later
17:14:08 <mriedem> yeah maybe
17:14:15 <gibi> but we can hunt those down one by one
17:14:23 <mriedem> i actually needed to fix that for some scale testing i was doing with the fake driver
17:14:55 <gibi> OK that was the last technical item on my list
17:15:25 <gibi> I will cancel the meeting next week as you will be in Sydney
17:15:40 <mriedem> ok
17:15:57 <gibi> That was all from my side
17:16:03 <gibi> anything else on yours?
17:16:12 <mriedem> nope
17:16:45 <gibi> I can try to chase dansmith with the patch tomorrow
17:17:07 <mriedem> sounds good
17:17:10 <gibi> lets close this
17:17:13 <gibi> thanks for the meeting
17:17:20 <mriedem> o/
17:17:21 * dansmith makes a note to put his running shoes on tomorrow
17:17:29 <mriedem> or just grease up
17:17:37 <gibi> dansmith: do you want to talk about it now?
17:17:48 <dansmith> gibi: if you want, sorry I was tied up earlier
17:17:52 <gibi> no problem
17:17:57 <gibi> let's try it now
17:17:58 <dansmith> 514943 right?
17:18:05 <gibi> yes
17:18:15 <gibi> ovo compatibility method in payload classes
17:18:22 <gibi> they are not used today
17:18:31 <gibi> and only the FlavorPayload has it today
17:18:35 <gibi> so I proposed to remove them
17:18:37 <gibi> as dead code
17:18:57 <dansmith> yeah, notifications are never passed over rpc right?
17:19:22 <gibi> never
17:19:22 <dansmith> ah, can't be,m
17:19:27 <dansmith> because they're register_if(False)
17:19:45 <gibi> they are serialized to json and emited on the message bus or in the log
17:19:48 <dansmith> and if you say there's nothing that ever calls that (and I believe you) then yeah
17:20:13 <gibi> nothing calls it as we don't support backporting notification payloads today
17:20:29 <dansmith> yep, so should be fine
17:20:35 <gibi> OK
17:20:38 <dansmith> +Wd
17:20:47 <gibi> thank you
17:20:58 <gibi> then let's close this meeting :)
17:21:06 <gibi> have a nice time in Sydney!
17:21:23 <mriedem> remember to keep out the crazy while we're gone
17:21:29 <gibi> will try
17:21:38 <gibi> #endmeeting