15:00:15 <bauzas> #startmeeting nova_scheduler
15:00:16 <openstack> Meeting started Tue Jun 16 15:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'nova_scheduler'
15:00:26 <bauzas> hola folks
15:00:48 <lxsli> o/
15:00:54 <hichihara> bye
15:00:55 <edleafe> o/
15:01:03 <bauzas> n0ano is unable to make the call, so I'm chairing for the best or the worst
15:01:17 <bauzas> feel free to buy tomatoes before we start
15:01:19 * edleafe is in another meeting on the phone
15:01:33 <edleafe> so sorry if I lag response time
15:01:46 <bauzas> edleafe: eh, wasn't my turn last week ? :)
15:02:15 <bauzas> okay, waiting a few more time for guests coming in, and then we can start
15:02:27 <edleafe> bauzas: :)
15:03:25 <bauzas> okay, guessing that 3 people is definitely good for having consensus, we can start
15:03:40 <bauzas> (at least, it is easier than 4)
15:03:49 <bauzas> (and better than 2)
15:04:02 <bauzas> #topic Spec tracking
15:04:17 <bauzas> so n0ano was wondering how to track our progress
15:04:33 <bauzas> from my perspective, we have 2 kind of things
15:04:35 <edleafe> didn't he create an etherpad or wiki page?
15:04:42 <bauzas> 1/ things that are priorities
15:04:48 <bauzas> 2/ things that aren't
15:05:11 <bauzas> edleafe: yup, but he recently raised the question about that during the last nova meeting
15:05:22 <bauzas> edleafe: and I was -1 about that
15:05:51 <bauzas> so, as I said, there are 2 possibilities
15:06:01 <bauzas> either you work on a prioritized spec
15:06:07 <bauzas> (or you claim for it)
15:06:08 <edleafe> suggestion for tracking these things?
15:06:12 <bauzas> or, you don't
15:06:29 <bauzas> so, given that, we already the Master Doom of the Etherpads for Nova
15:06:38 <lxsli> An etherpad to track our Liberty commitments and process sounds useful; in addition to the liberty-nova-priorities list where we may put 3 items for review
15:06:47 <bauzas> #link https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
15:07:14 <bauzas> MHO is that we can add our specs there, either it's a prio or not
15:07:42 <bauzas> L29 is for Scheduler priority specs
15:07:58 <edleafe> just added my teeny spec
15:08:19 <bauzas> so, I'm thinking we should just add non-prio specs in another Scheduler bullet at the bottom
15:08:23 <bauzas> johnthetubaguy: are you around ?
15:08:51 <bauzas> johnthetubaguy: we have some specs that are priorities or claiming for so we can add them to https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
15:08:58 <lxsli> We can add some extra things which aren't ready to be reviewed quite yet
15:09:14 <lxsli> I wouldn't like to clog it up with everything we're thinking of though
15:09:17 <bauzas> johnthetubaguy: but some specs couldn't be priority, so my gut is that we should add a Scheduler subteam item at the bottom
15:09:29 <edleafe> lxsli: as long as they are in a separate section
15:09:32 <bauzas> (and explicitely say those are not prio)
15:09:44 <edleafe> lxsli: we can move them around when they are ready for review
15:09:56 <johnthetubaguy> I think having a single scheduler subteam area is easiest if possible
15:10:05 <bauzas> lxsli: edleafe: +1, I want it very clear that the first section (L17) is only for those we consider mergeable
15:10:10 <johnthetubaguy> yeah, just have a separate ready vs needs review by sub team lists
15:10:14 <lxsli> johnthetubaguy: without a separate etherpad?
15:10:17 <johnthetubaguy> you can have non priority stuff separate if you want
15:10:29 <bauzas> johnthetubaguy: okay, I just want to make it clear that not all the specs are priority
15:10:29 <edleafe> lxsli: L17 is for the API
15:10:42 <edleafe> lxsli: you mean L35
15:10:50 <johnthetubaguy> lxsli: yeah, please not more etherpads, people don't seem to look at the current one at the moment, so I think adding more will be counter productive
15:10:55 <bauzas> edleafe: yup
15:11:21 <johnthetubaguy> bauzas: the blueprint and spec deadline is super soon, specs that are not up now are very unlikely to make the deadline at this point
15:11:45 <bauzas> johnthetubaguy: my point
15:12:05 <bauzas> johnthetubaguy: I mean, during Liberty, we will have 2 kind of changes
15:12:10 <johnthetubaguy> so yeah, I would focus on making sure you have the specs merged that you need, and focusing your view on those right now
15:12:12 <bauzas> johnthetubaguy: (speaking of changes, here)
15:12:31 <bauzas> johnthetubaguy: edleafe: lxsli: I'm just amending the etherpad now
15:13:35 <johnthetubaguy> cool, thanks for pushing on this folks
15:13:47 <bauzas> the idea is to separate non-prio changes from the prio ones, to help both nova cores and sched subteam to get the proper attraction for prio changes, while we still want to keep focus on non-prio
15:14:06 <bauzas> okay, I'm taking an action to refine a little bit the sections
15:14:36 <bauzas> #action bauzas to amend the etherpad to make clear what is a priority change vs. what is not a priority change
15:14:47 <bauzas> let's move on then
15:14:56 <bauzas> johnthetubaguy: thanks for your insights on that
15:15:12 <bauzas> #topic Liberty tracking
15:15:54 <bauzas> so, before going further, do we agree on using https://etherpad.openstack.org/p/liberty-nova-priorities-tracking for tracking ?
15:16:12 <bauzas> #startvote do we agree on using https://etherpad.openstack.org/p/liberty-nova-priorities-tracking for tracking? yes or no
15:16:14 <openstack> Begin voting on: do we agree on using https://etherpad.openstack.org/p/liberty-nova-priorities-tracking for tracking? Valid vote options are yes, or, no.
15:16:15 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:16:17 <lxsli> sounds like that's what john prefers
15:16:19 <lxsli> #vote yes
15:16:29 <bauzas> edleafe: ?
15:16:48 <bauzas> #vote yes
15:17:25 <bauzas> I would love if edleafe could give his view on that, even if I think we got his idea :)
15:17:30 <lxsli> ed's on the phone
15:18:01 <bauzas> right, that's why I make edleafe's IRC client blinking like Xmas
15:18:04 <bauzas> :)
15:18:17 <lxsli> heh
15:18:23 <bauzas> ok, let's close the vote
15:18:26 <edleafe> #vote yes
15:18:27 <bauzas> #endvote
15:18:27 <openstack> Voted on "do we agree on using https://etherpad.openstack.org/p/liberty-nova-priorities-tracking for tracking?" Results are
15:18:28 <openstack> yes (3): bauzas, edleafe, lxsli
15:18:32 <bauzas> woooh
15:18:35 <edleafe> whew, just made it!
15:18:42 <bauzas> edleafe: heh :)
15:18:54 <bauzas> ok, so, given that
15:19:19 <bauzas> #action all to update https://etherpad.openstack.org/p/liberty-nova-priorities-tracking to mention their changes if necessary for tracking
15:19:50 <bauzas> #info changes that are not given in the etherpad list are not considered for tracking yet
15:19:59 <bauzas> do you agree, guys ?
15:20:20 <edleafe> yep
15:20:33 <bauzas> I mean, I have the RequestSpec object patch series that is up for review, but I don't consider it yet good for being tracked
15:20:47 <lxsli> What's the significance of being tracked?
15:21:07 <bauzas> lxsli: being discussed periodically by the team to make sure we make our deadlines ? :)
15:21:23 <lxsli> so there's some kind of promise of delivery?
15:21:30 <bauzas> yup
15:21:36 <lxsli> OK, thanks
15:21:59 <bauzas> that doesn't mean that we can't discuss on some spec implementations now, but I really want to use the etherpad for things that are needing reviews
15:22:58 <bauzas> but let's loop back with n0ano next week
15:23:50 <edleafe> One thing I wanted to mention
15:24:00 <bauzas> given that, does anyone want to discuss about a specific spec or implementation they want to share ?
15:24:03 <bauzas> edleafe: fire it
15:24:06 <edleafe> If you review one of these specs and give a -1, please be sure to follow up
15:24:18 <bauzas> edleafe: wise words
15:24:21 <edleafe> n0ano gave me a -1 with some questions
15:24:29 <edleafe> and then left it all last week
15:24:38 <edleafe> as a result, no one reviewed the spec on Friday
15:24:46 <sudipto> bauzas, I guess it doesn't apply to specs that necessarily don't fall under the priority list? Is there a way out for specs that are deemed essential for someone beyond the ones listed?
15:24:56 <bauzas> edleafe: don't hesitate to bug people if you don't get feedback rapidely
15:25:02 <lxsli> bauzas: +1
15:25:11 <bauzas> edleafe: on my own, I seriously lag from reviews atm
15:25:38 <edleafe> bauzas: I lag reviews, but I always star those I give a -1 to so I can follow up
15:25:41 <bauzas> sudipto: we just agreed on tracking those in the etherpad too, so you could get attention from the sched team
15:25:51 <sudipto> bauzas, ok sure...
15:26:01 <bauzas> sudipto: https://etherpad.openstack.org/p/liberty-nova-priorities-tracking L43
15:26:11 <sudipto> bauzas, thx!
15:26:20 <bauzas> edleafe: fair point, but you can't assume everybody does that :)
15:26:44 <bauzas> we are a small team, it's reasonable to bug people if so
15:26:54 <edleafe> bauzas: hence my reminder :)
15:27:04 <bauzas> edleafe: cool
15:27:22 <bauzas> any spec/bp/change that we want to discuss now ?
15:27:46 <lxsli> I'm happy with Jay's resource objects spec, it'd be great to get some more reviews on that now
15:28:12 <bauzas> I could just tell that I'm suffering severe PITA with the ReqSpec object BP, but I guess you see my complaints all the day on IRC
15:28:22 <bauzas> lxsli: in my queue
15:28:32 <bauzas> lxsli: I saw you squashed the 2 specs, great and ty
15:28:47 <lxsli> bauzas: yep always the idea, just needed to work out the kinks with jay first
15:28:54 <bauzas> cool
15:29:04 <bauzas> moving on then ?
15:29:23 <bauzas> edleafe: I saw you were proposing a log information for NoValidHost ?
15:29:30 <bauzas> that's on my queue too
15:29:43 <edleafe> yep
15:29:51 <bauzas> edleafe: you could put it as non-prio stuff (or prio, don't remember your claim)
15:30:13 <edleafe> I had originally tied it to the ReqSpec, but since that isn't going to be used for filtering in Liberty, I simplified it
15:30:29 <edleafe> It was a priority from the summit, IIRC
15:30:34 <bauzas> edleafe: I missed that point, I'll take some time to decently -1 it
15:30:35 <bauzas> :p
15:30:50 <bauzas> (just kidding)
15:30:50 <edleafe> bauzas: I expect nothing less!
15:31:08 <bauzas> ok, moving on
15:31:21 <bauzas> #topic New meeting time
15:31:53 <bauzas> so I was horribly lagging last week, was there any consensus reached ?
15:32:21 <edleafe> no, since there was no single time where everyone was available
15:32:22 <bauzas> or are we just doomed because of a stupid French wanting to take some time with his daughters ?
15:32:44 <bauzas> edleafe: so, what was the outcome ?
15:32:46 <edleafe> we are doomed because stupid jaypipes wants to go to his meetings :)
15:32:50 <lxsli> They should move America east a bit
15:33:13 <edleafe> n0ano just punted
15:33:16 <bauzas> things would be far easier if anyone could just use the Paris TZ
15:33:20 * bauzas whispers
15:33:25 * edleafe wonders if 'punted' translates well...
15:33:56 <bauzas> ok, so we're stuck ?
15:34:03 <bauzas> should we think about alternating ?
15:34:27 <bauzas> even weeks using that timeslot, and odd weeks using a new timeslot ?
15:34:37 <edleafe> bauzas: there is another option
15:34:55 <bauzas> edleafe: I'm hanging at your lips
15:35:03 <edleafe> (looking it up...)
15:35:08 <bauzas> (don't know if that translates well too...)
15:35:16 <edleafe> 1600 UTC was ok for everyone except johnthetubaguy
15:35:27 <lxsli> he's not that important
15:35:35 <johnthetubaguy> +1
15:35:36 <bauzas> thinking about a rebellion ?
15:35:44 <edleafe> lxsli: heh, I'm sure he'll be glad to hear that :)
15:35:52 <lxsli> "coup, coup" tweeted the pigeons
15:36:03 <johnthetubaguy> I have a regular meeting at that time, but its moving soon anyways
15:36:04 <bauzas> don't forget we cut our King's head
15:36:06 <johnthetubaguy> but thats fine
15:36:16 <edleafe> but those were the only two times that jaypipes was available
15:36:16 <johnthetubaguy> its not on IRC so I can be vaguely around for both
15:36:24 <johnthetubaguy> I would go for that one
15:36:40 * johnthetubaguy wonders where in the agenda to raise his crazy spec and docs patches
15:36:50 <edleafe> the other option is to move it to monday or thursday
15:37:05 <bauzas> johnthetubaguy: it was during the previous topic, but let's discuss that during open time
15:37:22 <johnthetubaguy> bauzas: yeah, I figured I missed that, cool
15:37:40 <edleafe> bauzas: how about I ping jaypipes for his availability, and then create a new doodle based on that?
15:37:41 <bauzas> we only have that topic and then we open the discussion
15:37:47 <bauzas> edleafe: huge +1
15:37:58 <johnthetubaguy> seems like we can just go for 1600UTC though?
15:38:16 <edleafe> #action edleafe to ping jaypipes for availability and start new doodle for meeting time
15:38:22 <johnthetubaguy> ignore my no vote on that, I can lurk like I normally do just fine at that time, if it helps
15:38:28 <edleafe> johnthetubaguy: yes, but jay was a maybe for that
15:38:35 <johnthetubaguy> edleafe: ah, gotcha
15:38:38 <bauzas> edleafe: not sure you logged the action
15:38:42 <edleafe> johnthetubaguy: so you're not the only problem :)
15:38:45 <bauzas> #chair edleafe
15:38:46 <openstack> Current chairs: bauzas edleafe
15:39:00 <lxsli> edleafe: action should be to find out the issue with 1600 first then
15:39:01 <edleafe> bauzas: yeah, actions and links can be posted by anyone
15:39:13 <bauzas> lxsli: agreed
15:39:17 <bauzas> #undo
15:39:18 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9730650>
15:39:32 <lxsli> ooh undo, fancy
15:39:46 <edleafe> #action edleafe to ping jaypipes for his issue with Tuesday 1600 UTC
15:39:53 <bauzas> edleafe: before we agree on that, could we just consider using the 1600UTC slot and check with jaypiprsd
15:39:58 <bauzas> ?
15:40:01 <bauzas> yeah, that one
15:40:16 <bauzas> I missed the new doodle thing when I shouted "hell yea"
15:40:23 <edleafe> bauzas: is there a meeting room available?
15:40:46 <bauzas> edleafe: we can sort that out quickly, or complain about that to ttx if no
15:40:54 <bauzas> edleafe: I'm not that worried
15:41:03 <edleafe> I remember the 1700 was open
15:41:08 <edleafe> not sure about 1600
15:41:11 <bauzas> edleafe: the #openstack-meeting room was sexy, but I can leave with that
15:41:12 <lxsli> shall we move on?
15:41:21 <bauzas> lxsli: +1, that can be figured out later
15:41:25 <bauzas> #topic open discussion
15:41:34 <bauzas> johnthetubaguy: had a status to share ?
15:41:44 <johnthetubaguy> #link https://review.openstack.org/192260
15:41:57 <johnthetubaguy> so I had an action to write up a summary of the scheduler evolution plans
15:42:03 <johnthetubaguy> thats a first draft of that effort
15:42:17 <lxsli> oh cracking, I was thinking of doing that but not looking forward to it
15:42:19 <johnthetubaguy> help extremely welcome, like please take over that patch and make it better
15:42:28 <johnthetubaguy> any one other thing tooo
15:42:28 <bauzas> johnthetubaguy: okay, are you fine with me providing some updates ?
15:42:36 <johnthetubaguy> bauzas: please do, that would be awesome
15:42:45 <bauzas> johnthetubaguy: sure, that's on my todo list
15:42:53 <bauzas> starring it even :)
15:43:16 <johnthetubaguy> so I wrote up some stuff around the parallel scheduling effort too
15:43:22 <bauzas> johnthetubaguy: ooooooh
15:43:28 <johnthetubaguy> based on the summit session, and stuff I was mumbling about during that session
15:43:31 <johnthetubaguy> #link https://review.openstack.org/#/c/191914/
15:43:35 <johnthetubaguy> its a backlog spec
15:43:35 <bauzas> johnthetubaguy: saw ndipanov's proposal btw ?
15:43:46 <johnthetubaguy> bauzas: yeah, this is mostly unrelated it turns out
15:43:53 <johnthetubaguy> so its a backlog spec
15:43:59 <johnthetubaguy> so its collecting a problem definition
15:44:07 <johnthetubaguy> and its talking about alternatives
15:44:15 <bauzas> johnthetubaguy: cool, I should probably say the same that for the last spec
15:44:16 <johnthetubaguy> I am not trying to pick a winner, or assign the work
15:44:19 <bauzas> s/spec/devref
15:44:22 <johnthetubaguy> just doument the ideas
15:44:28 <bauzas> sure, that's a backlog spec
15:44:42 <johnthetubaguy> somehow, its over 400 lines long
15:44:43 <johnthetubaguy> oops
15:44:46 <bauzas> okay, that's pretty fancy
15:44:47 <edleafe> johnthetubaguy: curious - backlog specs don't go in nova-specs?
15:45:02 <bauzas> edleafe: they do, but on a separate path
15:45:09 <johnthetubaguy> edleafe: http://specs.openstack.org/openstack/nova-specs/specs/backlog/index.html
15:45:46 <bauzas> ok, that's cool, we could even put those both changes in the etherpad for reviews
15:45:59 <edleafe> johnthetubaguy: just confused, since your spec is in nova, not nova-specs
15:46:07 <bauzas> edleafe: hell no
15:46:10 <edleafe> johnthetubaguy: haven't created a backlog spec myself
15:46:16 <johnthetubaguy> edleafe: one is a nova doc on architectural evolution
15:46:21 <bauzas> edleafe: https://review.openstack.org/#/c/191914/ is in nova-specs
15:46:21 <johnthetubaguy> edleafe: the other is in the nova-specs backlog specs
15:46:35 <bauzas> edleafe: https://review.openstack.org/192260 is a devref doc
15:46:42 <edleafe> johnthetubaguy: ah, I see
15:46:43 <bauzas> huh, jinxed
15:46:55 <johnthetubaguy> edleafe: the nova doc stuff is designed to span multiple nova-specs, giving a high level overview, then pointers once thats possible
15:47:07 <edleafe> johnthetubaguy: I saw the .rst and assumed it was a spec
15:47:09 <johnthetubaguy> edleafe: this is all very shiny and new process right now
15:47:25 <johnthetubaguy> edleafe: ah, easy done!
15:47:27 <edleafe> johnthetubaguy: too shiny - it blinded me! :)
15:47:42 <bauzas> :)
15:47:49 <johnthetubaguy> I keep -2ing specs because they don't have a spec merged, so I can't throw stones
15:48:13 <bauzas> johnthetubaguy: thanks a lot for your proposals, we'll follow up on those
15:48:27 <johnthetubaguy> so there are other actions folks have from the summit
15:48:36 <johnthetubaguy> it would be good to update the etherpad when they are done
15:48:44 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
15:48:46 <bauzas> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
15:48:49 <bauzas> #undo
15:48:50 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x9503d90>
15:49:24 <bauzas> johnthetubaguy: yeah we're just starting to collect feedback
15:49:59 <bauzas> johnthetubaguy: given all the things we are, I'm at least wanting to have some design discussions for things that are in the list but not yet with a clear plan
15:50:13 <bauzas> johnthetubaguy: so we could propose and implement those for Muppet cycle
15:50:51 <johnthetubaguy> bauzas: I really want backlog specs for that stuff
15:50:55 <bauzas> johnthetubaguy: +1
15:51:09 <johnthetubaguy> bauzas: so folks outside the usual groups can be more invovled
15:51:33 <bauzas> johnthetubaguy: that's what I say "design discussions", translate it to 'draw a draft'
15:51:47 <bauzas> johnthetubaguy: which is even one step further than a backlog spec
15:52:20 <lxsli> bauzas: perhaps 'requirement discussions'
15:52:23 <bauzas> johnthetubaguy: +1 on welcoming new contributors, hence the idea to open up the reviews to things that people want to share with us
15:52:30 <johnthetubaguy> bauzas: just agreeing the problem in a backlog spec I think is good step forward
15:52:54 <bauzas> I got your idea :)
15:53:06 <bauzas> collect feedback, iterate over that
15:53:44 <edleafe> so if someone has an outlandish new approach, a backlog spec would be the place to propose it?
15:53:57 <bauzas> edleafe: a backlog spec is for stating a problem
15:54:19 <edleafe> bauzas: not for proposing solutions?
15:54:30 <bauzas> edleafe: technically, there is no section for that IIRC
15:54:55 <bauzas> edleafe: but that doesn't mean we're avoiding to think about the solution
15:55:03 <edleafe> hmmm... I thought that if there was a proposed solution that couldn't be implemented in the current cycle, it went into the backlog
15:55:07 <johnthetubaguy> so you can do both
15:55:10 <lxsli> aiui backlog specs you don't plan to implement yourself
15:55:25 <johnthetubaguy> so I am about to update the doc page on this
15:55:26 <lxsli> so you can propose a solution but it might not get implemented that way
15:55:39 <johnthetubaguy> but basically, if you miss out any section of the spec
15:55:41 <johnthetubaguy> its on the backlog
15:55:49 <edleafe> lxsli: sure. Propose a solution, and let others have at it
15:55:51 <johnthetubaguy> that include assignee or implementation
15:55:54 <bauzas> maybe this discussion is wider than just for our subteam ? :)
15:56:17 <edleafe> bauzas: yeah - 3 minutes left
15:56:18 <johnthetubaguy> bauzas: sure, I thought it was already "agreed" though, as defined here: http://specs.openstack.org/openstack/nova-specs/specs/backlog/index.html
15:56:37 <bauzas> johnthetubaguy: let's discuss that back on #openstack-nova, I guess some people could voice there
15:56:49 <johnthetubaguy> sounds good
15:57:10 <bauzas> (and you would get better exposure for your thoughts)
15:57:23 <bauzas> ok, any other topic for the 2 mins left ?
15:57:24 <lxsli> Anything else then/
15:57:49 <bauzas> crickets ?
15:58:22 <bauzas> fair, let's call the wrap
15:58:26 <bauzas> #endmeeting