14:59:55 <n0ano> #startmeeting nova_scheduler
14:59:56 <openstack> Meeting started Tue Jun 30 14:59:55 2015 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:59 <openstack> The meeting name has been set to 'nova_scheduler'
15:00:05 <n0ano> anyone here to talk about the scheduler?
15:02:04 <edleafe> o/
15:02:11 <bauzas> \o
15:02:39 <n0ano> I was thinking it was going to just be me today (easier to come to decisions :-)
15:03:38 <n0ano> let's start, hopefully it'll be quick today
15:03:38 <edleafe> n0ano: sorry, but I'm on a call for another meeting :(
15:03:43 <PaulMurray> o/
15:03:51 <edleafe> so I might be slow in responding
15:03:56 <n0ano> edleafe, you get all the ARs :-)
15:04:01 <n0ano> #topic new meeting time
15:04:02 <edleafe> of course
15:04:16 <edleafe> Results: http://i.imgur.com/aPmIwLi.png
15:04:31 <n0ano> according to the doodle 1 hour earlier (1400UTC) on Mon. seems to work, any objections?
15:04:47 <bauzas> LGTM
15:05:09 <bauzas> PaulMurray: you weren't voting, OK for you ?
15:06:02 <PaulMurray> bauzas, sorry - been out of touch
15:06:21 <n0ano> PaulMurray, so is the new time OK for you?
15:06:23 <lxsli> o/
15:06:29 <bauzas> PaulMurray: np, so the question was, Mondays 1400UTC ok with you ?
15:06:42 <bauzas> (and lxsli as well)
15:06:52 <lxsli> works for me
15:06:55 <PaulMurray> bauzas, more or less
15:07:12 <bauzas> ok, n0ano, I guess you can put an #agreed there :)
15:07:38 <n0ano> #agreed new time 1400UTC Mondays
15:07:53 <n0ano> #action n0ano to update the wiki's and send a mail out to the dev list on this
15:08:22 <bauzas> n0ano: you also have to do a commit for the global page
15:09:07 <n0ano> bauzas, yeah, there are multiple administrivias I'll have to do, should be OK
15:09:11 <bauzas> n0ano: http://git.openstack.org/cgit/openstack-infra/irc-meetings/tree/
15:09:47 <n0ano> I have to do ical's for the new schedule which is new but I'll deal with it.
15:10:03 <bauzas> n0ano: if you don't feel comfortable, I can do it
15:10:20 <bauzas> n0ano: I already made a change for it
15:10:22 <n0ano> bauzas, I'll ping you if I have a problem but it should be OK
15:10:23 <bauzas> http://eavesdrop.openstack.org/#Nova_Scheduler_%28ex._Gantt%29_Team_Meeting
15:10:28 <bauzas> n0ano: coolness
15:10:38 <n0ano> so...
15:10:47 <n0ano> #topic Liberty spcecs
15:10:59 <bauzas> n0ano: saw our recent agreements ?
15:11:22 <n0ano> according to the tracking page https://etherpad.openstack.org/p/liberty-nova-priorities-tracking we only have one priorty spec that is still open
15:11:31 <bauzas> agreed
15:11:40 <bauzas> edleafe's one was not needed
15:11:46 <n0ano> I lied, looks like there are 2
15:11:48 <bauzas> hence john's -2
15:12:04 <bauzas> n0ano: eh eh
15:12:16 <bauzas> n0ano: thanks for introducing https://review.openstack.org/#/c/190322/7/specs/liberty/approved/servicegroup-api-control-plane.rst,cm
15:12:27 <bauzas> n0ano: I was about to discuss on it for the open discussion
15:12:40 <bauzas> but I can do it now
15:12:46 <n0ano> go ahead,no reason to wait
15:12:55 <bauzas> since it's claiming for the sched prio
15:13:20 <bauzas> so, I'll leave a change speak for itself
15:13:20 <bauzas> https://review.openstack.org/#/c/195559/
15:13:24 <bauzas> #link https://review.openstack.org/#/c/195559/
15:14:10 <bauzas> so, my comment here is that I wanted to see the subteam opinion for it
15:14:14 <bauzas> my point is
15:14:33 <bauzas> 1/ I don't like specs using the scheduler prio as a placeholder for getting more room for being merged
15:15:02 <n0ano> bauzas, +1
15:15:03 <bauzas> 2/ the SG API change is technically modifying something out of the scheduler and can benefit more than the scheduler
15:15:27 <bauzas> so, while it's definitely something worth being done
15:15:36 <bauzas> and I'm a huge fan of the spec
15:16:24 <bauzas> I just think it's better to explain to johnthetubaguy and the nova community that this is not a 'scheduler' prio spec, but is still considered as something important and deserves an exception
15:16:28 <edleafe> If it isn't tied to the scheduler efforts, it shouldn't use the scheduler priority, IMO
15:16:40 <bauzas> so, given that, could we make a vote ?
15:16:41 <edleafe> it should stand on its own
15:16:46 <bauzas> edleafe: that's my point
15:16:50 <edleafe> bauzas: ack
15:16:55 <n0ano> I think, here, we're in violent agreement, this is a good idea but it is not a scheduler thing
15:17:02 <edleafe> bauzas: I'm agreeing with you.
15:17:10 <bauzas> n0ano: let's do an official vote
15:17:14 <edleafe> bauzas: probably the first time ever :)
15:17:19 <bauzas> n0ano: give me the chair rights
15:17:23 <bauzas> #chair bauzas
15:17:28 <bauzas> and I'll pass to the vote
15:17:30 <n0ano> bauzas, if you insist :-)
15:17:33 <n0ano> #chair bauzas
15:17:37 <openstack> Current chairs: bauzas n0ano
15:18:15 <bauzas> #startvote Do you consider that https://review.openstack.org/#/c/190322/ is a 'scheduler' priority spec ? yes or no
15:18:16 <openstack> Begin voting on: Do you consider that https://review.openstack.org/#/c/190322/ is a 'scheduler' priority spec ? Valid vote options are yes, or, no.
15:18:18 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:18:21 <bauzas> #vote no
15:18:29 <n0ano> #vote no
15:18:32 <lxsli> #vote or
15:18:40 <edleafe> #vote no
15:18:52 <PaulMurray> #vote no
15:19:05 <bauzas> lxsli: lol, you found a bug
15:19:09 <edleafe> lxsli: smartass :-P
15:19:12 <bauzas> #endvote
15:19:13 <openstack> Voted on "Do you consider that https://review.openstack.org/#/c/190322/ is a 'scheduler' priority spec ?" Results are
15:19:15 <openstack> or (1): lxsli
15:19:16 <openstack> no (4): bauzas, PaulMurray, n0ano, edleafe
15:19:23 * n0ano wonders what an `or' vote means
15:19:40 <bauzas> okay, I'll remove my -W and provide the result of the vote as a change comment
15:19:40 <PaulMurray> it counts "or" - ha - I bet we could vote anything
15:19:53 <PaulMurray> didn't know that
15:20:03 <bauzas> I sould have said yes, no :)
15:20:15 <PaulMurray> he would have put :)
15:20:22 <lxsli> yes,
15:20:24 <n0ano> `and' I would understand but `or' ...
15:20:49 <bauzas> anyway, I'm done for that
15:20:58 <bauzas> so, last point about specs
15:21:05 <n0ano> bauzas, NP and wew had some fun with it also
15:21:08 <n0ano> bauzas, go ahead
15:21:13 <bauzas> I urge you to review https://review.openstack.org/#/c/179224/
15:21:43 <bauzas> I consider it as a needed behavioural change for making all the scheduler queries consistent
15:21:59 <bauzas> and it also fixes a bunch of bugs and misunderstandings
15:22:48 <n0ano> good one, I'll review this after noon (after I climb out of the hole I created by effectively taking 2 weeks off)
15:23:35 <bauzas> that's it for me, RequestSpec implem is on its way
15:23:51 <n0ano> anything else on specs?
15:24:26 <n0ano> then, moving on
15:24:30 <n0ano> #topic opens
15:24:36 <n0ano> anything new?
15:24:36 <edleafe> I'll re-review it later, too. Then I'm out for the rest of the week
15:24:50 <xyhuang> hi, any chance we can look at this nit again:
15:24:54 <xyhuang> https://review.openstack.org/#/c/193635/
15:25:03 <xyhuang> a brief spec here:
15:25:06 <n0ano> oh yeah, the 4th is coming, I always forget about hoidays
15:25:09 <xyhuang> https://review.openstack.org/#/c/195696
15:25:34 <lxsli> Nova midcycle soon
15:26:13 <n0ano> xyhuang, tnx for mentioning these, we'll try and review them
15:26:14 <edleafe> xyhuang: I still don't think that this change requires a spec
15:26:34 <xyhuang> bauzas: i feel that it’s trivial impact on existing works because
15:26:44 <xyhuang> requested_networks are passed from outside from user, not something inside nova-compute
15:26:59 <bauzas> edleafe: I still think it deserves a spec because it changes the interface between the scheduler and Nova
15:27:10 <xyhuang> lxsli: i checked out the resource object work as you mentioned, and i think it is not affected, at least atm.
15:27:22 <bauzas> edleafe: and also because it's worth discussing on how we pass this information to the scheduler
15:27:41 <lxsli> xyhuang: OK I can take a longer look, only glanced last time
15:27:56 <bauzas> xyhuang: your both changes are on top of my review queue, I should comment them soon
15:28:04 <xyhuang> lxsli: i definitely agree though if the networks will be tracked in resources but that’d be another story i guess…
15:28:34 <xyhuang> bauzas: thanks :) glad to know what you think
15:29:00 <bauzas> xyhuang: tbh, I need a bit of time to see if passing thru filt_properties is a good idea or not
15:29:56 <bauzas> moving on ?
15:30:04 <xyhuang> bauzas: i guess fltr_properties is also possible but IMO it's easier to pass in the req_spec
15:30:21 <bauzas> xyhuang: lemme comment that out in your spec :)
15:30:30 <n0ano> lxsli, in re midcycle - I plan to be there, who else is coming?
15:30:38 <xyhuang> bauzas: thx!
15:30:41 <bauzas> n0ano: I won't
15:30:42 <bauzas> :(
15:31:04 <bauzas> I heard about PaulMurray and lxsli coming
15:31:16 <bauzas> so, edleafe will wait for his 2 beers :(
15:31:17 <n0ano> bauzas, bummer, RH is making money, what's their excuse :-)
15:31:22 <lxsli> yes I'll be there, not sure PaulMurray will
15:31:45 <edleafe> I'll be there, and thirsty
15:32:01 <bauzas> n0ano: well, that's not because you earn money that you can expense much than what you earn :)
15:32:14 <bauzas> n0ano: so, I understand the reasons
15:32:27 <bauzas> expense more* of course
15:32:41 <PaulMurray> bauzas, I'm ont coming - I have holiday planned
15:32:57 <bauzas> PaulMurray: and people complain about French holidays...
15:33:20 <PaulMurray> bauzas, strangely I will be in France
15:33:34 <n0ano> PaulMurray, how - ironic :-)
15:33:35 <bauzas> PaulMurray: so, you'll be acting like locals :)
15:33:40 <PaulMurray> so it is sort of a french holiday
15:33:45 <PaulMurray> :)
15:34:42 <bauzas> PaulMurray: I suppose you won't go to Grenoble :p
15:34:50 <bauzas> anyway, that's off-topic
15:34:53 <n0ano> seriously, we should think about any topics we want to discuss at the mid-cycle, obviously the oustanding Liberty spcs/bps, but anything else we care about
15:35:08 <bauzas> n0ano: I should remotely attend the midcycle tho
15:35:25 <bauzas> n0ano: providing there would be some connectivity in there
15:35:31 <bauzas> provided even
15:35:43 <n0ano> bauzas, that'll help but good luck hearing everyone in the room
15:35:58 <bauzas> n0ano: I'm not that worried :)
15:36:21 <n0ano> so think about the mid-cycle and we can discuss that at the next meeting (on Mon.)
15:37:02 <n0ano> so, anything else for today?
15:37:21 <edleafe> n0ano: I get back very late Sunday night, so I might not be on next Monday
15:37:47 <n0ano> edleafe, NP, get some sleep
15:38:32 <n0ano> I'm hearing crickets
15:38:39 <edleafe> n0ano: sleep? nah. I'm worrying about plane delays
15:39:22 <n0ano> edleafe, why worry, you `never` miss a connection :-)
15:39:45 * n0ano like everyone, has some interesting missed connection stories
15:39:58 <n0ano> anyway, I think we're done for today
15:40:13 <n0ano> tnx everyone, talk to you soon and do those reviews
15:40:23 <n0ano> #endmeeting