14:01:09 <n0ano> #startmeeting nova-scheduler
14:01:10 <openstack> Meeting started Mon Dec  7 14:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:13 <openstack> The meeting name has been set to 'nova_scheduler'
14:01:25 <n0ano> anyone here (other than edleafe & lxsli ) to talk about the scheduler
14:01:59 <lxsli> bauzas: ping
14:02:26 <johnthetubaguy> lurking, ish
14:02:32 <edleafe> lxsli: he's busy with ndipanov atm
14:03:12 <n0ano> I wonder if jaypipes has that other meeting again
14:03:31 <cdent> o/
14:04:02 <n0ano> cdent, welcome
14:04:09 <cdent> thanks
14:04:24 <Yingxin> o/
14:04:29 <n0ano> well, let's start, might be a relatively quick meeting today
14:04:39 <n0ano> #topic specs & BPs
14:05:17 <n0ano> I see from the etherpad, https://etherpad.openstack.org/p/mitaka-nova-spec-review-tracking, that the only outstanding BP is one from jaypipes on request spec, is everyone else happy with their BPs
14:06:59 <n0ano> I guess we'll take silence as assent so I think the specs are under control, speak up if you have any concerns
14:07:27 <n0ano> moving on
14:07:32 <n0ano> #topic bugs
14:08:10 <n0ano> not much change in the bug list, if anything it's gotten one or two bugs added so we need to think about that
14:08:51 <n0ano> I'm going to see if I can get the Intel team in San Antonio to look into the scheduler bug list, I need to talk to them this week
14:08:57 <Yingxin> I proposed 3 bugs just now
14:09:18 <Yingxin> think they are related to scheduler
14:09:21 <n0ano> Yingxin, you're supposed to clear them not add new ones :-)
14:09:30 <cdent> If someone wants to (or can) point me to a bug or two related to the scheduler that might be a good starting point, that would be excellent.
14:09:39 <n0ano> NP, they'll just have to be triaged to make sure that's correct
14:09:48 <edleafe> n0ano: there's a new guy on the SA Intel team I know from the Python world. Fresh to OpenStack.
14:09:57 <n0ano> cdent, start from here https://bugs.launchpad.net/nova/+bugs?field.tag=scheduler
14:10:14 <edleafe> n0ano: I'd be happy to help him work on Scheduler bugs
14:10:15 <cdent> Yup, n0ano already  made it that far but the list is not short :)
14:10:33 <n0ano> edleafe, sure, feel free to reach out
14:10:57 <n0ano> cdent, feel free to scan the list and attack any bugs that looks interesting
14:11:01 <edleafe> n0ano: his name is Yarko - I assume he's the only Yarko there :)
14:11:18 <johnthetubaguy> n0ano: sorry, got distracted there. Heads up on specs, we are in the freeze period for all specs now, so any other specs will need to apply for an exception ASAP
14:11:32 <n0ano> edleafe, probably, we're pulling in some people from Poland so that is not that strange
14:11:46 * bauzas waves late
14:11:49 <edleafe> n0ano: he's from Chicago :)
14:12:05 * n0ano has to stop sterotyping :-)
14:12:31 <n0ano> johnthetubaguy, the only one open is jaypipes and hopefully he's aware of the schedule, if not he will be now
14:13:22 <n0ano> #action jaypipes to apply for exception on his request spec BP
14:14:30 <n0ano> anyway, we have a list of bugs, please try and address any you can (and encourage others to look at our bug list)
14:14:39 <n0ano> #opens
14:14:44 <n0ano> #topic opens
14:14:48 <cdent>14:14:53 <n0ano> so, anything new for today?
14:16:01 * n0ano listening to crickets
14:16:47 <n0ano> OK, for once I didn't jinx it and it was a short meeting
14:16:51 <jaypipes> n0ano: you mean the resource-pools spec?
14:16:52 <Yingxin> https://review.openstack.org/#/c/246476/ can I add this to https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking to get noticed?
14:17:24 <n0ano> jaypipes, yes, that's the only one not striked out so and it has -1's, are you going to update it?
14:17:31 <Yingxin> It implements the bp use stevedore for scheduler host manager
14:17:59 <n0ano> Yingxin, note johnthetubaguy comment about spec freeze, it'll probably require an exception
14:18:25 <Yingxin> It is approved as specless
14:18:31 <jaypipes> n0ano: yes. I actually have broken the resource-providers spec out into smaller more consumable chunks. I will try to get all of the chunks pushed today.
14:18:44 <cdent> chunks++
14:19:07 <n0ano> Yingxin, Oh, in that case you should be good, I don't see a problem adding it to the priorities page, we can take if off it's a problem.
14:19:32 <Yingxin> n0ano: thanks
14:19:34 <n0ano> jaypipes, cool but it looks like you'll have to ask for an extension for it
14:20:58 <jaypipes> n0ano: yes understood.
14:21:06 <n0ano> anything else anyone?
14:21:16 <jaypipes> n0ano: Moscow is cold.
14:21:19 <jaypipes> there, I said it.
14:22:00 <n0ano> jaypipes, actually I think that only true something like 10-11 months out of the year :-)
14:22:07 <edleafe> jaypipes: controversial~
14:22:14 <edleafe> s/~/!
14:22:22 <jaypipes> hehe
14:22:51 <n0ano> OK, tnx everyone, we'll talk again next week
14:23:08 <n0ano> #endmeeting