14:00:07 <edleafe> #startmeeting Nova Scheduler
14:00:07 <openstack> Meeting started Mon Mar  7 14:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:29 <edleafe> Anyone interested in talking about the scheduler?
14:00:33 <_gryf> o/
14:00:44 <Yingxin> \o
14:00:55 * bauzas waves
14:01:04 * alaski lurks
14:01:28 * n0ano lurks
14:01:42 * edleafe spots n0ano in the shadows
14:01:53 * n0ano run away!
14:01:54 <bauzas> meh, I have a French movie about that case :p
14:02:00 <cdent> o/
14:02:09 <edleafe> #topic Mitaka priorites
14:02:14 <edleafe> #link https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:02:27 <cdent> everything everywhere got -2 :(
14:02:34 <edleafe> looks like nearly all has either merged or been -2'd
14:02:44 <cdent> we should have a retrospective on how to do better next time
14:03:20 <edleafe> cdent: easy: clone jaypipes early in the cycle
14:03:21 <Yingxin> unfortunately got two -2s
14:03:29 <jaypipes> o/
14:03:40 <cdent> edleafe: next time
14:03:59 <edleafe> anyone have anything to mention about any of outstanding patches?
14:04:02 <bauzas> heh, don't be worry, it should be merged very close after RC1
14:04:15 <edleafe> cdent: start mixing the DNA
14:04:35 <edleafe> nothing? OK
14:04:41 <edleafe> #topic Bugs
14:04:43 <cdent> bauzas: I'm not worried about the code, I'm worried about the users
14:04:44 <edleafe> #link https://bugs.launchpad.net/nova/+bugs?field.tag=scheduler
14:05:15 <edleafe> cdent: missing the end of a cycle always stings
14:05:57 <edleafe> So is anyone working on these, or focusing on the RC-blockers for nova?
14:05:58 * cdent shrugs, does not feel stung
14:06:09 <cdent> edleafe: I will be looking at bugs later in the week
14:06:24 <edleafe> cdent: cool
14:06:30 <Yingxin> fixed a bug, looking for reviewers: https://review.openstack.org/#/c/289193/
14:06:54 <edleafe> Yingxin: thanks - I'll look at that later
14:07:03 <bauzas> I propose to add a section in the etherpad of doom for mentioning priority bugs
14:07:17 <Yingxin> will fix more during bug smash day :)
14:07:25 <edleafe> bauzas: sounds like a good idea - go for it!
14:07:29 <bauzas> https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:07:37 <jaypipes> bauzas, Yingxin, cdent, edleafe: I pushed new revisions for the scheduler blueprints (targeted now at Newton) for the generic-resource-pools, compute-node-inventory, and resource-providers-allocations specs. Reviews welcome and appreciated.
14:08:13 <edleafe> #action Review new versions of jaypipes' specs
14:08:22 <edleafe> thanks jaypipes
14:08:25 <bauzas> just modified https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking to add a note for bugs in the scheduler prio
14:09:06 <edleafe> thx bauzas
14:09:11 <edleafe> Anything else for bugs?
14:09:55 <jaypipes> when does newton code open again?
14:10:12 <edleafe> as soon as they cut RC1
14:10:13 <bauzas> jaypipes: right when pushing RC1
14:10:20 <jaypipes> which is..?
14:10:21 <edleafe> jinx
14:10:51 <bauzas> https://wiki.openstack.org/wiki/Nova/Mitaka_Release_Schedule
14:10:55 <bauzas> jaypipes: $
14:10:58 <bauzas> erm
14:11:02 <bauzas> Mar 15-17: RC1 and HardStringFreeze
14:11:06 <jaypipes> k
14:11:18 <bauzas> or rather http://releases.openstack.org/mitaka/schedule.html
14:11:25 <bauzas> R-3
14:11:32 <jaypipes> question... should I tackle https://bugs.launchpad.net/nova/+bug/1549984 in next week?
14:11:32 <openstack> Launchpad bug 1549984 in OpenStack Compute (nova) "PCI devices claimed on compute node during _claim_test()" [High,In progress] - Assigned to Jay Pipes (jaypipes)
14:12:01 <edleafe> #topic opens
14:12:06 <edleafe> I have one thing
14:12:07 <jaypipes> I did a patch for ^ in the pci-generate-stats patch series, but I can pull it out of there and add into mainline
14:12:46 <edleafe> n0ano asked me to chair this meeting from now on, and I'm glad to do it. But I will be on holiday next week. Anyone want to run it in my place?
14:13:18 <bauzas> jaypipes: that's an High prio bug, we can even discuss that straight after the meeting in -nova
14:13:31 <jaypipes> bauzas: k
14:13:47 <bauzas> hopefully we could land this for Mitaka
14:14:31 <edleafe> is there a chance of this making it into Mitaka?
14:15:03 <bauzas> well, that's why we should talk on that right after the meeting (or now)
14:15:10 <bauzas> but not wait for one week :)
14:15:16 <bauzas> if that's an high prio bug
14:15:44 <edleafe> -nova would be better if others might need to weigh in on it
14:16:06 <bauzas> jaypipes: that said, I would honestly having it categorized as Medium because it doesn't impact having instances scheduled with pci requests, right?
14:16:18 <bauzas> but let's discuss on the problem and see how we can fix that by Mitaka
14:16:41 <jaypipes> bauzas: it is a data corruption bug. the PCI device can be claimed on a host when the instance actually fails the claim.
14:16:43 <bauzas> what we honestly need is some decent CI for PCI :)
14:17:07 <edleafe> bauzas: without that, it's just P
14:17:15 <edleafe> :)
14:18:14 <edleafe> OK, anything else?
14:18:17 <bauzas> jaypipes: yeah I see, it's exhausting PCI resources
14:19:02 <bauzas> either way, I don't want to nitpick on the prio, if we have people volunteering on that one, I'd be glad to review and hopefully approve that by Mitaka
14:19:47 <jaypipes> bauzas: yes, I already have code pushed that fixes the issue. I just need to rebase it on master instead of dstepanenko's patch series.
14:20:00 <jaypipes> I will do that shortly.
14:20:07 <bauzas> nice, so, adding this in the etherpad for tracking bugs, and ping me once you're done with the rebase
14:20:12 <bauzas> jaypipes: ^
14:20:17 <jaypipes> rock on. thx sir :)
14:20:41 <bauzas> honestly, I totally understand this as a blocker for people wanting to do PCI requesting, we should make sure it lands in time
14:21:08 <bauzas> that's one of the reasons we have FF, to make sure we can decently work on those kind of nasty bugs
14:21:09 <edleafe> yes, let's get this in Mitaka
14:21:32 <edleafe> Antyhing more?
14:21:38 <edleafe> Anything, even
14:21:53 <Yingxin> jaypipes: I'd like to participate in implementing resource provider series for newton
14:23:15 <edleafe> I think a goal for us as a subteam is to get better at spreading out the workload
14:23:23 <edleafe> We improved in this cycle
14:23:37 <edleafe> but could do better in Newton
14:24:22 <edleafe> Let's continue in -nova if there is anything else.
14:24:26 <edleafe> #endmeeting