14:00:20 <edleafe> #startmeeting nova_scheduler
14:00:20 <openstack> Meeting started Mon Mar 28 14:00:20 2016 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:24 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:26 <jaypipes> o/
14:00:30 <mlavalle> o/
14:00:30 <Yingxin> o/
14:00:53 <edleafe> Ah, good. I thought I'd be talking with myself today :)
14:00:55 <mriedem> o/
14:01:17 <edleafe> #topic specs
14:01:49 <edleafe> First up is Jay's resource pools: https://review.openstack.org/#/c/253187/
14:02:05 <edleafe> mriedem: is there consensus that this can proceed before the summit?
14:03:03 <mriedem> hrm
14:03:09 <jaypipes> If we disregard the Neutron-specific comments, is everyone happy with the spec as-is? mlavalle and others have good Neutron-specific comments regarding routed networks, but IMHO, it's not necessary to resolve each and every one of those before approving the spec for generic resource pools.
14:03:11 <mriedem> is dansmith awake?
14:03:18 <dansmith> yes
14:03:28 <edleafe> jaypipes: agreed
14:03:34 <mriedem> was https://blueprints.launchpad.net/nova/+spec/generic-resource-pools somethign that was partially implemented in mitaka?
14:03:38 <mriedem> but we just didn't land the spec?
14:03:47 <edleafe> jaypipes: it's good to surface those issues. They don't have to be resolved now, though
14:03:49 <mlavalle> jaypipes: I agree... The spec looks good. My comments only add precision from the Neutron poinbt of view
14:04:19 <jaypipes> mlavalle: right, they are excellent points, just not things that would kill the entire idea of generic resource pools.
14:04:57 <jaypipes> mriedem: no, it was proposed and the spec went through a ton of reviews and revisions, but was not approved.
14:05:06 <mlavalle> jaypipes: in fact, from the Neutron point of view, we think this spec is good now and want it to move forward
14:05:08 <mriedem> jaypipes: and no code in mitaka?
14:05:12 <edleafe> mriedem: generic resouce pools is still 'Pending Approval' https://blueprints.launchpad.net/openstack/?searchtext=generic-resource-pools
14:05:21 <jaypipes> mriedem: there was code proposed, yes.
14:05:38 <jaypipes> mriedem: but much of that went into the compute-node-inventory spec.
14:06:01 <mriedem> i thought last week that parts of compute-node-inventory was what dansmith was saying was mostly done in mitaka and we could give a pass to in newton even though the spec wasn't approved
14:06:14 <jaypipes> mriedem: the work that cdent and dansmith did around the compute node object was primarily against the compute-node-inventory spec, which is a dependency for generic-resource-pools.
14:06:28 <jaypipes> mriedem: yes, that is absolutely correct.
14:06:54 <mriedem> ok, so if generic-resource-pools wasn't nearly complete in mitaka, then i think it has to wait for after the summit
14:06:58 <jaypipes> mriedem: here is the compute-node-inventory spec: https://review.openstack.org/#/c/260048/
14:07:02 <mriedem> and we focus on getting compute-node-inventory done
14:07:06 <dansmith> mriedem: inventory wasn't mostly done, but we were aiming for it to be done, we just ran out of time
14:07:42 <mriedem> yeah, that's what i remember hearing, so i think inventory gets (re-)approved in newton
14:07:46 <mriedem> like, this week
14:07:51 <jaypipes> mriedem: I'd be happy to just get the compute-node-inventory spec approved before th esummit.
14:08:01 <mriedem> dansmith: you agree with that?
14:08:09 <edleafe> dansmith: so how does that impact the Allocation and AllocationList objects: https://review.openstack.org/#/c/282442 ?
14:08:22 <dansmith> mriedem: it's what I was saying we should be fast-tracking, yes
14:08:27 <mriedem> dansmith: ok, cool
14:08:45 <dansmith> edleafe: I believe the allocation bits are outside that scope, although definitely related
14:09:20 <dansmith> edleafe: up to mriedem if he wants to consider them in or out, but we can make progress on the inventory bits before those, as we were only going to land inventory (not allocation) in mitaka
14:09:32 <mriedem> edleafe: that patch was already ok to get into newton
14:09:48 <edleafe> mriedem: ok thanks
14:09:53 <mriedem> edleafe: https://review.openstack.org/#/c/282442 is the last remaining thing for resource-providers
14:09:56 <mriedem> from what i'm told
14:10:23 <mriedem> would be good to get the subteam to review https://review.openstack.org/#/c/282442
14:10:25 <edleafe> I was confused by the topic on that being resource pools
14:10:43 <mriedem> edleafe: yeah, the topics and ordering are confusing
14:10:45 <edleafe> #action Scheduler subteam to review https://review.openstack.org/#/c/282442
14:10:50 <mriedem> i'll add https://review.openstack.org/#/c/282442 to the priorities etherpad along with the inventory spec
14:11:42 <edleafe> #agreed compute-node-inventory spec to proceed;generic-resource -pools to wait until post-summit
14:11:52 <edleafe> ^^ Does that sound right?
14:11:58 <jaypipes> sure
14:12:13 <edleafe> ok, then - moving on...
14:12:16 <jaypipes> hold up.
14:12:18 <edleafe> #topic Reviews
14:12:33 <Yingxin> sorry
14:12:38 <edleafe> Are there any specific reviews (other than 282442) to discuss?
14:12:41 <Yingxin> the bp for scheduler functional test is ready, told it is a specless one.
14:12:43 <jaypipes> I'd like to please know what, if anything, needs to be changed on the compute-node-inventory spec in order for it to be approved.
14:12:49 <Yingxin> https://blueprints.launchpad.net/nova/+spec/scheduler-functional-test
14:13:02 <edleafe> #undo
14:13:03 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa39da50>
14:13:28 <edleafe> let's stick to specs now
14:14:08 <mriedem> for the inventory spec, i'd like to see dansmith and johnthetubaguy ok with that since they have been more involved in this than i have, i can go through it though
14:14:21 <mriedem> but i'll likely be in the dark on some of the implied stuff given dependencies
14:14:35 <edleafe> jaypipes: link for that spec?
14:14:38 <mriedem> https://review.openstack.org/#/c/260048/
14:14:44 <edleafe> thx
14:15:07 <edleafe> #link https://review.openstack.org/#/c/260048/
14:15:29 <mriedem> #help need review on compute node inventory spec https://review.openstack.org/#/c/260048/ - what else needs to be done?
14:16:11 <edleafe> Yingxin: you had some issues with that spec?
14:16:27 <Yingxin> edleafe: which spec?
14:16:35 <mriedem> Yingxin: https://review.openstack.org/#/c/260048/
14:16:56 <edleafe> what he said ^
14:17:12 <Yingxin> I have some comments made before.
14:17:41 <Yingxin> I need to review that again, nearly forget
14:18:01 <edleafe> Yingxin: ok, if you could do that soon, it would help
14:18:08 <mlavalle> edleafe: before we leave the specs topic, I want to propose to track this one https://review.openstack.org/#/c/253187 in this meeting. It is closely related to the scheduler and resource pools
14:18:59 <edleafe> mlavalle: uh, that was the first spec we discussed
14:19:19 <mriedem> mlavalle: the spec can continue to be worked, but it won't be approved before the summit
14:19:25 <jaypipes> I think mlavalle meant the routed networks spec :)
14:19:29 <mlavalle> edleafe: sorry, wrong url: https://review.openstack.org/#/c/263898/
14:19:38 <edleafe> mlavalle: :)
14:19:52 <jaypipes> mlavalle: yeah, I'll re-review that one later today on the plane flight.
14:20:19 <mlavalle> I just want to mention today that carl_baldwin added some clarity on the 3 use cases to be served
14:20:50 <Yingxin> edleafe: jaypipes: yes, I found some issues there, but no one replies till now
14:20:52 <mlavalle> and that I added a proposal on how to handle the use case where the user creates the port in Neutron with an ip address
14:20:54 <edleafe> #link https://review.openstack.org/#/c/263898/
14:21:29 <mriedem> mlavalle: the routed networks spec won't be approved before the summit, but it would be good to come prepared to the summit with anything that needs to be discussed about that one, i'm assuming we'll have a nova/neutron cross-project session
14:21:58 <mlavalle> mriedem: that's ok, I just want to gather as much feedback as possible before Summit
14:22:26 <mlavalle> mriedem: and yes, let's add it to the Neutron-Nova agenda during summit
14:22:26 <edleafe> Yingxin: you wanted to discuss https://blueprints.launchpad.net/nova/+spec/scheduler-functional-test ?
14:22:38 <Yingxin> edleafe: yes
14:23:12 <Yingxin> I also have a prototype there: https://review.openstack.org/#/c/281825/
14:23:34 <Yingxin> I was told that this bp doesn't need a spec.
14:24:22 <edleafe> Yingxin: I wouldn't think so, but in any case it won't get approved before the summit
14:24:56 <mriedem> well,
14:25:15 <edleafe> mriedem: ?
14:25:24 <mriedem> we never really talked about specless bp's, especially ones for testing, this is arguably not needing a blueprint at all
14:25:30 <mriedem> since it's just testing
14:26:15 <mriedem> but i'd want to know if the scheduler sub-team thinks this is valuable to get in to help with testing the other things that are approved to get in right now, like resource providers and compute node inventory
14:26:31 <edleafe> mriedem: ok, but it *is* new work that wasn't targeted for Mitaka
14:26:47 <mriedem> ya, but it's testing
14:27:20 <mriedem> anyway, if you guys think it's valuable and helps with the other stuff that is approved, then we should consider it
14:27:26 <jaypipes> mriedem: I'll review it today.
14:27:47 <edleafe> mriedem: ok, wasn't sure where the line was drawn for new stuff
14:28:07 <edleafe> #link https://review.openstack.org/#/c/281825/
14:28:15 <edleafe> Any more spec discussion?
14:28:17 <Yingxin> many features need schduler functional tests
14:29:21 <edleafe> #topic Reviews
14:29:49 <edleafe> Are there any reviews that we haven't yet discussed that need attention?
14:30:26 <jaypipes> https://review.openstack.org/#/c/286931 compute_node_statistics() rework with new DB schema
14:31:22 <edleafe> jaypipes: brings back memories...
14:32:15 <edleafe> at least postgres is happy with it now
14:32:27 <edleafe> Any other reviews?
14:32:34 <Yingxin> hmm, maybe remove -2 for https://review.openstack.org/#/c/292362/ ?
14:32:55 <Yingxin> I think I should ping sbauza, he's not here today
14:33:09 <mriedem> Yingxin: yeah just ping bauwser when he's available to remove the -2 on https://review.openstack.org/#/c/292362/
14:33:22 <mriedem> europe is still on holiday today
14:33:37 <Yingxin> mriedem: thanks
14:34:05 <edleafe> Any other reviews?
14:34:32 <mriedem> Yingxin: question on that change,
14:34:41 <Yingxin> mriedem: yes?
14:34:44 <mriedem> are you saying quotas are the last thing in the scheduler that have direct db access?
14:35:15 <Yingxin> mriedem: yes, I've run the scheduler on the different host
14:35:35 <Yingxin> mriedem: only quota will raise exception
14:35:59 <mriedem> then you should also add a change that blocks db access for the scheduler service, like we do for nova-network here https://github.com/openstack/nova/blob/master/nova/cmd/network.py#L42-L53
14:36:49 <Yingxin> mriedem: ok, will add that, thx
14:37:29 <edleafe> Any other reviews?
14:37:50 <edleafe> #topic Opens
14:38:02 <edleafe> Austin Design Summit ideas
14:38:13 <edleafe> https://etherpad.openstack.org/p/newton-nova-summit-ideas
14:38:21 <edleafe> The scheduler part starts around line 135
14:39:22 <edleafe> Just some rough ideas there now; feel free to add yours and we can discuss in future meetings
14:40:21 <edleafe> Also, I need someone to chair next 2 meetings on April 4 & 11
14:40:51 <edleafe> Normally bauzas would fill in, but he's not here, so if anyone else wants to get in on the fun, now's your chance!
14:41:04 <mriedem> edleafe: make cdent do it
14:41:22 <mriedem> edleafe: probably just ask bauwser tomorrow
14:41:41 <edleafe> mriedem: I was planning on that
14:41:51 <edleafe> But I like the cdent idea...
14:42:09 <edleafe> Anyone else have anything to discuss?
14:42:35 <mriedem> nope
14:42:47 * edleafe hears crickets
14:42:48 <mriedem> le'ts get that allocation objects patch reviewed and merged this week
14:43:00 <mriedem> i challenge you all! :)
14:43:10 <edleafe> oooohh, a challenge!
14:43:35 <mriedem> a shiny nickel to whomever brings me the head of colonel montoya by the start of the rainy season
14:43:42 <jaypipes> and the compute_node-statistics one please.
14:43:51 <jaypipes> and the compute-node-inventory spec please.
14:44:33 <mriedem> end it
14:44:41 <edleafe> Looks like we have enough to keep us busy
14:44:47 <edleafe> #endmeeting