13:59:49 <edleafe> #startmeeting nova_scheduler
13:59:50 <openstack> Meeting started Mon Nov  7 13:59:49 2016 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:53 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:06 <bauzas> \o for 25 mins
14:00:12 <edleafe> huh, my laptop is off by a minute
14:00:20 <cdent> o/
14:00:21 <alex_xu> o/
14:00:40 <Yingxin> o/
14:00:45 * bauzas imagines edleafe running to finding a power cable :)
14:00:58 <edleafe> jaypipes said something about having a meeting...
14:01:15 <bauzas> oh, you guys shifted time too
14:01:19 <edleafe> so he may or may not be here
14:01:39 <bauzas> like I said in -nova, I will need to leave by 1425UTC
14:01:39 <edleafe> bauzas: Yeah. 8am instead of 9am for me
14:01:57 <bauzas> I could be back by 20 mins later
14:02:28 <edleafe> #topic Specs and Reviews
14:02:34 <edleafe> Nothing added to the agenda
14:02:50 <edleafe> And I'm on my first day back after a wonderful holiday in Barcelona
14:02:59 <edleafe> So I have no idea what's going on :)
14:03:14 <edleafe> Anyone want to put something up for discussion?
14:04:07 * edleafe thinks everyone else is also recovering
14:04:19 <bauzas> well, we're still needing a bit of discussion around the possible REST API for get me a list of RPs
14:04:39 <edleafe> bauzas: has that been happening?
14:04:45 * alex_xu can't recover due to he know still have people enjoy vacation in Barcelona
14:04:46 <bauzas> but that can wait a bit since I rebased my patch into a couple of changes
14:04:47 <edleafe> the discussion, I mean
14:04:51 <bauzas> edleafe: nope
14:04:55 <bauzas> edleafe: nothing yet
14:05:02 <edleafe> ok
14:05:07 <edleafe> probably best on the ML?
14:05:13 <bauzas> please no
14:05:17 <edleafe> why?
14:05:20 <edleafe> lag?
14:05:36 <bauzas> because we have already a list of very opiniated people that I don't want to grow :)
14:05:53 <bauzas> we somehow need to have a synchronous call
14:06:01 <bauzas> that's what missing
14:06:06 <bauzas> what's*
14:06:18 <edleafe> IMO a synchronous call works when the options are already laid out for people to consider
14:06:29 <bauzas> edleafe: I think we passed thru all the options
14:06:44 <bauzas> edleafe: now we need to pick the one that makes consensus
14:06:59 <edleafe> So is there a summary that people like me who haven't been keeping up-to-date can review?
14:07:02 <cdent> edleafe: we agreed at the last day of summit that we'd have a hangout in the following week, but we put it off to this week so more people (notably you) would be around
14:07:10 <bauzas> and for that, a synchronous call is fine by me
14:07:25 <bauzas> yeah that
14:07:35 <edleafe> cdent: heh, I figured you would do in that week precisely because I wouldn't be around! :)
14:07:45 <cdent> :)
14:07:58 <bauzas> cdent: edleafe: either way, it's public by https://review.openstack.org/#/c/392569/ anyone can already give their opinion :)
14:08:08 <cdent> I agree a summary doc would be nice. I think what we have instead are the etherpad and the review
14:08:10 <bauzas> no need to open a ML thread since we have Gerrit :)
14:08:15 <edleafe> #link https://review.openstack.org/#/c/392569/
14:08:33 <edleafe> bauzas: cool. As long as there is _something_ written
14:08:45 <bauzas> FWIW https://review.openstack.org/#/c/386242/6 is decoupled from the REST API change and can be rewieded as it is
14:08:53 <bauzas> reviewed*
14:08:57 <edleafe> So now we just need to find a time that works for most people?
14:09:03 <bauzas> zactly
14:09:09 <bauzas> that can be done in -nova
14:09:14 <edleafe> yep
14:09:15 <alex_xu> +1 for summary doc, there are too many discussion happened when i'm sleeping
14:09:21 <bauzas> once all interested parties are there
14:09:27 <edleafe> alex_xu: stop sleeping so much!!!
14:09:29 <edleafe> :)
14:09:32 <bauzas> alex_xu: I remember some etherpad
14:09:33 <alex_xu> edleafe: heh
14:10:05 <bauzas> alex_xu: but I can surely highlight you when discussing on IRC so you can catch-up the day after by your proxy
14:10:11 <edleafe> bauzas: so is that review current? Can we use that as our starting point?
14:10:28 <alex_xu> bauzas: thank you, that is cool!
14:10:30 <bauzas> edleafe: yup, as fresh as any fish recently snapped
14:10:52 <edleafe> mmmmmm.... fresh fish...
14:11:23 * bauzas wanted edleafe to be nostalgic from BCN
14:11:44 <edleafe> I think we ate our way across BCN this past week
14:11:50 <edleafe> (and drank!)
14:12:22 <bauzas> anyway, that's it for me: review https://review.openstack.org/#/c/386242/6 and yell on https://review.openstack.org/#/c/392569/4
14:12:22 <edleafe> OK, so I'll try to herd all you cats to come up with a meeting time for a hangout
14:12:56 <edleafe> #action edleafe to organize a hangout that is at a time convenient to all involved
14:13:24 <edleafe> Anything else?
14:14:13 <edleafe> #topic Opens
14:14:27 <edleafe> The floor is open. Anything else to discuss?
14:14:38 <cdent> Just to again point out the newton leftovers:
14:14:41 <cdent> #link: https://etherpad.openstack.org/p/placement-newton-leftovers
14:15:14 <cdent> I've started on some of those, and added links to the code that's being created. _gryr and macsz have said they are going to help out but there's plenty in there for others too
14:15:50 <edleafe> OK, that sounds great
14:15:55 <edleafe> Anything else?
14:15:58 <cdent> sorry, _gryf
14:16:11 * cdent has his monday typing hands
14:16:14 <cdent> they not so good
14:16:35 <bauzas> some custom resource class patches are in good hand
14:16:47 <bauzas> but I had a question before +Wing the bottom one
14:17:02 <edleafe> bauzas: Link?
14:17:24 <bauzas> edleafe: https://review.openstack.org/#/c/386843/ is having a question to jaypipes
14:17:40 <edleafe> thanks
14:17:48 <bauzas> honestly, I think we're fine but I wanted to make sure that we can leave it as it is
14:18:08 <bauzas> honestly not a big deal, if no answer by tonight my time, I'll +W and discuss that for a follow-up
14:18:29 <edleafe> sounds like a good plan
14:18:32 <edleafe> Anything else?
14:18:52 <edleafe> Otherwise we get to wrap up before bauzas has to leave!
14:19:19 <bauzas> edleafe: I haven't forgotten your request to clarify my RequestSpec modification BP
14:19:40 * edleafe has forgotten everything this past week
14:20:04 <edleafe> bauzas: ok, ping me when it's ready
14:20:05 <bauzas> edleafe: given we're pretty close to spec freeze and given I sincerely hope that effort being specless, I'll try to provide that blueprint for the next nova meeting so mriedem could ack/nack
14:20:41 <edleafe> OK, anything else?
14:20:45 <bauzas> edleafe: me was speaking of the internal RPC cleanup for passing the spec object down to the compute
14:21:05 <bauzas> (and removing the old code for primitiving that to dict)
14:21:33 <edleafe> yeah, let the objects handle that
14:22:03 <edleafe> So are we done?
14:22:08 <cdent> looks like it
14:22:18 <edleafe> Thanks, everyone!
14:22:21 <edleafe> #endmeeting