14:00:09 <edleafe> #startmeeting nova_scheduler
14:00:10 <openstack> Meeting started Mon Nov 21 14:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:20 <edleafe> anyone here today?
14:01:01 <alex_xu> o/
14:01:12 * _gryf is lurking
14:01:58 <jaypipes> o/
14:01:59 <edleafe> I knew it would be quieter today, but...
14:02:00 <edleafe> :)
14:02:13 <jaypipes> morning folks :)
14:02:21 <jaypipes> note: cdent is out sick today.
14:02:27 <edleafe> morning jaypipes
14:02:40 <edleafe> sorry to hear
14:03:04 <edleafe> Let's start
14:03:20 <edleafe> #topic Last spec
14:03:31 <edleafe> #link https://review.openstack.org/#/c/300178/
14:03:44 <edleafe> Still needs +2s. No disagreement
14:03:55 <edleafe> Do we need an exception?
14:05:05 <jaypipes> edleafe: that's up to mriedem I think.
14:05:29 <edleafe> that's what I thought
14:05:53 <edleafe> #action edleafe to pester mriedem for exception for https://review.openstack.org/#/c/300178/
14:06:07 <jaypipes> edleafe: there's also the custom-resource-classes spec and the nested-resource-providers spec.
14:06:09 <edleafe> #topic Reviews
14:06:22 <edleafe> #undo
14:06:23 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7fac5534f9d0>
14:06:29 <jaypipes> c-r-c: https://review.openstack.org/#/c/312696/
14:06:53 <jaypipes> n-r-p: https://review.openstack.org/#/c/386710/
14:07:29 <jaypipes> edleafe: since there's code already merged for c-r-c, that should really be easy...
14:07:33 * _gryf need to catch up quickly with those
14:07:34 <edleafe> jaypipes: ok, I'll try to get all 3
14:07:40 <jaypipes> edleafe: and kind of same for n-r-p
14:07:45 <jaypipes> edleafe: thx
14:08:11 <edleafe> Any other specs?
14:08:50 <edleafe> #topic Reviews
14:09:11 <edleafe> There are several listed on the agebda
14:09:30 <edleafe> None of which show any strong disagreement
14:09:34 <jaypipes> edleafe: yeah, there's a bunch that need intel-nfv-ci rechecking.. :(
14:09:52 <jaypipes> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/custom-resource-classes
14:09:57 * edleafe cut his finger and is hunt-and-peck typing today
14:09:58 <jaypipes> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/custom-resource-classes
14:10:49 <edleafe> jaypipes: any which need particular attention?
14:11:27 <jaypipes> edleafe: all of them? :)
14:11:49 <jaypipes> edleafe: they all are failing intel-nfv-ci so need to recheck them once that CI is fixed.
14:11:50 <edleafe> ... where every child is above-average
14:11:56 <jaypipes> edleafe: :)
14:12:12 <jaypipes> edleafe: Lake Wobegone indeed.
14:12:15 <edleafe> yeah, saw the slew og failures
14:12:21 <edleafe> of
14:12:53 <jaypipes> does anyone other than me have reviews they need/want?
14:13:00 <jaypipes> bauzas: ?
14:13:21 <jaypipes> I believe the remaining cdent patch on aggregates is ready for final review/merge?
14:14:05 <edleafe> yes, those should be good to go
14:14:31 <alex_xu> found a race case at that patch, but not sure how to test it
14:14:33 <jaypipes> ok. and there were a number of reviews that  cdent had written about in his status email on friday.
14:14:40 <jaypipes> let's try to get to those as well.
14:14:53 <jaypipes> alex_xu: cool, will take a look and think about that.
14:15:22 <alex_xu> jaypipes: thanks, but I already +2, leave that to you make a decision :)
14:15:57 <edleafe> alex_xu: maybe a follow-up patch to handle the race?
14:16:37 <alex_xu> edleafe: that race already handled, just not sure how to test it. but i thought we didn't have test all the race cases
14:16:56 <edleafe> alex_xu: ah, I see
14:17:08 <jaypipes> alex_xu: np :)
14:17:13 <edleafe> alex_xu: haven't looked at that patch in a while
14:17:37 <alex_xu> edleafe: too many patches for scheduler :)
14:17:50 <jaypipes> is bauzas off today?
14:18:26 <edleafe> jaypipes: dunno, but I didn't see him in -nova
14:18:44 <_gryf> he was at the morning
14:19:25 <_gryf> although not very active
14:19:36 <edleafe> Which brings us to...
14:19:42 <edleafe> #topic Opens
14:19:53 <jaypipes> edleafe: POST vs. GET :)
14:19:54 <edleafe> This week is a big US holiday
14:20:22 <alex_xu> ah, that is why super quiet
14:20:33 <edleafe> I'm off starting tomorrow, so I won't be able to work on stuff after today
14:20:34 <jaypipes> edleafe: indeed, which is why I'm keen to front-load reviews and patches through Wednesday.
14:20:39 <jaypipes> gah.
14:20:51 <jaypipes> ok, do your best to get through reviews today then :)
14:21:04 <edleafe> jaypipes: that's the plan!
14:21:23 <jaypipes> coolio.
14:21:38 <edleafe> 6am flight tomorrow!
14:23:07 <jaypipes> alright, we good to wrap up and get back to work? :)
14:23:24 <edleafe> Unless anyone else has something
14:24:10 <johnthetubaguy> which one was the POST vs GET on again?
14:24:13 <johnthetubaguy> I lost track
14:24:33 <edleafe> johnthetubaguy: bauzas's spec that merged
14:24:46 <edleafe> we're going to fight it out in the code
14:24:49 <johnthetubaguy> ah, cool, it merged
14:25:44 <edleafe> Well, everyone back to work (or sleep, depending on time zone)
14:25:46 <edleafe> #endmeeting