14:00:02 <edleafe> #startmeeting nova_scheduler
14:00:03 <openstack> Meeting started Mon Dec 12 14:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:12 * edleafe yawns
14:00:15 <edleafe> Who's here?
14:00:33 <macsz> \o
14:00:45 <jaypipes> o/
14:01:38 <cdent> o/
14:02:01 <edleafe> Mondays are always slow...
14:02:30 <alex_xu> o/
14:02:36 <edleafe> Well, maybe we can make this quick
14:02:39 <cdent> did I remember to put "let's move the meeting" on the agenda?
14:02:43 <bauzas> \o
14:02:45 <edleafe> #topic Reviews
14:02:48 <edleafe> cdent: I did
14:02:54 <cdent> you star
14:03:07 <edleafe> We have several patches/series in progress
14:03:23 <edleafe> They were summed up nicely in cdent's email
14:03:34 <jaypipes> #link https://review.openstack.org/#/c/398469/
14:03:38 <edleafe> Is there anything about any of them to discuss?
14:03:51 <jaypipes> would be awesome to get eyeballs on the above patch series.
14:03:56 <edleafe> jaypipes: yes, the RT cleanup series
14:04:31 <edleafe> jaypipes: any problems, other than lack of eyeballs?
14:04:46 <jaypipes> edleafe: the reason that one is important is so we can avoid having lots of scheduler report client objects in memory on nova-compute's that handle Ironic requests.
14:05:18 <jaypipes> edleafe: no, no problems, just needs reviews.
14:05:25 <edleafe> jaypipes: cool
14:05:33 <jaypipes> edleafe: from cores. I believe you and cdent have already reviewed them.
14:06:00 <bauzas> roger.
14:06:06 <edleafe> #action edleafe to add the RT cleanup series to the etherpad for "ready for general review"
14:06:47 <edleafe> I'd like to clarify the model for the Ironic inventory
14:06:50 <edleafe> #link https://review.openstack.org/#/c/404472/
14:07:01 <electrocucaracha> o/
14:07:16 <edleafe> I had been under the impression that this was a classic use of nested RPs
14:07:36 <edleafe> jaypipes: can you clarify the model?
14:08:08 <jaypipes> edleafe: sure
14:08:21 <jaypipes> edleafe: each Ironic baremetal node is itself a separate resource provider.
14:08:36 <jaypipes> edleafe: each of those resource providers will have a single record for its inventory.
14:09:09 <jaypipes> edleafe: having a quantity of 1 for a resource class that matches the Ironic node.resource_class attribute (supplied from the Ironic API)
14:09:16 <jaypipes> edleafe: no nesting.
14:09:26 <edleafe> ok, thanks
14:09:50 <edleafe> I remembered you saying that each of those ironic RPs would be a child of a compute RP
14:10:03 <edleafe> But alzheimer's a bitch
14:10:50 <jaypipes> edleafe: :)
14:10:56 <edleafe> OK, so anything else to discuss regarding reviews?
14:11:10 <cdent> jaypipes, edleafe: I guess that means the area with lack of clarity is how any given compute node knows which baremetals it "cares for"?
14:11:27 <jaypipes> just that I rebased and fixed review comments on bauzas' patch for the GET /resource_providers?resources=XXX
14:11:40 <jaypipes> pushed it and needs follow up reviews.
14:12:08 * cdent enqueues
14:12:11 <edleafe> cdent: or whether a compute node cares at all anymore?
14:12:17 <jaypipes> #link https://review.openstack.org/#/c/392569/
14:12:21 <jaypipes> ^^ bauzas patch
14:12:27 <bauzas> jaypipes: thanks for that
14:12:31 <jaypipes> np
14:12:32 <cdent> edleafe: well presumably if the resource tracker does, then a compute node does?
14:13:23 <jaypipes> cdent: to answer your question, nothing about how that is *currently* handled is changing.
14:13:34 * cdent nods
14:13:49 <cdent> that's what I figured, I just wanted to make sure it was aired, as that seemed a gap in the above
14:13:57 <jaypipes> cdent: the compute_nodes table will still be storing the hypervisor_hostname field which is the mechanism used to do that association currently.
14:15:05 <jaypipes> cdent: eventually it would be great to have that "resource_provider_queue_mapping" table we discussed back in Portland. but that's a ways off.
14:15:29 <edleafe> what I remembered from our discussion was that nested RPs would provide that mapping
14:15:32 <cdent>14:17:21 <edleafe> Well, let's move on
14:17:25 <edleafe> #topic Opens
14:17:35 <edleafe> Two items on the agenda
14:17:45 <edleafe> First, should this be the last meeting for 2016?
14:17:56 <cdent> +1
14:18:01 <edleafe> I.e., skip the 19th?
14:18:44 <jaypipes> edleafe: no, nested providers relates two resource providers to each other. what we're referring to there is not a relationship between a resource provider and another resource provider but instead a resource provider and the *nova-compute* service worker that handles control plane requests.
14:18:45 <bauzas> I will probably be on PTO next week (ski season has begun)
14:19:00 <bauzas> I mean, only on Monday
14:19:07 <jaypipes> bauzas: enjoy :)
14:19:32 <edleafe> bauzas: I might be forced to be on PTO, due to company policy of not carrying over time off
14:19:40 <edleafe> still figuring that out
14:19:43 <jaypipes> edleafe: I'll be working next Monday. so if we want to do a little quick status update, I'm game.
14:19:54 <bauzas> jaypipes: already did :) https://twitter.com/sylvainbauza/status/806777384565227520
14:20:11 <jaypipes> bauzas: tres bien.
14:20:19 <cdent> i'll be around on monday too, but don't reckon we need an official meeting
14:20:22 <edleafe> bauzas: sweet
14:20:48 <jaypipes> edleafe: yeah, go ahead and cancel it for Monday. we can always do an informal catchup if folks are around.
14:20:50 <edleafe> OK, let's cancel the meeting, and if need be, get a hold of one another in -nova.
14:20:55 <edleafe> Sound good?
14:21:23 <cdent> aye
14:22:22 <edleafe> #agreed No meeting on December 19
14:22:38 <edleafe> OK, next up: Should we move the meeting time?
14:23:08 <edleafe> given bauzas school responsibilities, and the sleepiness of those in CST
14:23:09 <cdent> This was my suggestion, since it seems like it is inconvenient for bauzas.
14:23:12 <cdent> jinx
14:23:27 * bauzas shrgus
14:23:32 * cdent writes jinx as a service
14:23:33 * bauzas shrugs even
14:23:41 <edleafe> yeah, it was hard to find this time where we were all available
14:24:09 <edleafe> mainly due to a certain someone always being in meetings <cough>jaypipes<cough>
14:24:13 <bauzas> I mean, don't feel constrainted by me
14:24:20 <bauzas> constrained even
14:24:36 <edleafe> I like 'constrainted' better :)
14:24:40 * bauzas is not on a ski slope but looks like he's still wearing gloves
14:25:12 <cdent> I think if we're going to bother to have meetings at all then it is best that we have a time when both sylvain and jaypipes can be there with whatever most available attention happens to be.
14:25:51 <bauzas> the problem is that my Monday afternoons are always pretty busy
14:26:02 <bauzas> I have an internal meeting right after that one
14:26:21 <bauzas> well, actually depending on the time shift, but even
14:26:51 <bauzas> but the point is, I feel a bit ashamed if you feel you would move the meeting just because 2 of us
14:27:18 <edleafe> bauzas: well, we moved the meeting to this time because of 1 of you :)
14:27:20 <bauzas> I certainly understand how my French prose and my arguments can be missed by you guys
14:27:59 <bauzas> but I hopefully think some people are reading us without contributing to the discussion
14:28:10 <bauzas> either way
14:28:16 <edleafe> Well, it seems that it isn't a pressing need at the moment
14:28:17 <bauzas> if you feel you wanna move, okaty
14:28:23 <cdent> well, I guess we just leave it as is for now then, and visit it in the new year
14:28:33 <bauzas> agreed
14:28:35 <edleafe> Let's at least keep in mind that we can be flexible in the future if it becomes a problem
14:28:42 <bauzas> and the problem would be solved by the next timeshift
14:28:52 <bauzas> I mean, the DST
14:29:12 <bauzas> it's really a 6-month problem because school doesn't work UTC time weirdly
14:29:46 <edleafe> #agreed No immediate need to move the meeting time. Will revisit if necessary
14:30:09 <edleafe> That's all that was on the agenda. Anything else for Opens?
14:30:19 <cdent> I'd like a pony for christmas
14:30:37 <edleafe> #agreed cdent to get a pony for christmas
14:30:49 <cdent> \o/
14:31:08 <edleafe> ...and with that, I think we're done
14:31:13 <edleafe> #endmeeting