14:00:10 <edleafe> #startmeeting nova_scheduler
14:00:11 <openstack> Meeting started Mon Jul 24 14:00:10 2017 UTC and is due to finish in 60 minutes. The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:19 <edleafe> #link Agenda: https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Weekly_Nova_Scheduler_team_meeting
14:00:24 * gibi lurks
14:00:24 <edleafe> Who's here?
14:00:32 <ralonsoh> hi
14:00:44 <cdent> o/
14:00:54 <mriedem> o/
14:02:24 <edleafe> Ah, we can stretch out - not crowded at all!
14:02:27 <jaypipes> o/
14:02:58 <jaypipes> edleafe: I'm horizontally scalable. I consume quite a bit of room. Sorry.
14:03:13 <edleafe> jaypipes: :)
14:03:27 <edleafe> Guess we should get started
14:03:29 <edleafe> #topic Specs & Reviews
14:03:37 <edleafe> #link Amend spec for Custom Resource Classes in Flavors: https://review.openstack.org/#/c/481748/
14:03:43 <edleafe> This looks like its fine as is, but there are some lingering questions on the review
14:04:25 * bauzas waves
14:04:34 <edleafe> And this is the implementation of that spec amendment:
14:04:35 <mriedem> i just need to update wording
14:04:36 <edleafe> #link Migrate Ironic Flavors https://review.openstack.org/#/c/484949/
14:04:51 <cdent> i posted in response to mriedem on the os-dev list as well, with a related question (on rp update 29 thread)
14:04:53 <edleafe> I'm working on addressing dansmith's comments
14:05:09 * edleafe still has to catch up on dev list emails
14:06:11 <edleafe> #link Claims in the Scheduler - series starting with: https://review.openstack.org/#/c/486170/
14:06:27 <edleafe> jaypipes: How is that looking for FF Thursday?
14:06:50 <jaypipes> edleafe: err... just needs to get through the gate :)
14:07:01 <edleafe> ok, so just gate issues?
14:07:09 <jaypipes> ya
14:07:18 <bauzas> jaypipes: looks you need a rebase nope ?
14:07:18 <edleafe> kewl
14:07:23 <jaypipes> edleafe: I addressed all of your and mriedem's comments IIRC
14:07:36 <edleafe> jaypipes: it's in my review stack
14:07:39 <bauzas> jaypipes: I just +W'd the bottom change but it requires updating the others
14:07:41 <mriedem> jaypipes: in https://review.openstack.org/#/c/483566 ?
14:07:44 <jaypipes> edleafe: put a tight retry loop for claiming into the report client (the dep patch)
14:08:07 <jaypipes> mriedem: yes..
14:08:13 <mriedem> ok dropped the -1
14:08:16 <mriedem> will have to re-review
14:08:24 <jaypipes> mriedem: danke
14:08:37 <jaypipes> mriedem: how was beautiful South Dakota? :)
14:08:49 <mriedem> great
14:08:56 <bauzas> jaypipes: like I said https://review.openstack.org/#/c/483566/ needs to be rebased to be on top of the last rev of https://review.openstack.org/#/c/486170/
14:08:56 <jaypipes> good. happy times.
14:09:13 <mriedem> jaypipes: i wrestled 5 kids in a green lake for a full day, your dream
14:09:31 <jaypipes> bauzas: done
14:09:40 <bauzas> jaypipes: cool, will review shortly
14:09:41 <jaypipes> mriedem: eww.
14:09:49 <edleafe> Following up on that series:
14:09:51 <edleafe> #link Add alternate hosts: https://review.openstack.org/#/c/486215/
14:09:51 <bauzas> honestly, I'd make sure we land this one before Wed
14:10:10 <edleafe> I would appreciate some feedback on those patches
14:10:12 <bauzas> or we could enter the gate blackhole
14:10:32 <jaypipes> edleafe: I will review again shortly. it's top of my list this morning.
14:10:39 <jaypipes> edleafe: first run through looked sensible.
14:10:40 <edleafe> jaypipes: thanks
14:10:45 <mriedem> jaypipes: seems like you have a thing to change here https://review.openstack.org/#/c/483566/7/nova/scheduler/filter_scheduler.py@214
14:10:50 <mriedem> based on your comment for 'good catch'
14:11:03 <mriedem> and you didn't change it in the latest patch, otherwise the -1 would be gone from edleafe after the rebase
14:12:28 <jaypipes> mriedem: hrmph.
14:12:36 <jaypipes> mriedem: k, I thought I'd done that.
14:12:43 <jaypipes> mriedem: will be done in a pinch....
14:13:11 <edleafe> Next up:
14:13:13 <edleafe> #link Traits support in the Allocation Candidates: https://review.openstack.org/478464/
14:13:24 <edleafe> This should probably be merged/coordinated with
14:13:24 <edleafe> #link Add traits to the ResourceProviders filters: https://review.openstack.org/#/c/474602/
14:13:46 <edleafe> Both are doing similar things, but each on one of the 2 methods for returning RPs
14:14:06 <mriedem> we don't need those for pike right?
14:14:13 <mriedem> they seem like noise at this point
14:14:41 <edleafe> mriedem: yeah, I'm not spending time on them. Just noting them for completeness
14:15:05 <edleafe> Similarly:
14:15:06 <edleafe> #link Devstack to use resource classes by default: https://review.openstack.org/#/c/476968/
14:15:09 <edleafe> Currently marked as -W
14:15:19 <edleafe> and:
14:15:19 <edleafe> #link Nested Resource Providers: series starting with https://review.openstack.org/#/c/470575/
14:15:22 <edleafe> Still in limbo
14:15:37 <jaypipes> edleafe: without traits, nested r-ps is kinda neutered.
14:15:40 <bauzas> I'm confused about traits use for Pike
14:15:42 <jaypipes> edleafe: so might as well push.
14:15:59 * dtantsur is sorry, he could not spend much time on the resource classes patch
14:16:06 <bauzas> if we don't check them by the scheduler, how is it working if someone is updating a flavor ?
14:16:16 <jaypipes> dtantsur: it's cool. I said I'd look into the failure and haven't had a chance to yet :(
14:16:30 <dtantsur> releasezzz and broken gatezzzz
14:16:32 <bauzas> or is it just meaning the traits support is incomplete ?
14:16:36 <jaypipes> bauzas: the filters in the scheduler still check all qualitative stuff.
14:16:43 <edleafe> bauzas: support for traits in flavors won't make it in Pike
14:16:50 <jaypipes> bauzas: right. just the placement-scheduler integration of traits.
14:17:08 <edleafe> what jaypipes said
14:17:17 <jaypipes> bauzas: due to flavors not containing them and virt drivers not (yet) reporting them.
14:17:36 <bauzas> okay, thanks for clarifying
14:17:56 <bauzas> I wasn't fully on board due to my numerous leaves :(
14:18:21 <edleafe> Next up:
14:18:23 <edleafe> #link wsgi-intercept-based PlacementFixture: https://review.openstack.org/486237
14:18:27 <edleafe> cdent: anything to note?
14:18:52 <cdent> mriedem, melwitt and I discussed making that happen last friday so I made it happen. seems to work. just wanted to highlight it's existence as it ought to smooth the gate a bit
14:19:15 <cdent> also have a version of the same thing for the OSAPIFixture pending (it's a little more messy, but nearly there)
14:19:17 <mriedem> but, it failed
14:19:37 <cdent> sigh
14:19:45 <cdent> that's the first time in in 8(?) tries
14:20:47 <cdent> I saw those same two failures on some other changes too. I'll investigate later, but I suspect it is not a killer
14:20:50 <edleafe> Finally:
14:20:51 <edleafe> #link Placement api-ref docs: https://review.openstack.org/#/q/topic:cd/placement-api-ref+status:open
14:20:54 <edleafe> Looking very green!
14:21:23 <edleafe> Anything else for specs/reviews?
14:21:32 <jaypipes> not from me, thanks edleafe
14:22:15 <edleafe> #topic Bugs
14:22:18 <edleafe> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:22:25 <edleafe> Nothing new this week
14:23:01 <edleafe> #topic Open Discussion
14:23:12 <edleafe> Anyone have something on their mind?
14:24:04 <ralonsoh> hi
14:24:11 <edleafe> hi ralonsoh
14:24:19 <ralonsoh> I still have some reviews pending
14:24:33 <ralonsoh> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/enable-sriov-nic-features
14:24:47 <ralonsoh> The first you patches are needed for the feature
14:25:05 <ralonsoh> and I don't think there is time enough for Pike...
14:26:19 <ralonsoh> This feature is needed for OVS offload features (Nova and Neutron)
14:26:24 <edleafe> The first two look pretty solid
14:26:28 <ralonsoh> cool
14:27:56 <edleafe> #action All to review the Neutron port series https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/enable-sriov-nic-features
14:28:03 <ralonsoh> thanks!
14:28:12 <mriedem> the 2nd needs to be rebased on the 1st
14:28:46 <ralonsoh> in 1 min I'll do it
14:29:03 <edleafe> Anything else? Or is it time to get back to work/dinner/sleep?
14:29:51 <cdent> naw mate
14:30:05 <edleafe> OK, that's a wrap! Thanks everyone!
14:30:06 <edleafe> #endmeeting