14:00:31 <edleafe> #startmeeting nova_scheduler
14:00:31 <openstack> Meeting started Mon Aug 21 14:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:34 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:36 * edleafe can't spell
14:00:42 <edleafe> Who's here?
14:00:58 <gibi> o/
14:01:09 <cdent> o/
14:01:50 <cdent> you can spell edleafe it’s just that meetbot doesn’t understand your dialect
14:02:47 * edleafe channels Sarah Palin
14:04:16 <edleafe> Well, let's get started. We have plenty of room, so feel free to stretch out your legs
14:04:31 <edleafe> #topic Specs and Reviews
14:04:51 <dtantsur> o/
14:04:55 <edleafe> #link spec for returning allocation requests to the scheduler https://review.openstack.org/#/c/471927/
14:05:12 <edleafe> Jay posted this this morning
14:05:31 <edleafe> Looks pretty straightforward with the simplification
14:06:04 <edleafe> I revived my series to add alternates and allocation candidates to the value returned from the scheduler
14:06:08 <edleafe> And the WIP series to implement implement
14:06:08 <edleafe> #link Return alternates and allocations https://review.openstack.org/#/c/486253/
14:06:12 <edleafe> #link Add alternate hosts https://review.openstack.org/486215/
14:06:14 <edleafe> #link Scheduler returns allocations too https://review.openstack.org/#/c/495854/
14:06:46 <edleafe> Please take a look at those. They are marked WIP, because I think we need to have some design discussion
14:07:11 <edleafe> Returning a big glob of data feels icky
14:07:28 <cdent> do you talk about other ideas in those, or is that for here?
14:07:34 <edleafe> When you have to describe it as a list of lists of lists, you know it's gonna be fragile
14:08:01 <edleafe> Those just implement it straightforward
14:08:34 <edleafe> The first adds alternates, the second adds allocs to the (selcted+alts), and the third changes the signature
14:09:00 <edleafe> The more I worked with this, the more convinced I am that this is a huge stinking pile of tech debt
14:09:33 * cdent alerts the media
14:09:56 * alex_xu waves late
14:10:00 <edleafe> Yeah, we wouldn't want to spoil Nova's pristine, tech-debt-free code base
14:10:08 * edleafe waves back at alex_didenko
14:10:10 <edleafe> ugh
14:10:14 * edleafe waves back at alex_xu
14:10:20 <alex_xu> heh
14:10:32 <edleafe> two alex_* in the room?
14:11:19 <edleafe> I am thinking of writing a post to explain the problems I see, and maybe that could spur further discussions
14:11:32 <cdent> good
14:12:11 <edleafe> #action edleafe to write up his concerns about the scheduler returning huge nested data structures
14:12:14 <edleafe> #link Add alternate hosts https://review.openstack.org/486215/
14:12:14 <edleafe> #link Scheduler returns allocations too https://review.openstack.org/#/c/495854/
14:12:27 <edleafe> #undo
14:12:28 <openstack> Removing item from minutes: #link https://review.openstack.org/#/c/495854/
14:12:31 <edleafe> #undo
14:12:31 <openstack> Removing item from minutes: #link https://review.openstack.org/486215/
14:12:40 <edleafe> Sorry, copy/paste fail
14:13:04 <edleafe> Moving on...
14:13:05 <edleafe> Nested RPs to come out of their coma soon?
14:13:05 <edleafe> #link Nested RP series https://review.openstack.org/#/c/470575/
14:13:21 <edleafe> Was hoping to get jaypipes
14:13:25 <edleafe> geez
14:13:31 * edleafe need moar coffee!
14:13:43 <cdent> If possible, I’d like to see us pause for refactoring before diving into nested
14:13:46 <edleafe> Was hoping to get jaypipes's input on nested RPs
14:14:13 <cdent> if we go straight into that, the db code in the objects/resource_provider.py is going to from inscrutable to painfully inscrutable
14:14:48 <edleafe> cdent: well, that was one of the main reasons to keep placement in its own code base
14:15:15 <edleafe> Now we are cramming so much stuff into that one module it's messier than it needs to be
14:15:25 <cdent> arp
14:16:12 <edleafe> Well, that should be something we discuss and settle sooner rather than later
14:16:54 <edleafe> moving on...
14:16:56 <edleafe> #link Saner RT agg map updates https://review.openstack.org/#/c/489633/
14:17:04 <edleafe> cdent: that's yours
14:17:27 <cdent> yeah, that was prompted by me asking “what should I do?” and jay saying “do $that”
14:17:28 <cdent> so I did
14:17:37 <cdent> was relatively straightforward
14:17:55 <edleafe> ok, I have it open for re-review
14:18:11 <edleafe> #link Replace Chance with FilterScheduler in functional tests https://review.openstack.org/#/c/491529/
14:18:29 <cdent> that’s been +Wd
14:18:34 <edleafe> That has +W
14:18:43 <edleafe> Just wanted to be sure everyone saw it
14:18:56 <edleafe> Anything else for specs/reviews?
14:19:27 <cdent> just to mention that I’ve started adding last-modified headers, see os-dev for some discussion between jay and me. Still uncertain if it is fully worth it
14:19:41 <cdent> #link https://review.openstack.org/#/c/495380/
14:20:24 <edleafe> is this something that breaks a bunch of unit tests?
14:20:40 <edleafe> i.e., expecting certain headers?
14:21:21 <edleafe> oh, I see the failures. Not too bad
14:21:58 <cdent> it was sent up with known failures
14:22:36 <edleafe> So... anything else for specs/reviews?
14:23:15 <edleafe> #topic Bugs
14:23:20 <edleafe> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:23:27 <edleafe> 2 new ones today
14:23:34 <cdent> gibi’s colleague is the new gibi
14:23:50 <edleafe> I think gibi has started cloning himself
14:24:20 <cdent> he’s going on holiday, so is good
14:24:44 <gibi> :)
14:25:07 <edleafe> Any more for bug discussion?
14:25:45 <edleafe> #topic Open discussion
14:25:58 <edleafe> Now is the time to share what's on your mind
14:26:22 <cdent> anybody who hasn’t already done so please put your placement/scheduler related concerns on the ptg etherpad:
14:26:24 <cdent> #link https://etherpad.openstack.org/p/nova-ptg-queens
14:26:34 <cdent> who will be there?
14:26:51 <edleafe> \o
14:27:16 <gibi> o/
14:27:36 <cdent> o/
14:28:02 <alex_xu> o/
14:29:32 <edleafe> PTG starts 3 weeks from today
14:30:07 <edleafe> Anything else to discuss?
14:31:08 <cdent> not from me
14:31:32 <edleafe> OK, then, everyone back to whatever it was that you were doing!
14:31:34 <edleafe> #endmeeting