#openstack-meeting-alt: nova_scheduler

Meeting started by edleafe at 14:00:11 UTC (full logs).

Meeting summary

    1. Meeting Agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler (edleafe, 14:00:22)

  1. Specs (edleafe, 14:03:01)
    1. Granular Resource Request Syntax https://review.openstack.org/510244 (edleafe, 14:03:43)
    2. Add spec for symmetric GET and PUT of allocations https://review.openstack.org/#/c/508164/ (edleafe, 14:03:46)
    3. Support traits in the Ironic driver https://review.openstack.org/#/c/507052/ (edleafe, 14:03:49)
    4. https://review.openstack.org/#/c/507052/ is approved, just won't merge because of the depends-on (mriedem, 14:04:41)

  2. Reviews (edleafe, 14:08:47)
    1. Nested RP series starting with: https://review.openstack.org/#/c/470575/ (edleafe, 14:08:56)
    2. AGREED: Add root provider uuid to GET /resource_providers (edleafe, 14:14:28)
    3. Add traits to GET /allocation_candidates https://review.openstack.org/479776 (edleafe, 14:19:57)
    4. Add traits to get RPs with shared https://review.openstack.org/478464/ (edleafe, 14:21:33)
    5. Allow _set_allocations to delete allocations https://review.openstack.org/#/c/501051/ (edleafe, 14:24:55)
    6. WIP - POST /allocations for >1 consumer https://review.openstack.org/#/c/500073/ (edleafe, 14:26:06)
    7. Use ksa adapter for placement https://review.openstack.org/#/c/492247/ (edleafe, 14:26:47)
    8. Migration allocation fixes: series starting with https://review.openstack.org/#/c/498950/ (edleafe, 14:28:45)
    9. Alternate hosts: series starting with https://review.openstack.org/#/c/486215/ (edleafe, 14:29:56)

  3. Bugs (edleafe, 14:33:23)
    1. https://bugs.launchpad.net/nova/+bugs?field.tag=placement (edleafe, 14:33:36)
    2. placement server needs to retry allocations, server-side https://bugs.launchpad.net/nova/+bug/1719933 (edleafe, 14:33:44)
    3. Evacuate cleanup fails at _delete_allocation_for_moved_instance https://bugs.launchpad.net/nova/+bug/1721652 (edleafe, 14:34:45)
    4. https://review.openstack.org/#/c/510176/ (mriedem, 14:35:18)
    5. Functional test for bug 1721652 https://review.openstack.org/#/c/510176/ (edleafe, 14:36:50)

  4. Open Discussion (edleafe, 14:38:39)
    1. Getting allocations into virt http://eavesdrop.openstack.org/irclogs/%23openstack-nova/%23openstack-nova.2017-10-04.log.html#t2017-10-04T13:49:18-2 (edleafe, 14:38:58)


Meeting ended at 15:00:01 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. edleafe (77)
  2. mriedem (62)
  3. efried (60)
  4. jaypipes (28)
  5. dansmith (27)
  6. bauzas (22)
  7. cdent (14)
  8. openstack (7)
  9. alex_xu (7)


Generated by MeetBot 0.1.4.