14:00:03 <efried> #startmeeting nova_scheduler
14:00:04 <openstack> Meeting started Mon Jul 23 14:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:12 <cdent> o\
14:00:12 <mriedem> o/
14:00:29 <bauzas> hello folks
14:00:30 <tetsuro> o/
14:00:38 <bauzas> (back from sick days)
14:00:51 <takashin> o/
14:01:06 <gibi> o/
14:01:25 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Agenda_for_next_meeting
14:01:42 <efried> #topic last meeting
14:01:48 <alex_xu> o/
14:01:50 <efried> #link last minutes: http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-07-16-13.59.html
14:01:57 <efried> Any old business?
14:02:19 <jaypipes> o/ (kinda)
14:02:33 <efried> #topic specs and review
14:03:03 <efried> #link latest pupdate: http://lists.openstack.org/pipermail/openstack-dev/2018-July/132387.html
14:03:20 <efried> Comments, questions, concerns, or other feedback on the pupdate?
14:04:01 <efried> #link reshaper series: https://review.openstack.org/#/q/topic:bp/reshape-provider-tree+status:open
14:04:16 * mriedem hasn't read it yet
14:04:40 <efried> cdent and gibi co-discovered a bug this morning:
14:04:42 <efried> #link IndexError when clearing a provider's inventories: https://bugs.launchpad.net/nova/+bug/1783130
14:04:42 <efried> ...on the bottom patch, which is already gateward.
14:04:42 <openstack> Launchpad bug 1783130 in OpenStack Compute (nova) "placement reshaper doesn't clear all inventories for a resource provider" [Medium,Confirmed] - Assigned to Eric Fried (efried)
14:04:59 <efried> But since we're not consuming the thing yet, it's not worth yanking it out of the gate. I'm going to work a fix after this meeting.
14:05:56 <mriedem> the reshaper api change is approved?
14:06:03 <efried> No
14:06:06 <efried> just the db side
14:06:14 <mriedem> so https://review.openstack.org/#/c/582383/
14:06:20 <efried> yes
14:06:24 <efried> The API change is the second patch
14:06:24 <efried> #link reshaper handler & microversion https://review.openstack.org/#/c/576927/
14:06:30 <mriedem> and the regression is *just* for the reshaper flow?
14:06:35 <bauzas> I'll try to review those
14:06:46 <efried> mriedem: yes, it's not a regression, just a bug in the new code.
14:06:50 <mriedem> ok
14:07:02 <efried> The API patch (above) is still running afoul of https://bugs.launchpad.net/nova/+bug/1782340
14:07:02 <openstack> Launchpad bug 1782340 in OpenStack Compute (nova) "allocation schema does not set additionalProperties False in all the right places" [Medium,In progress] - Assigned to Chris Dent (cdent)
14:07:11 <efried> Which we need to discuss here.
14:07:36 <efried> openstack: cdent has proposed a
14:07:36 <efried> #link "just fix it" fix for bug 1782340: https://review.openstack.org/#/c/583907/
14:07:42 <efried> that was weird
14:08:08 <efried> anyway, we need to decide whether it's acceptable to break the rules and just fix it, or insist on a microversion.
14:08:11 <mriedem> how far along are the nova compute side bits to consume reshaper at this point?
14:08:34 <efried> mriedem: Will get to that in after we discuss --^
14:08:43 <bauzas> mriedem: good question
14:08:44 <efried> s/in//
14:08:54 <bauzas> mriedem: that's why I need to review the series
14:09:00 <bauzas> to know how to consume it
14:09:09 <bauzas> but not for this cycle
14:09:21 <efried> I expressed my opinion in the review. By the rules, we need a microversion. But we should break the rules and not do one.
14:10:02 <cdent> efried: that's the majority opinion, so if majority rules, we're good to go
14:10:04 <mriedem> i hedged on the bug report https://bugs.launchpad.net/nova/+bug/1782340/comments/8
14:10:04 <openstack> Launchpad bug 1782340 in OpenStack Compute (nova) "allocation schema does not set additionalProperties False in all the right places" [Medium,In progress] - Assigned to Chris Dent (cdent)
14:10:33 <mriedem> i won't fight against just fixing this w/o a microversion if that helps
14:10:39 <efried> Good enough for me. So let's get a second core to +A that sucker and get the series moving.
14:11:16 <efried> cdent: wait, is that the bug that's blocking the reshaper API patch?
14:12:05 <efried> jaypipes: Can you see well enough to push that patch? It's just 16LOC and very simple.
14:12:30 <cdent> efried: yes, I didn't base it into the tree because stuff was too in-flight. I figured I'd wait until jay's thing merges
14:12:44 <cdent> or just let it merge all on its lonesome
14:13:15 <efried> wfm. I'm going to need to take over the pile to fix the IndexError bug, so I'll do whatever rebase shuffling is necessary at that time.
14:13:50 <efried> gibi: Maybe you want to save jaypipes's eyeballs and push https://review.openstack.org/#/c/583907/ for us?
14:13:53 <mriedem> we can find the cores after the meeting to deal with it, let's let jaypipes heal a bit
14:14:00 <jaypipes> efried: done
14:14:04 <efried> Thanks jaypipes
14:14:12 <efried> moving onward.
14:14:17 <gibi> efried: ack
14:14:22 <cdent> efried: I'll push up my pending code on /reshaper after we're done here, and then be hands off for the rest of my day
14:14:24 <efried> gibi: cancel, jaypipes got it.
14:14:29 <gibi> :)
14:14:32 <efried> cdent: what do you have pending?
14:14:33 * jaypipes goes to make a homemade eyepatch. yarr.
14:14:47 <cdent> efried: the test that found the bug and...
14:15:06 <cdent> fixes as suggested by gibi
14:15:21 <cdent> (which is moving a thing inside the nested exception)
14:15:39 <cdent> and your suggestion about an improved debug message
14:16:00 <efried> Okay, the client side:
14:16:00 <efried> #link client side cumulative patch https://review.openstack.org/#/c/576236/
14:16:08 <cdent> jaypipes: I require that you go out on a boat. Even only briefly
14:16:16 <efried> To answer mriedem, ^ has all the code side written, but no tests yet.
14:16:44 <efried> That patch is already big, so as I started writing tests, I started breaking it up into smaller pieces for ease of review.
14:17:20 <efried> Those start here:
14:17:21 <efried> #link bottom of the new-and-improved reshaper client side series https://review.openstack.org/#/c/584598/
14:17:51 <efried> It's still pretty early days, but that's my main focus from now until it's done.
14:18:20 <mriedem> ok, can we agree to hold off on merging the reshaper api change until we have a good pass on the client side changes?
14:18:25 <efried> That cumulative patch will be either abandoned or drastically trimmed to comprise some part of that series, but if you want to look at it now to get an overview of how things are gonna work, it's there.
14:18:54 <efried> mriedem: That's a fair idea. I'll -2...
14:19:33 <efried> ...done.
14:19:39 <cdent> mriedem: that was the original idea on the back end too, but we ... forgot basically
14:19:51 <efried> The back end is not a big deal.
14:19:59 <efried> we can keep fixing that
14:20:08 <efried> We just don't want to burn a microversion if we can help it.
14:20:26 * cdent knows
14:20:36 <mriedem> cdent: as long as the backend was a new thing and not a big refactor/merge of existing functionality, then that's fine
14:20:41 <mriedem> that's why i was worried about a regression
14:21:13 <efried> mriedem: Yup, good call.  It is (a totally new thing).
14:21:30 <efried> Anything else for reviews?
14:21:45 <efried> Any non-reshaper specs/reviews anyone wants to bring up?
14:22:01 <efried> oh, here, lemme make the minutes prettier:
14:22:37 <efried> #agreed to "just fix" https://bugs.launchpad.net/nova/+bug/1782340 via https://review.openstack.org/#/c/583907/ without a microversion.
14:22:37 <openstack> Launchpad bug 1782340 in OpenStack Compute (nova) "allocation schema does not set additionalProperties False in all the right places" [Medium,In progress] - Assigned to Chris Dent (cdent)
14:23:19 <efried> #agreed to put a procedural hold on the reshaper API change https://review.openstack.org/#/c/576927/ until the client side matures, so we don't burn a microversion.
14:24:37 <efried> #agreed no need to pull the db side reshaper patch https://review.openstack.org/#/c/582383/ out of the gate for https://bugs.launchpad.net/nova/+bug/1783130 since it's all new code, no regressions in existing.
14:24:37 <openstack> Launchpad bug 1783130 in OpenStack Compute (nova) "placement reshaper doesn't clear all inventories for a resource provider" [Medium,Confirmed] - Assigned to Eric Fried (efried)
14:24:42 <efried> Moving on.
14:24:50 <efried> #topic bugs
14:24:55 <efried> #link placement bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=placement&orderby=-id
14:25:34 <efried> Anyone have anything specific to discuss on bugs?
14:26:05 <efried> #topic opens
14:26:21 <efried> Planning/Doing support in nova/report client for:
14:26:21 <efried> #link consumer generation handling (gibi): https://review.openstack.org/#/c/583667/
14:26:41 <efried> This is getting active work/review.
14:27:03 <efried> nested and shared providers for initial allocations
14:27:03 <efried> nested and shared providers when modifying migration (and other?) allocations
14:27:03 <efried> These haven't been started afaik
14:27:25 <efried> whatever else is not being remembered right now <== anyone have anything specific we can add to the list?
14:27:59 <efried> next up
14:28:01 <efried> os-resource-classes alternative:
14:28:12 <efried> #link library spike: https://github.com/cdent/os-resource-classes
14:28:12 <efried> #link placement integration spike: https://review.openstack.org/#/c/584084/
14:28:39 <efried> cdent and I discussed some of this over the weekend via reviews on both of those.
14:28:44 <cdent> what I'm after with those is "shall I carry on or is that not a good way to go?"
14:29:37 <efried> What's really needed at this point is a discussion including both cdent and jaypipes to figure out which way (or some other option not yet proposed) we want to go on os-resource-classes, so we can move forward.
14:30:03 <mriedem> that's probably ptg fodder at this point yeah?
14:30:15 <mriedem> https://etherpad.openstack.org/p/nova-ptg-stein
14:30:17 <efried> #link jaypipes' os-resource-classes proposal: https://github.com/jaypipes/os-resource-classes
14:30:17 <mriedem> throw it on the big board
14:30:27 <cdent> omg, that's like _years_ away
14:30:30 <cdent> :D
14:30:34 <efried> I read "pig fodder". I need *my* eyes checked.
14:32:27 <efried> Okay, I added it to the etherpad. But I kinda hope we can discuss it before then.  As cdent notes, the ptg is a ways off, and it would be nice to get this done soonish so we can focus on other, harder extraction topics in Denver.
14:32:53 <mriedem> sure,
14:32:56 <mriedem> my point is,
14:33:12 <mriedem> we need to focus this week and avoid any noise on stuff that's not going to happen in rocky
14:33:26 <efried> point taken
14:33:38 <cdent> speaking of "harder extraction topics". Whatever they are, can people add those to etherpad too (line 36-ish)
14:33:59 <cdent> (probably something slightly less than 36)
14:35:15 <efried> Okay, any other topics for open discussion?
14:35:44 <efried> 3
14:35:49 <efried> 2
14:35:50 <mriedem> i need review
14:35:57 <mriedem> on sync_aggregates https://review.openstack.org/#/c/575912/
14:36:01 <mriedem> to close out that bp
14:36:20 <efried> #link Add nova-manage placement sync_aggregates https://review.openstack.org/#/c/575912/
14:36:28 <mriedem> at this point i think with efried's changes to how aggregate generation and conflicts are handled in report client i could probably re-use that code in the report client for this change,
14:36:35 <mriedem> but i'm not sure i'll have time to re-write this in time for FF
14:36:52 <mriedem> so i'm proposing we defer the refactor, get this in for FF and then i can refactor later
14:37:01 <bauzas> mriedem: again, I'm slowly returing full steam
14:37:09 <bauzas> mriedem: ping me for your sync_aggs serie
14:37:16 <mriedem> bauzas: ok, consider yourself pinged then
14:37:19 <efried> I'll take a look at it mriedem. If I can see a path to refactor, would you be amenable to me doing it?
14:37:27 * bauzas opening a tab then
14:37:42 <mriedem> efried: then you probably can't +2 it
14:37:49 <mriedem> and with it taking a week to merge code...
14:38:03 <mriedem> efried: your +2 is more valuable at this point
14:38:22 <efried> okay, it's on my radar anyway.
14:38:26 <efried> to review
14:38:36 <mriedem> i have a TODO in there for handling generatoin conflicts,
14:38:41 <mriedem> so there is a marker to eventually clean that up
14:39:05 <jaypipes> I've got a series of patches that splits out the resource_provider.py object file for placement into multiple files. been waiting to push it until the reshape stuff is cleared.
14:39:17 <efried> ++ love that idea.
14:39:34 <efried> that file is >4KLOC
14:39:38 <bauzas> jaypipes: given FF is next week, probably a good idea to wait next week ;)
14:39:49 <efried> yeah, that's a thing that can totally be done after FF.
14:39:56 <bauzas> or people would scream about merge conflicts :p
14:40:42 <mriedem> bauzas: it's this week
14:40:44 <mriedem> thursday
14:40:48 <bauzas> oh shit
14:41:04 <mriedem> bauzas: and it's taking about a week to merge code right now
14:41:07 <bauzas> that's what happens when you have 2 weeks off
14:41:20 <efried> yeesh, wir haben sehr viel zu tun
14:42:06 <efried> okay, so unless there's anything else, let's go make code happen
14:42:23 <efried> #endmeeting