14:00:06 <efried> #startmeeting nova-scheduler
14:00:07 <openstack> Meeting started Mon Oct 22 14:00:06 2018 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:31 <edleafe> \o
14:01:22 <cdent> o/
14:02:02 <takashin> o/
14:02:03 <tetsuro> o/
14:02:26 <alex_xu> o/
14:02:50 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Agenda_for_next_meeting
14:02:57 <mriedem> o
14:03:17 <efried> Not a lot going today. If you have something to discuss, get ready to draw.
14:03:31 <efried> #topic last meeting
14:03:31 <efried> #link last minutes: http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-10-15-14.00.html
14:03:31 <efried> Any old business?
14:03:40 * cdent stands ready
14:04:07 <efried> #topic specs and review
14:04:07 <efried> #link latest pupdate: http://lists.openstack.org/pipermail/openstack-dev/2018-October/135877.html
14:04:07 <efried> Spec review tomorrow. ^ has a nice list of placement-related specs.
14:04:28 <efried> I will be spending today working on a new "placement config yaml file" spec.
14:05:18 <cdent> resource provider config yaml spec, yes?
14:05:55 <efried> Yes, that makes more sense. It will be a synthesis of
14:05:55 <efried> #link Jay's Rocky provider-config-file proposal: https://review.openstack.org/#/c/550244/2/specs/rocky/approved/provider-config-file.rst
14:05:55 <efried> and the file format bits of
14:05:55 <efried> #link Konstantinos's device-placement-passthrough spec: https://review.openstack.org/#/c/591037/8/specs/stein/approved/device-placement-model.rst
14:05:55 <efried> (which was based on
14:05:56 <efried> #link Eric's device-passthrough spec: https://review.openstack.org/#/c/579359/10/doc/source/specs/rocky/device-passthrough.rst
14:05:56 <efried> )
14:06:21 * cdent blinks
14:06:35 <cdent> it will be nice for there to be options to be explicit
14:06:54 <efried> what do you mean?
14:07:56 <cdent> a provider config file allows people to make statements about the config of their providers, explicitly, rather than the virt driver producing a bunch of things that _might_ be different from desired
14:08:08 <cdent> (just make a general assertion that ambiguity is no fun)
14:09:01 <efried> oh, don't worry, there will still be plenty of non-fun ambiguity. I imagine most of the time people will compose their provider.yaml files after first seeing what nova/virt does to their providers by default.
14:09:11 <cdent> hawt
14:09:43 <efried> but the hope is that said provider.yaml file will allow you to tweak most of the things you would want to tweak, and their presence in that file will do what you would expect.
14:10:05 <efried> Anything else about specs?
14:10:32 <cdent> not from me
14:10:57 <efried> #link nrp use in nova: Series still starting at https://review.openstack.org/#/c/606050/ (no change since last week)
14:10:57 <efried> Matt asked for a rebase on some cleanup patches that'll make the series more sane and less confusing.
14:11:10 <efried> gibi_off: is off today and tomorrow, plans to get to it on Wed.
14:11:45 <efried> Any other reviews to bring up?
14:11:55 <cdent> nawp
14:12:00 <mriedem> that rebase,
14:12:06 <mriedem> will depend on dropping the caching scheduler
14:12:06 <cdent> oh, actually...
14:12:13 <mriedem> i don't know how long that needs to sit
14:12:33 <mriedem> the one user i know of has +1ed the removal
14:12:35 <mriedem> and it's in the ML
14:12:46 <efried> It went like a whole weekend, didn't it?
14:13:12 <mriedem> i'd say once gibi gets his series rebased then it's ok to drop if no one has spoken up by then
14:13:33 <efried> wfm
14:13:40 <cdent> that. will. be. awesome.
14:14:03 <efried> cdent: did you have reviews to bring up? (other than Extraction which will be a separate topic)
14:14:24 <cdent> What I was gonna say is that the stack of grenade, devstack, tempest, integration test, etc, jobs is hung up on needing some database stuff. Right now it uses a stub table creator:
14:14:29 <cdent> #link stub table creator https://review.openstack.org/#/c/600161/
14:14:46 <efried> #topic Extraction
14:14:46 <efried> (^ /me just decided this gets its own topic)
14:14:50 <cdent> which _might_ be useful to go ahead and merge as a temporary thing so we can move those integration tests forward
14:15:13 <mriedem> why aren't we just waiting for alembic stuff?
14:15:31 <cdent> because it's not clear how long that is going to take
14:15:38 <edleafe> I've got the alembic stuf sort of working, but the sqla code doesn't see the tables.
14:15:39 <cdent> but that's certainly an option
14:15:48 <edleafe> My lack of sqla understanding is the bottleneck
14:16:09 <cdent> if you want to push up extant code I can look at it in your off hours?
14:16:40 <edleafe> sure, I could do that. I was going to hack a bit more once this meeting is over and I get more caffeine
14:17:04 <cdent> drop a messsage somewhere with your state when you let go of it tonight, and I can play with it tomorrow morning
14:17:13 <edleafe> riger that
14:17:16 <edleafe> roger, even
14:18:14 <efried> Anything else related to extraction?
14:18:19 <cdent> the other extraction thing I wanted to mention is something along the lines of "what's up with docs". We haven't really got a solid plan there, yet. Ideas? Thoughts?
14:18:36 <mriedem> if the docs are going to be published from the placement repo,
14:18:42 <mriedem> then nova's docs just need redirect links
14:19:52 <efried> is that what you meant, cdent? Publishing the docs? Or were you talking about conten?
14:19:53 <efried> t
14:19:59 <cdent> all of it
14:20:06 <cdent> when we publish, we need redirect links
14:20:31 <mriedem> sure, so it's just a two-step,
14:20:36 <cdent> but just publishing is not enough because the content is currently embedded in the context of nova without a notion of placement being first class
14:20:41 <mriedem> get the docs publishing with the desired content,
14:20:54 <mriedem> and then push a nova patch to change the redirects and drop the nova placement docs i guess
14:20:56 <cdent> and we don't currently have anyone thinking about that content as far as I know
14:21:09 <cdent> so mostly I'm saying "hey, we need to think about that content"
14:21:23 <efried> tetsuro: any chance you've got time for ^ ?
14:21:45 <cdent> within that is also: the api-ref is published and managed separately so we could go ahead and switch that whenever we like, as the api is currently frozen
14:21:45 <edleafe> I think the focus on meeting the extraction goals has lessened the interest in working on docs
14:22:04 <tetsuro> efried: You mean I clean up the content of the placement docs?
14:22:04 <cdent> indeed, but we can't say we are extracted without  being able to publish docs, presumably?
14:22:20 <efried> tetsuro: Yes, de-nova-ify and get them ready to publish.
14:22:39 <edleafe> I wouldn't think so, but writing down what has to be done has definitely focused efforts on those things
14:23:04 <efried> tetsuro: Last doc you did, you made it look easy :) The reward for good work is...
14:24:28 <tetsuro> efried: Okay, I have time to look into that
14:24:41 <efried> tetsuro: Thanks!
14:25:02 <efried> I don't know what is needed to trigger publishing, but we can figure that out as the content is being made ready.
14:25:08 <cdent> edleafe: I agree, I mentioned in penultimate pupdate that we might want to restart the placement extraction etherpad to start from a clean slate and understanding of the now
14:25:12 <cdent> but nobody said anything
14:25:20 <efried> implicit agreement ^
14:25:34 <mriedem> didn't read it yet
14:25:35 <efried> keep the old one for posterity
14:25:41 <edleafe> Guilty. I remember reading that and thinking "Hey, we should definitely do that"
14:26:15 <cdent> efried: have you been listening to me for the last few years? I don't  do implicit, sirrah
14:26:58 <efried> cdent: I agree with the notion of starting a new extraction etherpad, while keeping the old for posterity. +1. Make it so. Do it, and let the English see you do it.
14:27:03 <efried> ^ explicit.
14:27:33 <cdent> Oh, you mean "implicit agreement" which translate as "yeah, as long as the smeller is the feller, than it's cool"?
14:27:59 * cdent takes notes in his instruction manual
14:28:36 <cdent> If I follow that policy all the time I will end up doing everything and I ain't gonna do that
14:28:52 <cdent> but in this case I'll take that action
14:29:01 <cdent> #action cdent to make a new extraction etherpad
14:29:48 <efried> oh, if we're using that tag...
14:29:48 <efried> #action tetsuro to de-nova-ify placement docs and make ready for publishing
14:30:46 <efried> okay, we done with extraction?
14:31:15 <efried> (silence <= implicit agreement)
14:31:17 <efried> #topic bugs
14:31:17 <efried> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:32:16 <efried> Any bugs worthy of discussion?
14:32:36 <cdent> rgerganov has started backporting a fix for update running more than once in the resource tracker
14:32:54 <cdent> the race condition it fixes is present back to queens (where it has presented a problem for the vmware product)
14:33:14 <efried> neat
14:33:15 <cdent> #link update less in rt https://bugs.launchpad.net/nova/+bug/1729621
14:33:15 <openstack> Launchpad bug 1729621 in OpenStack Compute (nova) pike "Inconsistent value for vcpu_used" [Undecided,In progress] - Assigned to Radoslav Gerganov (rgerganov)
14:33:40 <cdent> it seems the race is more of a big deal if you have many hundreds of vms on the same nova compute
14:34:50 <efried> that would seem unsurprising
14:35:04 <cdent> quite
14:36:44 <efried> other buggage?
14:36:49 <mriedem> my only concern about those backports
14:36:57 <mriedem> is the related 0.0 allocation fix that came later
14:37:06 <mriedem> which is in rocky but not queens or pike
14:37:29 <mriedem> well, that's not my only concern, but my biggest one
14:37:40 <mriedem> this https://github.com/openstack/nova/commit/2588af87c862cfd02d860f6b860381e907b279ff#diff-afb9c0c0ca5276c7eacd987bbf51d8e6
14:38:58 <cdent> presumably this will come out in the review?
14:39:22 <mriedem> i'll leave something yes
14:40:26 <efried> #topic opens
14:40:41 <efried> Anyone? Bueller?
14:41:00 <cdent> spec sprint tomorrow, yes?
14:41:44 <efried> yup
14:42:20 <efried> mentioned at :04:09
14:43:08 <efried> Anything else before we close?
14:43:47 <efried> Thanks y'all
14:43:47 <efried> #endmeeting