16:31:26 <tjones1> #startmeeting NovaBugScrub
16:31:27 <openstack> Meeting started Wed Mar 26 16:31:26 2014 UTC and is due to finish in 60 minutes.  The chair is tjones1. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:31:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:31:32 <openstack> The meeting name has been set to 'novabugscrub'
16:32:54 <tjones1> *listening….*
16:33:10 <alexpilotti> hi there!
16:33:14 <tjones1> hi alex
16:33:22 <tjones1> so far it's just you and me
16:33:27 <alexpilotti> heh
16:33:54 <alexpilotti> let me take teh list of hyper-v bugs then :-)
16:34:18 <tjones1> got a bunch of untagged bugs - want to take a look and see if any are yours?
16:34:19 <tjones1> https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
16:34:57 <tjones1> im just going to start through the list.  there were 6 last night and 23 this morning.  i already tagged several.  clearly people are testing!  which is good
16:35:50 <alexpilotti> looking!
16:36:08 <tjones1> great - im going to start in case others join in and want to help out too
16:36:11 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297796
16:36:45 <tjones1> not sure what to use for client issues
16:37:07 <tjones1> going to skip for now then
16:38:00 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1291396
16:38:34 <tjones1> again not sure so skipping
16:39:02 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1295608
16:39:24 <tjones1> guessing compute
16:39:43 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296690
16:39:54 <tjones1> db
16:40:09 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296808
16:40:12 <tjones1> networking
16:40:42 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296913
16:40:51 <alexpilotti> #link https://bugs.launchpad.net/nova/+bug/1295608 shoud specify the compute driver IMO
16:41:06 <alexpilotti> which is libvirt
16:41:30 <tjones1> thanks
16:41:34 <tjones1> i'll change it
16:41:37 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296913
16:41:37 <alexpilotti> so the caption should be: ""QCOW2" image has a problem in Creating an instance on libvirt Compute node"
16:41:39 <tjones1> scheduler
16:42:01 <tjones1> this one could be a big deal im thinking - regression if it is a real bug
16:43:07 <alexpilotti> agreed
16:43:16 <tjones1> and by "this one" i meant  irc://chat.freenode.net:6667/#link https://bugs.launchpad.net/nova/+bug/1296913
16:43:39 <tjones1> #action show https://bugs.launchpad.net/nova/+bug/1296913 to russellb
16:43:59 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296967
16:44:46 <alexpilotti> compute
16:44:47 <tjones1> compute and havana (not sure how to tag it to havana)
16:45:36 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1296995
16:45:37 <tjones1> doc
16:45:40 <melwitt> in general I don't think bugs get tagged to specific releases
16:46:24 <tjones1> hey melwitt - ok thanks.  Could you take a look at the 1st 2 in the list ?  i did not know what to make of them
16:46:31 <tjones1> https://bugs.launchpad.net/nova/+bug/1297796
16:46:37 <tjones1> https://bugs.launchpad.net/nova/+bug/1291396
16:47:34 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297052 this one asked for logs
16:47:59 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297261
16:48:09 <melwitt> seems like 1297796 should be under novaclient, not nova
16:49:24 <tjones1> thanks
16:49:43 <tjones1> moved it
16:50:02 <melwitt> 1291396 has to do with nova baremetal and ironic, they need exact match in scheduler filter, so scheduler I think
16:50:16 <tjones1> ok thanks
16:50:32 <melwitt> i.e. they want to add a scheduler filter to support baremetal
16:50:46 <tjones1> ah ok - prob not icehouse ;-) as they said
16:50:59 <alexpilotti> #link https://bugs.launchpad.net/nova/+bug/1297261 look slike oslo
16:51:17 <alexpilotti> "The problematic code is at least:
16:51:36 <alexpilotti> "/usr/lib/python2.6/site-packages/nova/openstack/common/importutils.py
16:51:40 <tjones1> oh ok - thanks
16:52:08 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297309
16:53:11 <tjones1> matt says that's a dup of 1282842
16:54:10 <tjones1> looking at logstash...
16:55:01 <tjones1> don't think this is necessarily an error - the token auth is failing
16:55:15 <tjones1> but it does look like a dup
16:56:10 <tjones1> im gonna say network and let them decide for sure
16:56:44 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297375
16:57:52 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297375
16:57:58 <tjones1> oops
16:58:02 <tjones1> sill on that one
16:58:14 <tjones1> db perhaps
16:58:34 <melwitt> I might put db and compute on that one. one of them needs to lock
16:58:49 <tjones1> ok
16:59:01 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297635
16:59:43 <melwitt> volumes?
17:00:05 <tjones1> rc issue?
17:00:10 <tjones1> potential?
17:00:16 <tjones1> ah they are on havana
17:00:24 <tjones1> but could still be an issue
17:02:16 <tjones1> #action point out https://bugs.launchpad.net/nova/+bug/1297635 to russelb just in case
17:02:19 <melwitt> at best rc potential, I don't know how severe it needs to be at this point to be that
17:02:45 <tjones1> i think pretty darn severe - but race condition always gets a 2nd look just in case
17:02:57 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297642
17:03:16 <tjones1> this one seems like a corner case to me but could be wrong
17:03:40 <melwitt> yeah I think it's best to have it looked at to make sure
17:03:51 <tjones1> compute then?
17:04:47 <melwitt> yeah compute
17:04:52 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1297642
17:05:35 <melwitt> I've seen related bugs too on how state is handled when compute goes away and rpc timeout occurs. generally hangs in a "-ing" state
17:06:39 <tjones1> not good
17:07:03 <tjones1> so??  scheduler??
17:08:44 <melwitt> I think just compute. I think in these cases if they issue "reset state" it'll go to active or error depending
17:10:23 <tjones1> ok
17:10:25 <tjones1> #link https://bugs.launchpad.net/nova/+bug/1295674
17:10:29 <tjones1> this is a process bug
17:11:33 <tjones1> no idea how to tag it.
17:11:51 <tjones1> woa - check out this one (just opened) #link https://bugs.launchpad.net/nova/+bug/1297962
17:13:25 <melwitt> I think it would just be untagged
17:13:52 <tjones1> ok i will leave the process bug
17:14:03 <tjones1> but the other one?  either a misconfig or a big deal?
17:14:40 <melwitt> can't tell from the information that's there
17:15:04 <tjones1> yeah i asked for more info
17:15:28 <tjones1> so we are done!  and only 15 minutes later
17:15:42 <tjones1> peeking at rc bugs
17:15:59 <tjones1> #link https://blueprints.launchpad.net/nova/+milestone/icehouse-rc1
17:16:35 <tjones1> 2 new this morning (from the ones we just tagged) dansmith must be lurking again
17:17:10 <tjones1> the other 3 are moving - we are trying to cut rc1 on friday.
17:17:16 <tjones1> anything else from a bugs point of view??
17:18:05 <tjones1> listening
17:18:25 <tjones1> ok then - thanks melwitt and alexpilotti
17:18:28 <tjones1> #endmeeting