19:55:58 <blogan> #startmeeting octavia
19:55:58 <openstack> Meeting started Wed Sep 24 19:55:58 2014 UTC and is due to finish in 60 minutes. The chair is blogan. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:55:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:56:02 <openstack> The meeting name has been set to 'octavia'
19:56:12 <blogan> hello all
19:56:18 <blogan> if anyone has mad it to the room yet
19:56:22 <johnsom_> Hello
19:56:30 <rm_work> I'm not mad at the room
19:56:35 <johnsom_> Aren't we four minutes early?
19:56:36 <rm_work> not sure what it did to you...
19:56:36 <xgerman> you are 4 minutes early
19:56:43 <xgerman> are clocks fast at RAX?
19:56:55 <rm_work> we just like to be prompt :)
19:56:56 <barclaac> Hi all
19:56:56 <blogan> damnit my clock!
19:57:07 <blogan> meh we can use this time to get to know each other
19:57:15 <blogan> i like walks on the beach
19:57:23 <TrevorV> The beach doesn't
19:57:24 <rohara> o/
19:57:29 <blogan> ...
19:57:38 <xgerman> I live near a beach :-)
19:57:58 <barclaac> Showoff
19:58:09 <blogan> i live near a river?
19:58:18 <blogan> that i can walk on
19:58:52 <dougwig> o/
19:59:00 <blogan> anyone remember what the action items from last week were?
19:59:09 <xgerman> nope
19:59:17 <TrevorV> You can look it up in the meeting notes
19:59:17 <blogan> if our meeting minutes person would have actually done his job
19:59:36 <xgerman> lol
19:59:38 <dougwig> #link http://eavesdrop.openstack.org/meetings/octavia/2014/octavia.2014-09-17-20.00.html
19:59:53 <johnsom_> First one... ACTION: TrevorV write up 2 weeks worth of meeting notes. (TrevorV_, 20:01:35)
19:59:55 <johnsom_> Grin
19:59:59 <xgerman> :-)
20:00:01 <TrevorV> Totally did it.
20:00:05 <blogan> lol
20:00:07 <TrevorV> Just not as pretty as I would have done with the webex
20:00:18 <blogan> i didn't realize webex gave you pretty tools
20:00:22 <sballe__> hi
20:00:31 <blogan> okay meeting has now officially started
20:00:37 <xgerman> yeah, I like webex more, too, but I have seen a couple of references that IRC is the OpenStack way
20:00:42 <sballe__> Are we meeting in iRC? or webex?
20:00:45 <blogan> #topic Review progress on action items from last week
20:00:54 <blogan> RIC
20:00:55 <blogan> IRC
20:01:00 <sballe__> thx
20:01:15 <davidlenwell> can we vote on that again...
20:01:17 * davidlenwell ducks
20:01:18 <blogan> sbalukoff had his mind jedi mind tricked
20:01:26 * blogan kick davidlenwell
20:01:28 <blogan> and kicks
20:01:31 * dougwig sighs.
20:01:35 <xgerman> we need IRC with voice and video
20:01:51 <blogan> okay, dougwig octavia etherpad
20:02:06 <blogan> what was that action item
20:02:12 <blogan> oh wait
20:02:12 <dougwig> start here: https://etherpad.openstack.org/p/lbaas_reviews
20:02:18 <dougwig> and from there, stephen's is linked.
20:02:24 <dougwig> that gets you all lbaas and octavia reviews.
20:02:31 <blogan> excellent
20:02:54 <xgerman> nope, we just link the query
20:02:55 <blogan> dougwig: thanks for getting all those neutron lbaas reviews moved to the feature branch
20:03:08 <xgerman> http://bit.ly/1wqy47t
20:03:14 <dougwig> i'll do the drivers as soon as we have jenkins passing.
20:03:25 <xgerman> thanks
20:03:43 <blogan> yeah I think stephen had said he was going to do a list for octavia with priorities
20:03:54 <TrevorV> That exists blogan
20:04:02 <blogan> where?
20:04:20 <blogan> unless he's using launchpad
20:05:06 <TrevorV> I
20:05:07 <TrevorV> I
20:05:11 <TrevorV> I'm looking for it
20:05:12 <TrevorV> Stutter
20:05:25 <xgerman> I think I have seen a list but it got replaced with the LBaaS one
20:05:28 <blogan> okay well we'll move on until you find it
20:05:31 <xgerman> as the MOTD
20:05:32 <TrevorV> https://etherpad.openstack.org/p/octavia-pending-reviews
20:05:33 <TrevorV> Got it
20:05:34 <dougwig> https://etherpad.openstack.org/p/octavia-pending-reviews
20:05:44 <blogan> ah excellent
20:05:45 <dougwig> let me link that through the other one
20:05:52 <xgerman> +1
20:06:03 <sballe__> +1
20:06:17 <dougwig> done
20:06:27 <xgerman> cool
20:06:40 <blogan> looks fairly up to date too
20:07:00 <blogan> okay anything anyone wants to add to this?
20:07:31 <blogan> moving on
20:07:31 <johnsom_> Looks good to me
20:07:48 <blogan> #topic Neutron LBaaS VIP to Octavia VIP
20:08:36 <blogan> currently Neutron LBaaS v1 and V2 creates a neutron port for the VIP before it even passes control to the driver
20:09:08 <blogan> so this means when we link up Octavia with Neutron LBaaS (with an Octavia driver) it will have this neutron port already created
20:09:43 <blogan> and since we're probably goign to support different front end plumbing (floating ips), we need to keep this in mind
20:09:54 <sballe__> good point
20:10:03 <blogan> plus Neutron LBaaS has no concept of floating ips as vips either
20:10:09 <blogan> at least none that I am aware of
20:10:42 <blogan> so if Neturon LBaaS is the frontend to Octavia, then we've got a problem
20:10:59 <dougwig> neutron lbaas can do floating ips, just not in one step. you can assign a float to the vip, and it works fine.
20:11:06 <xgerman> hence Neutron LBaaS v2?>
20:11:14 <blogan> we can add that support in V2, but will all vendors support that as well?
20:11:35 <blogan> dougwig: how do you assign a float to the vip?
20:11:57 <dougwig> allocate one and associate it directly to that ip. can do it in horizon or the CLI.
20:12:16 <blogan> ah okay, i see what you mean
20:12:32 <blogan> but the user would have to have the vip created first, and then make that into a floating ip?
20:12:37 <dougwig> you can also have the vip on a completely different subnet and ignore the neutron port entirely, if the routing tables are correct.
20:13:08 <rohara> blogan: that is what i've done in the past
20:13:13 <rohara> neutron floatingip-associate ...
20:13:26 <dougwig> blogan: yep.
20:13:44 <blogan> i'm not sure that workflow would work in our (RAX's) case but I'm not 100% sure
20:14:43 <blogan> i think it would be best if we added that to automatically happen in V2, but I'm not sure of the implications to vendor drivers
20:15:21 <xgerman> well, ther eprobbaly is some flag we could use?
20:15:39 <sballe__> yes I agree.
20:15:50 <blogan> yeah but don't we have the current problem that woudl fall under flavors domain, which doesn't exist yet
20:15:51 <rohara> xgerman: +1
20:15:56 <blogan> as in one vendor supports it but another does not
20:16:53 <dougwig> or the octavia does its own plumbing, and then we push it upwards once we know more about how it'll all work.
20:17:03 <dougwig> octavia driver.
20:17:22 <blogan> yeah i was just thinking that octavia will just do the floating ip association if it got a vip_port_id
20:17:25 <dougwig> nothing in lbaas precludes the driver deleting the current port and rewiring everything its own way.
20:17:38 <xgerman> well, sounds wasteful
20:17:44 <blogan> dougwig: yeah that was another option but not a fan of it
20:17:47 <blogan> hacky
20:17:52 <xgerman> +1
20:17:54 <blogan> but it would be a temporary solution
20:18:08 <dougwig> yes, it is, but it lets us take an isolated step before we make a final decision for all
20:18:27 <blogan> xgerman, sballe__: do you know if the workflow of creating a vip as a neutron port and then doing a floating ip association would work for you?
20:18:55 <xgerman> I think it would
20:18:58 <sballe__> yes
20:19:16 <blogan> okay, I'm not so sure on our end but I'm leaning towards yes
20:19:41 <blogan> #action brandon investigate neutron port and floating ip association feasability for RAX
20:20:01 <blogan> anyone have anything else to add or concerns?
20:20:35 <xgerman> a lot of new blueprints appeared last night
20:20:35 <blogan> moving on
20:20:49 <blogan> #topic Discuss any outstanding blockers
20:21:01 <TrevorV> xgerman, can save that for open discussion, yeah?
20:21:02 <blogan> xgerman: i think that will fall into the last agenda item
20:21:07 <xgerman> yep
20:21:13 <xgerman> soryy, jumoing ahead
20:21:16 <blogan> is anyone being blocked?
20:21:16 <TrevorV> :)
20:21:27 <blogan> or is any blueprint blocked
20:21:36 <TrevorV> I'm not "blocked" but I would like more eyes on the repository review
20:21:44 <blogan> link it
20:21:47 <TrevorV> Apparently my testing could be more accurate
20:22:01 <TrevorV> #link https://review.openstack.org/#/c/120927/
20:22:03 <johnsom_> Controller is technically blocked, but I am working on a spec anyway, so not really blocked
20:22:30 <blogan> controller is probably going to be "blocked" for a while, at least a fully functioning controller
20:22:38 <johnsom_> Yep
20:23:11 <blogan> alright moving on
20:23:14 <blogan> #topic Review status on outstanding gerrit reviews
20:23:20 <blogan> trevor already linked his
20:23:41 <blogan> xgerman: you just updated your spec
20:23:47 <xgerman> yep, I did
20:24:24 <xgerman> I expect sbalukoff to ecstatically approve it
20:24:28 <blogan> #link https://review.openstack.org/#/c/121694/
20:24:31 <dougwig> xgerman's, which is likely the #1 review for eyeballs this week: https://review.openstack.org/121694
20:24:39 <blogan> xgerman: i can totally nitpick you on the commit message
20:25:01 <xgerman> I got an pep8 last time so I kept it short
20:25:20 <blogan> well i mean it has no context, i dont know what 3rd version it is until i actually look at the doc
20:26:01 <dougwig> xgerman: google "openstack git commit message". there's more than a few things you need to fix. :)
20:26:26 * TrevorV thinks the weeds are getting pretty thick here
20:27:03 <blogan> well the commit message doesn't have to be detailed like some of those examples
20:27:37 <blogan> anyway I think those are the only 2 reviews that are open
20:27:43 <blogan> and ready to be looked at
20:27:55 <blogan> so lets get some eyeballs on them
20:27:58 <blogan> moving on
20:27:59 <xgerman> I think we need to re-open some based on what I learn about commit messages :-)
20:28:04 <blogan> lol
20:28:23 <blogan> #topic Review list of blueprints, assign people to specific blueprints and/or tasks
20:28:59 <xgerman> a bunch of new belueprints appeared and we didn't have time to look athe in detail
20:29:18 <xgerman> so I suggest to defer that unless somebody needs work
20:29:24 <blogan> ah yeah i didn't realize new ones appeared either
20:29:36 <blogan> stephen must have added those last night
20:29:45 <johnsom_> I would like to talk about the blueprint process, but that might be better in open discussion.
20:30:22 <xgerman> +1
20:30:28 <TrevorV> #link https://review.openstack.org/#/q/stackforge/octavia+status:open,n,z
20:30:33 <TrevorV> For any not having the link open...
20:31:02 <TrevorV> Wait, those are only open BPs...
20:31:10 <blogan> alright lets move to open discussion, and we have our first item
20:31:15 <johnsom_> #link https://blueprints.launchpad.net/octavia
20:31:18 <blogan> #topic talk about blueprint process
20:31:22 <TrevorV> Thanks johnsom_
20:32:01 <johnsom_> I would like to understand our blueprint management process a bit better.
20:32:23 <blogan> i think stephen is in the process of actually making it a process
20:32:37 <johnsom_> I am assigned (by volunteer) the image building blueprint as an example.
20:33:01 <sballe__> blogan to me it sounds like sbalukoff is just creating blueprints
20:33:18 <davidlenwell> I believe he's just thinking ahead ..
20:33:32 <sballe__> Could we have a session where we talk about what blueprints are needed?
20:33:38 <johnsom_> Last night Stephen made a number of changes to this blueprint, some I am not aligned with, some that ignored the task list in the approved spec, and he marked it as started.
20:33:41 <sballe__> I am happy to sync-up with him as well
20:33:43 <blogan> he probably is, but also prioritizing things, i'm sure all of tehse aren't just set and stone and can't be changed
20:34:08 <blogan> johnsom_: ah well then in that case it woudl ahve been nice for him to be here
20:34:23 <johnsom_> My understanding of blueprints was to assign ownership and track the progress, etc.
20:34:40 <xgerman> +1
20:34:52 <blogan> that and also list out things that need to be done
20:34:53 <sballe__> +1
20:35:09 <xgerman> the owner of the blueprint should be consulted when changing things
20:35:17 <dougwig> there is a certain amount of prioritizing and milestone planning that also happens, which might involve some shuffling. whether that's just the PTL or a committee activity is a choice for the group to make. but this is a discussion to be had with stephen.
20:35:22 <johnsom_> blogan - Sorry, I saw him join the room and he is on the list
20:35:26 <sballe__> yeah but we have to do this as a group
20:35:33 <blogan> i agree
20:35:34 <xgerman> +1
20:35:39 <dougwig> johnsom_: he had an emergency and had to leave.
20:36:36 <dougwig> can we table this for when stephen is present and move on? i'm certain none of his changes were meant to be final.
20:36:50 <johnsom_> Well, should we talk about blueprint process as a team without him?
20:36:50 <davidlenwell> +1
20:37:10 <davidlenwell> I don't think you should talk about process without the team lead present
20:37:14 <davidlenwell> doesn't sound fruitful
20:37:20 <dougwig> discuss the team without all of the team? :)
20:37:29 <davidlenwell> just my humble opinion
20:37:36 <blogan> well it is an open discussion
20:38:01 <blogan> and yeah we need stephen to weigh in but I don't see the harm in expressing thoughts on the process
20:38:07 <blogan> that is my humble opinion as well
20:38:08 <xgerman> +1
20:38:17 <blogan> if there is anything more pressing to talk about we can do that first though
20:38:27 <dougwig> oh, i don't see any harm either. we'll just be having the conversation twice. i'm not really opposed to it.
20:39:49 <blogan> well other than consulting the blueprint owner before changing the blueprint, what other concerns do you have johnsom_?
20:40:29 <xgerman> well, we also liked the priorites, milstones, etc. set by committee
20:40:34 <johnsom_> That is the bulk of it. Having a clear understanding, as a team, how we are managing blueprints/work.
20:40:44 <TrevorV> I think throwing ideas out and gaining understanding about process is a good idea regardless of attendance, but making a decision can't happen without him so its probably best to wait
20:41:20 <xgerman> ok, let's juts make sure those two points make it into the minutes
20:41:37 <xgerman> so we can discuss them next time :-)
20:41:44 <blogan> im pretty sure his intentions were to just get things set, similar to how I just created blueprints to actually get the discussion and implementation of Octavia moving
20:42:06 <TrevorV> xgerman, add #action to those 2 things with some reference to talk about it next meeting
20:42:15 <blogan> #action Talk to Stephen about blueprint process and how priorities, milestones, and blueprint changes are done.
20:42:29 <TrevorV> There you go xgerman :D
20:42:50 <xgerman> yep, I hoped we would have human minutes again :-)
20:43:11 <dougwig> one thing that gets tough with distributed teams is doing everything by committee. having rough planning sessions every now and again where everyone is involved is fine, sure. but for smaller scale stuff, you do get an email on every change, so it's not happening in a vacuum. i view that as more of an asynchronous conversation.
20:43:46 <johnsom_> I thought that is why we are distributing ownership and work...
20:43:51 <TrevorV> xgerman, one of the links in each minutes section is an exact recording of the conversations, which I view as better than paraphrasing with a single point of bias (me, being scribe in this case) but I can write them up if we all like that better
20:44:16 <xgerman> well, we can always use WebEx and talk things through
20:44:23 <dougwig> johnsom_: i'm not sure we're disagreeing?
20:44:37 <xgerman> I think we are all agreeing :-)
20:44:55 <xgerman> TrevorV, I liked the bias :-)
20:45:46 <rm_work> BTW: If anyone wants to comment on the ML thread I started, that'd be cool: [openstack-dev] [Neutron][LBaaS] Interaction with Barbican and Keystone
20:45:57 <blogan> alright well since that is tabled until we can talk to Stephen, anything else
20:46:05 <rm_work> no one has responded since I posted that :(
20:46:14 <blogan> #topic Open Discussion
20:46:46 <blogan> rm_work: I bet markmcclain would have some thoughts on that
20:46:58 <blogan> probably ping him tomorrow in the neutron lbaas meeting
20:47:15 <rm_work> I cc'd a bunch of people besides just the ML, surprised I have gotten no response
20:47:30 <blogan> well no one really cares about you
20:47:48 <rm_work> (cc'ed Stephen, Susanne, Doug, German, Adam Young (keystone) and Doug Mendizabal (barbican))
20:48:43 <dougwig> i'd wager it's a gross can of worms that no one wants to touch. maybe schedule a webex meeting and get everyone in the same room?
20:49:14 <rm_work> T_T k
20:49:23 <rm_work> it's honestly not like there's much choice, I think
20:49:37 <xgerman> I love webex so I am all for it
20:49:38 <rm_work> just need to get everyone to AGREE on a direction
20:49:43 <rm_work> I'm fine with that
20:49:44 <xgerman> #vote?
20:49:48 <rm_work> or gchat
20:50:02 <xgerman> guys, in case you missed it:
20:50:20 <xgerman> https://isc.sans.edu//#__utma=216335632.683171903.1411576676.1411576676....
20:50:22 <rm_work> #vote for what? :P
20:50:34 <rm_work> oh yeah
20:50:36 <rm_work> that bash thing
20:50:55 <xgerman> yep --
20:50:58 <rm_work> I've updated my servers, but no OSX update yet that I'm aware of (OSX seems also vulnerable)
20:51:14 <blogan> alright time to end the meeting
20:51:18 <xgerman> yep
20:51:21 <blogan> #endmeeting