20:00:06 <sbalukoff> #startmeeting Octavia
20:00:07 <openstack> Meeting started Wed Oct  1 20:00:06 2014 UTC and is due to finish in 60 minutes.  The chair is sbalukoff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:11 <openstack> The meeting name has been set to 'octavia'
20:00:11 <TrevorV> o/
20:00:16 <blogan> \o/
20:00:18 <rohara> o/
20:00:23 <xgerman> o/
20:00:23 <sbalukoff> Hi guys!
20:00:25 <rm_work> o/
20:00:32 <sbalukoff> rm_work: Did you want to actually do a roll call?
20:00:48 <blogan> present!
20:00:48 <dougwig> o/
20:00:54 <rm_work> I mean, it's just a nice thing to get a handle on who is here
20:00:55 <sbalukoff> Haha! Me too.
20:00:59 <sbalukoff> Oh, sure.
20:01:05 <sbalukoff> #topic Roll Call
20:01:05 <rm_work> and not interrupt our first topic with a bunch of "hello!" :P
20:01:12 <sbalukoff> If you're here for the meeting, say something now.
20:01:16 <rm_work> though by now a ton of people have already waved :)
20:01:29 <jwarendt> Wave
20:01:33 <xgerman> o/
20:01:35 <ajmiller> o/
20:01:35 <dougwig> present, and my mommy packed my lunch.  anyone want to trade?
20:01:38 <rm_work> o/
20:01:41 <rohara> o/
20:01:44 <sbalukoff> Haha!
20:01:47 * blogan beats dougwig up for his lunchable
20:01:50 <rm_work> dougwig: do you have any fruit rollups??
20:01:56 <rm_work> all I got was this mini-pack of twizzlers
20:01:57 <TrevorV> o/\/
20:02:00 <sbalukoff> Ok, folks, the actual meeting agenda is here:
20:02:01 <sbalukoff> https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Agenda
20:02:20 <sbalukoff> You'll probably notice that it closely resemble's last week's agenda.
20:02:27 <sbalukoff> Sorry I had to duck out at the last minute like that.
20:02:42 <sbalukoff> #topic Quick update on "Octavia" trademark
20:03:04 * TrevorV wonders if sbalukoff realizes there is no agenda listing on the page for last week's meeting...
20:03:05 <sbalukoff> I've been contacted by the government lawyer handling the "Octavia" trademark request.
20:03:27 <rm_work> excellent!
20:03:28 <sbalukoff> TrevorV: Yes, I had noticed that.
20:03:29 <rm_work> ... excellent?
20:03:55 <sbalukoff> Yes, he had one question for me (which was a quick yes/no), and anticipates no problem getting things taken care of there.
20:04:03 <rm_work> excellent.
20:04:13 <sbalukoff> I anticipate we will officially "own" the Octavia name in a week or so. I'll let you all know when that happens.
20:04:18 * TrevorV is wondering what punctuation comes next from rm_work
20:04:49 <sbalukoff> Anyway, moving on...
20:04:49 <xgerman> +1
20:04:51 <blogan> thats good news
20:04:55 <xgerman> +1
20:04:58 <TrevorV> thanks for the update sbalukoff that's awesome
20:05:09 <rm_work> ¿ Excellent
20:05:14 <sbalukoff> #topic Review progress on action items from last week
20:05:50 <sbalukoff> It looks like there were only two action items from last week, the latter of which I'll be discussing later in this meeting.
20:06:12 <sbalukoff> blogan: Any update on: brandon investigate neutron port and floating ip association feasability for RAX (blogan, 20:19:41) ?
20:06:43 <blogan> still need get more clarity on that
20:06:53 <blogan> so need another action
20:06:59 <sbalukoff> Ok, cool.
20:07:30 <sbalukoff> #action blogan to get more clarity on  neutron port and floating ip association feasability for RAX
20:07:36 <sbalukoff> Ok, again, I'll cover the other action item a little later.
20:07:40 <blogan> ty
20:07:53 <sbalukoff> #topic Discuss any outstanding blockers
20:08:06 <sbalukoff> Ok, folks, what are y'all blocked on?
20:08:31 <dougwig> hunting season.
20:08:36 <TrevorV> Still waiting for reviews on https://review.openstack.org/#/c/120927/
20:08:39 <sbalukoff> dougwig: Haha! Awesome. XD
20:08:57 <TrevorV> Its the repository review
20:09:07 <dougwig> i'll take a look today.
20:09:09 <sbalukoff> TrevorV: Cool. I'm working on that today and should be able to get back to you.
20:09:10 <blogan> db repository
20:09:23 <xgerman> +1
20:09:30 <TrevorV> ^^ thanks blogan.  Any feedback is great.
20:09:54 <blogan> there's many ways to skin that cat so if the path chosen is something unliked, please put it in the reivew
20:10:18 <sbalukoff> Sounds good.
20:10:23 <sbalukoff> Any other blockers?
20:10:52 <blogan> not sure if this is a blocker, but i decided im not going to implement paste deploy until its actually needed in the operator api
20:11:08 <blogan> unless someone has a valid reason why we need it right now
20:11:27 <TrevorV> Any who haven't updated the weekly standup probably should... That's a good place to put blockers as well (as they come up)
20:11:40 <sbalukoff> TrevorV: Thanks, and good point.
20:11:48 <TrevorV> #link https://etherpad.openstack.org/p/octavia-weekly-standup
20:11:59 <xgerman> blogan sounds good
20:12:08 <xgerman> not sure we sue that anywhere at HP
20:12:29 <blogan> well ive noticed that ironic, who is incubated, isn't using it and i talked to them and they said they didn't really have a reason to use it yet
20:13:11 <sbalukoff> blogan: I'm not hearing any reasons why we need it right now, so I think you're probably good to go with that decision, eh.
20:13:29 <sbalukoff> Ok, moving on...
20:13:45 <sbalukoff> #topic Review status on outstanding gerrit reviews
20:13:46 <sbalukoff> #topic Review status on outstanding gerrit reviews
20:13:56 <dougwig> #undo
20:14:00 <blogan> well i suppose one of those has been covered
20:14:05 <sbalukoff> #undo
20:14:06 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x28eb7d0>
20:14:23 <sbalukoff> Ok.
20:14:29 <rm_work> Q: is working on the neutron-lbaas CRs still a high priority, or are we focusing 100% on JUST Octavia for a bit?
20:14:33 <sbalukoff> blogan: The other major one is yours
20:14:34 <TrevorV> #link https://etherpad.openstack.org/p/octavia-pending-reviews
20:14:47 <dougwig> only one that isn't WIP is trevor's.
20:14:58 <blogan> yeah
20:15:13 <blogan> but yall are more than welcome to look at the WIP and give feedback on the direction
20:15:14 <dougwig> rm_work: we have neutron mindshare right now, so if we can capitalize on that to get some v2 reviews done, i'd say we should go for it.
20:15:30 <sbalukoff> dougwig: +1
20:15:36 <xgerman> +1
20:15:37 <rm_work> ok
20:15:53 <xgerman> I need to review but I will be on vacation Friday-Tuesday
20:15:53 <dougwig> #link https://etherpad.openstack.org/p/lbaas_reviews
20:16:00 <sbalukoff> rm_work: If you're looking for stuff to do, I can probably come up with something in Octavia. But dougwig has a really good point: The iron is hot in LBaaS v2 right now.
20:16:07 <rm_work> ok
20:16:30 <rm_work> I was starting on some neutron-lbaas stuff but was wondering whether my time would be better spent dropping that for now and switching to Octavia things
20:16:47 <blogan> yeah and so for neutron lbaas v2 plugin/db review
20:16:50 <rm_work> since I finally got the Barbican client up to date (approximately)
20:16:58 <blogan> i mean start +1'ing that review
20:17:01 <xgerman> yeah, barbican!!
20:17:37 <sbalukoff> rm_work: The plan is still to have Octavia plug into Neutron LBaaS v2 as a driver, so we do still want that one in as soon as we can get it in.
20:18:01 <TrevorV> then it sounds like you have your work cut out for you rm_work o_0
20:18:02 <xgerman> +1
20:18:08 <sbalukoff> Anyway, we can cover the Neutron LBaaS reviews in tomorrow morning's meeting.
20:18:19 <blogan> yeah
20:18:21 <sbalukoff> Ok, moving onto the next topic
20:18:25 <ptoohill> Is evgeny around? My CR's were based off of his. But with these changes and me being focused elsewhere I'm a bit unsure what the status of anything is.
20:18:39 <blogan> ptoohill: he may be around tomrorow
20:18:46 <blogan> sure they dont come to this meeting
20:18:55 <rm_work> yeah
20:18:58 <sbalukoff> Yeah, I'm not sure I've ever seen Evgeny here.
20:18:59 <ptoohill> Alrighty, Ill be more focused on that side of things tomorrow anyhow
20:19:04 <ptoohill> Thank you
20:19:12 <sbalukoff> #topic Review list of blueprints, assign people to specific blueprints and/or tasks
20:19:33 <sbalukoff> Ok, folks, I know there was a lot of confusion as to just what the heck I was doing in launchpad last week.
20:19:44 <sbalukoff> So, I wrote a follow-up e-mail trying to explain that.
20:19:54 <sbalukoff> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/047100.html
20:19:56 <dougwig> usurping power and stepping on necks?
20:20:03 <rm_work> where you elected yourself dictator? :P
20:20:04 <sbalukoff> Also...
20:20:06 <sbalukoff> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/047103.html
20:20:16 <sbalukoff> Exactly.
20:20:16 * rm_work is ok with it, just sayin'
20:20:29 <sbalukoff> I will crush the pathetic resistance under my boots.
20:20:36 <xgerman> not so fast
20:20:49 <sbalukoff> Haha!
20:20:53 <xgerman> we think that the owner of a blueprint is like a vasall who can tax his own people
20:21:13 <sbalukoff> xgerman: Right. So here's where we should probably move away from analogy.
20:21:17 <rm_work> #sbalukoff4dictator2014
20:21:22 <blogan> sbalukoff with dictatorial powers...its as if a million voices cried out and then there was silence
20:21:37 <dougwig> his father's face already stares at me every time i open my mailbox.
20:21:44 <sbalukoff> blogan: If only there were a million people working on this. XD
20:21:56 <rm_work> sbalukoff: oh god, we'd never get ANYTHING done
20:21:57 <sbalukoff> dougwig: Give in to the power of the dark side.
20:21:58 <xgerman> well, who knows ifd they are people?
20:22:14 <sbalukoff> Aaanyway....
20:22:18 <xgerman> do we need to start ordering light sabers for paris
20:22:20 <xgerman> ?
20:22:22 <blogan> digression complete
20:22:24 <sbalukoff> Does anyone have questions or concerns about the e-mail I wrote?
20:22:51 <xgerman> well, we had some discussion around committee or dictator
20:23:01 <xgerman> which wasn't resolved
20:23:08 <sbalukoff> xgerman: Sure. Could you summarize?
20:23:13 <dougwig> i think johnsom and sballe had the issues, and i don't think they're here.
20:23:33 <xgerman> true.
20:23:33 <sbalukoff> Wonderful.
20:23:42 <sbalukoff> I know I talked with johnsom in IRC afterward.
20:23:43 <blogan> hopefully xgerman can speak for them?
20:24:07 <xgerman> well, not really --
20:24:12 <sbalukoff> I think we were on the same page by the end of it: Mostly, I think johnsom wasn't sure what it meant to be "owner" of a blueprint.
20:24:23 <sbalukoff> And felt that by touching *everything* I had overstepped my bounds.
20:24:30 <xgerman> yep, exactly
20:24:46 <xgerman> and sballe roughly likes a Jedi Council over a supreme leader
20:24:54 <xgerman> prefers
20:25:02 <sbalukoff> These concerns were taken into account in how I wrote up that e-mail (which I did pretty much directly after I'd had that conversation.)
20:25:09 <sbalukoff> xgerman: Sure.
20:25:20 <blogan> well i dont mind the process of sbalukoff setting the priorities for all blueprints, and if some of us disagree then we can bring it up with him
20:25:30 <sbalukoff> So, I also tried addressing this as best as I understood it in my e-mail
20:25:43 <rm_work> yeah, owning a BP doesn't matter much, they can be reassigned... the REAL issue is dougwig owning all of the neutron-lbaas CRs, the power-hungry fascist!
20:25:53 <sbalukoff> Or you can bring it up before the group in a meeting.
20:26:04 * rm_work shakes fist at dougwig
20:26:07 <dougwig> committee or not, the person ultimately responsible for keeping bp's up to date is the PTL, and until we have an election, that's stephen.
20:26:16 <sbalukoff> In most cases, I have no problem with these kinds of discussions happening out in the open so long as they're productive.
20:26:19 <dougwig> rm_work: I WANT THEM ALL
20:26:24 <rohara> dougwig: +1
20:26:39 <rm_work> dougwig is playing Pokemon with our gerrit reviews
20:26:47 <blogan> was it more going into the blueprint and changing TODO items that johnsom had a problem with?
20:26:49 <sbalukoff> Haha!
20:27:14 <rm_work> (of course, all THAT means is that we can't abandon or 1-click rebase...)
20:27:16 <xgerman> yeah, tye blueprint owner should be consultefd before changes are made
20:27:32 <blogan> xgerman: even on priority changes?
20:27:35 <dougwig> rm_work: your rebase button is now "/msg dougwig hey, rebase xxx".  i learned my lesson.  :)
20:27:36 <sbalukoff> blogan: Yes, I think so. And, again, he's certainly free to change them back (but hopefully after he's talked with the person who added them-- who in this case was me.)
20:28:10 <sbalukoff> xgerman: That's a good goal, but we do work asynchronously here.
20:28:25 <xgerman> we have e-mail to consult
20:28:29 <sbalukoff> If you can't get ahold of the BP owner, you should feel free to make the change and follow up with them (hopefully shortly) afterward.
20:28:43 <sbalukoff> the idea here is: It's easy to change things back because *every* change generates an e-mail.
20:28:45 <xgerman> yeah, if they don;t answer for some time
20:28:57 <sbalukoff> And I want to avoid the situation where people don't feel like they can do anything without permission.
20:28:59 <blogan> sbalukoff: well i do agree major changes should wait for a converstion, unless in the obvious case the BP owner hasn't been heard from in a while
20:29:00 <xgerman> some people are more touchy then others
20:29:13 <sbalukoff> blogan: Yes.
20:29:45 <blogan> of coruse thats when comments in the actual blueprint would be quite handy (a la storyboard)
20:29:54 <sbalukoff> xgerman: I do understand that-- and I will try to soothe egos. But really, I *think* we're all on the same team here, and so far I've not seen anyone trying stupid power-plays.
20:30:15 <sbalukoff> So, it's usually safe to assume that someone stepping on another's toes has not done so maliciously.
20:30:18 <dougwig> i made this statement earlier, "committee or not, the person ultimately responsible for keeping bp's up to date is the PTL, and until we have an election, that's stephen."  and what i hear xgerman saying is that no, the bp owner has more priority than the PTL.  i don't agree with that.
20:30:37 <TrevorV> +1 dougshelley66
20:30:39 <TrevorV> dougwig,
20:30:41 <TrevorV> my bad lulz
20:30:53 <rm_work> lol
20:31:02 <xgerman> dougwig, I am saying that we should consult with the blueprint owner and ultimately the PTL decides
20:31:08 <rm_work> yeah, PTL needs the power to update BPs
20:31:19 <rm_work> at LEAST on priority, timing, etc
20:31:35 <sbalukoff> dougwig: I would add to that that in the absence of the PTL, a quorum of core devs (ie. +2 people) can also arbitrate disputes, eh.
20:31:41 <dougwig> xgerman: that's just a slower process with the same end result.  if both parties assume the best intentions of the other, a required pre-consult is just a synchronous point.
20:31:41 <TrevorV> I don't think re-prioritizing a blue-print stops the work-flow from a blueprint owner, does it?
20:31:47 <rm_work> just because you own the BP doesn't mean you can give it high priority and fix it to kilo-1
20:32:04 <sbalukoff> Really, I'm not actually interested in bringing down my iron fist-- you will see that I almost always will ask for others' input.
20:32:16 <sbalukoff> (hopefully you have seen that from me.)
20:32:18 <TrevorV> +1 rm_work
20:32:31 <sbalukoff> I'm mostly after trying to keep up velocity in making decisions
20:32:36 <rm_work> now, I don't think the PTL can go in and change your DESIGN for the BP anyway, since that's in a review in octavia-specs :P
20:32:40 <TrevorV> I think blue-print owner should only control the blueprint content, not its relation to the project... Maybe that's just me
20:33:14 <rm_work> the launchpad BP doesn't actually contain anything in depth anyway, all of the content is in gerrit/git :)
20:33:44 <sbalukoff> rm_work: That's true as far as designs are concerned.
20:34:08 <rm_work> most BPs in Launchpad are just "who owns this, what's the title, what's the priority, what's the milestone, and where are the links to gerrit" >_>
20:34:26 <sbalukoff> Really: launchpad is such a crappy system for managing this that I intend to move to Storyboard the moment it's sanctioned. So any actual content we care deeply about should be in other systems.
20:34:55 <sbalukoff> And designs, especially intricate designs, should always go through a gerrit review.
20:34:59 <xgerman> well, there might be a migration tool :-)
20:35:07 <sbalukoff> xgerman: I highly doubt it.
20:35:22 <sbalukoff> But that's neither here nor there.
20:35:27 <blogan> lets write it
20:35:30 <sbalukoff> The point is that launchpad is *not* a good system for doing reviews.
20:35:33 <sbalukoff> gerrit is.
20:35:41 <rm_work> let's NOT write it >_>
20:35:47 <sbalukoff> launchpad is also a terrible place to have a discussion.
20:35:49 <rohara> haha
20:35:52 <dougwig> well, launchpad or storyboard are just management tools.  and any organization of such requires communication with the devs.  we're just diving into the weeds on the details of how that communication happens; there's really nothing in either tool that a dev should care much about.  just the manager in question.
20:35:55 <xgerman> there he is johnsom...
20:36:02 <sbalukoff> And... crap, I started ranting about launchpad. Sorry.
20:36:15 <blogan> i have one word, incubator
20:36:22 <blogan> begin rant
20:36:24 <rm_work> sbalukoff: dictators aren't ever sorry. you are bad at this.
20:36:25 <sbalukoff> blogan: I will destroy you with fire.
20:36:32 <xgerman> yeah, and the PTL should not throw blueprints in an incubator
20:36:39 <sbalukoff> ...
20:36:40 <rm_work> sbalukoff: that's more like it! more fire.
20:36:43 <dougwig> via UDP, no less.
20:36:50 <sbalukoff> Haha!
20:36:53 <blogan> load balanced UDP
20:36:55 <TrevorV> I guess I don't understand our current contention point.
20:36:59 <dougwig> i move that UDP becomes our godwin's law.
20:37:09 <blogan> i like godwin's law how it is
20:37:19 <dougwig> so hitler of you.
20:37:23 <xgerman> ok, I am saying we should ask the nlueprint owner first before making changes -- dougwig says that takes too much time
20:37:28 <blogan> invoked!
20:37:28 <sbalukoff> Ok, so... let's wrap this one up: Does anything have anything else they'd like to discuss as far as process or division of responsibility around launchpad blueprints that isn't covered in the e-mail I wrote?
20:37:31 <johnsom_> Oye, more launchpad "discussion"
20:37:46 <rm_work> xgerman: changes to WHAT
20:38:00 <TrevorV> xgerman, do you mean making changes to the blueprint itself, or the priority and release date expectations of the work described by the blueprint?
20:38:05 <rm_work> the only thing in Launchpad is assignee, priority, and milestones
20:38:12 <rm_work> and links to gerrit reviews >_>
20:38:14 <xgerman> it also has a work list
20:38:18 <sbalukoff> xgerman: Again, I think anyone should feel free to update blueprints, but that they should try to be courteous about it: Make an effort to contact the BP owner and such.
20:38:23 <rm_work> do people use that?
20:38:33 <sbalukoff> And BP owners need to not feel like other's shouldn't be allowed to do this.
20:38:35 <xgerman> apparently svalukoff does
20:38:37 <dougwig> not too much, just unnecessary.  when one of my blueprint's changes, i get an email.  if it's wrong, i go talk to the PTL.  so far, i have a 100% hit rate of not needing to talk to the PTL.
20:38:38 <rm_work> and I guess if they do, then yeah, why would the PTL ever have reason to change someone else's worklist <_<
20:38:43 <sbalukoff> That is: It's a collaborative system, get over it. :P
20:39:27 <sbalukoff> I have been using the work lists like checklists.
20:39:56 <sbalukoff> Not ideal (since it's harder to divvy up a blueprint's work to multiple people obviously that way), but eh... we use the tools we have. :P
20:39:58 <xgerman> for me courteous means ask first
20:40:19 <sbalukoff> xgerman: I agree in most cases.
20:40:21 <blogan> can we agree that changing the priority should be the PTL's discretion?
20:40:21 <xgerman> and then ignore the answer if necessary
20:40:25 <dougwig> i think he's just saying, "ask first, if not online, make the change, wait for screams."
20:40:31 <TrevorV> xgerman, it depends.  If removing content from a blueprint, that makes sense to talk to the owner.  When adding to one, I can't say I agree with consultation first
20:40:38 <sbalukoff> dougwig: Yep.
20:40:46 <sbalukoff> Again, my goal is:
20:41:17 <sbalukoff> I want to try to empower people. People should not feel like they need permission to do work which brings the project forward.
20:41:31 <rohara> what there really anything in the last round of blueprint changes that was that contentious?
20:41:53 <sbalukoff> rohara: Only the work items I added to the blueprint that johnsom owns.
20:42:01 <rohara> i see
20:42:05 <sbalukoff> And that was mostly because it was unclear how I was trying to use the blueprinting system.
20:42:17 <sbalukoff> Which again, I hope I've sufficiently clarified in that e-mail.
20:42:18 <sbalukoff> Oh!
20:42:26 <sbalukoff> I'll get the contents of that e-mail added to a wiki.
20:42:39 <TrevorV> action that up sbalukoff
20:42:39 <dougwig> rohara: this conversation isn't really about blueprints; it's about governance, but we're dancing around it.
20:42:49 <sbalukoff> Since, it's clear this will probably come up again, and we need a living document to make sure we can evolve our process as appropriate.
20:42:53 * TrevorV thinks dougwig dances like a fairy
20:43:11 <sbalukoff> #action sbalukoff to add contents of blueprint process e-mail to wiki
20:43:27 <rohara> dougwig: yeah i am picking up on that. its all good.
20:43:31 <sbalukoff> dougwig: You're correct.
20:43:41 <xgerman> yeah, there is the part were we want to be nice and then theres the part who owns the decision
20:43:53 <xgerman> I think we are clear on the later
20:44:11 <sbalukoff> xgerman: Yep, and the answer to the former is two part:
20:44:41 <sbalukoff> 1. For the person wanting to do work: Try to check with the person currently working on the problem first, but feel free to do work if you don't hear back.
20:44:55 <sbalukoff> 2. If you're the person working on something: Try not to take it personally if someone steps on your toes.
20:45:23 <sbalukoff> We're trying to move this train pretty fast, and there are a lot of different personalities and styles of working involved.
20:45:50 <sbalukoff> So, hopefully we can be patient and forgiving with each other-- after all, we are all working toward the same ultimate goal here.
20:46:09 <blogan> agreed
20:46:11 <TrevorV> is it really an ultimate goal, or just a regular one sbalukoff
20:46:12 <xgerman> yep, and we should keep stepping on peoples toes to a minimum - otherwise I need to bring working boots
20:46:35 * blogan steps on xgerman's toes
20:46:46 <xgerman> ouch!! I am wearing flip-flops
20:46:53 <sbalukoff> Haha!
20:46:56 <sbalukoff> Ok, folks!
20:47:04 <dougwig> udp! udp!
20:47:10 <sbalukoff> So, here's what I would like to see from y'all:
20:47:34 <xgerman> dougwig, I need some more drinks before talking udp loadbalancing
20:47:46 <sbalukoff> Now that I've had time to add and update blueprints and explain myself...
20:48:08 <sbalukoff> Please go through them, update them, provide feedback (to me and any owner of the BPs).
20:48:24 <sbalukoff> Please also take on one or more of these blueprints if you have time to work on Octavia.
20:48:43 <johnsom_> Yeah, I like the "ping the assignee" policy.
20:48:54 <sbalukoff> There are a lot of unclaimed things on the list, and even among the claimed things, most of these can be sub-divided into work that people can do asynchronously.
20:49:19 <sbalukoff> Let me action item that.
20:49:33 <johnsom_> Plus, I already updated mine after the changes
20:50:00 <sbalukoff> #action Everyone to go through blueprint list, ask questions, update, and claim unclaimed ones as they are able.
20:50:27 <sbalukoff> johnsom_: Yep! Thanks also for your understanding on this (and the discussion we had last week-- it was really enlightening for me.)
20:50:39 <sbalukoff> Ok! Anything more on this topic?
20:51:06 <sbalukoff> Moving on, then...
20:51:11 <sbalukoff> #topic Open Discussion
20:51:43 <sbalukoff> Out of curiosity, who all is going to Paris?
20:51:46 <sbalukoff> (I am)
20:51:47 <rm_work> While I have people: what version(s) of the Keystone API are exposed in your cloud implementations?
20:51:48 <rohara> moi
20:51:52 <dougwig> me
20:51:57 <blogan> ptoohill and I
20:51:58 <xgerman> me
20:52:02 <blogan> no one else from rax
20:52:13 <xgerman> rm_work it seems we have 1.1, 2, and 3
20:52:20 <sbalukoff> rm_work: I think we're on version 2
20:52:23 <xgerman> 2 is the one we use the most
20:52:28 <rm_work> xgerman: ok, so all versions are exposed though?
20:52:34 <rm_work> sbalukoff: ok, no v3?
20:52:56 <rm_work> I think Keystone is technically still v2 but it exposes IdentityAPI v2.0 and v3?
20:53:03 <xgerman> rm_work you only get to go to paris, TX?
20:53:06 <dougwig> 2
20:53:10 <rm_work> I'm a little fuzzy on it, they were being very confusing
20:53:18 <sbalukoff> rm_work: I think we ought to be able to do that when we're ready to run Octavia in production.
20:53:21 <rm_work> xgerman: lol yes, I'll road-trip
20:53:34 <rm_work> ok, so
20:53:45 <rm_work> I'll ask this again tomorrow in the neutron-lbaas meeting but
20:53:49 <sbalukoff> rm_work: Do we have a choice?
20:54:03 <rm_work> Is anyone skittish about introducing a hard-requirement for Keystone Identity API v3?
20:54:07 <rm_work> sbalukoff: kindof
20:54:13 <sbalukoff> rm_work: If we don't have a choice other than v3, that answers our question. :/
20:54:17 <rm_work> I think. In some circumstances.
20:54:34 <rm_work> so, there's a way to use trusts via the APIv2.0?
20:54:41 <rm_work> but it's worse? (more round-trips)
20:54:49 <rm_work> but I am not clear on how that works if Trusts are a new thing?
20:54:50 <sbalukoff> rm_work: I'm definitely skiddish about that, but if the alternative is to do nasty, nasty things in our code, I'm more in favor of making v3 a requirement.
20:54:59 <rm_work> maybe that's only if you have v3 available but need to use v2?
20:55:04 <rm_work> I don't quite understand
20:55:38 <rm_work> everything about keystone is very unclear, and every time i talk to keystone people i get a different picture of what's going on
20:55:42 <rohara> can we get clarification on the mailing list?
20:55:50 <rohara> rm_work: same
20:55:52 <sbalukoff> rohara: +1
20:55:56 <rm_work> I'm working on getting a full picture
20:56:02 <rm_work> I sent some stuff previously on the subject...
20:56:15 <rm_work> but nothing about this specific issue
20:56:23 <rm_work> I'm going to discuss it tomorrow at the meeting
20:56:24 <sbalukoff> rm_work: Did you tag the discussion as keystone on the ML?
20:56:25 <rm_work> but
20:56:27 <rm_work> I'll mail after
20:56:32 <sbalukoff> Sounds good.
20:56:39 <rm_work> sbalukoff: no, though I did cc a bunch of people including the keystone guy I talked to
20:56:59 <rohara> adam young?
20:57:03 <rm_work> yes
20:57:07 <rohara> yeah
20:57:11 <sbalukoff> rm_work: Keep being persistent, eh.
20:57:14 <rm_work> yep
20:57:24 <rohara> le sigh (working on my french)
20:57:36 <rm_work> ... fire ze missiles?
20:57:40 <sbalukoff> HAHA
20:57:42 <rohara> haha
20:58:30 <sbalukoff> Ok, folks, anyone have anything else they'd like to bring before the group?
20:58:36 <sbalukoff> (You've got about 1 minute)
20:59:23 <sbalukoff> Ok, y'all. Thanks very much for your participation in this meeting, eh!
20:59:34 <xgerman> bye
20:59:41 <dougwig> bye
20:59:44 <rm_work> \o
20:59:56 <sbalukoff> #endmeeting