20:15:28 <blogan> #startmeeting octavia
20:15:29 <openstack> Meeting started Wed Nov 12 20:15:28 2014 UTC and is due to finish in 60 minutes. The chair is blogan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:15:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:15:32 <openstack> The meeting name has been set to 'octavia'
20:15:47 <rm_work> umm so yeah, hey
20:15:53 <blogan> starting a meeting late since im a dummy and forgot about the time change here
20:16:02 <rm_work> maybe we should ping people and hang out a bit?
20:16:08 <johnsom> o/
20:16:12 <rm_work> sballe
20:16:19 <rm_work> dougwig
20:16:45 <rm_work> uhh, i ran out of names
20:17:09 <johnsom> I thought I had missed last week's because my reminder didn't have UTC on it....
20:17:13 <blogan> sbalukoff davidlenwell amiller
20:17:22 <johnsom> german is on a plane
20:17:24 <blogan> last week's was canceled bc of the summit
20:17:36 <blogan> he manage to get into germany with the strikes?
20:17:44 <blogan> he was worried they'd drop him off at the german border
20:18:14 <bedis> he could have taken a train
20:18:23 <TrevorV_> o/ (late)
20:18:35 <blogan> bedis the train conductors were on strike
20:18:42 <bedis> car ?
20:18:44 <bedis> :)
20:18:57 <blogan> planes trains and autombiles
20:19:05 <bedis> foot :(
20:19:41 <blogan> he's been americanized, no self respecting american walks anywhere
20:19:54 <blogan> too much exercise
20:20:10 <rm_work> truth
20:20:12 <rm_work> gotta get a scooter
20:20:20 <blogan> a rascal!
20:20:30 <rm_work> otherwise how would we maintain our winter blubber reserves
20:20:40 <TrevorV_> Is a meeting going to happen here or wut?
20:20:58 <rm_work> we were pinging people and hoping they'd show up
20:20:59 <blogan> ok we shall start
20:21:05 <blogan> there's not going to be much
20:21:06 <rm_work> in case everyone else forgot about the time change too T_T
20:21:19 <blogan> so anyway there are reviews out there ready to be reviewed
20:21:25 <blogan> https://review.openstack.org/#/q/stackforge/octavia+status:open,n,z
20:21:32 <rm_work> yeah a few of mine even got merged today :P
20:21:36 <rm_work> thanks blogan, dougwig
20:21:47 <blogan> im still trying to figure out a race condition in the API tests
20:22:06 <TrevorV_> For those of you who like to see things organized: https://etherpad.openstack.org/p/octavia-pending-reviews
20:22:10 <rm_work> I'm trying to figure out how to mock file open/write correctly
20:22:11 <blogan> and i've flipped flopped on TrevorV's reviews
20:22:13 <TrevorV_> (Like me
20:22:14 <TrevorV_> )
20:22:41 <blogan> rm_work: i am almost certain that is one of the examples mock gives for patch
20:23:06 <rm_work> oh, it is
20:23:11 <rm_work> and they have a nice wrapper
20:23:20 <rm_work> but I end up with PyCharm read/writes in my mocks >_<
20:23:24 <TrevorV_> rm_work, google foo failing you today?
20:23:27 <rm_work> because it mocks EVERYTHING
20:23:37 <rm_work> and it messes up the IDE, lol
20:23:49 <blogan> you've confused me
20:23:55 <TrevorV_> Either way, next topic?
20:24:06 <blogan> oh yeah thte topic command lol
20:24:14 <blogan> #topic Octavia hack-a-thon
20:24:50 <blogan> so its been moved from Dec 8, to Dec 1, and now to Dec 15
20:25:08 <TrevorV_> In any of those options, I can't attend :(
20:25:11 <blogan> Are there any objections from the few who are present today for it being on Dec 15?
20:25:13 <dougwig> Which I actually have a small conflict now.
20:25:26 <blogan> dougwig: fly out on the 17th
20:25:30 <dougwig> I can only do mom-wed that week
20:25:35 <johnsom> I am open to any of those dates
20:25:46 <blogan> was it going to be the entire week?
20:25:55 <bedis> I would prefer 15th to 19th
20:26:37 <blogan> bedis you'll be able to fly in from paris?
20:26:42 <bedis> yep
20:26:45 <blogan> awesome
20:26:52 <blogan> wish i could attend
20:27:37 <blogan> well anyway we won't get the exact dates until everyone gets back, but it looks like Dec 15 as a start date is good, the end date still needs some decision
20:27:38 <TrevorV_> So no strong objections aside from dougwig yeah? Even then doug can make it for most of it?
20:27:57 <blogan> #action Everyone agree on end date of hack-a-thon
20:28:07 <blogan> #topic Open Discussion
20:28:18 <TrevorV_> I have a couple of topics to discuss.
20:28:24 <blogan> go for it
20:28:42 <TrevorV_> Should we actually have a "backup" command run in nova?
20:28:51 <TrevorV_> rm_work, (adam) has some comments to make on this
20:29:00 <rm_work> my comment was "no"
20:29:05 <rm_work> the end :P
20:29:16 <blogan> there were comments on it in the spec
20:29:26 <TrevorV_> I know our customers (Rax) like backups, but we don't really have anything to back up for the most part
20:29:28 <blogan> yall should have read the spec
20:29:37 <TrevorV_> I remember, German said something
20:29:42 <rm_work> which spec?
20:29:52 <rm_work> i mean, do you have a link?
20:30:17 <blogan> #link https://review.openstack.org/#/c/130002/8/specs/version0.5/amphora-manager-interface.rst
20:30:51 <rm_work> you mean http://docs.octavia.io/review/130002/specs/version0.5/amphora-manager-interface.html
20:30:59 <rm_work> :P
20:31:33 <blogan> sure!
20:31:38 <blogan> well you can't see the comments
20:31:40 <blogan> there
20:31:51 <rm_work> I can't see the comments on the review very well either T_T
20:31:54 <blogan> of coure there's only one comment, and it was against it :(
20:32:04 <rm_work> trying to pick through all the patchsets, don't see any comments on the backup part
20:32:10 <blogan> there's one
20:32:18 <blogan> i was thinking of the suspend method
20:32:20 <blogan> anyway
20:32:24 <TrevorV_> I'm looking through them as well, and can't come up with German's comment ha
20:32:27 <rm_work> yeah also don't need that
20:32:34 <rm_work> no suspend, no backup
20:32:37 <blogan> we probably don't need it, and if we do end up needing it we can add it then
20:32:43 <rm_work> why would we need those for amphorae? >_
20:32:49 <blogan> i can see a reason for suspend
20:32:54 <TrevorV_> https://review.openstack.org/#/c/130640/5/specs/version0.5/nova-compute-driver.rst
20:32:56 <TrevorV_> There
20:32:59 <rm_work> amphorae are up or broken
20:33:00 <dougwig> We should only support backup to floppies.
20:33:17 <blogan> if we actually suspend an account we suspend their amphora
20:33:25 <rm_work> err
20:33:32 <rm_work> we should just shoot the amphorae
20:33:33 <dougwig> A
20:33:36 <sballe> I am here. I have this meeting starting in 27 mins
20:33:39 <rm_work> and spin them up again if they unsuspend
20:33:44 <blogan> sballe: time change
20:33:52 <sballe> oh I see.
20:33:52 <rm_work> i see no reason to bother with the complication of suspending
20:34:04 <blogan> you mean the complication of toggling?
20:34:15 <rm_work> and keeping the resources active and tracking them
20:34:31 <rm_work> there is absolutely nothing stateful about the amphorae
20:34:39 <blogan> build time
20:34:49 <rm_work> eh, we have a pool
20:34:55 <blogan> some may not
20:34:57 <TrevorV_> rm_work, so you're saying we don't need start/stop/suspend/resume/backup?
20:35:01 <rm_work> correct
20:35:06 <rm_work> well, is start == boot?
20:35:12 <TrevorV_> no
20:35:19 <rm_work> we need two commands: boot && delete
20:35:35 <TrevorV_> so we don't need a get nor a status check either?
20:35:53 <rm_work> err, those are kinda a different category (and you didn't list them above :P)
20:36:00 <rm_work> yes i would keep status checking
20:36:06 <rm_work> that's part of the spinup procedure
20:36:15 <johnsom> Status has value
20:36:16 <TrevorV_> You said we need 2 commands, boot && delete, that's all the same "operations on amphora" category to me
20:36:18 <blogan> well start, stop, and backup i don't know of use cases
20:36:32 <blogan> suspend and resume i can see uses for
20:36:51 <rm_work> I would get rid of start/stop/suspend/resume/backup
20:36:55 <blogan> yes i know
20:37:05 <rm_work> being clear now since TrevorV_ is being pedantic :P
20:37:10 <blogan> so how bout we just leave it to reviews to decide on this
20:37:24 <rm_work> badly pedantic IMO, since he also forgot about status in his original list :P
20:37:26 <TrevorV_> I don't understand why all of this wasn't discussed when ajmiller and I were concerned about it in his spec review though
20:37:26 * rm_work prods TrevorV_
20:37:29 <TrevorV_> Which is accepted
20:37:32 <blogan> i'm not strongly in favor of one or the other, just stating that there are possible use cases for a suspend/resume
20:37:54 <johnsom> Just a process question here, this is merged. So we are re-thinking this interface?
20:37:56 <rm_work> TrevorV_: I didn't get a chance to look at that review, not sure why people would have assumed those were necessary
20:38:05 <sballe> rm_work: the problem with suspend/resume is that that will depend if it is supported in the way nova is configured. It is not supported in our public cloud.
20:38:23 <rm_work> sballe: yeah it's a complication that I don't think is necessary
20:38:27 <blogan> johnsom: looks like it, i wouldn't want to say that since the spec got approved it must be done exactly as the spec describes
20:38:39 <rm_work> sballe: do you agree that essentially, boot -> delete should be the entire lifecycle of an amphora? :P
20:38:52 <rm_work> johnsom: we can patch the spec, too
20:39:02 <rm_work> just to keep things up to date and clear
20:39:29 <sballe> let's think. What is the usecase for suspend/resume? isn't it just as easy to delete/boot or whatever we call it?
20:39:36 <bedis> (what's an amphora ??)
20:39:37 <rm_work> and "status" but that's not an operation so much as an observation
20:39:41 <rm_work> bedis: lol
20:39:48 <blogan> sballe: the only one i can come up with is if an account is suspended, but you don't want to remove their amphorae
20:39:51 <rm_work> sballe: yes, exactly
20:39:56 <blogan> and then whey they get paied up, resume
20:40:01 <rm_work> blogan: why wouldn't you want to remove their amphorae
20:40:13 <blogan> rm_work: like i said, build time is the only reason i can think of
20:40:19 <blogan> and you can't assume a pool
20:40:27 <rm_work> i don't agree with that being a valid reason >_>
20:40:29 <blogan> its not a strong reason
20:40:40 <rm_work> anyone who isn't going to use a pool is already shooting themselves in the foot
20:40:47 <rm_work> I would assume a pool for any serious deployer
20:41:04 <rm_work> and if they're not a serious deployer, they probably A) won't care, B) won't use suspend/resume
20:41:27 <blogan> ok so they have a pool but it just got through a massive amount of load balancer creation so the pool is now empty and creating amphorae
20:41:37 <dougwig> Backup is for pets. Amps are cattle
20:41:39 * sballe thinking
20:42:05 <TrevorV_> dougwig, I have no idea what you just said
20:42:09 <rm_work> blogan: then there is some wait time, that's not really avoidable
20:42:29 <rm_work> dougwig is saying with a metaphor what I am trying to get across
20:42:33 <johnsom> Amps are cattle, I struggle with the backup
20:42:34 <TrevorV_> rm_work, it is avoidable, with suspend/resume
20:42:42 <blogan> well if it was just suspended, a simple resume would bypass the create
20:42:49 <blogan> im just playing devils advocate here
20:43:07 <blogan> i think we all agree backup has 0 use cases we can come up with right now
20:43:20 <blogan> and i appear to be the only one even entertaining the idea of suspend having exactly 1
20:43:22 <rm_work> I'm saying if there's enough activity to empty the pool, then it's not just suspend/resume LBs that would be problematic
20:43:28 <rm_work> that means your pool is too small
20:43:41 <blogan> bursts happen
20:43:54 <rm_work> and in a *burst* it should be expected that wait time could happen
20:44:05 <blogan> you're arguing for the sake of arguing, im telling you its a weak use case
20:44:19 <blogan> and i'd be fine with either decision
20:44:25 <rm_work> I'm arguing because there's a bigger point herer
20:44:36 <rm_work> we're putting weight on the value of a single amphora and that is dangerous
20:44:46 <rm_work> it has to be CLEAR that they are, as dougwig put it, cattle
20:44:55 <sballe> I agree with rm_work no need for suspend/resume
20:45:13 <TrevorV_> So what about start/stop sballe ? That should be removed then as well right?
20:45:33 <rm_work> does RS actually support stop/start?
20:45:42 <rm_work> I don't know that we do
20:45:51 <sballe> I think we need boot/delete unless start/stop means the same
20:46:00 <rm_work> yeah, that was my confusion
20:46:12 <blogan> alright so someone should update the spec for this
20:46:13 <TrevorV_> No, start/stop is different
20:46:19 <rm_work> but if TrevorV_ says they are different (right?) then we're good
20:46:20 <rm_work> kk
20:46:30 <TrevorV_> are different***
20:46:56 <sballe> so what's the difference between start and resume assuming stop means suspend
20:47:03 <blogan> sballe: i have no idea
20:47:05 <TrevorV_> stop doesn't mean suspend
20:47:11 <sballe> I'll read the spec. I am confused now
20:47:12 <TrevorV_> They are all distinct calls in nova
20:47:45 <rm_work> yeah I don't think RS supports start/stop, i asked about that once
20:48:01 <TrevorV_> Alright, so the spec needs changed. Got it.
20:48:03 <rm_work> our instances are either running, or deleted (or suspended)
20:48:10 <rm_work> I *believe*
20:48:19 <rm_work> would need someone from nova to actually verify that
20:48:25 <blogan> so start and stop is a pause/unpause commands, it continues to run but in a "frozen" state
20:48:40 <blogan> suspend stores teh state on disk and actually stops the VM
20:49:06 <blogan> should amiller change it?
20:49:15 <rm_work> oh, yeah then suspend would actually be *bad*
20:49:27 <rm_work> because then memory would be stored on disk, and we're trying to keep SSL data in memory only
20:49:35 <rm_work> so we'd violate that by suspending T_T
20:49:48 <TrevorV_> blogan, ajmiller or I would be able to do that
20:50:00 <TrevorV_> ajmiller's review technically was accepted and merged, so I just have to do a CR right?
20:50:07 <blogan> ping ajmiller and ask him
20:50:17 <blogan> he may have his reasons that we haven't heard today as well
20:50:23 <rm_work> I think he's pretty well pinged by now ^_^
20:50:25 <ajmiller> Hi, I missed the start of the meeting, I'm here now, catching up on the discussion
20:50:30 <blogan> there he is
20:51:17 <ajmiller> When I put those calls in the spec, my reasoning was to cover ops that can be done to a VM, and determine whether they are useful during review/discussion.
20:51:35 <sballe> ajmiller: make sense.
20:51:37 <blogan> ajmiller: okay so you'd be fine with remove start/stop/suspend/resume?
20:51:47 <TrevorV_> and backup blogan
20:51:55 <blogan> pedantic sob
20:52:04 <ajmiller> Yes, I'm fine with this, if the consensus is that they are not useful (or in some cases potentially harmful)
20:52:05 <blogan> but yes what TrevorV_ said
20:52:11 <rm_work> yeah there were not enough eyes on that review before it got merged, I think
20:52:19 <rm_work> which is a problem I believe we've begun to work on
20:52:27 <rm_work> just have to get people to actually look at reviews
20:52:32 <blogan> yeah eyes have been on more reviews
20:52:34 <rm_work> seems it is happening more now, so should be less of a problem,
20:53:01 <dougwig> ok, i'm done walking back from restaurant now.
20:53:04 <ajmiller> I will be happy to do the patc.
20:53:04 <blogan> ajmiller: would you be able to do another review that updates taht spec?
20:53:05 <rm_work> (That last comma was a typo. I'm done. That was the end of my sentence.)
20:53:06 <ajmiller> patch
20:53:17 <rm_work> blogan: bam, pre-answered
20:53:18 <blogan> ajmiller: excellent
20:53:20 <TrevorV_> blogan, you want to give him an "#action" then?
20:53:29 <blogan> yeah if you give me a chance!
20:54:00 <blogan> #action ajmiller creates patch for computer driver interface to remove start, stop, suspend, resume, and backup methods
20:54:08 * TrevorV_ wants to explain to everyone that brandon is using an ancient IRC client and it rate-limits his input/output
20:54:30 * blogan sighs
20:54:41 <blogan> anyway, anything else from anyone?
20:54:48 <TrevorV_> Yes
20:54:56 <TrevorV_> But we don't really have time
20:55:06 <blogan> bring it up real quick
20:55:13 <rm_work> 6 minutes GO
20:55:32 <TrevorV_> Should we have "amphora_type" included in the build command via the interface?
20:55:44 <TrevorV_> Idk if I said that right
20:55:47 <TrevorV_> I was rushed
20:56:13 <rm_work> :P
20:56:19 <TrevorV_> Right now we use "amphora_type" in the build command described in the same interface we just decided to trim down. The interface though doesn't really fit for containers, and doesn't fit for bare-metal (ironic)
20:56:21 <blogan> TrevorV_: i don't think anyone has any context for that right now, so yeah we need people to look at the review
20:56:27 <TrevorV_> Right, thought so
20:56:54 <barclaac|2> ^^ On the mid-cycle hackathon dates. Please put me out of my admin's misery soon. I've got our conf room booked for 3 weeks solid.
20:57:09 <TrevorV_> ha ha ha ha nice barclaac|2
20:57:45 <rm_work> heh
20:57:51 <sballe> barclaac|2: we have agreed on dec 15-19
20:57:54 <blogan> barclaac|2: it likely will be Dec 15th, but when it ends we don't know yet, Dec 17th at the earliest
20:57:57 <rm_work> Well, I booked tickets up on the 13th, so I really hope it's solid by now
20:58:15 <sballe> it is
20:58:18 <rm_work> Speaking of, does anyone up there have a decent couch? :P
20:58:28 <barclaac|2> I saw it as an open action up above so was asking. Decisions = good
20:58:28 <rm_work> I'm on the standard Rackspace budget for this one
20:58:31 <blogan> sballe: almost all of the midcycle meetups are only 3 days
20:58:34 <rm_work> IE nothing
20:58:46 <blogan> noting prevents octavia from doing 5 days though
20:58:50 <blogan> thats why I am unsure
20:58:55 <sballe> ok. so 15-17 and I'll break my travel rule and will travel on a Sunday
20:59:09 <barclaac|2> Thanks sballe
20:59:13 <sballe> I only do that because it is you guys :-)
20:59:16 <dougwig> i can only do 15-17, but i'll be there then
20:59:21 <rm_work> I will plan to be available for 15-19 i think just dougwig was the 17th
20:59:33 <rm_work> the rest of us could stay till the 19th
20:59:56 <sballe> I'll probably leave on the 18 with the red eye back
21:00:09 <rm_work> yeah I guess it is getting close to the holiday
21:00:24 <blogan> alright i think we're done with the meeting
21:00:25 <rm_work> tickets aren't cheap past the 16th T_T
21:00:29 <blogan> #endmeeting