20:00:04 <sbalukoff> #startmeeting Octavia
20:00:04 <openstack> Meeting started Wed Dec 10 20:00:04 2014 UTC and is due to finish in 60 minutes.  The chair is sbalukoff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:08 <openstack> The meeting name has been set to 'octavia'
20:00:11 <sbalukoff> #topic Roll Call
20:00:17 <TrevorV> \o
20:00:18 <barclaac|2> o/
20:00:20 <jorgem> o/
20:00:23 <johnsom> o/
20:00:38 <sbalukoff> Here's the agenda for today:
20:00:41 <sbalukoff> #link https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Agenda
20:00:44 <xgerman> o/
20:00:52 <xgerman> sbalukoff we just reviewed
20:01:06 <sbalukoff> It's short as I'm anticipating a pretty short meeting so people can get back to the Neutron LBaaS split stuff.
20:01:24 <TrevorV> sbalukoff that and we're having the hackathon next week where A LOT will happen
20:01:28 <sbalukoff> Yep.
20:01:30 <TrevorV> I figured this one should be short as well
20:01:31 <blogan> hello!
20:01:36 <sbalukoff> #topic Octavia hack-a-thon next week (reminder)
20:01:41 <sbalukoff> Speaking of which...
20:01:49 <rm_work> o/
20:02:02 <sbalukoff> #link https://etherpad.openstack.org/p/octavia-kilo-meetup
20:02:13 <xgerman> I think HP will host dinner on Thursday (still working on the budget)
20:02:15 <sbalukoff> Again, if you have topics you'd like to see white-boarded, please add them to that list.
20:02:25 <sbalukoff> I'm assuming if you're going, you've RSVPed at this point. :)
20:02:28 <barclaac|2> Thursday is looking tough. It may need to be Tuesday.
20:02:31 <sbalukoff> xgerman: Rad!
20:02:36 <sbalukoff> Either or.
20:02:46 <barclaac|2> We're running into xmas party season. everywhere is booked up
20:02:48 <xgerman> what barclaac|2 said
20:02:49 <sbalukoff> My plan is to be at HP's offices each day around 9:00am.
20:02:59 <blogan> im not going to be there thursday night!
20:03:02 <blogan> jerks
20:03:05 <sbalukoff> Haha!
20:03:10 <jorgem> good planning
20:03:27 <TrevorV> blogan read the messages, they said Tuesday instead
20:03:35 <blogan> i was catching up
20:03:36 <TrevorV> :D
20:03:38 <blogan> had to immediately respond
20:03:43 <sbalukoff> Heh!
20:03:45 <blogan> i retract my jerk comment
20:03:50 <sbalukoff> Ok, let's keep going...
20:03:53 <sbalukoff> #topic Brief Progress reports
20:03:55 <TrevorV> I have one thing to ask about, but its not a priority for the hackathon (I don't think)
20:04:10 <TrevorV> I'll go first if you don't mind
20:04:19 <TrevorV> I still need eyes on the Octavia API documentation
20:04:20 <sbalukoff> I don't want to call out individual people this week in the interests of time, and in light of the fact that we're all either working on reviews or working on the Neutron split.
20:04:24 <sbalukoff> Go for it.
20:04:32 <TrevorV> Brandon gave some good feedback this morning that I'm working on
20:04:45 <TrevorV> After that I still need other eyes hopefully
20:04:47 <sbalukoff> #action Review all the things
20:05:05 <sbalukoff> #link https://review.openstack.org/#/q/stackforge/octavia+status:open,n,z
20:05:06 <TrevorV> #link https://review.openstack.org/#/c/136499
20:05:16 <TrevorV> Oh... that's a better link
20:05:19 <sbalukoff> Ok, TrevorV. I should have time to give you more feedback today.
20:05:22 <blogan> yes
20:05:23 <johnsom> #link https://review.openstack.org/#/c/132904/
20:05:25 <TrevorV> Alright awesome sbalukoff thanks
20:05:50 <TrevorV> I think I still have changes to make on the nova driver implementation review as well, but still could use reviews there too
20:05:52 <blogan> the controller review shoudl be priority next week
20:05:54 <sbalukoff> FWIW, obviously the work being done at the Neutron hack-a-thon is a Big Deal.
20:06:03 <TrevorV> #link https://review.openstack.org/#/c/133108
20:06:05 <sbalukoff> So, while that's going on, people should help out as they can.
20:06:24 <sbalukoff> But keep in mind we also want to hit next week running.
20:06:30 <xgerman> +10
20:06:32 <TrevorV> +1
20:06:48 <johnsom> Agreed on the controller.  I hope to have an updated patch set up today. Still need to merge base image code though
20:07:00 <sbalukoff> So maybe Friday, if people could spend some time reviewing Octavia blueprints, gerrit reviews, and the whiteboard discussion topics, that would be great.
20:07:53 <sbalukoff> And yes, especially the controller-- this is something that needs to see significant progress next week.
20:08:07 <TrevorV> Which I suspect is going to happen
20:08:15 <sbalukoff> Does anyone else have progress reports they'd like to share at this time?
20:08:31 <xgerman> sballe ask me to share the following:
20:08:51 <xgerman> I am working on the bp: scheduler in the controller. I ahve made some progress around anti-affinity and I am going to look at HA models. I plan to send out an email or a google doc draft soon for review
20:09:08 <sbalukoff> Cool beans.
20:09:11 <sbalukoff> Thanks, sballe!
20:09:16 <TrevorV> awesome sballe via xgerman
20:09:38 <sbalukoff> Ok... moving on...
20:09:45 <sbalukoff> #topic Open Discussion
20:09:52 <TrevorV> Alright, I have one thing to address specifically
20:09:59 <TrevorV> And one thing that's important to the hackathon
20:09:59 <sbalukoff> Go for it.
20:10:08 <johnsom> Question about the whole graphviz thing.  The arch diagram for the controller looks horrible with GraphViz.
20:10:24 * TrevorV glares at johnsom....
20:10:31 <TrevorV> ha ha just kidding
20:10:33 * rm_work prefers BlockDiag series, but I think either is allowed
20:10:35 <xgerman> yeah, my 2 year old does better graphs with crayons
20:10:46 <TrevorV> Dang xgerman shots fired
20:11:01 <TrevorV> Do we have a resident GraphViz authority?
20:11:07 <rm_work> that'd be sbalukoff
20:11:17 <sbalukoff> johnsom: Feel free to use another supported graphing format. But note that binary images aren't allowed because it's very difficult for others to effectively review / allter them.
20:11:17 <TrevorV> Legit?  Didn't know that
20:11:23 <johnsom> Min was helping me out with a graphviz version, but neither of us can really get it to be readable.
20:11:28 <blogan> would blockdiag accomplish the same thing?
20:11:38 <dougwig> o/, sorry i'm late
20:11:48 <sbalukoff> Hi dougwig. We
20:11:51 <johnsom> The only openstack docs I could find listed PNG with the image tag.  Does someone have a link to the list of supported formats?
20:11:58 <sbalukoff> are trying to keep the meeting short today. :)
20:11:59 <blogan> i feel like blockdiag is better for reviews, i dont know if its any better looking
20:12:24 <sbalukoff> johnsom: A list is in specs/template.rst
20:12:28 <TrevorV> Would there be a problem making ascii diagrams?
20:12:31 <TrevorV> I can do those like a boss
20:12:32 <sbalukoff> Though I don't know that it's definitive.
20:12:50 <sbalukoff> TrevorV: That's essentially the same thing as a blockdiag. And yes, go for it.
20:13:03 <TrevorV> Awesome!  I didn't know that... :D
20:14:15 <xgerman> we should totally allow turtle and logo
20:14:16 <johnsom> Alright, we will try out blockdiag and if all else fails, do an asciiflow
20:14:18 <TrevorV> Alright, so first thing that's a real concern here:  who is going to host the remote connection for the hackathon, and how can we get it set up before hand and tested so we don't waste time doing it day one?
20:14:45 <xgerman> we will set up a laptop with a web cam
20:14:51 <johnsom> xgerman: logo, nice...
20:15:03 <sbalukoff> xgerman: Is the plan to use google hangout or cisco webex for that?
20:15:04 <barclaac|2> Is inkscape supported - outputs SVG?
20:15:13 <xgerman> google hangout
20:15:16 <TrevorV> sbalukoff xgerman my personal preference would probably be a hangout
20:15:25 <TrevorV> Webex was fairly unclear under most circumstances
20:15:26 <xgerman> that;s ours as well
20:15:30 <rm_work> if that doesn't work, we can set up something easily with Vidyo too for rackers...
20:15:33 <sbalukoff> Mine too, so long as we have few enough remote participants.
20:15:39 <rm_work> for once it actually seems pretty simple to do
20:15:45 <johnsom> The template.rst says: If you require an image (screenshot) for your BP, attaching that to the BP
20:15:45 <johnsom> and checking it in is also accepted.
20:15:48 <TrevorV> rm_work forgot about that
20:15:53 <xgerman> sbalukoff we have a corporate license so 15 is the new max
20:16:13 <sbalukoff> johnsom: That's intended for UI design
20:16:27 <TrevorV> xgerman I think we'll have an actual room for ours so we might just have one connected anyway
20:16:29 <sbalukoff> xgerman: Great!
20:16:33 <TrevorV> Rather than all of us individually
20:16:34 <johnsom> SVG seems the same as PNG to me.  I can easily export SVG.
20:16:46 <johnsom> sbalukoff: actually that is the diagram paragraph
20:17:02 <rm_work> SVG is not binary
20:17:02 <rm_work> so
20:17:04 <rm_work> :P
20:17:16 <sbalukoff> So here are the requirements for diagrams:
20:17:45 <xgerman> make it in gerrit so we can +/-1
20:17:46 <sbalukoff> * Must be able to review / edit using standard gerrit tools (ie. 'diff' does something useful)
20:18:05 <sbalukoff> * Must be able to be built into actual images by the doc build process.
20:18:12 <sbalukoff> Beyond that, I don't care.
20:18:40 <blogan> well it would be nice to standardize so taht we don't have learn how to read 50 different formats
20:18:48 <sbalukoff> I specifically want to avoid the scenario where we're checking binary crap into gerrit, or where one person has a master source file that never gets checked into gerrit.
20:19:44 <johnsom> sbalukoff: Grin, so png is fine as gerrit and the doc render tools accept it.  We will keep messing with these tools.  I just hate burning so much time on less than readable file formats.
20:20:05 <blogan> johnsom: no one can comment on specific parts of a png though
20:20:14 <sbalukoff> blogan: +1
20:20:22 <barclaac|2> Ahem - svg...
20:20:40 <barclaac|2> If you truly want to view the text, you're welcome.
20:20:57 <xgerman> postscript?
20:21:05 <TrevorV> ascii diagram?
20:21:19 <xgerman> nah, postscript is a programming language :-)
20:21:20 <mwang2> ascii diagram for some image is very hard to read
20:21:43 <blogan> i think openstack standardizes on ascii and blockdiag
20:21:51 <blogan> for specs
20:21:54 <TrevorV> mwang2 trust me, I can get it all pretty... It might not match the 80 char limit though :D
20:21:57 <xgerman> so graphviz was never in
20:22:01 <sbalukoff> So... use the "right" format for the image you're producing. It would be silly to use GraphViz for a web sequence diagram, for example.
20:22:16 <sbalukoff> xgerman: What do you mean?
20:22:20 <TrevorV> mwang2 I did it every day in my programming classes in college :D
20:22:34 <xgerman> just expanding on blogan
20:22:42 <xgerman> anyhow, can we take that to gerrit
20:22:57 <mwang2> TrevorV how do you draw diagonal
20:22:58 <mwang2> line
20:23:03 <blogan> so neutron accepts asciiflow, blockdiag, actdiag, nwdiag, and seqdiag
20:23:08 <TrevorV> mwang2 very carefully ha ha ha.
20:23:20 <xgerman> I don't think we will get a conclusion here  + need it in the rst
20:23:21 <sbalukoff> And we support all those and GraphViz.
20:23:24 <TrevorV> mwang2 I can talk to you about it later, or work with you on it if needed, kk?
20:23:27 <blogan> yep
20:23:51 <TrevorV> Okay my last concern is code documenation
20:23:56 <TrevorV> documentation***
20:24:02 <xgerman> +1
20:24:14 <TrevorV> Last I knew there needs to be documentation throughout the code, right?  As a requirement to be in Openstack at least?
20:24:19 <TrevorV> When should we start working on that?
20:24:25 <sbalukoff> But I really don't want to allow binary or 'machine-generated' formats (like postscript) for the same reason we don't do specs as .pdf's.
20:24:42 <xgerman> you have the power to -2
20:25:15 <sbalukoff> xgerman: Yes, and this is why I'm saying this now, so people won't be surprised when they get a -2.
20:25:54 <sbalukoff> TrevorV: So, we're already doing some of that.
20:26:12 <sbalukoff> I seem to recall we've been requiring docstrings in most code we've written.
20:26:23 <sbalukoff> That which doesn't have this, is usually code imported from another project.
20:26:45 * xgerman was changing postscript in a text editor
20:26:49 <sbalukoff> TrevorV: Are you thinking of anything specific that doesn't have this?
20:27:15 <sbalukoff> xgerman: And I've edited sendmail.mc files by hand too. I wouldn't recommend it.
20:28:36 <TrevorV> sbalukoff my nova driver doesn't have doc strings that I remember...
20:28:47 <TrevorV> I mean, I guess I could have done it unknowingly
20:28:49 <TrevorV> ha ha
20:29:20 <sbalukoff> TrevorV: I recommend adding docstrings to your nova driver. :)
20:29:51 <TrevorV> sbalukoff hey thanks!  Ha ha, I don't suppose you could -1 in the review with that suggestion at some point today, could ya?
20:29:58 <sbalukoff> But to answer your question: If you see code that isn't documented properly (that wasn't imported from another project), then please feel free to add said documentation immediately or bring it to others' attention.
20:30:10 <sbalukoff> Keeping the code documented is going to be easier if we do it as we write it.
20:30:30 <sbalukoff> TrevorV: Will do.
20:31:25 <sbalukoff> Ok, does anyone have anything else for the group today?
20:31:46 <sbalukoff> Going once...
20:32:00 <sbalukoff> Going twice...
20:32:26 <sbalukoff> #endmeeting