20:00:18 <sbalukoff> #startmeeting Octavia
20:00:19 <openstack> Meeting started Wed Jan 14 20:00:18 2015 UTC and is due to finish in 60 minutes.  The chair is sbalukoff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:23 <openstack> The meeting name has been set to 'octavia'
20:00:24 <sbalukoff> Howdy folks!
20:00:24 <TrevorV> o/
20:00:29 <sbalukoff> #topic Roll Call
20:00:34 <TrevorV> o/ again
20:00:35 <blogan> present
20:00:46 <johnsom> o/
20:01:03 <ajmiller> o/
20:01:06 <dougwig> I/
20:01:14 <TrevorV> dougwig is a cone head
20:01:14 <sbalukoff> Here's our agenda for today:
20:01:18 <sbalukoff> #link https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Agenda
20:01:23 <xgerman> o/
20:01:25 <a2hill> o/
20:01:31 <bedis> o/
20:01:45 <sbalukoff> Let's also see if we can get through it fairly quickly so people can get back to being productive. :D
20:02:05 <sbalukoff> #topic Brief progress reports
20:02:20 <sbalukoff> Ok, so! We got a lot of stuff merged this last week which is great.
20:02:31 <xgerman> +100
20:02:43 <jorgem> o/
20:02:45 <sbalukoff> On the amphora API: I'm sorry to report no progress this last week; Should have more time for this this week.
20:03:11 <blogan> off with his head
20:03:15 <TrevorV> On the client side, I've got a little bit more testing to write, but it should be updated per the current spec
20:03:15 <xgerman> I will integrate TrevorV's code into the flows + test it
20:03:20 <TrevorV> However the spec needs updated
20:03:27 <sbalukoff> I also notice that we've got a ton of WIP reviews, so I consider that a good sign that people are working on stuff and committing early and often. :)
20:03:36 <a2hill> i submitted a start on the haproxy driver and was working on some taskflow/taskflow testing. Will probably work on neut-lbaas ref-impl ext
20:03:45 <sbalukoff> TrevorV: Yes, spec needs updating. I'll do that before adding more code.
20:03:57 <TrevorV> kk sbalukoff I'll update accordingly as well
20:04:19 <sbalukoff> a2hill: I understand you're blocked on the spec updates, right?
20:04:28 <sbalukoff> Anything else anyone is blocked on presently?
20:04:30 <bedis> a2hill: don't hesitate to contact me directly to review your haproxy driver :)
20:05:09 <rm_mobile> Kinda blocked on the requirements cr I linked
20:05:15 <TrevorV> bedis sbalukoff you might want to talk with each other about the backend of the amphora API as well
20:05:40 <ajmiller> I have seen the comments by sbalukoff and blogan regarding the housekeeping manager spec https://review.openstack.org/#/c/142633/9.  I will reply with some comments and a new patch today or tomorrow.
20:05:42 <sbalukoff> rm_mobile: Could you like it here?
20:05:45 <sbalukoff> link
20:05:52 <a2hill> Correct sbalukoff, some of the answers there will help decide driver logic
20:05:59 <sbalukoff> ajmiller: Thanks! that's great!
20:06:12 <a2hill> bedis, the driver itself is very simple mostly because things like the api is abstracted from it.
20:06:20 <sbalukoff> a2hill: Ok, I will do what I can to prioritize getting those answers done.
20:06:21 <a2hill> sbalukoff rm_work will be joining soon
20:06:32 <a2hill> Thank you sbalukoff
20:06:41 <blogan> a2hill, bedis: except building the haproxy config
20:06:59 <xgerman> +1
20:07:02 <blogan> ajmiller: good to know
20:07:03 <a2hill> well yea, and in that case its sorta ready for review inside here:
20:07:12 <rm_work> sbalukoff: https://review.openstack.org/#/c/146231/
20:07:17 <a2hill> https://review.openstack.org/#/c/144348/
20:07:22 <rm_work> sbalukoff: linked in the meeting overview thing too
20:07:23 <sbalukoff> blogan: Yeah, but that's basically just a template. ;)
20:07:31 <a2hill> ^
20:07:39 <xgerman> jinja template I hope
20:07:42 <TrevorV> #link https://review.openstack.org/#/c/146231/
20:07:50 <TrevorV> #link https://review.openstack.org/#/c/144348/
20:07:59 <a2hill> Thank you TrevorV ;)
20:08:06 <sbalukoff> xgerman: You can -1 it if it isn't. (It is.) ;)
20:08:08 <TrevorV> #link https://review.openstack.org/#/c/142633/9
20:08:26 <sbalukoff> rm_work: Aah! Right.
20:08:28 <a2hill> Unicorn Template, what is this 'jinja' you speak of
20:08:33 <xgerman> I was just checking :-)
20:09:25 <sbalukoff> Heh!
20:09:49 <sbalukoff> Ok! Any other progress reports people would like to share at this time and/or blockers / requests for help people want to bring up?
20:10:25 <dougwig> rm_mobile: you don't have to wait for that review.  Our req file is already in violation. And while that needs to be fixed, you can make progress
20:10:31 <sbalukoff> (FWIW, I'm pretty happy with the velocity we've achieved since the new year...)
20:10:57 <xgerman> guess that was everybody's new year resolution ;-)
20:11:11 <rm_work> dougwig: it breaks the gate
20:11:14 <rm_work> dougwig: jenkins -1s
20:11:20 <rm_work> oh wait shit
20:11:35 <rm_work> I think I am thinking of a neutron-lbaas CR >_< nm ignore me
20:12:02 <dougwig> So just import blindly for now, and try wrap
20:12:14 <dougwig> Ok
20:12:17 <blogan> im pretty sure he's talking about neutron-lbaas
20:12:20 <rm_work> yep
20:12:25 <rm_work> which is the only reason it matters
20:12:27 <rm_work> so ignore me
20:12:32 <blogan> always do :)
20:12:42 <rm_work> forgot which meeting i was in T_T
20:12:44 <dougwig> That's not stack forge, so has less leeway
20:12:48 <rm_work> it's all the same people...
20:13:02 <sbalukoff> :)
20:13:05 <sbalukoff> No worries, eh.
20:13:10 <sbalukoff> Ok, so!
20:13:16 <sbalukoff> Let's move on to the next topic.
20:13:20 <dougwig> Infra rules vary.
20:13:20 <sbalukoff> #topic Closing in on an alpha release
20:13:44 <blogan> define "closing ini"
20:13:51 <blogan> i mean "closing in"
20:13:57 <sbalukoff> Basically, with this I just wanted to say that I'd like to put together a list of the last to-do's and whatnot's we'll need to get an alpha release going. Something akin to the 0.25 release.
20:14:12 <sbalukoff> But something which spins up an amphora, plumbs it, and can configure listeners on it.
20:14:27 <xgerman> we can spin up amphora today
20:14:30 <sbalukoff> I'm going to try to coordinate / document this via launchpad (as much as I hate it.)
20:14:33 <blogan> we can't end to end
20:14:46 <rm_work> kk, but only on the condition that when we release our 0.5 version, we code-name it '50-cent'
20:14:52 <sbalukoff> xgerman: I'm looking for something people can really start playing with that will actually do some load balancing.
20:14:53 <jorgem> Geting a create end to end would be a nice milestone
20:15:13 <barclaac> Rm-work +1
20:15:19 <sbalukoff> jorgem: I also know you want to see features, etc. tied to milestones.
20:15:34 <sbalukoff> I'll try to do this, but again, I think launchpad is a very hamfisted tool for this kind of thing, to put it nicely.
20:15:47 <jorgem> sbalukoff: correct
20:16:05 <sbalukoff> On this front, if y'all have insights that are not obvious, or know of things we will need to do that are not presently covered in a blueprint, please let me know!
20:16:10 <sbalukoff> (Outside of this meeting)
20:16:40 <xgerman> ok, we should probably define what end-to-end mean
20:17:01 <xgerman> you want to use the neutron/open stack client create??
20:17:22 <blogan> end-to-end to me means octavia api request spins up a vm with haproxy loaded that can accept traffic and load balance
20:17:39 <xgerman> so no neutron lbaas integration?
20:17:42 <blogan> no
20:17:54 <blogan> just using the octavia api
20:18:07 <dougwig> I'll write a quick neutron driver.
20:18:16 <xgerman> thanks dougwig
20:18:28 <sbalukoff> #action dougwig to write a quick Neutron driver for Octavia
20:18:39 <blogan> hes good at writing drivers
20:18:44 <sbalukoff> Indeed!
20:18:50 <bedis> (in .rb)
20:18:56 <sbalukoff> HAHA
20:18:57 <barclaac> Quick and neutron in the same sentance. Cool!
20:18:58 <rm_work> T_T
20:19:09 <dougwig> Yes yes in rb!!
20:19:11 <blogan> he should have said neutron-lbaas
20:19:18 <blogan> bedis dont encourage dougwig
20:19:36 <bedis> I'm challenging him
20:19:42 <sbalukoff> Ok, anyway, I just wanted to get that out there, and let you know where my intentions lie for the next few weeks-- we're so close, I feel like we should be able to have an alpha pretty quickly.
20:20:09 <sbalukoff> (Obviously, the Neutron LBaaS meet-up is in those next few weeks-- and that work will take priority then, of course.)
20:20:20 <sbalukoff> Ok, next topic;
20:20:24 <sbalukoff> #topic Summit talk proposals
20:20:27 <xgerman> well, next end-to-end question: Our goal is devstack?
20:20:40 <sbalukoff> xgerman: Not necessarily.
20:20:45 <blogan> it would be a nice to have
20:20:47 <xgerman> glad I asked :-)
20:20:54 <jorgem> blogan: true dat
20:21:02 <blogan> but its not end to end to me
20:21:28 <sbalukoff> jorgem: Did you have any particular summit talk proposals in mind?
20:21:34 <jorgem> Well...
20:21:50 <jorgem> since we spoke in Paris I was wondering what kind of talk WOULD make sense for Vancouver
20:21:53 <dougwig> I want to submit another version of what we did in Paris
20:21:59 <jorgem> I wanted to get some thoughts on that
20:21:59 <a2hill> ><
20:22:03 <blogan> dougwig: for neutron-lbaas?
20:22:23 <jorgem> dougwig: Should it be more Octavia based this time?
20:22:25 <dougwig> Yes, but we could bundle in the mew reference, Octavia
20:22:29 <dougwig> New
20:22:41 <sbalukoff> I think it makes sense to have a Neutron LBaaS v2 talk in any case. I also think Octavia should be at a state where we can show people "Look! It does stuff!"
20:22:43 <xgerman> well, we can have two talks -- espeically if we announce Octavia .5 there
20:22:46 <dougwig> On phone and walking
20:23:08 <sbalukoff> dougwig: Hell yeah!
20:23:13 <dougwig> I'd like to demo DSL and Octavia.  Could be 2
20:23:22 <blogan> dsl?
20:23:22 <dougwig> Ssl
20:23:24 <blogan> ohh
20:23:29 <sbalukoff> Agreed.
20:23:31 <blogan> you mean tls
20:23:32 <dougwig> Dya
20:23:34 <jorgem> Cable modems?
20:23:38 <sbalukoff> HAHA
20:23:54 <xgerman> sounds like udp load balancing
20:23:54 <bedis> how to LB modems with HAProxy :)
20:24:03 <a2hill> ;p
20:24:09 <bedis> haproxy.rb :)
20:24:12 <bedis> of course
20:24:15 <a2hill> ><
20:24:15 <sbalukoff> XD
20:24:27 <jorgem> okay so two talk proposals then. On on Neutron LBaaS and one on Octavia?
20:24:31 <jorgem> One*
20:24:32 <blogan> the only person stopping us from udp load balancing is bedis
20:24:42 <xgerman> jorgem +1
20:24:54 <sbalukoff> I guess part of the reason to discuss this in this group is to collaborate between our companies on who is going to be giving these talks, right?
20:25:10 <jorgem> sbalukoff: that would be nice
20:25:15 <xgerman> +1
20:25:24 <sbalukoff> Well, I'm game for helping out with both of those talks. :D
20:25:24 <blogan> i figure dougwig and i will be doing a neutron-lbaas talk
20:25:24 <jorgem> I'm planning on going this time around and I love speaking :)
20:25:40 <sbalukoff> (Especially since I somehow ended up on stage even though I wasn't a speaker last time.)
20:25:46 <sbalukoff> (Again, I'm a jerk)
20:25:55 <xgerman> I went up there, too
20:25:58 <jorgem> Who would like to talk?
20:26:01 <sbalukoff> Indeed!
20:26:03 <xgerman> me
20:26:03 <rm_work> i doubt i'll go to this one, again
20:26:09 <jorgem> Let's get names and then split up talks?
20:26:10 <blogan> vivek somehow ended up on stage and we hadn't talked to him prior ot that
20:26:24 <xgerman> he did the best demo there though!
20:26:28 <jorgem> Somehow blogan got on stage
20:26:30 <sbalukoff> Haha! True!
20:26:30 <rm_work> since if blogan and jorgem are going, they probably won't send a third, and i don't want to push my luck since i REALLY want to go to Tokyo
20:26:33 <a2hill> I want to try again, but others may want to hang me or themselves before letting me do it again
20:26:35 <johnsom> me as well
20:26:56 <a2hill> i would love to do one in Tokyo
20:27:00 <a2hill> :D
20:27:00 <sbalukoff> Vancouver is practically in our back yard. Expect a lot of Blue Box people there.
20:27:10 <xgerman> same for HP Cloud
20:27:15 <sbalukoff> Yep!
20:27:35 <sbalukoff> Ok, I would definitely like to talk, it sounds like german would, as well as jorgem and blogan.
20:27:45 <sbalukoff> And dougwig, right?
20:27:45 <xgerman> + johnsom
20:28:11 <sbalukoff> Ok, perhaps we can take it offline to refine the talk ideas and who is probably most appropriate to be speaking for which?
20:28:22 <blogan> well ill definitely do a neutron-lbaas one but if a lot want to do octavia i dont ahve to do that one
20:28:29 <sbalukoff> (Though we are doing well on time here-- we could continue to discuss this here.)
20:28:52 <sbalukoff> It probably makes sense for me to do the Octavia one.
20:28:59 <xgerman> yep
20:29:09 <xgerman> after all you are the PTL :-)
20:29:11 <sbalukoff> Until y'all rise up in a bloody coup.
20:29:18 <sbalukoff> ;)
20:29:45 <sbalukoff> (Or, you know, we do an actual PTL election.)
20:30:58 <xgerman> ok, two talks lots of people
20:31:00 <jorgem> so so far 4 people would like to talk?
20:31:16 <xgerman> I counted 6
20:31:17 <sbalukoff> I count 6 with dougwig and johnsom
20:31:28 <jorgem> ah yes didn't see those lines
20:31:35 <johnsom> Man no respect, no respect at all...
20:31:38 <jorgem> lol
20:31:39 <sbalukoff> HAHA
20:31:49 <blogan> johnsom should change his name to dangerfielr
20:31:57 <sbalukoff> XD
20:32:03 <jorgem> we will most likely ad several people during the talk anyways
20:32:10 <sbalukoff> Yup.
20:32:14 <xgerman> +1
20:32:18 <jorgem> add* gosh I can't type today
20:32:37 <xgerman> we are fond of calling people on stage for a demo
20:32:39 <sbalukoff> Does it make sense to have separate talks in Neutron LBaaS land for:  v2, and TLS?
20:32:47 <sbalukoff> (ie. three talk ideas?)
20:33:05 <dougwig> I don't think so
20:33:06 <jorgem> sbalukoff: I'm going with not really
20:33:06 <blogan> well i would say no if we were guaranteed to get both accepted
20:33:07 <xgerman> +1
20:33:16 <xgerman> two talsk areenough
20:33:21 <sbalukoff> blogan: That was what I was getting at.
20:33:27 <blogan> yeah but octavia getting accepted is probably low
20:33:36 <xgerman> sadly, you are right
20:33:40 <sbalukoff> Though I suppose more proposals is just likely to dillute th vote.
20:33:41 <blogan> since the masses dont know much about it
20:33:42 <sbalukoff> the.
20:33:44 <dougwig> Openstack has many pieces, and limited talk slots.  Lbaas isn't that huge to anyone but us to warrant half a dozen talks.
20:34:00 <xgerman> we should have a whole track
20:34:04 <sbalukoff> dougwig: You're right.
20:34:10 <jorgem> Let's call it "Neutron LBaaS Drivers" and then only talk about Octavia :)
20:34:15 <sbalukoff> XD
20:34:19 <sbalukoff> And A10, right?
20:34:30 <sbalukoff> *That* won't piss any vendors off at all.
20:34:32 <dougwig> I still think that a neutron lbaas plus Octavia, with demos, would make a very focused 40 minutes.
20:34:43 <bedis> add a "pr0n" keyword inside ;)
20:34:46 <sbalukoff> dougwig: A very full 40 minutes.
20:34:54 <sbalukoff> Especially if "with demos" happens.
20:34:58 <blogan> dougwig: yeah we sped through the neutorn lbaas talk in paris and had way too much time at the end
20:35:11 <dougwig> We only used 30 last time, with an ad hoc demo.
20:35:24 <rm_work> yeah because ya'll talked SUPER fast
20:35:25 <xgerman> but now you could demo v2 calls
20:35:27 <rm_work> slow it down :P
20:35:27 <sbalukoff> Aah, that's right.
20:35:37 <sbalukoff> That, too.
20:35:52 <bedis> fail the demo
20:35:54 <bedis> then fix it
20:36:10 <dougwig> Each demo is about 5 minutes.  15 minutes to talk about lbaas and split, 15 minutes for an Octavia diagram and overview?
20:36:21 <sbalukoff> jorgem: Do you want to coordinate the talk proposals?
20:36:37 <xgerman> well, it seems there is only one
20:36:52 <xgerman> can we have 6+ people in one talk?
20:37:06 <xgerman> or does OpenStack limit us?
20:37:10 <bedis> hard :/
20:37:12 <TrevorV> xgerman isn't that just a panel then?
20:37:17 <dougwig> Lightning mode.  We had four last time.
20:37:18 <xgerman> yep
20:37:22 <sbalukoff> I doubt they'd give us all speaker credit.
20:37:39 <sbalukoff> But if most of us have ATC anyway... what's the harm?
20:37:49 <blogan> xgerman doesnt
20:37:59 <jorgem> sbalukoff: Are we saying 1 or 2 talks?
20:38:00 <sbalukoff> xgerman: Get on that, yo!
20:38:06 <jorgem> I say 2 to hedge our bets
20:38:06 <xgerman> yep, dougwig let me down some hollow path
20:38:22 <blogan> i think we should go with two proposal, one neutorn lbaas and one octavia, if octavia gets accepted then neutorn lbaas has enough material to just mention octavia
20:38:22 <dougwig> Let's find out what the submission allows, then figure it out
20:38:33 <sbalukoff> It sounds like we could do one-- but I think I'd like to do two. I think we could do one just on Octavia and have more than enough to talk about for 40 minutes.
20:38:34 <dougwig> xgerman: we will still get that in
20:38:35 <jorgem> alright I'll check in on that
20:38:37 <blogan> if octavia doesn't neutorn lbaas can expand on octavia
20:38:43 <rm_work> yeah
20:38:53 <sbalukoff> blogan: +1
20:39:05 <dougwig> Fine by me.  I can coordinate the neutron talk?
20:39:07 <xgerman> blogan +1
20:39:08 <jorgem> #action jorgem to check on speaker limit
20:39:18 <sbalukoff> dougwig: Sounds good.
20:39:19 <jorgem> sbalukoff: I think you need to give me the action item
20:39:21 <blogan> dougwig: go
20:39:25 <xgerman> also RAX can always rent a suite so we can give more talsk ;-)
20:39:30 <sbalukoff> #action: jorgem to check on speaker limit
20:39:39 <blogan> xgerman: HP better have an amazing party
20:39:46 <sbalukoff> #action: dougwig to coordinate on Neutron LBaaS talk.
20:39:51 <sbalukoff> HAHA
20:39:54 <xgerman> lol
20:40:03 <sbalukoff> jorgem: Did you want to coordinate on the Octavia talk, or leave that to me?
20:40:04 <dougwig> The bar is set
20:40:29 <sbalukoff> I will be very surprised if that bar gets even closely approached for a long time.
20:40:34 <jorgem> sbalukoff: I guess you can. I'd just like to participate in the speaking. But I can work with you on the outline
20:40:39 <sbalukoff> Epic doesn't even begin to describe that party.
20:40:46 <sbalukoff> jorgem: Sounds good!
20:40:55 <sbalukoff> #action: sbalukoff to coordinate on Octavia talk.
20:40:59 <sbalukoff> Ok!
20:41:03 <sbalukoff> Moving on...
20:41:07 <sbalukoff> #topic Open Discussion
20:41:39 <sbalukoff> Er... anyone have anything they'd like to discuss in the group here?
20:41:44 <TrevorV> I have a question for anyone!  Does anyone have any knowledge of "responses", a library used to mock the "requests" library?
20:41:51 <blogan> nope
20:41:56 <xgerman> nope
20:41:59 <jorgem> nope
20:42:02 <a2hill> nope
20:42:04 <sbalukoff> I do.
20:42:07 <sbalukoff> Just kidding. I don't
20:42:07 <jorgem> heyo!
20:42:11 <jorgem> lol
20:42:11 <xgerman> I usually used mock
20:42:11 <a2hill> lel
20:42:44 <TrevorV> xgerman responses seems to make it really really simple
20:42:58 <rm_work> hmm
20:42:59 <xgerman> yeah, go for it :-)
20:43:02 <rm_work> no idea
20:43:07 <bedis> just to let you know I should come to San Antonio meetup
20:43:07 <sbalukoff> TrevorV: Yep! Give it a shot.
20:43:17 <sbalukoff> bedis: Excellent!
20:43:19 <TrevorV> Oh I wasn't looking for permission ha ha, I was wondering if someone could be a source of a question or two :D
20:43:34 <blogan> permission will be rejected with a -2
20:43:40 <sbalukoff> :)
20:43:44 <xgerman> bedis: awesome!
20:44:02 <sbalukoff> Ok, anyone have anything else they'd like to ask or discuss?
20:44:31 <xgerman> it's a wrap
20:44:50 <a2hill> \0
20:44:52 <sbalukoff> Ok, folks! Looks like we're done for today. Thanks, y'all!
20:45:00 <xgerman> o/
20:45:03 <sbalukoff> #endmeeting