20:00:08 <xgerman> #startmeeting Octavia
20:00:09 <openstack> Meeting started Wed Feb 11 20:00:08 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'octavia'
20:00:23 <xgerman> #topic roll call
20:00:25 <johnsom> o/
20:00:26 <dougwig> o/
20:00:27 <ajmiller> o/
20:00:39 <ptoohill> o/
20:00:46 <xgerman> Agenda: https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Agenda
20:01:01 <sballe__> o/
20:01:05 <xgerman> o/
20:01:43 <TrevorV> o/
20:01:45 <TrevorV> late
20:01:53 <rm_work> o/
20:02:40 <xgerman> #topic Brief progress reports
20:02:48 <Aish> o /
20:02:59 <ptoohill> Focus on neutron-lbaas for me.
20:03:33 <johnsom> I am getting back to working on the controller worker.  I have removed the WIP from the spec, so if you can review it would be great.
20:03:43 <johnsom> #link https://review.openstack.org/#/c/149801/
20:03:43 <mwang2_> working on health manager database model, have changed based on the comment, now working on the update health method
20:04:13 <crc32> Watching neutron-lbaas bork out on tox during neutron egg installation.
20:04:16 <TrevorV> So I've been working on the neutron lbaas v2 tempest tests, with franklin and carlos, and have essentially stalled my work on the octavia amphora api
20:04:38 <blogan> hi!
20:04:44 <ptoohill> HP guys may pick up work on the amphora api
20:04:57 <ptoohill> We (RS) may focus on a ssh-client/agent
20:05:00 <ptoohill> thing
20:05:06 <xgerman> ok, sound sgood
20:05:25 <ptoohill> atleast according to chats earlier.
20:05:36 <xgerman> yeah, that's our intention ;-)
20:05:42 <ptoohill> ;)
20:05:51 <xgerman> jorgem submitted another patch for the queue-consumer
20:06:22 <blogan> xgerman: will yall take over the api spec bp sbalukoff started?
20:06:29 <TrevorV> well HP will for the REST API right?  Someone here at Rax will probably do an SSH driver... as far as I recall
20:06:30 <xgerman> yep, will do
20:07:29 <jorgem> o/
20:07:48 <xgerman> assigned that spec to me for now
20:08:01 <xgerman> s/spec/blueprint/
20:08:19 <xgerman> anything else?
20:08:30 <fnaval> o/
20:08:38 <xgerman> moving on...
20:08:43 <xgerman> #topic Demo Octavia in Neutron LBaaS Talk
20:09:28 <blogan> so the plan is to have at least one neutron lbaas talk and in that talk we'll be demoing octavia
20:09:52 <xgerman> exactly + and we are trying to pull together the missing puzzle pieces
20:10:38 <xgerman> The pieces are:
20:10:45 <xgerman> Amphora Driver
20:10:45 <xgerman> Network Driver
20:10:45 <xgerman> Deploy Worke
20:10:59 <xgerman> dis we miss anyhting?
20:11:06 <sballe__> how about compute driver?
20:11:12 <dougwig> neutron lbaas driver
20:11:24 <sballe__> or is that part of the deploy worker
20:11:32 <sballe__> dougwig: +1
20:11:33 <xgerman> sballe__ that one is already merged
20:11:38 <xgerman> dougwig +1
20:11:51 <blogan> compute driver is pretty much done i think
20:11:57 <blogan> btu yeah forgota bout neutron lbaas driver
20:11:58 <sballe__> xgerman: Are we only talking about he missing pieces? or all the pieces?
20:12:04 <blogan> missing
20:12:21 <sballe__> ok thx
20:12:50 <xgerman> so dougwig any progress on the neutron driver ?
20:13:01 <xgerman> (it's your piece :-)
20:13:27 <blogan> i volunteered for the network driver for this, because phil and I have already dong a run through of neutron and nova calls to set up the appropriate plumbing
20:13:33 <dougwig> none yet, i've been focused on the lbaas v2 stuff, flavors, and this: https://review.openstack.org/#/c/154736
20:13:40 <dougwig> i will circle back to that driver shortly.
20:14:24 <blogan> dougwig ill run through what we've done manually if you want
20:15:57 <dougwig> let's take that offline
20:16:22 <blogan> sounds good
20:16:55 <xgerman> johnsom + me will do deploy worker
20:17:01 <jorgem> +1
20:17:04 <jorgem> what
20:17:09 <rm_work> I will be doing reviews! :)
20:17:12 <jorgem> what's the timeframe on that you think?
20:17:46 <xgerman> it's high on our list so the next few weeks
20:17:53 <johnsom> Timeframe for controller worker code?
20:17:55 <johnsom> What he said.
20:18:11 <jorgem> xgerman: johnsom: correct
20:18:12 <johnsom> I hope to have another WIP check in today.
20:18:24 <jorgem> k I'll check it out.
20:18:34 <sballe__> ditto on the review
20:19:53 <xgerman> leaves the amphora driver --
20:20:05 <TrevorV> Oh, you mean the amphora ssh driver?
20:20:13 <xgerman> I think HP will try an API version whereas RAX will do the ssh driver
20:20:24 <xgerman> TrevorV yes
20:20:36 <dougwig> and i will make popcorn and side bets.
20:20:42 <TrevorV> I would put my name on that, but I'm not entirely sure when I can get to it (tempest testing and all that)
20:21:14 <rm_work> eh dougwig already convinced me of the sense in using ssh
20:21:27 <crc32> wow.
20:21:39 <TrevorV> Alright, I'll take ownership of that one
20:21:40 <sballe__> dougwig: +1
20:21:57 <rm_work> dougwig: so no bets to be found here, I would think :P
20:22:12 <dougwig> i didn't say i wasn't rooting for one side.  :)
20:22:25 <sballe__> was just talking abput the popcorn
20:22:41 <dougwig> sballe__: oh, heh.  :)
20:22:50 <xgerman> #agreed TrevorV will write ssh amphora driver
20:23:06 <xgerman> #agreed HP will attempt REST based driver/agent
20:23:47 <sballe__> how do we decide what solution we want to use in the demo?
20:24:04 <sballe__> ;-)
20:24:12 <crc32> sballe_: Wait to see which one performs better or works in reality.
20:24:17 <dougwig> sballe__: that's a problem that i'd love to have.
20:24:25 <dougwig> let's get there first.
20:24:25 <sballe__> dougwig: ;-)
20:25:27 <ptoohill> Theyll both work, i was under the assumption that the ssh driver we were going to work on to get done quick to get our point and this demo across
20:25:39 <crc32> so. Is paramiko still a good idea these days or is something better out there now?
20:25:42 <xgerman> yep, that wa smy impression as well
20:25:48 <ptoohill> the rest api will require more devlopment and a concensus of the contract amongst other things
20:26:14 <xgerman> ptoohill +1
20:26:23 <xgerman> we likely need to iterate
20:26:38 <ptoohill> indeed
20:26:46 <blogan> paramiko bleh
20:26:52 <crc32> I'm kinda burnt out on Rest APIs now. specially sense this isn't something that is customer facing.
20:26:54 <dougwig> crc32: paramiko or just popen('ssh ' + foo)
20:27:14 <rm_work> popen is super ugly <_<
20:27:26 <rm_work> paramiko would have to be REALLY bad
20:27:35 <rm_work> but I feel like this is getting off-topic
20:27:48 <crc32> At the very least let us use paramiko. I'm not in the mood for STDIN STDOUT parsing and mangling.
20:27:56 <xgerman> +1
20:27:59 <dougwig> eh, wrap it once, hide the ugly.  example (not claiming it's not ugly, though): https://github.com/a10networks/neutron-thirdparty-ci/blob/master/ax/ax_ssh.py
20:28:05 <TrevorV> good thing I'll be working on it then, eh crc32 ?
20:28:14 <crc32> yea the wrapper is called Paramiko.
20:28:40 <xgerman> maybe there is an oslo version
20:28:41 <blogan> just use whatever, its going to just be simple and if people want to improve upon it go ahead
20:28:53 <dougwig> no, paramiko is a pure python implementation.  it's much slower.  but i don't think that matters at all here.
20:29:15 <xgerman> yep + long term I expect us to use an agent on the amphora
20:29:22 <TrevorV> Alright, since its my task for the amphora driver I'll sort out the logistics later, kk?  We can move on at this point :P
20:29:45 <xgerman> #topic Open Discussion
20:29:54 <dougwig> since it's open, we can bring up ssh again.
20:29:55 <dougwig> jk
20:30:04 * xgerman hides
20:31:42 <xgerman> dougwig you have the etherpad links for the Vancouber talks
20:31:44 <xgerman> ?
20:32:04 <dougwig> dangit, forgot that.  one sec, i'll create and post a link here or in lbaas channel
20:32:14 <xgerman> great
20:32:29 <TrevorV> dougwig could I steel your attention later for some reviews
20:32:47 <xgerman> also regarding Vancouver - are we trying to do something in the design summit?
20:32:48 <blogan> ^ steal
20:33:43 <blogan> i woudl like to
20:33:57 <xgerman> me, too - so
20:34:02 <blogan> for octavia?
20:34:04 <blogan> or for neutron-lbaas
20:34:13 <blogan> i mean both kind of need one
20:34:19 <xgerman> yep
20:34:21 <sballe__> Agreed
20:34:40 <xgerman> #action find out to get Octavia and Neutron LBaaS into the design summit
20:34:49 <dougwig> https://etherpad.openstack.org/p/lbaas-vancouver-talks
20:34:59 <dougwig> i'll get talk outlines added there as well.
20:35:27 <xgerman> dougwig so johnso, jorgem, na dme need our won talk?
20:35:33 <dougwig> what contentious stuff do we have that needs the entire community?
20:35:59 <dougwig> xgerman: i can barely parse that sentence, but those speaker lists are far from final.
20:36:02 <jorgem> xgerman: eh? lol
20:36:22 <xgerman> well, last time we said johnsom, jorgem, and I would like to talk, too
20:36:33 <xgerman> so reading that we need a third talk ;-)]\
20:36:40 <dougwig> everyone is welcome to add their feedback, requests, new speakers, etc, there, and then we can talk about what makes sense. i just had to get the slots submitted by monday.
20:36:55 <sballe__> we need to be careful with too many speakers on the talks. it gets confusing. Should we do a panel with more companies represented?
20:37:03 <dougwig> xgerman: that was for a standalone octavia talk, which i didn't submit.  did stephen send that?
20:37:10 <xgerman> nope
20:37:30 <blogan> i doubt it would have been accepted anywya, no one knows what octavia is yet
20:38:22 <johnsom> Who is Sam?
20:38:27 <xgerman> Radware
20:38:41 <dougwig> nothing says we can't fold some or all of those folks into the octavia part of the lbaas talk.  note it in the etherpad, and we can talk about what makes sense.
20:39:11 <sballe__> The talk is 20 minute right? or is it longer>
20:39:26 <dougwig> 40 minutes.
20:39:38 <dougwig> 5 minutes for qa, 10 for demo, the rest for talking.  ish.
20:41:40 <dougwig> btw, i'm not dead set on being a speaker, either. please give your feedback on the etherpad.
20:41:48 <johnsom> dougwig, didn't you ask me for my openstack details for a talk or was that for something else?
20:42:14 <xgerman> well, so we lock in on those two talks or are we trying to submit an Octavia talk as well?
20:42:20 <johnsom> Maybe it was Stephen
20:42:22 <dougwig> i was testing the speaker submissions, but ended up not being the octavia submitter.
20:42:27 <sballe__> dougwig: I think one person from each company makes sense to me.
20:42:49 <TrevorV> +1 sballe__
20:42:56 <xgerman> +1
20:44:13 <johnsom> +1
20:44:29 <mwang2_> +1
20:44:30 <dougwig> let's put our feedback into the etherpad, and circle back next week?  my apologies if anyone feels left out; i think he octavia half got lost in the transition shuffle, and I never considered the current submissions final.
20:44:56 <TrevorV> Sounds good
20:45:01 <sballe__> dougwig: no problem.
20:45:01 <rm_work> i mean, i agree that it seems unlikely Octavia talks would get accepted, since it's still Stackforge and relatively unknown
20:45:24 <xgerman> rm_work - and HP was ready to run a super bowl ad foer it
20:45:30 <rm_work> heh
20:45:36 <rm_work> that would have been awesome :P
20:45:36 <sballe__> We could submit the octavia talk as a brownbag or whatever they call the 10 mins talks
20:45:44 <dougwig> the submission deadline was this last monday.
20:45:47 <rm_work> yeah I assume that'd be where we'd fit
20:45:57 <dougwig> so if we don't have a placeholder in there, i think that ship has sailed.
20:46:00 <rm_work> brownbag submissions are much later I thought?
20:46:13 <dougwig> i meant for the conference talks
20:46:17 <sballe__> yes They are after the people have voted on the talks
20:46:19 <rm_work> or "lightning talks" or whatever they are called in the Openstack world
20:46:22 <rm_work> yeah
20:47:03 <xgerman> let's do that
20:47:12 <sballe__> and people don;t vote on lighting talks so we can submit more than one and they will be accepted ;-)
20:49:20 <xgerman> so who is taking the action item to submit that talk
20:49:23 <xgerman> ?
20:50:00 <sballe__> Did you agree on the list of speakers?
20:50:44 <xgerman> I was talking brownbag - I am really afraid things fall again through cracks
20:51:12 <sballe__> I agree but one of the speakers will have to submit the talk and not random peopel
20:51:45 <blogan> one of the speakers of an accepted talk has to submit it?
20:51:50 <dougwig> eh, it's pretty fluid, actually.  any speaker can add or remove others, so you can bootstrap it.
20:52:59 <sballe__> I was talking about speakers for the brownbag. never mind.
20:53:28 <xgerman> ok, I will try to keep an eye on that deadline
20:54:19 <dougwig> i'd suggest we add design session topics in the same etherpad.
20:54:22 <dougwig> if any
20:54:26 <sballe__> +q
20:54:30 <xgerman> +1
20:54:30 <sballe__> +1 ;-)
20:55:26 <xgerman> we have 5 minutes left...
20:55:41 <xgerman> (in case we have other topics :-)
20:56:30 <dougwig> the beauty of ssh and ruby!
20:56:38 <dougwig> sorry, in a weird mood today.  :)
20:56:42 <xgerman> #link https://etherpad.openstack.org/p/lbaas-vancouver-talks
20:56:56 <xgerman> pretty ruby...
20:56:59 <johnsom> Gem stones?
20:57:20 <dougwig> gems versus pip, lord yes.
20:57:31 <xgerman> lol
20:57:52 <xgerman> guess better finish before somebody gets hurt
20:57:57 <ptoohill> clear
20:57:57 <xgerman> #endmeeting