20:00:17 <xgerman> #startmeeting Octavia
20:00:18 <openstack> Meeting started Wed Mar 18 20:00:17 2015 UTC and is due to finish in 60 minutes. The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:21 <openstack> The meeting name has been set to 'octavia'
20:00:33 <johnsom> o/
20:00:42 <xgerman> #chair blogan
20:00:44 <openstack> Current chairs: blogan xgerman
20:01:08 <bharath> o/
20:01:20 <ptoohill> o/
20:01:24 <mwang2> o/
20:01:31 <barclaac|2> o/
20:01:38 <blogan> o/
20:01:46 <xgerman> agenda: https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-03-18
20:01:47 <ajmiller> o/
20:02:16 <sballe> o/
20:02:41 <xgerman> #topic Announcements
20:03:01 <xgerman> Crunch time for Neutron LBaaS; SSL merged yesterday...
20:03:04 <rm_work> o/
20:03:15 * TrevorV late but present
20:03:43 <bedis> o/
20:03:51 <xgerman> that's all the announcements I can think of...
20:04:02 <rm_work> barclaac|2: are you barclaac's evil twin, or just a clone? :)
20:04:31 <barclaac|2> no damn idea. I think it thinks I'm signed in somewhere else, probably on my phone.
20:04:43 <jorgem> o/
20:05:08 <xgerman> Moving on...
20:05:15 <xgerman> #topic Brief progress reports
20:06:16 <johnsom> Controller worker is functional through the listener methods. Still to finish is pool, member, and health. Would like to have a network driver and amphora driver to test against and make sure that is all wired up correctly.
20:06:52 <TrevorV> johnsom my focus starting tomorrow should be on the SSH driver, which is theoretically done.
20:06:54 <sballe> Amphora rest driver: working on "rebasing" https://review.openstack.org/#/c/145637/12 and https://review.openstack.org/#/c/144348/ of Jinja Templates: https://review.openstack.org/#/c/157537/ Talk to TrevorV and ptoohill and got their ok since they are the original authors of the patches. Will start to test as soon as I have rebased and added in my changes.
20:06:58 <blogan> i can update on the network driver, ill be restarting back on that this weekend and next week, i expect ill have a simple implementation done using the allowed address pairs for HA and vrrp
20:07:17 <johnsom> Also there is a discrepancy between the api spec and the api code blogan put in about where database updates are occurring. API server side vs. controller side
20:07:58 <xgerman> Amphora REST server is finished -- will do another push but then need some eyes: https://review.openstack.org/#/c/160034/
20:08:15 <blogan> johnsom: are you talkinga bout the update actions being done on the api side but should be done on the controller side?
20:08:59 <johnsom> I am fine with them on the API side, but worried that the spec says otherwise. So far I have coded expecting the API side to do them per the code that is currently merged
20:09:49 <blogan> johnsom: i think what we ended up agreeing to was that only the creates get put into the db API side, and then updates and deletes just update the status
20:09:59 <blogan> the controller will do the actual db update and deletion
20:10:11 <blogan> but i can update the spec to specify that
20:10:29 <xgerman> updating spec = goodness
20:10:50 <johnsom> Yeah, if you could just take a quick look at spec vs code it would be great!
20:11:03 <blogan> johnsom: sure will, but what i said above, does that sound right?
20:11:13 <johnsom> I am fine with that, yes
20:11:18 <blogan> my memory has bit rot for octavia
20:11:27 <xgerman> I remember it that way also
20:11:36 <blogan> ok ill update the spec
20:11:51 <johnsom> Thanks!
20:11:53 <blogan> #action blogan update api and controller specs to reflect what has been the final agreement
20:12:08 <xgerman> now the other piece is dougwig's lbaas-v2 octavia driver...
20:13:18 <blogan> which i doubt will make it in for kilo
20:13:33 <dougwig> no, and i'll start it in the octavia tree.
20:13:40 <xgerman> yep
20:13:57 <xgerman> I thought that was our plan for a long time ;-)
20:14:04 <xgerman> out of tree
20:14:39 <TrevorV> way to keep up dougwig , geez
20:16:21 <dougwig> sorry, kilo slammed today
20:16:32 * TrevorV was kidding
20:16:39 <sballe> dougwig: no problem. We understand
20:16:42 <xgerman> mwang2 added a config frive to compute so we can shuffle files/data around
20:16:49 <xgerman> sballe +1
20:17:26 <xgerman> also I will keep it brief and try to steer clear of controversial topics ;-)
20:17:37 <sballe> xgerman: +1
20:17:47 <xgerman> #topic Open Discussion
20:18:30 <blogan> i like turtles
20:18:36 <bedis> ?
20:18:43 <blogan> it was quiet
20:18:55 <bedis> blogan: I like them too, in a soup
20:18:58 <sballe> blogan: to eat? or as pets
20:19:06 <ptoohill> lol
20:19:15 <blogan> both~
20:20:15 <blogan> okay, i think we'll all be able to focus on octavia soon, at least put a lot more focus on it
20:20:33 <xgerman> yeah, I think we are close to end-to-end
20:20:56 <johnsom> Excellent. I think we are getting close
20:20:57 <blogan> yep, just need the network driver and polishing
20:21:15 <xgerman> +1
20:21:31 <xgerman> and the neutron lbaas v2 driver for true end-to-end
20:21:32 <sballe> are we done in this meeting?
20:21:38 <xgerman> #endmeeting