20:00:08 <xgerman> #startmeeting octavia
20:00:10 <openstack> Meeting started Wed Mar 25 20:00:08 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'octavia'
20:00:21 <xgerman> #chair blogan
20:00:22 <openstack> Current chairs: blogan xgerman
20:00:38 <crc32> Are you there yet blogan?
20:00:41 <Trevor_V> o/
20:00:44 <blogan> hi
20:00:45 <xgerman> o/
20:00:46 <mwang2> o/
20:00:47 <johnsom> o/
20:00:48 <madhu_> hi
20:00:52 <ajmiller> o/
20:00:54 <blogan> just got herre
20:01:12 <xgerman> with car?
20:01:16 <xgerman> Agenda: https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-03-25
20:01:27 <crc32> ^..^
20:01:28 <crc32> (00)  )~
20:01:28 <crc32> mm mm
20:01:28 <sballe> o/
20:01:33 <crc32> o/
20:01:55 <xgerman> #topic Announcements
20:01:56 <sballe> I can never remember what channel we meet in ;-(
20:01:59 <dougwig> o/
20:02:09 <crc32> sballe: This one
20:02:20 <xgerman> Horizon stuff: https://etherpad.openstack.org/p/LBaaS_Horizon_Use_Cases
20:02:25 <sballe> crc32: really ;-)
20:02:43 <blogan> did we ever find out if we can have our own horizon plugin in tree? similar to devstack?
20:02:53 <xgerman> I think we can
20:02:57 <blogan> i suppose this is neutron lbaas territory
20:03:01 <blogan> but whatevs
20:03:08 <xgerman> yep
20:03:25 <Trevor_V> (I thought we decided some crossover was okay?)
20:03:36 <xgerman> sballe and I talked with our UX designer and he will tell us how much work it is
20:03:56 <xgerman> Horizon will get really cool with angularjs and what not
20:04:24 <blogan> it will do all the things
20:04:58 <xgerman> absolutely
20:05:16 <dougwig> i think we can sort out details here and just give a summary at the neutron meeting, no problem.
20:05:24 <xgerman> +1
20:05:28 <sballe> +1
20:06:33 <xgerman> We will keep updating the etherpad as we learn more things... (and post designs :-)
20:07:01 <xgerman> #topic Brief progress reports
20:07:15 <Trevor_V> I could use reviews on the ssh_driver
20:07:32 <Trevor_V> #link https://review.openstack.org/#/c/160964/
20:07:32 <johnsom> Yes, I hope to get a look at ssh driver today
20:08:03 <xgerman> +1
20:08:07 <blogan> i finally started the first network driver, which is using allowed address pairs
20:08:12 <johnsom> Controller work continues, I took some time out to test v2 TLS and to rework some of my unit tests that had issues.  Hope to finish pools today.
20:08:14 <sballe> I tested it and it works.
20:08:19 <dougwig> if i can roll back to announcements, the lbaas kilo and beyond talk was accepted, so hopefully we can have an octavia demo ready (and horizon, maybe!)
20:08:24 <sballe> above refers to ssh_driver
20:08:43 <xgerman> douwig: Hooray!!
20:08:44 <blogan> im sure we'll have an octavia demo ready
20:08:46 <johnsom> dougwig it is my goal to have an octavia demo for the talk
20:08:52 * blogan knocks on wood
20:08:58 <johnsom> horizon I cannot speak to
20:09:11 <xgerman> yeah, horizon is a bit fuzzy
20:09:12 <sballe> Amphora agent REST API should be tested and completed next week. That is my goal.
20:09:30 <sballe> Note tested with German's agent api server
20:09:47 <xgerman> I should have another version of the api server before the end of the week
20:09:57 <sballe> we can an octavia demo without Horizon.
20:10:01 <xgerman> yep
20:10:06 <johnsom> yes
20:10:31 <sballe> Real devs use clis ;-)
20:10:42 <xgerman> GUI's look slick in demos ;-)
20:10:51 <dougwig> heh, certainly.  i meant horizon for a v2 demo, not conjoining them.  :)
20:11:15 <xgerman> + we need to leave soemthing to demo in Tokyo
20:11:16 <sballe> dougwig: Oh sorry I misunderstood what you said ;-)
20:12:34 <xgerman> #topic How should a Octavia dev/test environemnt look like?
20:12:39 <xgerman> this a segway for the demo
20:12:53 <xgerman> how are we gonna package octavia for people to demo/play with it?
20:13:06 <Trevor_V> git clone? :P
20:13:17 <xgerman> more like devstack?
20:13:17 <dougwig> with a mullet wig and a ratty metallica shirt.
20:13:26 * sballe thinks that xgerman is now on the vagrant train
20:13:33 <johnsom> torn black jeans
20:13:33 <xgerman> I am
20:13:46 <blogan> cant we just do a devstack plugin like neutron lbaas?
20:13:48 <xgerman> X-mas sweater
20:14:01 <madhu_> maybe copy the working vm (ovf file) in usb and handout usbs to the people?
20:14:04 <dougwig> what about publishing to pypi and let folks 'pip install' ?
20:14:13 <blogan> that works too
20:14:21 <xgerman> +1
20:14:30 <dougwig> somewhere we might be able to find a major cloud operator that can host the image files.
20:14:39 <sballe> I personally prefer any method that is easy and doesn't fail
20:14:42 <dougwig> digital ocean, maybe.
20:14:43 <blogan> im not sure where you will find that
20:15:05 <xgerman> maybe one with fanatical support?
20:15:09 <dougwig> or AWS.
20:15:11 <johnsom> dougwig ouch...
20:15:21 <dougwig> :)
20:15:27 <sballe> yeah AWS would be bad1
20:15:43 <madhu_> lol
20:15:48 <johnsom> RAX and HP can mirror  grin
20:16:14 <xgerman> so the othe rend is should we make a devstack plugin
20:16:16 <xgerman> ?
20:16:42 <blogan> yes and no?
20:16:42 <johnsom> I think an easy install is good.  We will probably need devstack if we aspirations beyond stackforge
20:16:55 <sballe> johnsom: +1
20:17:13 * xgerman wonders if ha[roxy runs on cirros
20:17:19 <blogan> we could put the pip install in neutron-lbaas's plugin if the octavia driver is chosen
20:17:22 <sballe> it needs to be super easy to get up and running
20:17:22 <ajmiller> I've got the basic devstack development mojo....  Shouldn't be too horribly difficult.
20:17:38 <sballe> blogan: +1
20:17:45 <xgerman> +1
20:18:01 <dougwig> yeah, i'd treat it like any vendor device, and make it separate from the driver/lbaas/devstack.
20:18:21 <dougwig> long-winded way of agreeing with blogan.
20:18:30 <sballe> :-)
20:18:49 <blogan> it oddly sounded like disagreeing with me, but i think you're just a creature of habit
20:19:01 <xgerman> got confused as well
20:19:22 <xgerman> so basically git install into devstack
20:19:43 <xgerman> ah, pip install
20:19:54 <dougwig> blogan: if neutron-lbaas devstack does a pip install, that's handy, but also a good separation from its own devstack proper, which wouldn't quite make as much sense to me.  better?
20:20:09 <blogan> lol yeah, i know what you mean
20:20:12 <sballe> blogan: xgerman that make sense to me and is an easy way to get it installed and up and running
20:20:14 <blogan> and i agree its different
20:20:37 <ajmiller> neutron-lbaas devstack doesn't do pip install, but in the long run it could/should.
20:21:03 <sballe> ajmiller: can we make it di pip install in the shorter term?
20:21:15 <sballe> shorter being by the demo?
20:21:24 <xgerman> I would be happy with git clone
20:21:30 <xgerman> into devstack
20:21:33 <dougwig> yeah, we can env var it.
20:22:05 <ajmiller> That would be a matter of priority.  We would want to keep the option of git clone (so that it is useful to developers) but add a pip option.
20:22:08 <blogan> may as well make an octavia devstack plugin honestly
20:22:31 <xgerman> blogan +1
20:23:14 <dougwig> wouldn't hurt.
20:23:19 <johnsom> I think we have ajmiller do the plugin while it's fresh in his mind.
20:23:39 <xgerman> sounds good + we can put that in launchpad
20:23:44 <johnsom> Just get err done
20:23:55 <sballe> I would prefer to see the neutron lbaas v2drive octavia But that is my personal preference
20:23:59 <johnsom> I will do the launchpad
20:24:03 <ajmiller> I'm happy to do it, just need to fit it in with other stuff...
20:24:15 <xgerman> we will make it fit ;-)
20:24:18 <blogan> ajmiller is an expert at devstack, he knows all the things
20:24:25 <xgerman> +100
20:24:26 <johnsom> +1
20:24:33 <ajmiller> LOL... -100
20:24:40 <sballe> lol
20:24:47 <mwang2> +1
20:24:58 <xgerman> #action johnsom add launchpad story/ticket/task
20:25:10 <blogan> sballe: you mean you would prefer octavia in neutron lbaas tree?
20:25:12 <xgerman> #action ajmiller makes devstack plugin for octavia
20:25:21 <sballe> blogan: No.
20:25:57 <sballe> Maybe I misunderstood. I was thinking that the LBaaS v2 API would drive octavia rather than Octavia as a deperate service
20:26:12 <sballe> seperate
20:26:20 <xgerman> yeah, octavia would depend on neutron lbaas v2
20:26:34 <sballe> ok so I just misunderstood what was being said
20:26:34 <ajmiller> sballe:  That is correct, but they don't need to be supplied together.
20:26:47 <sballe> totally in agreemnt
20:26:52 <ajmiller> +1
20:26:53 <xgerman> well, we could make the neutron-octavia drive rin tree
20:27:06 <xgerman> but not for Kilo
20:27:18 <blogan> yeah
20:27:30 <dougwig> sballe: you'd end up putting q-lbaasv2,octavia in your local.conf, plus maybe need to do a service_provider swap after install, and then neutron lbaas drives octavia.
20:27:49 <xgerman> +1
20:27:55 <sballe> I understand now and agree.
20:28:37 <johnsom> #link https://blueprints.launchpad.net/octavia/+spec/devstack-plugin
20:28:46 <xgerman> awesome!!
20:29:18 <sballe> johnsom: that was fast :-)
20:29:49 <blogan> we should start a wiki page on building the thing manually end-to-end as well
20:30:00 <blogan> from git clone to deploy
20:30:00 <Trevor_V> agreed blogan
20:30:03 <xgerman> +1i
20:30:07 <sballe> +1 Maybe a google doc
20:30:24 <madhu_> +1
20:30:24 <blogan> would wiki.openstack not work?
20:30:25 <xgerman> and I like that all be a vagrant image since building neutron-lbaas v2 was a pain for us
20:30:46 <xgerman> but I can take that on
20:31:04 <johnsom> I like the wiki.openstack path better.  To many permissions issue with google doc
20:31:08 <sballe> blogan: wiki should be fine. I just linke google doc for things that are still WIP
20:31:10 <xgerman> +1
20:31:18 <blogan> building any openstack service manually is a pain
20:31:32 <xgerman> +1000
20:31:51 <blogan> yeah thats a good point, though wiki's are much more accessible
20:32:03 <sballe> johnsom: you can make a google doc sharable by everyone
20:32:18 <xgerman> I think eventually it needs to be wiki
20:32:23 <johnsom> Yes, but I continually run into docs that are not setup correctly
20:32:32 <sballe> I agree and was thinking that as well.
20:32:51 <sballe> As long as we write on the wiki page that this is WIP I am fine with the wiki.
20:33:01 <blogan> works for me
20:33:06 <xgerman> #decision wiki
20:33:15 <johnsom> +1
20:33:42 <xgerman> #topic Open Discussion
20:33:52 <blogan> "when a problem comes along you must WIP it"
20:33:59 <xgerman> lol
20:34:06 <sballe> lol +1
20:34:29 <johnsom> Do we need to do any lobbying at the summit about moving Octavia out of stackforge?  It might be too early, but I'm not sure if there is leg work we need to start.
20:35:30 <xgerman> well, let's gte it working well...
20:35:33 <dougwig> johnsom: things have been primed to move it into the neutron project once we have shipping code, if that's a direction we want to take.
20:35:36 <sballe> I am not sure we have to do anything to move it in. Isn't it just going to be the reference driver for neutron LBaaS ?
20:35:55 <sballe> dougwig: +1
20:36:01 <xgerman> dougwig +1
20:36:03 <johnsom> Ok cool.  Just checking.
20:36:11 <dougwig> separate repo and all.  but let's focus on getting it working first.
20:36:13 <johnsom> It would be cool to aim for Liberty
20:36:26 <sballe> +1
20:36:35 <xgerman> +1
20:38:03 <xgerman> ok, anything else?
20:38:15 <sballe> Cannot think of anything
20:38:33 <blogan> i still need to update the specs/docs for the api and queue changes
20:38:33 <Trevor_V> Thanks sballe for helping test the SSH driver.
20:38:36 <blogan> sorry slacked on that
20:39:05 <johnsom> Cool, yeah, I know I will need to go back and fix the update flows
20:39:08 <sballe> Trevor_V: You are welcome.
20:39:43 <xgerman> we will be doing some two day mini hackathon at HP next week
20:39:59 <xgerman> if anyone of you happens to be in Seattle ;-)
20:40:06 <Trevor_V> Pfff nope
20:41:25 <mwang2> also these two patches need to be reviewed, https://review.openstack.org/#/c/149802/ https://review.openstack.org/#/c/163240/
20:41:39 <Trevor_V> #link https://review.openstack.org/#/c/149802/
20:41:48 <Trevor_V> #link https://review.openstack.org/#/c/163240/
20:42:22 <xgerman> ok
20:42:29 <mwang2> thanks Trevor
20:42:41 <xgerman> +1
20:42:45 <Trevor_V> No problem :)
20:43:00 <xgerman> well, I think we are done
20:43:14 <xgerman> #endmeeting