20:00:42 <xgerman> #startmeeting Octavia
20:00:43 <openstack> Meeting started Wed Apr 15 20:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:47 <openstack> The meeting name has been set to 'octavia'
20:00:54 <xgerman> #chair blogan
20:00:57 <openstack> Current chairs: blogan xgerman
20:01:03 <TrevorV> o/
20:01:06 <xgerman> hi
20:01:13 <ajmiller> o/
20:01:17 <bharath_> o/
20:01:20 <mwang2> Hi
20:01:43 <xgerman> agenda: https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-04-15
20:02:18 <jwarendt> o/
20:02:22 <ptoohill> o/
20:02:26 <blogan_> crap i forgot im on a different user
20:02:40 <xgerman> chair blogan_
20:02:47 <johnsom> o/
20:02:48 <xgerman> #chair blogan_
20:02:49 <openstack> Current chairs: blogan blogan_ xgerman
20:03:00 <xgerman> #topic Announcements
20:03:03 <blogan_> you're outnumbered now xgerman
20:03:26 <xgerman> I am shaking in my boots...
20:04:01 <xgerman> ok, midcycle link: https://etherpad.openstack.org/p/LBaaS-FWaaS-VPNaaS_Summer_Midcycle_meetup
20:04:08 <xgerman> but broken due to etehrpad broken...
20:04:33 <xgerman> or maybe borken forever
20:05:22 <xgerman> Kilo RC1 is released and mestery is hoping that will be the only RC needed
20:05:39 <mestery> xgerman: I lied! WE'll need an RC2
20:05:47 <mestery> xgerman: It's secretly in the works as we speak :)
20:06:00 <xgerman> ok, thanks :-)
20:06:39 <xgerman> ptoohill got promoted to Neutron LBaaS core - Congrats!!
20:06:42 <blogan_> mestery: is this being organized in a secret neutron core channel?
20:07:02 <mestery> blogan_: lol
20:07:03 <barclaac> blogan: he can't tell you or he'd have to kill you
20:07:10 <mestery> blogan: I am literally juggling so many balls right now ...
20:07:12 <ptoohill> :D
20:07:17 <ptoohill> Thank you!
20:07:20 <blogan_> mestery: i dont know how to take that
20:07:22 <mestery> Congrats ptoohill
20:07:24 <blogan_> mestery: lol
20:07:25 <mestery> blogan: lol
20:07:30 <xgerman> isn't that the Neutron snapchat group?
20:07:39 <mestery> blogan: If you find any LBaaS RC blockers, tag them as "kilo-rc-proposed"
20:07:41 * blogan_ copies that quote from mestery
20:08:05 <blogan_> mestery: will do
20:08:11 <dougwig> mestery: i think the radware driver has a few.
20:08:21 <mestery> dougwig: File a bug and get them merged to master ASAP
20:08:28 <mestery> dougwig: If they arne't on master by Firday they won't make the RC
20:08:29 <blogan_> they are merged i think
20:08:35 <mestery> dougwig: They have to merge there first and be cherry-picked back
20:08:40 <mestery> blogan_: Cool! Tag the bugs :)
20:09:06 <blogan_> mestery: nope 1 still not merged
20:09:17 <rm_work> o/
20:09:30 <sballe> o/
20:09:52 <xgerman> ok, should we move on?
20:10:10 <xgerman> #topic Brief progress reports
20:10:10 <dougwig> sure
20:10:39 <dougwig> neutron-lbaas driver - i just started beating on brandon's operator API.  it keeps getting towed.
20:10:40 <xgerman> I should have a new version of REST driver and API later today...
20:10:44 <TrevorV> I'm still having issues with modifying the tests for the PUT updates.
20:11:07 <xgerman> dougwig lol
20:11:24 <xgerman> (we need a 500 picture of a tow truck)
20:11:24 <blogan_> code 444 - towed
20:11:30 <johnsom> Controller worker is just about functional.  I just need to wrap up the "update" calls and some minor clean up.  Currently working on data model issues.
20:11:55 <blogan_> i'm finishing jorge's review, just need to get the tests done
20:12:02 <xgerman> cool!!
20:12:07 <blogan_> which is the controller consumer piece
20:12:09 <johnsom> It's a bit tricky with the taskflow stuff.
20:12:11 <blogan_> err queue consumer
20:12:53 <ptoohill> I made an update recently to allow the api to actually run again. Also playing with tempest testing and attempting to verify other Octavia related services at the same time
20:13:27 <ajmiller> This is partly octavia and partly neutron-lbaas.  I moved the devstack/samples scripts from octavia to neutron-lbaas.  They are in https://review.openstack.org/#/c/173438/ and work well.  Would appreciate reviews on that.
20:13:43 <ajmiller> Also made a new blog post discussing this:
20:13:47 <ajmiller> #link https://chapter60.wordpress.com/2015/04/14/sample-scripts-to-automatically-set-up-lbaas-v2-loadbalancers-in-devstack/
20:13:50 <ptoohill> those work for me, thanks ajmiller!
20:14:14 <ajmiller> ptoohill, great thanks!
20:14:18 <TrevorV> #link https://review.openstack.org/#/c/173438/
20:15:26 <xgerman> ok, mwang2?
20:15:28 <TrevorV> (just followed up ajmiller's review with a bot "link" command)
20:15:49 * xgerman scred her
20:15:53 <ajmiller> She's not at her desk...
20:16:11 <xgerman> ok, the NOOP drivers she did merged
20:16:17 <xgerman> moving on...
20:16:44 <xgerman> #topic logo: We like to select a logo
20:17:03 <xgerman> #link http://bit.ly/Octavia_logo_vote
20:17:05 <Mwang2> Just disconnected, we merged compute and network bop driver and unit test
20:17:17 <xgerman> #link https://docs.google.com/drawings/d/1PvJj_8A6oFRdUN9xAgm9Z8joM33Z7CuTJUzCQn3GoCM/edit
20:17:34 <TrevorV> So is this a LOGO vote or a sticker vote?
20:17:43 <barclaac> I think it should be both.
20:17:46 <blogan_> both
20:17:47 <ptoohill> im torn on this
20:17:49 <xgerman> +1
20:17:54 <blogan_> a + i = WIN
20:18:09 <sballe> +1
20:18:13 <rm_work> not sure how a+i would actually WORK
20:18:18 <TrevorV> I wouldn't hate it as much if a + i chose i's color.
20:18:20 <rm_work> what about happen
20:18:22 <dougwig> i think somebody needs to narrow that down to some finalists, on one page.
20:18:32 <TrevorV> I agree dougwig
20:18:33 <rm_work> *what would happen
20:18:37 <blogan_> well as long as their the same color, i could live with orange or red
20:18:38 <rm_work> yeah
20:18:47 <rm_work> what about orangered
20:18:48 <crc32> I don't like the stop signs
20:18:52 <barclaac> I can go back to our design group for one more pass.
20:19:03 <barclaac> Why not split into "colors", "text" and "visual motif"
20:19:08 <dougwig> and if airbnb has taught us anything, it's that logos should look like genitals, while you claim with a straight face that of course they don't.
20:19:10 <xgerman> sounds good
20:19:17 <rm_work> heh
20:19:32 <rm_work> I did like A, and I, and also L.
20:19:41 <dougwig> i was pleasantly surprised by all of the choices above, btw.  nice work.
20:19:41 <rm_work> I also like blues :P
20:19:47 <TrevorV> Did everyone here look at the google docs link as well?
20:19:59 <blogan_> looks like a lifesaver with a trident in the middle
20:20:00 <sballe> yes
20:20:08 <rm_work> heh
20:20:08 <barclaac> yup.
20:20:15 <barclaac> I like the i motif
20:20:23 <johnsom> #link https://docs.google.com/drawings/d/1PvJj_8A6oFRdUN9xAgm9Z8joM33Z7CuTJUzCQn3GoCM/edit
20:20:30 <johnsom> #link https://drive.google.com/file/d/0B2PMpzWrmNENemdfNVJ5WmtyQ2M/view
20:20:48 <dougwig> i was definitely the most openstack-y.
20:21:04 <dougwig> i like the three prong more than the circle-y thing, given the function.
20:21:06 <barclaac> I'd go with i + b
20:21:07 <sballe> I personally think that A looks too much like the designate logo. But in itself it is a good logo design IMHO
20:21:20 <rm_work> L would look really good if done by an actual art team I think :P
20:21:26 <dougwig> i like the blues better, though red is more the openstack color.
20:21:37 <blogan_> lets put the neutron-lbaas art department on it
20:21:41 <barclaac> If you want a round logo then put the b font in l with i in the middle
20:21:43 <TrevorV> See, the problem I have with " i " is its not clear what the picture is... It doesn't mean much to me, just dots connected by lines... The 'trident' is the actual network image for a load balancer.
20:21:45 <crc32> red just screams violence to me.
20:22:21 <ptoohill> but it has a 'lifesaver' around it so its from the ocean
20:22:25 <blogan_> barclaac: should we put the a color with the b text on the e motif with the f gradient?
20:22:49 <dougwig> TrevorV: the trident looks less.... concise.
20:23:04 <rm_work> it's the ACTUAL icon for a LB isn't it?
20:23:15 <barclaac> blogan: nice - you've got a career in visual design
20:23:17 <TrevorV> Less concise?  Technically that's EXACTLY accurate, since it has one more line and one more dot on it... ha ha
20:23:17 <ptoohill> yes
20:23:21 <xgerman> why would we pick that - we are LB 2.0
20:23:24 <crc32> I kinda like "L"
20:23:26 <blogan_> barclaac: enhance!
20:23:37 <dougwig> if all logos looked like their ACTUAL things, life would be ugly.  :)
20:23:46 <sballe> lol
20:23:46 <barclaac> I did one too but the team at this end didn't like it
20:23:51 * blogan_ pictures dougwig's logo and shivers
20:23:57 <rm_work> of course RAX people like it... http://ddf912383141a8d7bbe4-e053e711fc85de3290f121ef0f0e3a1f.r87.cf1.rackcdn.com/cloud-load-balancers-icon.png
20:24:13 <ptoohill> so, i have a new thing to add to the list of harddest things to do, 'pick a logo'
20:24:19 <blogan_> TrevorV got outted as a plagiarist
20:24:25 <xgerman> lol
20:24:29 <sballe> lol
20:24:30 <rm_work> blogan_: not EXACTLY what I was going for
20:24:33 <TrevorV> Not plagiarism...
20:24:35 <xgerman> yeah, please no trademark violations
20:24:38 <rm_work> lol
20:24:48 <rm_work> it's the LB symbol
20:24:55 <blogan_> i think it is trademarked though
20:25:00 <rm_work> we didn't put it on a cloud
20:25:02 <rm_work> so it's ok
20:25:10 <TrevorV> Not the LB symbol, just in a cloud, and purple
20:25:23 <xgerman> I hate to involve lawyers in firguring things out ;-)
20:25:24 <blogan_> its got rounded corners though, so apple might not like that
20:25:25 <ptoohill> i brought that up, but its also the recognized LB symbol in networking diagrams
20:25:49 <TrevorV> Either way, I disagree with a's colors.
20:25:56 <blogan_> anyone not like i) + something else?
20:25:56 <ptoohill> 'I' looks like USB
20:25:59 <ptoohill> or something
20:26:13 <barclaac> Let's vote on i) as the motif bit
20:26:30 <rm_work> http://www.cisco.com/c/dam/en/us/td/i/200001-300000/220001-230000/223001-224000/223114.eps/_jcr_content/renditions/223114.jpg
20:26:38 <rm_work> cisco's symbol looks pretty much like that
20:26:39 <xgerman> ok, let's vote than
20:27:08 <TrevorV> So is it 'i' versus "trident" then?
20:27:15 <barclaac> I think so
20:27:15 <xgerman> #startvote a, f, h, i, l
20:27:15 <openstack> Unable to parse vote topic and options.
20:27:17 <rm_work> so we're voting on: Motif, then Colors?
20:27:21 <rm_work> or what
20:27:32 <xgerman> yep, first motif, then colors, then sticker
20:27:39 <blogan_> #vote i
20:27:40 <barclaac> +1
20:27:51 <blogan_> vote bot not worky
20:27:52 <crc32> #vote l
20:27:52 <johnsom> The vote didn't start
20:27:54 <barclaac> we didn't start the vote
20:28:02 <crc32> #vote L
20:28:07 <crc32> #vote L
20:28:08 <blogan_> #startvote help
20:28:08 <openstack> Unable to parse vote topic and options.
20:28:13 <rm_work> so how do I vote for a+i+l? :P
20:28:15 <barclaac> we may have to label as option-a, option-b etc. Maybe the bot wants more text
20:28:29 <crc32> L wins
20:28:30 <dougwig> #startvote What should we have as the motif? A, F, H, I, L
20:28:30 <openstack> Only the meeting chair may start a vote.
20:28:46 <xgerman> #startvote What should we have as the motif? A, F, H, I, L
20:28:46 <blogan_> #startvote What should we have as the motif? A, F, H, I, L
20:28:46 <openstack> Begin voting on: What should we have as the motif? Valid vote options are A, F, H, I, L.
20:28:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:28:49 <openstack> Already voting on 'What should we have as the motif'
20:28:58 <blogan_> #vote I
20:28:59 <barclaac> #vote I
20:29:02 <ajmiller> #vote I
20:29:04 <xgerman> #vote I
20:29:11 <dougwig> #vote I
20:29:22 <johnsom> #vote I
20:29:22 <sballe> #vote I
20:29:29 <jwarendt> #vote I
20:29:34 <barclaac> what happened to the trident crew?
20:29:36 <crc32> #vote L
20:29:40 <crc32> #vote l
20:29:41 <barclaac> there we go
20:29:46 <Mwang2> #vote I
20:29:48 <TrevorV> (never existed apparently)
20:29:50 <sballe> lol
20:29:58 <xgerman> 3
20:29:59 <bharath_> #vote I
20:30:00 <xgerman> 2
20:30:01 <crc32> L and I look the same in text
20:30:03 <rm_work> #vote A
20:30:07 <madhu_ak> #vote I
20:30:15 <xgerman> 1
20:30:20 <xgerman> #endvote
20:30:21 <openstack> Voted on "What should we have as the motif?" Results are
20:30:23 <openstack> I (11): xgerman, sballe, Mwang2, johnsom, dougwig, barclaac, madhu_ak, blogan_, ajmiller, bharath_, jwarendt
20:30:24 <openstack> A (1): rm_work
20:30:25 <openstack> L (1): crc32
20:30:35 <dougwig> pretty divided vote.
20:31:03 <barclaac> OK. Let's move onto color
20:31:03 <xgerman> next we need colors
20:31:17 <rm_work> I object on the grounds that NONE of the options had an amphora depicted :P
20:31:33 * blogan_ uses an amphora as a spitoon
20:31:39 <rm_work> that could be a valid use
20:31:48 <dougwig> rm_work: the vote is over.  go over and hang with the hanging chad bitter folks.
20:31:54 <crc32> sounds like the use case
20:31:55 <xgerman> #startvote what color should we choose? A, B, C, J, L, O
20:31:56 <openstack> Begin voting on: what color should we choose? Valid vote options are A, B, C, J, L, O.
20:31:57 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:32:02 <rm_work> wait
20:32:08 <rm_work> why are we not just voting on COLORS
20:32:10 <crc32> what the hell?
20:32:11 <rm_work> lol
20:32:29 <xgerman> so I should gibe you a pantone reel?
20:32:32 <crc32> which one is blue?
20:32:34 <rm_work> I mean
20:32:36 <dougwig> #vote B
20:32:38 <barclaac> #vote pantone435 :-)
20:32:38 <openstack> barclaac: pantone435 :-) is not a valid option. Valid options are A, B, C, J, L, O.
20:32:46 <rm_work> lol
20:32:49 <barclaac> I got spanked for that
20:32:50 <blogan_> #vote A
20:32:51 <crc32> #vote blue
20:32:52 <openstack> crc32: blue is not a valid option. Valid options are A, B, C, J, L, O.
20:32:56 <rm_work> #vote blue
20:32:57 <openstack> rm_work: blue is not a valid option. Valid options are A, B, C, J, L, O.
20:33:00 <crc32> #vote L
20:33:00 <barclaac> #vote B
20:33:01 <sballe> #vote C
20:33:02 <rm_work> #vote L
20:33:02 <TrevorV> #vote O
20:33:04 <fnaval> #vote L
20:33:04 <ajmiller> #void B
20:33:10 <ajmiller> #vote b
20:33:16 <johnsom> #vote l
20:33:21 <xgerman> #vote b
20:33:23 <crc32> #vote lavender
20:33:24 <openstack> crc32: lavender is not a valid option. Valid options are A, B, C, J, L, O.
20:33:29 <blogan_> vote for A jerks
20:33:43 <rm_work> at least b is somewhat closer to blue
20:33:53 <blogan_> i believe that is blue
20:33:54 <crc32> #vote b
20:33:55 <jwarendt> #vote A
20:34:01 <ajmiller> #vote L
20:34:01 <xgerman> L is pretty blue, too
20:34:02 <rm_work> it's more like.. a purple
20:34:05 <crc32> #vote B
20:34:06 <rm_work> L is blue
20:34:06 <blogan_> thanks jwarendt, comeback train!
20:34:18 <rm_work> #vote B
20:34:39 <xgerman> ok, tally?
20:34:49 <xgerman> #endvote
20:34:49 <openstack> Voted on "what color should we choose?" Results are
20:34:51 <openstack> A (2): blogan_, jwarendt
20:34:52 <openstack> C (1): sballe
20:34:54 <openstack> B (5): xgerman, rm_work, dougwig, barclaac, crc32
20:34:55 <openstack> L (3): fnaval, johnsom, ajmiller
20:34:56 <openstack> O (1): TrevorV
20:35:08 <rm_work> damnit if I stuck with L it would have been tied T_T
20:35:11 <ptoohill> another blue
20:35:13 <dougwig> should we have a runoff between the two blues?
20:35:22 <barclaac> Nearly there. Stay the course.... What about text next?
20:35:25 <blogan_> had 2 of the Bs come to A, A would have won!
20:35:26 <crc32> the real blue vs purple
20:35:27 <TrevorV> I would prefer not 2 different blues.
20:35:38 <rm_work> ooh, what about both blues :P
20:35:45 <rm_work> ^^ the anti-TrevorV
20:35:49 <jwarendt> And A is Orange, which starts with O for Octavia.
20:35:53 <barclaac> just subtely different so guaranteed to clash
20:36:03 <blogan_> jwarendt: good point, it makes perfect sense
20:36:10 <rm_work> I am wearing green plaid shorts right now
20:36:11 <rm_work> so
20:36:16 <rm_work> I am used to clashing colors
20:36:16 <xgerman> do we need a run-off?
20:36:19 <rm_work> yeah
20:36:20 <TrevorV> So does Olive, but no one picked green.
20:36:25 <crc32> so. Where is the name octavia going to be?
20:36:30 <xgerman> lol
20:36:38 <xgerman> that's the next vote
20:36:54 <sballe> What's the vote? Blue or Purple?
20:36:58 <barclaac> I prefer the long type stickers, like the designate one. Anyone have a URL for that?
20:37:32 <sballe> The designate sticker is at: http://www.rackspace.com/blog/designate-gaining-momentum-as-openstack-dns-as-a-service/
20:37:32 <dougwig> towgan is going to get this tattooed on himself, right?
20:37:34 <TrevorV> sballe it was purple, the NOT pop color.
20:37:42 <xgerman> while his truck is being towed
20:39:01 <xgerman> we have color and motif -- so we should now mock up some sticker designs?
20:39:17 <xgerman> we ahve the round, edgy ones and then a longish one like designe
20:39:22 <jwarendt> Do we need sublabel "Load balancing for OpenStack" ala Designate?
20:39:22 <barclaac> Yes. I'll go back to "the cool kids over in the corner" and get some creativeness from them.
20:39:23 <TrevorV> Are we sticking to rounded-corner square background then?
20:39:36 <barclaac> jwarendt: yes
20:40:01 <blogan_> i wonder the legal implications of using openstack in a logo but not being in openstack
20:40:02 <TrevorV> Should I NOT design something with a little more differentiation then?  Just leave it to your design guys?
20:40:26 <xgerman> well, I like the Octagon sticker
20:40:52 <TrevorV> xgerman not sure what you're talking about... in my design?
20:40:54 <rm_work> I do too, but
20:41:03 <rm_work> I think we give the art guys a second pass
20:41:06 <rm_work> with this direction
20:41:10 <sballe> blogan_: I am more wondering how this will confuse people around the netron lbaas role
20:41:15 <rm_work> "we like these couple of designs, and these colors"
20:41:20 <xgerman> TrevorV designs M, N
20:41:23 <rm_work> let them do the art thing they're good at
20:41:33 <TrevorV> xgerman just with i's design.  GOt it
20:41:34 <crc32> An octagon feels like a great to shout "STOP".
20:41:35 <TrevorV> Got it.
20:42:05 <dougwig> sballe: anything that raises lbaas awareness is a good thing, IMO.
20:42:05 <barclaac> I'll come back with some designs early next week (I hope)
20:42:19 <xgerman> dougwig +1
20:43:00 <xgerman> #topic Provisioning status
20:43:07 <xgerman> johnsom can explain that best
20:44:01 <xgerman> BTWL Designate
20:44:19 <xgerman> #link https://s3.amazonaws.com/uploads.hipchat.com/8522/37400/G4pQRYTCfGjwtGn/designate-logo.png
20:44:43 <johnsom> We don't have provisioning status in the pool, health_monitor, member, amphora tables.  So, we can't mark them "Pending_delete".
20:45:13 <blogan_> johnsom: htey just ahve operating status?
20:45:25 <johnsom> So, if I am given the id in the call to the controller worker, I can't lookup which listener to update, etc. because the API would have deleted the data
20:45:38 <johnsom> health doesn't even have operating
20:46:10 <blogan_> johnsom: all that got created before neutron-lbaas api was finalized with provisioning status on everything as well, so we can change it or just use the load balancer's provisioning status as the catch all
20:46:29 <johnsom> So, I'm not sure how I can get the listener to tell that a health monitor should be deleted via new config
20:46:31 <xgerman> mmh, if deleting errors out we can even put it in error
20:46:51 <xgerman> can=can't
20:47:06 <xgerman> yeah, the worker should do the delete...
20:47:20 <johnsom> I propose we update the model to be like neutron-lbaas and add them
20:47:31 <blogan_> im not understanding how not having provisioning status means you dont get an id?
20:48:05 <johnsom> I still get the ID, but don't have anything to look it up against if the DB has already deleted the record.
20:48:09 <blogan_> johnsom: but yeah im for updating the model to be more like neutron-lbaas now, though not as far as having nested resources
20:48:57 <xgerman> bloagn: his problem Octavia API deletes in DB, hands him the ID, and all he has is the ID
20:49:01 <blogan_> johnsom: how would you get an id to something that the db has already deleted?
20:49:11 <blogan_> octavia api shouldn't delete in db
20:49:14 <blogan_> controller worker should
20:49:24 <johnsom> Right
20:49:27 <blogan_> if it is doing that then it should be changed
20:49:27 <xgerman> +1
20:50:02 <xgerman> #decision octavia api shouldn't delete in db - controller worker should
20:50:15 <johnsom> For listener we have pending_delete state
20:50:21 <blogan_> api currently is not deleting it
20:50:45 <xgerman> ok, then we just keep it that way ;-)
20:51:07 <blogan_> so the real question is just putting provisioning status on everything else
20:51:32 <johnsom> So, API will do nothing on delete call, just pass me the id?  We will not be using pending_delete state?
20:51:55 <xgerman> well, we first need to decide to have a provisoning state
20:52:00 <ptoohill> The api should update to pending then pass the id
20:52:02 <blogan_> way back when, the original idea was that any change to anything would update the loadbalancr and listener provisioning statuses, and nothing else would, but with neutron-lbaas finalized on its status management, that doesn't align
20:52:46 <blogan_> johnsom: currently it updates the stauts of the entities listener, and load balacner to PENDING_UPDATE, if it is a listener hten it'll update the listene'rs provisioning status to PENDING_DELETE and load balancer to PENDING_UPDATE
20:53:20 <xgerman> yeahm having state diagrams would be real nice ;-)
20:53:23 <johnsom> Does someone have cycles to update this stuff?
20:53:43 <johnsom> blogan_ we don't want to set a listener to pending delete if we are only deleting a member
20:53:57 <blogan_> johnsom: it would be set to PENDING_UPDATE in that instance
20:54:05 <blogan_> bc a member is a child of listener
20:54:12 <blogan_> and the listene'rs configuration is being updated
20:54:38 <xgerman> yeah, makes sense and now we need to figure out if we ened a provisioning status on member, healthmonitor and such
20:55:01 <blogan_> i'm fine with whatever, it makes sense to be aligned with neutron-lbaas though
20:55:07 <xgerman> +1
20:55:10 <johnsom> +1
20:55:58 <blogan_> changing it right now though would add in extra work for the demo
20:56:22 <xgerman> we have like 4 more weeeks
20:56:41 <xgerman> + half of Monday :-)
20:56:51 <dougwig> lol
20:56:52 <johnsom> So, for now just expect the prov status to be updated on the listener?
20:56:56 <blogan_> i'd much rather get it working with this, and polish it up, and then fix this if there is time
20:57:06 <blogan_> johnsom: and load balancer
20:57:53 <blogan_> johnsom: unless you've already coded it in a way that requires the neutron-lbaas status structure, then that work might negate not doing it
20:58:17 <johnsom> I coded it up with all of the elements having prov status before I dumped the ERD.  Easy to comment out.
20:58:25 <blogan_> okay
20:58:27 <dougwig> i'm gonna leak out an open discussion item here shortly, since we're almost out of time...
20:58:39 <johnsom> Let's move on
20:58:42 <blogan_> johnsom: we can talk about after
20:58:44 <xgerman> ok, let's skip to open discussion
20:58:46 <blogan_> just to get aligned on it
20:58:51 <xgerman> #topic Open Discussion
20:58:53 <dougwig> quick question for the group - do we think octavia will be ready to be the reference for neutron-lbaas by the end of august?  just checking whether I should submit a spec to neutron for L.
20:59:16 <xgerman> I would liek that
20:59:20 <sballe> +1
20:59:28 <johnsom> I think we can make August
20:59:42 <blogan_> does the reference implementation have to be completely polished?
20:59:46 <dougwig> ok, if there's even a chance, it's better for us to submit a spec now to make it the default.
20:59:52 <blogan_> there is a chance
20:59:53 <dougwig> we can always defer it.
20:59:54 <xgerman> +1
21:00:03 <dougwig> #action dougwig neutron-lbaas spec to make octavia the ref impl
21:00:10 <xgerman> #endmeeting