20:00:18 <xgerman> #startmeeting octavia
20:00:18 <openstack> Meeting started Wed Jun 17 20:00:18 2015 UTC and is due to finish in 60 minutes. The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:21 <openstack> The meeting name has been set to 'octavia'
20:00:22 <xgerman> #chair blogan
20:00:23 <openstack> Current chairs: blogan xgerman
20:00:28 <blogan> hi!
20:00:29 <ptoohill> 0/
20:00:31 <johnsom> o/
20:00:31 <rm_work> o/
20:00:34 <TrevorV> o/
20:00:46 <blogan> https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-06-17
20:00:49 <blogan> tehre's your agenda
20:00:53 <xgerman> #topic Announcements
20:01:05 <xgerman> CfP Tokyo Summit - https://www.openstack.org/summit/tokyo-2015/call-for-speakers/manage/3647/summary
20:01:17 <xgerman> never seen such a broken web site
20:01:26 <ajmiller__> o/
20:01:32 <xgerman> we will have a topic later in the agenda
20:01:47 <xgerman> External DNS resolution - http://docs-draft.openstack.org/24/88624/4/check/gate-neutron-specs-docs/36e883b//doc/build/html/specs/liberty/external-dns-resolution.html
20:02:05 <dougwig> o/
20:02:39 <xgerman> this is interesting since a problem we usually face is that if we update LBaaS installation we end up in different address spaces — this will help with that if we only hand out DNS names
20:02:52 <rm_work> that is what Amazon ELB does
20:03:02 <xgerman> yep
20:03:44 <xgerman> though I have been told that we still need IP’s for GLB
20:03:56 <rm_work> would be good, I think
20:04:04 <rm_work> though you can CNAME
20:04:19 <xgerman> exactly
20:04:21 <dougwig> it's annoying as F in some cases, like wanting to fire up an LB to do your apex redirection, or dealing with legacy IPs. neither of which apply to octavia, though.
20:05:23 <blogan> i think there's a group of people who like IPs and like the DNS names
20:05:29 <blogan> if we can support both, great
20:05:38 <rm_work> I am vaguely of the opinion that I would rather give out IPs, but I can't explain exactly why
20:05:43 <rm_work> and could be convinced either way
20:06:01 <rm_work> and definitely wouldn't mind BOTH options
20:06:07 <xgerman> well, we can change our world view that we know amphora only by DNS name
20:06:08 <sballe> hi Sorry I am late
20:06:27 <xgerman> so you can replace a broken one transparently
20:06:32 <rm_work> err, we still want to know our Amps by IP i think
20:06:51 <crc32> sounds like GLB all over again.
20:06:55 <johnsom> IPsec load balancing can't use DNS typically
20:06:59 <crc32> and we all know how that went.
20:07:05 <rm_work> lol
20:07:08 <xgerman> crc32 GLB is back
20:07:12 <rm_work> it went: the discussion is restarted! :P
20:07:18 <rm_work> yep
20:07:28 <xgerman> anyway, just announcing that proposal
20:07:39 <xgerman> needs more investigation ;-)
20:07:44 <rm_work> crc32: moar GLB -- was just reading through the logs from that: http://eavesdrop.openstack.org/meetings/gslb/2015/
20:07:56 <crc32> johnsom: I think IPSec would work but your constantly resigning after every change.
20:07:58 <rm_work> which I guess we're discussing later, sorry xgerman :P
20:08:00 <ptoohill> We may need different meetings for some of these topics, octavia != glb or is it?
20:08:03 <ptoohill> :)
20:08:11 <rm_work> ptoohill: well, it's on the agenda
20:08:11 <xgerman> yep
20:08:18 <ptoohill> yea, my point for saying that
20:08:37 <xgerman> nah, I just put it there to raise awareness
20:08:41 <crc32> GLB died way back in 2013
20:09:05 <xgerman> ok, here is the resurrected GLB: Global Load Balancing - https://docs.google.com/document/d/1016shVnPaK8l8HxMpjADiYtY2O94p4g7JxjuIA-qv7w/edit
20:09:43 <xgerman> anyway, they have their own meeting
20:10:00 <xgerman> and GLV != External DNS resolution
20:10:16 <xgerman> GLB
20:10:52 <xgerman> #topic Tokyo talks
20:11:13 <xgerman> #link https://etherpad.openstack.org/p/Octavia-Tokyo-Talks
20:11:25 <xgerman> so I am trying to collect all our talks there
20:11:38 <xgerman> and the web site is terribly brpoken
20:11:44 <xgerman> for inserting talks
20:11:57 <dougwig> works with safari, not chrome. i already submitted the usual lbaas talk, listed at the bottom.
20:12:07 <xgerman> I did safari
20:12:07 <blogan> of course, safari
20:12:13 <xgerman> of course
20:12:22 <blogan> dougwig: i updated it to be Liberty and Beyond, instead of Kilo and Beyond
20:12:30 <dougwig> xgerman, you game to merge the second and third talks?
20:12:48 <dougwig> thanks. i think i had it as liberty in chrome. three times, before i switched to safari.
20:12:54 <blogan> lol
20:13:00 <xgerman> sure, whatever increases our chances
20:13:34 <sballe> it works fine in chrome
20:13:45 <blogan> not in os x apparently
20:13:53 <xgerman> well, I tried ten times to enter a talk in Safari no dice
20:14:09 <johnsom> dougwig My only thought is the Liberty and beyond talk might be more vendor focused like Vancouver where Octavia reference might go deep
20:14:24 <blogan> no matter what, that site sucks
20:14:34 <sballe> do we need a Octavia hands on lab and an Octavia talk?
20:14:41 <xgerman> yep, I wish they could get some 8 year old to do a redesign
20:14:43 <sballe> That seems like a lot
20:15:04 <xgerman> well, we can submit a lot and the program committee will whittle it down
20:15:14 <dougwig> johnsom: i think the vendor road show was showing off API adoption, and I don't personally see a need for it in tokyo. i'd have no problem with that talk being a deeper dive in octavia (maybe also using the new horizon).
20:15:31 <sballe> yeah that double our chances of getting something on
20:15:32 <blogan> can title our talk "docker docker octavia without docker"
20:15:49 <sballe> lol
20:15:50 <xgerman> throw in security - everybody loves that
20:16:05 <johnsom> dougwig ok, cool
20:16:25 <johnsom> blogan lol
20:16:27 <xgerman> ok, let’s merge #2 and #3 then
20:16:36 <dougwig> docker flavor chaining for nfv.
20:16:44 <xgerman> now we have a winner
20:16:46 <blogan> insta-accept
20:16:51 <sballe> xgerman: blogan "docker docker 'secure" octavia without docker"
20:17:17 <dougwig> xgerman: ok, i'll update the speaker list now.
20:17:55 <xgerman> also we need some more speakers for the hands on
20:18:18 <xgerman> blogan?
20:18:21 <xgerman> rm-work?
20:18:30 <sballe> I would be happy to help wit the hands on
20:18:34 <crc32> cgarza
20:18:35 <rm_work> yeah
20:18:38 <rm_work> i can do hands-on
20:18:42 <crc32> me too
20:18:49 <crc32> I got my hands all over it.
20:18:55 <blogan> there will probably be a neutron-lbaas and octavia working group/design session right?
20:19:21 <dougwig> blogan: indeed.
20:20:06 <dougwig> i don't know what the space situation is like yet (vancouver had lots of extra rooms), so i don't know if it'll be 1 or 3, but that doesn't happen for a month or so yet.
20:20:11 <blogan> dougwig: put me down for as co-moderator for those and ill let others to the hands on, unless we dont have enough for the hands on then ill do it
20:20:23 <xgerman> #action german add cc32 rm_work sable to hands on talk
20:20:41 <blogan> keep in mind, as always with us, we're not sure who, if any, will be going to tokyo
20:20:47 <dougwig> blogan: ok
20:20:53 <xgerman> same with HP
20:21:41 <blogan> xgerman: wouldn't ajmiller be a good person for the hands on?
20:21:49 <blogan> since he did a lot of the devstack plugin stuff
20:21:49 <xgerman> I will ask him
20:22:00 <xgerman> yeah, I was thinking he would be
20:22:04 <ajmiller> I'
20:22:06 <ajmiller> I'm here.
20:22:14 <xgerman> ok, hand-on?
20:22:19 <ajmiller> Yes, would love to
20:22:31 <ptoohill> Ill gladly help wherever I can, assuming I can go
20:22:41 <ptoohill> If others would like me to help
20:22:52 <xgerman> well, for us a deciding factor being able to go is a talk accepted
20:23:15 <xgerman> what’s the speaker limit dougwig?
20:23:19 <blogan> ptoohill: you should do the beyond talk at least
20:23:31 <blogan> dougwig weasled himself out of it
20:23:38 <ptoohill> lol
20:23:41 <xgerman> lol
20:23:49 <xgerman> he was on the side lines - literally
20:23:57 <dougwig> xgerman: there is no limit that i've found, but more than 3 gets to be a tad awkward.
20:24:10 <xgerman> even for hands-on?
20:24:24 <dougwig> no, i meant for the talk.
20:24:35 <xgerman> ok, yeah, agreed
20:24:37 <sballe> xgerman: for hand on you need extra folks.
20:24:42 <xgerman> yep
20:25:04 <xgerman> yep
20:25:07 <TrevorV> Oh, you can put me on the list for the hands-on I spose
20:25:12 <dougwig> packing a hands-on for speaker creds for flights is kinda wonky, but it's your company. :)
20:25:14 <TrevorV> If we still need names I mean
20:25:42 <sballe> dougwig: but it works ;-)
20:26:02 <ptoohill> I cant view that page, says i dont have perms to edit it, but i just wanted to view it :)
20:26:16 <xgerman> yep, the CfP pages are broken
20:26:36 <xgerman> which honestly is embarrassing for an IT conference
20:26:49 <dougwig> it's probably running on kilo.
20:26:55 <sballe> Is the Horizon/Octavia integration done by eBay
20:27:07 <xgerman> if they only would have done it in ruby on rails..
20:27:17 <johnsom> jruby
20:27:32 <sballe> the reason I am asking is that then they should be on as a speaker too
20:27:33 <xgerman> on m1.tiny
20:27:46 <dougwig> if that site was ruby, it'd work better.
20:28:18 <xgerman> well, I haven’t heard from eBay in a while
20:28:23 <blogan> is ebay even working on the horizon integration?
20:28:33 <xgerman> I hope so
20:28:42 <xgerman> but we should check
20:28:44 <blogan> sure they have their own for v1 but we don't have access to that
20:28:47 <rm_work> sballe: I think it's just Horizon/Neutron-LBaaS integration anyway, not Octavia
20:28:49 <blogan> so i'm not holding my breath
20:28:57 <sballe> oh ok
20:29:09 <rm_work> I think Octavia is supposed to be invisible to end users
20:29:30 <xgerman> yep
20:29:40 <xgerman> we might want some admin/operator comsole
20:29:46 <blogan> well every driver is supposed to beinvisible to the end user
20:29:47 <xgerman> but that would be post-kilo
20:29:55 <xgerman> post-liberty
20:30:05 <xgerman> blogan +1
20:30:06 <dougwig> xgerman: easier to add an octavia panel to the dashboard than to try to wedge that into the user focused lbaas panel
20:30:25 <xgerman> yep
20:30:35 <dougwig> (says the person with an 'a10 networks' panel integrated in horizon, so i'm not making that up.)
20:30:42 <rm_work> wat
20:31:16 <xgerman> ok, I guess we covered that
20:31:26 <xgerman> #topic Brief progress reports
20:31:40 <TrevorV> #link https://review.openstack.org/#/c/192359/
20:31:42 <TrevorV> Need reviews there
20:31:50 <TrevorV> #link https://review.openstack.org/#/c/170989/
20:32:00 <TrevorV> xgerman, johnsom if you guys could take a look at the second, that'd be great
20:32:11 <xgerman> will do
20:32:37 <johnsom> Yep, trying to work through them
20:32:47 <TrevorV> I'm taking up the "fix member delete flows" as well, but not just yet
20:33:12 <xgerman> I switched https://review.openstack.org/#/c/171172/ to requests-mock
20:33:33 <johnsom> TrevorV cool
20:33:37 <blogan> i've got these two reviews ready: https://review.openstack.org/#/c/189087/ https://review.openstack.org/#/c/185244/
20:33:49 <TrevorV> #link https://review.openstack.org/#/c/189087/
20:33:55 <blogan> though i think this kind of exposes some bigger issues that we should probably discuss in depth at some point
20:33:59 <TrevorV> #link https://review.openstack.org/#/c/185244/
20:34:01 <johnsom> I have mostly been trying to review stuff and get fixes merged while working on Sonar gate setup
20:34:04 <blogan> good white board session
20:34:17 <rm_work> oh yeah, it looks like RAX will be very present at the midcycle, so that's good
20:34:18 <crc32> rm_work: what branch do I attempt to commit these STAG puppet changes too?
20:34:36 <xgerman> rm-work - that’s great!!
20:34:39 <TrevorV> Yeah, we've been approved for 4 people to go to the midcycle, including myself this time around :)
20:34:49 <xgerman> wow!!
20:34:55 <sballe> TrevorV: This great news!
20:35:00 <dougwig> sweet,
20:35:08 <johnsom> Excellent!
20:35:11 <ajmiller> cool!
20:35:49 <TrevorV> You'll have to show me a little somethin about Seattle, its one of the places people always suggest me to live since I like rain/snow/cold weather :D
20:35:57 <rm_work> I assume phil is the fourth but i am not sure?
20:36:01 <rm_work> or is it jorge?
20:36:09 <xgerman> fnaval talked about wanting to come, too
20:36:19 <TrevorV> Yeah, phil, brandon, adam, me. the fantastic 4
20:36:20 <TrevorV> :D
20:36:21 <blogan> jorge has officially become technically inept
20:36:29 <dougwig> TrevorV: then you'd like boise even more.
20:36:48 <ptoohill> But, I dont know if Idaho
20:37:22 <dougwig> don't worry, we only indiscriminately shoot people named adam.
20:37:33 <ptoohill> :)
20:37:37 <blogan> damnit why couldn't the midcycle have been in boise
20:37:46 <xgerman> blogan - votes?
20:38:10 <blogan> if you knew the perks of boise shooting people named adam i'm sure the votes would have been different
20:38:18 <xgerman> lol
20:38:25 <dougwig> xgerman: c'mon, votes are silly when you can mobilize the hp mafia. :)
20:38:41 <sballe> lol
20:38:50 <dougwig> i should get the hp boise folks to vote next time.
20:38:58 <xgerman> yep
20:39:10 <johnsom> dougwig I think I voted for fish, oh, bozeman
20:39:11 <xgerman> or get bodybuilding.com to adopt openstack
20:39:55 <dougwig> this is a public channel, so i won't comment on that.
20:40:03 <xgerman> lol
20:40:04 <blogan> never stopped you before
20:40:14 <sballe> lol
20:40:23 <xgerman> they are too close to home
20:40:47 <xgerman> for dougwig
20:41:03 <xgerman> #topic Open Discussion
20:41:15 <xgerman> we have been doing that the last 5 minutes
20:41:56 <rm_work> heh
20:42:11 <rm_work> I have survived Boise a few times, so I guess luck is with me :P
20:42:44 <xgerman> You didn’t where a “Hello, I am Adam” sign I take it
20:44:16 <rm_work> i did not :/
20:44:16 <rm_work> probably a good thing
20:44:16 <blogan> ill probably bring up some possible improvements we might look at making to make the drivers more decoupled and flexible
20:44:16 <blogan> in the near future
20:44:16 <dougwig> is everyone here aware of the new rfe process for neutron (and neutron-lbaas) ?
20:44:16 <rm_work> i am not
20:44:23 <blogan> i'm not
20:44:59 <blogan> i instantly forget processes that end in my requests being denied
20:45:00 <sballe> nope
20:45:38 <johnsom> Yes, but have not practiced it yet...
20:45:41 <dougwig> short form: you don't need to submit specs anymore, and there is no spec deadline. file a neutron bug with the tags 'rfe' and 'lbaas', and just state what you want. 9 times out of 10, the drivers will just approve it. sometimes, they'll ask for a spec.
20:46:04 <rm_work> hmm k
20:46:04 <dougwig> this applies to both neutron and lbaas, just leave off the lbaas tag for neutron stuff. :)
20:46:36 <dougwig> here is the longer form, for anyone interested: https://github.com/openstack/neutron/blob/master/doc/source/policies/blueprints.rst
20:47:04 <sballe> What is rfe again? I forgot
20:47:05 <xgerman> cool!!
20:47:19 <sballe> It sounds great in theory
20:47:26 <dougwig> 'request for enhancement'.
20:47:26 <xgerman> Also do we know how L7 is going?
20:47:38 <dougwig> xgerman: no, i need to touch base with evgeny
20:48:04 <xgerman> great!!
20:48:24 <ptoohill> for l7 I still need to make some template updates
20:48:38 <blogan> octavia needs to be updated for L7 as well
20:48:45 <ptoohill> Last time, according to him it was ready except for 'my part'.
20:49:01 <xgerman> well, now with Octavia being reference implementation...
20:49:14 <blogan> well it'll still need to be updated
20:49:20 <blogan> it has no knowledge of L7
20:49:36 <blogan> doesn't know what do if it sees it
20:49:42 <xgerman> yep, but we don’t need to update the “old” reference implementation
20:49:59 <dougwig> ptoohill: at lest yours is just a template. i get to translate haproxy to internal rules.
20:50:05 <ptoohill> It would be some jinja updates, which would probably be identical in both
20:50:11 <ptoohill> :)
20:50:18 <xgerman> yep
20:51:33 <dougwig> we done? :)
20:51:39 <xgerman> guess sao
20:51:43 <xgerman> #endmeeting