20:00:42 <xgerman> #startmeeting Octavia
20:00:42 <openstack> Meeting started Wed Oct  7 20:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:46 <openstack> The meeting name has been set to 'octavia'
20:00:48 <johnsom_> o/
20:00:48 <dougwig> o/
20:00:49 <blallau> Hi
20:00:50 <sbalukoff> Howdy, folks!
20:00:54 <bana_k> hello !
20:01:04 <xgerman> #topic Announcements
20:01:08 <blogan_> hello
20:01:15 <minwang2> o/
20:01:29 <johnsom_> Octavia is fully released.  The announce e-mail went out Friday.
20:01:37 * dougwig cheers
20:01:39 <sbalukoff> Huzzah!
20:01:43 * xgerman dances
20:01:45 * TrevorV|Home is late, my b
20:01:46 <sballe> yeah!
20:01:50 <johnsom_> The three bugs we wanted to get into Liberty merged last night, so those made it in.
20:01:50 <sballe> congrats
20:01:50 <blallau> :)
20:01:56 * blogan_ blinks
20:02:06 * blogan_ then dances
20:02:22 <sbalukoff> Our jobs are done. We can all go home now?
20:02:29 <xgerman> NO
20:02:36 <sballe> lol
20:02:38 <xgerman> Mitaka design summit topics
20:02:39 <sbalukoff> D'oh!
20:02:55 <xgerman> The PTL will  make a plan + Friday is open forum
20:03:01 <sballe> xgerman: can we talk about the Octavia hands on too
20:03:04 <johnsom> My IRC client keeps connecting me to a freenode server in Lithuania and I have no idea why...
20:03:12 <xgerman> (and I hope it’s not like Vancouver where everybody went home Thursday)
20:03:15 <sbalukoff> johnsom: I blame the NSA
20:03:24 <xgerman> sballe, sure
20:03:26 <sbalukoff> I'll still be there Friday.
20:03:49 <dougwig> let's add an agenda item, rather than discussing during announcements?
20:03:50 <TrevorV|Home> rm_work will be there for 3 weeks total I think
20:03:57 <sballe> I am leaving Thu but the reservation was made for me before I joined Intel.
20:03:57 <rm_work> correct
20:03:58 <johnsom> I have started working on graphics for the presentations.
20:04:06 <johnsom> #link https://drive.google.com/file/d/0Bw-iunw0Bbd2NWJ4cjdPZ3VKZ1U/view?usp=sharing
20:04:27 <sbalukoff> Oh, nice!
20:04:32 <johnsom> Comments welcome
20:04:47 <dougwig> johnsom: the color scheme hurts, but it's very clear. i like it.
20:05:15 <TrevorV|Home> -1 color scheme, +1 look otherwise johnsom
20:05:18 <johnsom> It's supposed to be bright and cheery for the projector....  And I'm lazy and used a built in color scheme
20:05:19 <sbalukoff> Does the controller worker have a driver?
20:05:31 <johnsom> It does now
20:05:35 <sbalukoff> Hah!
20:05:35 <madhu_ak> +1 that looks awesome, but agree with color scheme
20:05:36 <johnsom> (or soon)
20:06:08 <TrevorV|Home> johnsom I personally prefer pastels to "bright", but on a projector this might mellow out, so I'd have to test and see
20:06:12 <johnsom> If anyone is inspired, I will take color palettes
20:06:21 <sballe> lol
20:06:32 <xgerman> we just hand out shades… it will be fine
20:06:37 <sbalukoff> I'm colorblind. So I don't care so long as the contrast doesn't suck.
20:07:23 <xgerman> ok, moving on
20:07:32 <sbalukoff> Oh--
20:07:42 <sbalukoff> I added the active-active blueprint for a design summit topic.
20:07:46 <xgerman> RC2 has been cut with some LBaaS goodies
20:07:49 <sbalukoff> (Don't know if you saw that.)
20:08:02 <xgerman> where is the blueprint? Link?
20:08:15 <dougwig> in the prelim design summit schedule, lbaas/octavia has one fishbowl. subject to change, yada, yada.
20:08:18 <sbalukoff> I'll have a link for you in the next day or two. Still going over it with the IBM team.
20:08:27 <xgerman> ok
20:08:38 * xgerman already thought I missed it
20:08:55 <xgerman> johnsom anyhting for RC2?
20:09:05 <sbalukoff> Right now it's in our standard spec format-- should I just plan on doing a gerrit CR with it, or do you want to see a google doc version of it first?
20:09:17 <johnsom> xgerman I think I already mentioned that.  The three bugs we tagged made it in
20:09:22 <xgerman> +1
20:09:24 <johnsom> Otherwise, I have no news
20:09:37 <xgerman> sbalukoff gerrit is probably better to comment
20:09:46 <johnsom> +1 gerrit
20:09:47 <sbalukoff> xgerman: You've got it, eh!
20:09:52 <xgerman> awesome!!
20:10:04 <xgerman> #topic Lbaas Mid-cycle planning
20:10:26 <xgerman> dougwig has the floor
20:10:30 <sbalukoff> xgerman: I think IBM would be interested in hosting that for once. So... yay?
20:10:35 <sbalukoff> Oh!
20:10:35 <sbalukoff> Ok.
20:10:38 <xgerman> IBM or bluebox?
20:10:46 <sbalukoff> We have merged.
20:10:49 <dougwig> wanted to have us talk about potential dates and potential locations.
20:10:51 <sballe> still in Seattle? ;-)
20:10:54 <johnsom> borg
20:10:57 <sbalukoff> sballe: Yes.
20:11:06 <sbalukoff> johnsom: resistance is futile
20:11:11 <dougwig> one idea that has come up is to have it in ireland, co-located with the designate midcycle, so we could also do gslb.
20:11:15 <sbalukoff> dougwig: yes, let's talk about that.
20:11:27 <sbalukoff> Ooh, that'd be rad! When is that?
20:11:50 <dougwig> talking about mid-january-ish.
20:11:58 <TrevorV|Home> dougwig I highly doubt rax people can make that unless its on our own dime, but that's just a guess
20:12:01 <sbalukoff> dougwig: Yeah, that timeframe seems about right.
20:12:04 <dougwig> nothing firm yet, especially while we feel out budgets and such.
20:12:22 <sbalukoff> Who would host it in Ireland?
20:12:23 <blogan_> dougwig: and neutron one will be when?
20:12:26 <xgerman> yeah, then there is the option to combine with FWaaS if we stay stateside
20:12:36 <dougwig> blogan_: i don't know.  winter?  :)
20:12:46 <dougwig> sbalukoff: HP
20:13:07 <dougwig> fwaas has less overlap than GSLB does with designate+lbaas, IMO.
20:13:20 <xgerman> not denying that
20:13:37 <dougwig> besides, fwaas should be in mexico or something.
20:13:37 <sbalukoff> dougwig: +1
20:13:52 <sbalukoff> In January? No doubt.
20:14:02 <johnsom> We need more developers in Hawaii
20:14:16 <sbalukoff> I'm thinking we should convince our superiors that the group decided to have the mid-cycle in Cancun.
20:14:31 <sbalukoff> Hawaii is good, too. No complaints here.
20:14:32 <dougwig> the main gist of this topic was not to decide anything, but rather to socialize some possibilities, and maybe let folks talk to their management about budgets. if there are dates or locations that will absolutely NOT work, please mention it here, or PM me, or xgerman/blogan_, or armax.
20:14:53 <xgerman> cool!
20:15:07 <armax> hawaii sounds nice
20:15:09 <xgerman> I am gone most of December - so scratch that month
20:15:12 <sbalukoff> Ok, I'll quit screwing around as much:  I'm certain I could make a January mid-cycle hosted by Blue Box / IBM happen in Seattle.
20:15:22 <TrevorV|Home> Most of us from Rax are out most of December ha ha
20:15:26 <sbalukoff> Yeah, December is bad for vacations.
20:15:32 <sbalukoff> January is much better.
20:15:35 <blogan_> id like to know how many would show up to an ireland midcycle first, to see if it will even have enough people
20:15:36 <xgerman> +1
20:15:48 <xgerman> blogan_ HP might be able to send two people
20:15:54 <johnsom> I will probably be able to attend
20:16:04 <sbalukoff> I could probably convince my boss to send me to a January mid-cycle. But I don't know about other IBM teams.
20:16:04 <xgerman> ^ #1
20:16:05 <dougwig> i'd go
20:16:16 <sbalukoff> I could definitely convince other IBM teams to come to Seattle.
20:16:59 <dougwig> i think it might cost less to go to ireland, given the summer's midcycle.  :)
20:17:04 <sbalukoff> Of course, January would be better for our Israeli research team...  I can probe them about that if it makes sense?
20:17:11 <sbalukoff> Er... Ireland, I mean.
20:17:34 <xgerman> yeah, Seattle is expensive
20:17:44 <sbalukoff> Huh. I had no idea.
20:17:49 <TrevorV|Home> blogan_ I don't think WE can make Ireland.
20:17:49 <dougwig> how many here are interested in the designate/gslb cross-over? if that's a small group, then merging may make less sense.
20:18:04 <pc-pothole> o/
20:18:12 <xgerman> we can also fly Graham places
20:18:13 <johnsom> +1 gslb <grin>
20:18:15 <blogan_> TrevorV|Home: might be able to send 1 or 2, depends on other meetups, an probably whether its in q4 or q1
20:18:16 <sbalukoff> dougwig: I have not heard any noise from my team about being very interested in it.
20:18:33 <xgerman> so get mugs to come to the states
20:18:42 <TrevorV|Home> blogan_ yeah but I wouldn't want to detract from next summit possibilities... its something to explore I suppose
20:19:15 <johnsom> The next summit is in Austin, so I would guess not too big of an issue for the RAX folks
20:19:21 <blogan_> TrevorV|Home: will have to talk to those magical budget gnomes
20:19:28 <sbalukoff> TrevorV and other RAXers: Would you be able to come to Seattle if we hosted it there?
20:19:29 <blogan_> lol johnsom so true
20:19:32 <TrevorV|Home> Heh, and offer them bits of gold
20:19:46 <TrevorV|Home> johnsom I forgot about that... Oops
20:19:56 <xgerman> then it’s Bracelona
20:20:11 <dougwig> wasn't it *just* in seattle?  i mean... i like seattle and all.
20:20:15 <blogan_> is that a country of orthodontists?
20:20:19 <sbalukoff> dougwig: It was, yes.
20:20:31 <xgerman> keeps HP’s budget thin
20:20:44 <sballe> and now Bluebox's ;-)
20:20:54 <dougwig> you're on record as wanting to spend a billion on cloud. i'm just trying to help.
20:21:09 * johnsom lol
20:21:11 <xgerman> dougwig so is IBM
20:21:11 <sbalukoff> I can also probe to see whether there's an IBM office in Ireland (or elsewhere) willing to host. Unless HP has their heart set on hosting. :)
20:21:20 <xgerman> I expect an epic host
20:21:30 <sbalukoff> Apparently IBM has a lot of different offices.
20:21:37 <dougwig> yeah, it's IBM.
20:21:52 <xgerman> IBM can host in Mexico?
20:22:06 <xgerman> or hawaii?
20:22:11 <dougwig> hotels rent conference rooms everywhere.
20:22:11 <TrevorV|Home> johnsom I'd say its more likely to get us to Seattle than out of country, due to prices of flights/lodging, but I can't promise that
20:22:17 <sbalukoff> xgerman: I have an internal tool which lets me look up where IBM offices are. I'll be damned if there isn't one in Cancun.
20:22:18 <johnsom> Whoever offers up the most Guinness and best Bushmills....
20:22:19 <blogan_> sbalukoff: offices or orifices?
20:22:32 <blogan_> rackspace has 0 in ireland, one in london though!
20:22:38 <TrevorV|Home> I wouldn't mind Hawaii, its on my bucket list
20:22:45 <sbalukoff> blogan: The difference being?... ;)
20:23:11 <sbalukoff> I'm going to Hawaii less than a week after the Tokyo summit. :D
20:23:25 <xgerman> it’s p[ractically on the way
20:23:36 <johnsom> Yeah, direct flights even
20:23:38 <dougwig> i think we've hit our socializing this idea goal, it's probably safe to move on to the next topic...
20:23:41 <TrevorV|Home> sbalukoff You sound like you won't go back, but I think you would
20:23:42 <sbalukoff> Heh! Indeed.
20:23:48 <sballe> lol
20:23:49 <xgerman> #topic Brief progress reports
20:23:51 <dougwig> but will they let him back?
20:24:03 <sbalukoff> TrevorV|Home: I'm pretty sure my arm could be twisted. :)
20:24:12 <bana_k> heat spec almost done
20:24:15 <johnsom> I guess I covered mine already
20:24:20 <sbalukoff> bana_k: Woot!
20:24:24 <xgerman> +1
20:24:26 <bana_k> https://review.openstack.org/#/c/230197/
20:24:55 <TrevorV|Home> #link https://review.openstack.org/#/c/230197/
20:25:04 <sbalukoff> I pretty-much covered mine. Mostly. First pathetic draft of documentation additions is up for review. I'm working on updating t he hillariously quaintly out of date v0.5 design specs.
20:25:07 <bana_k> if someone from our community takes  a second look that will be great
20:25:57 <xgerman> #action all review https://review.openstack.org/#/c/230197/
20:26:10 <sbalukoff> Again, IBM Israeli research team is back from vacation and we're going over their active-active spec. Should have something this week to show y'all. Will generate a gerrit CR for this.
20:26:21 <xgerman> woot!
20:27:04 <blogan_> sbalukoff: is the active-active being implemented similarily to what was discussed long ago?
20:27:10 <minwang2> the following patches need to be reviewed for my progress:
20:27:11 <minwang2> #link https://review.openstack.org/#/c/215359/
20:27:12 <minwang2> #link https://review.openstack.org/#/c/224929/
20:27:12 <minwang2> #link https://review.openstack.org/#/c/226599/
20:27:28 <sbalukoff> blogan: Eerily so. And I don't think they even saw our original specs from those days. These guys are sharp!
20:28:10 <sbalukoff> There are a few differences though-- and I understand their reasoning. We'll see if y'all agree with them or me on it. ;)
20:28:45 <sbalukoff> (Just for fun, I'll try to not make it known which design I prefer for once until I hear your feedback.)
20:29:02 <TrevorV|Home> *COUGH* yeah right *COUGH*
20:29:17 <sbalukoff> Though that is hard for me. It comes from always being right.
20:29:21 <blogan_> sbalukoff: well since we'll probably be doing active active in a different way, my opinion may not matter
20:29:22 <sbalukoff> ;)
20:29:34 <dougwig> i'd caution against letting it bake too much before involving folks, or it tends to get really sticky when the debates start.
20:29:47 <sbalukoff> dougwig: Agreed.
20:30:34 <xgerman> I am looking forward to the spec — maybe we can find a middle ground between you and blogan_
20:31:05 <sbalukoff> I think so. I mean-- we've come this far, haven't we?
20:31:12 <xgerman> exactly
20:31:19 <xgerman> #topic Octavia talk(s)
20:31:22 <blogan_> xgerman: what i mean is, ours is giong to pretty custom to rackspace bc we like ot be different i guess
20:32:05 <blogan_> xgerman: is this the lab or also the neutron-lbaas talk?
20:32:08 <sbalukoff> blogan_: Yes, but there are new abstractions we can introduce in intelligent ways so that we're all still using essentially the same code base with similar enough behavior that nobody has to fork, eh.
20:32:23 <xgerman> +1
20:32:33 <johnsom> Docs are out on google docs.  I haven't really done much yet.  If you want edit access and don't have it pm me
20:32:34 <xgerman> dougwig is the master of abstraction
20:32:38 <blogan_> sbalukoff: i hope so!
20:32:52 <sbalukoff> johnsom: Cool beans! Could you share the link for that again?
20:33:10 <sbalukoff> I think our various driver layers have been a good thing for us, so far, eh.
20:33:18 <johnsom> blogan_ (and anyone else) up for a google hangout next week to work on a outline for the lbaas talk?
20:33:30 <xgerman> I am in
20:33:35 <johnsom> #link https://docs.google.com/presentation/d/1PYBLtNrkyg__FjyZ2ywynNv-22FW88hDz5j9q8W1ZOQ/edit?usp=sharing
20:33:41 <sballe> I am in for the Octavia lab. Please count me in
20:33:43 <sbalukoff> johnsom: I'm up for it. I don't know if I'm even part of the talk, but I'd love to help with it, eh!
20:33:45 <johnsom> #link https://docs.google.com/document/d/12x6Xc6ktopg9mhxz7yqp_VsFTTqVRxJ_PtZlvzb0xPU/edit?usp=sharing
20:33:48 <blogan_> johnsom: yes, and if dougwig wants to make up for last year and take my spot that'd be great!
20:33:53 <TrevorV|Home> rm_work should probably be in that hangout as well
20:33:54 <sbalukoff> sballe: Sweet!
20:34:03 <blogan_> well last summi
20:34:04 <sbalukoff> Thanks, johnsom!
20:34:06 <xgerman> yeah, let’s schedule something similar for the lab
20:34:12 <dougwig> blogan_: if you have bronchitis, i will fill in for you.  :)
20:34:19 <sballe> lol
20:34:24 <sbalukoff> xgerman: +1
20:34:27 <blogan_> dougwig: i feel like im getting a case of that as we speak
20:34:32 <johnsom> blogan_ Wait a second, I did dougwig's section, so he can take my spot <grin>
20:34:41 <blogan_> johnsom: shhh
20:34:43 <xgerman> we will just have dougwig answer all the questions ;-)
20:35:08 <xgerman> + doing the Horizon demo
20:35:10 <sbalukoff> xgerman: +1
20:35:26 <blogan_> oh yeah good, horizon demo
20:35:34 <blogan_> is that in liberty?
20:35:39 <johnsom> Ok, I will ping folks this afternoon about potential timeslots for the talk and a seperate hangout for the lab
20:35:46 <blogan_> or is that independent-release
20:35:51 <xgerman> nope, but doug-fish said they are close
20:36:20 <xgerman> and it would work in K?
20:37:19 <xgerman> #topic Open Discussion
20:37:48 <sbalukoff> Stupid question about Neutron-LBaaS integration tests:
20:37:54 <johnsom> How does Tuesday at 1pm work for folks for LBaaS talk hangout?
20:38:25 <sbalukoff> I see there's Octavia stuff being called by Jenkins, correct? So, this means that any Neutron-LBaaS tests need to pass Octavia as well, yes?
20:38:25 <xgerman> not so good
20:38:36 <xgerman> sbalukoff yes
20:38:57 <xgerman> this comes with being reference implementation
20:39:02 <johnsom> Ok, do I have any objections to 2pm Tuesday?
20:39:08 <sbalukoff> xgerman:  Ok. So... I'm going to need to get the Octavia side working with shared pools before I the Neutron-LBaaS patch for the same can be merged. Good to know!
20:39:09 * xgerman object
20:39:20 <xgerman> johnsom make it 1:30 to be safe
20:39:22 <dougwig> johnsom: what time zone?
20:39:36 <xgerman> pacific?
20:39:41 <johnsom> Ah, sorry, thought it, didn't type.  Pacific time
20:39:50 <sbalukoff> 2:00pm would be better. I have a company-wide meeting until 1:30 next Tuesday.
20:40:57 <blogan__> johnsom: pacific?
20:41:03 <blogan__> whoops
20:41:05 <blogan__> grrr
20:41:10 <johnsom> blogan_ pacific
20:41:11 <sbalukoff> But eh... if 1:30 PDT is what works, I can probably make that work.
20:41:31 <blogan_> okay that works
20:41:50 <johnsom> So, 1:30 pacific.  Going once...
20:42:14 <johnsom> Going twice...
20:42:22 <johnsom> Sold!  dougwig presents
20:42:28 <sbalukoff> Yay!
20:43:08 <johnsom> I will IRC a hangout link on Tuesday
20:43:18 <sbalukoff> Sounds good.
20:43:18 <blogan_> okay
20:43:22 <xgerman> awesome
20:43:29 <sbalukoff> Do we want to figure out a time to discuss the lab next week as well?
20:43:35 <xgerman> +1
20:43:44 <xgerman> sable any preference?
20:43:47 <xgerman> sballe
20:43:51 <sballe> that would be great! Please not Tuesday. I am in an all day face 2 face
20:44:25 <sbalukoff> sballe: Wednesday or Thursday?
20:44:26 <sballe> Wed or Thu at 2pmPST would work for me
20:44:40 <sbalukoff> Either of those work for me too.
20:44:42 <johnsom> Wednesday right after the Octavia meeting?
20:44:55 <xgerman> sold
20:45:03 <sballe> yep works for me
20:45:08 <sbalukoff> Sounds good!
20:45:34 * johnsom thinks his cat herding skills have improved...
20:45:45 <sbalukoff> IRC a hangout link for that during the meeting?
20:46:05 <johnsom> Yep
20:46:12 <sbalukoff> Cool.
20:46:13 <TrevorV|Home> johnsom might not boast that.
20:46:26 <TrevorV|Home> https://www.youtube.com/watch?v=1SmgLtg1Izw
20:46:48 <sbalukoff> Haha!
20:46:57 <sbalukoff> Ok... I've got nothing else for now.
20:47:21 <xgerman> https://www.youtube.com/watch?v=B00grl3K01g <- Danish ad campaign
20:47:30 <xgerman> anything else?
20:47:55 <xgerman> TrevorV|Home nice - EDS that’s actually now...
20:48:02 <xgerman> #endmeeting