20:00:26 <xgerman> #startmeeting Octavia
20:00:28 <openstack> Meeting started Wed Oct 14 20:00:26 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:31 <openstack> The meeting name has been set to 'octavia'
20:00:36 <xgerman> #chair blogan johnsom
20:00:37 <openstack> Current chairs: blogan johnsom xgerman
20:00:42 <sbalukoff> Howdy, folks!
20:00:44 <blallau> Hi,
20:00:45 <blogan> hi
20:00:47 <bana_k> hi
20:00:49 <xgerman> #topic Announcements
20:00:54 <johnsom> o/
20:01:16 <xgerman> Mitaka design summit schedule with ether pads #link http://permalink.gmane.org/gmane.comp.cloud.openstack.devel/66356
20:01:27 <dougwig> o/
20:01:29 <minwang2> o/
20:01:32 <xgerman> great stuff, three tracks...
20:01:49 <xgerman> which leads us to the next topic
20:01:57 <bharathm> o/
20:01:59 <xgerman> #topic Design session planning
20:02:01 <blogan> so tahts a session for lbaas and fwaas
20:02:09 <blogan> each
20:02:13 <Aish> o/
20:02:18 <sbalukoff> Yay!
20:02:27 <xgerman> Each?
20:02:36 <xgerman> #link https://etherpad.openstack.org/p/mitaka-neutron-next-adv-services
20:02:53 <johnsom> I added active/active
20:02:55 <xgerman> I thought it was a combined session?
20:02:57 <ajmiller> o/
20:03:06 <dougwig> services had 2, last i checked.
20:03:10 <blogan> says session 2/3
20:03:16 <blogan> err 3/4
20:03:26 <xgerman> yep, that confused me
20:03:38 <dougwig> adding up the sessions tells me we still have 2.
20:03:47 <blogan> looks to me like 2 sessions split between lbaas/octavia/fwaas
20:03:54 <xgerman> =ok, one ether pad for two sessions?
20:04:02 <dougwig> 2 sessions split up however we want, honestly. just fill in the etherpad with ideas.
20:04:07 <blogan> im sure we can make another etherpad
20:04:08 <xgerman> gotcha
20:04:41 <xgerman> nah, just took me a while to understand what is going on
20:04:58 <johnsom> There, made it easier for you folks
20:05:25 <sbalukoff> Heh!
20:05:26 <blogan> what do you mean by "you folks"?
20:05:31 <johnsom> Do we need to vote on one or two etherpads?
20:05:32 <johnsom> grin
20:05:35 <sbalukoff> He means me.
20:05:50 <johnsom> Actually I was thinking of xgerman but sure
20:05:55 <blogan> lol
20:06:05 * xgerman wonders if making johnsom chair was wrong
20:06:07 <blogan> okay well do we all just add bullet points?
20:06:14 <TrevorV> o/
20:06:15 <xgerman> +1
20:06:18 <blogan> i catn remember if thats what we do
20:06:39 <xgerman> I guess we all just add points
20:06:45 <blogan> alright
20:06:49 <sbalukoff> blogan: If you have something more specific you can expand on it there or in another etherpad.
20:07:05 <sbalukoff> But do it soon-- it's a good idea for people to see this stuff at least a week in advance.
20:07:11 <dougwig> let's gather ideas in one, we can split with points in that etherpad later.
20:07:20 <sbalukoff> Sure.
20:08:09 <xgerman> Ok, I guess we know what to do now ;-)
20:08:35 <xgerman> #topic Lbaas Mid-cycle planning
20:08:49 <xgerman> dougwig — any update from last week?
20:09:32 <dougwig> nothing new from me. i'm still waiting to hear from ths designate folks, neutron ptl, and y'all. anything from anyone else?
20:09:43 <sbalukoff> Not from me.
20:09:58 <xgerman> HP can send two people to Ireland and we can host in Seattle
20:10:43 <xgerman> maybe time to start an ether pad?
20:11:08 <sbalukoff> +1
20:11:26 <xgerman> #action xgerman start midcycle etherpad
20:11:27 <johnsom> Yeah, the sooner we decide where it is going to be, the better
20:11:37 <xgerman> +1
20:11:57 <xgerman> #topic Scenario tests for octavia---tempest or rally?
20:12:34 <xgerman> so at HP we are big fans of Rally and minwang2 is looking if we can do the testing we want easier in one or the other
20:12:58 <blogan> how much different is writing rally tests versus tempest?
20:13:20 <minwang2> so currently i am working on scenario test for active/passive, right now testing pc-pothole’s code, which is using tempest
20:13:26 <blogan> like the rally tests aren't importing tempest_lib at all?
20:13:40 <xgerman> they don’t need to
20:13:58 <johnsom> I am hearing there are rally tests that are different from tempest tests that rally runs
20:14:40 <xgerman> yep, Aish did tests that way for vpn
20:14:51 <johnsom> I think we need to make a directional call here as I don't want to duplicate work or change direction later.
20:15:00 <xgerman> +1
20:15:17 <sbalukoff> +1
20:15:21 <minwang2> +1
20:15:23 <fnaval> +1
20:15:45 <johnsom> Is there a list of other OpenStack projects switching/using Rally?
20:15:46 <blogan> well my concerns are: going away from tempest means people have to learn yet antoher testing framework, also, there's a lot of common code already written that assumes tempest that we may not be able to use
20:15:49 <dougwig> i'd be tempted to ask this in #openstack-qa, personally. have we tried that?
20:15:53 <sbalukoff> How mature is Rally?  Also, what's the trend? Are other projects seriously looking at it?
20:16:18 <sbalukoff> dougwig: +1
20:16:20 <xgerman> so Cue + DBaaS and some others are Rally only
20:16:26 <sbalukoff> I don't feel well enough informed to make this decision.
20:16:41 <xgerman> VPNaaS is doing lots of Rally
20:16:50 <blogan> lol but who did those?
20:16:52 <sbalukoff> So, it's the new hotness...
20:16:57 <xgerman> it is
20:17:01 <sbalukoff> But...?
20:17:02 <dougwig> sbalukoff: +1, nor do I want to deviate from the norm without a strong reason, as that hurts cross-project vibey-ness.
20:17:10 <sbalukoff> dougwig: +1
20:17:22 <blogan> i dont like going with the new hotness myself, but thats not a major reason for me
20:17:42 <sbalukoff> Same here.
20:17:58 <blogan> too much new hotness going on internally
20:18:05 <sbalukoff> Haha!
20:18:10 <johnsom> I do like the idea of performance tests, which I understand are much easier in Rally
20:18:31 <blogan> what if rally just did performance tests?
20:18:36 * johnsom thinks blogan is talking about himself
20:18:52 <xgerman> it does all other tests, too
20:19:09 <sbalukoff> Does rally have all tempest's features? As in, would we be giving anything up by moving to rally?
20:19:11 * blogan has a lot of coldness inside of him, vampire like
20:19:12 <Aish> johnsom +1 Rally is still evolving. I personally feel rally to be less complicated than tempest. Rally can internally invoke tempest tests and do the negatuve tests as well.
20:19:30 <xgerman> thanks Aish!!
20:20:00 <blogan> i would say most would not feel comfortable making a decision rgiht now
20:20:19 <blogan> most = (all - HP) :)
20:20:32 <sbalukoff> So... if what you want to do can be done in tempest, please do it in tempest for now?
20:20:41 <blogan> well this is for octavia
20:20:48 <sbalukoff> Right.
20:20:58 <johnsom> Do I hear an action coming on to go research?
20:20:59 <blogan> nothing, aside from some early stuff pc-pothole did, has been done
20:21:16 <madhu_ak> by the way, Is the current scenario tests for lbaas using octavia driver can't be resued anyway?
20:21:26 <madhu_ak> reused*
20:21:34 <xgerman> madhu_ak they will used for tetsing
20:21:48 <xgerman> but there are Octavia specific tests (e.g. Active-Passive) we like to write
20:22:00 <blogan> madhu_ak: its possible to reuse it if we want, but i dont understand enough about rally to know if we could do the same with rally
20:22:27 <pc-pothole> Yea, and i had some reservations about calling the neutron-lbaas scenarios ok for both n-lbaas and octavia
20:22:27 <xgerman> so I wouldn’t touch any of our LBaaS V2 tests right now
20:22:32 <dougwig> has anyone looked into the new tempest plugin mechanism?
20:22:48 <blogan> so much new hotness!
20:22:56 <pc-pothole> The driver manipulates things, id like to have tests that test our service specifically, which is what i was starting and thats way behind.
20:22:58 <blogan> that sounds like newer hotness
20:23:31 <pc-pothole> This also helps with other cases like a stand alone octavia in the future maybe.
20:23:45 <blogan> pc-pothole: yeah i don't think anyone disagrees with that now, but would you rather use tempest or rally?
20:23:50 <pc-pothole> But, theres been a lot of changes to n-lbaas tests, so those patches need some extra love
20:23:57 <pc-pothole> rally uses tempest
20:24:02 <pc-pothole> rally solves different issue
20:24:14 <pc-pothole> you build tests for tempest, rally runs tempest
20:24:27 <blogan> pc-pothole: ive heard that too but ive heard differently as well, i need a horse and a mouth to talk to
20:24:28 <pc-pothole> for different scenarios, and it does cool things like setting up envs and stuff
20:24:43 <sbalukoff> Heh!
20:24:48 <xgerman> I think it can do both
20:24:48 <pc-pothole> they have docs, and from what i read you have to have tempest test submitted to them
20:24:52 <madhu_ak> having worked on rally for vpnaas tests, it doesnt rely on tempest_lib anymore. meaning, we can write that are specific to the tests. Rally is good for performance. However, the challenge is, we might not be able to get good community reviews
20:25:04 <pc-pothole> unless they got the plugins stuff done, but that was a while back and wasnt even started last time i looked
20:25:09 <pc-pothole> ok
20:25:12 <pc-pothole> so thats been updated
20:25:21 <pc-pothole> my info was from past, thanks for clarifying.
20:25:26 <blogan> are the vpnaas tests in tree?
20:25:36 <xgerman> in the vpnaas tree? Yes
20:25:59 <madhu_ak> ye.. for scenario tests
20:26:02 <madhu_ak> yes*
20:26:18 <blogan> https://github.com/openstack/neutron-vpnaas/blob/master/neutron_vpnaas/tests/functional/common/test_scenario.py
20:26:20 <blogan> ?
20:26:31 <madhu_ak> that is written on     tempest which does mocking
20:26:48 <madhu_ak> not the actual scenario test like the end user tests it
20:28:08 <madhu_ak> blogan, like this https://github.com/openstack/neutron-vpnaas/tree/master/rally-jobs
20:28:09 <blogan> madhu_ak: can you link a test using rally?
20:28:11 <blogan> tanks
20:28:16 <madhu_ak> yep..
20:28:50 <xgerman> thanks made_ak was hunting for same...
20:29:22 <xgerman> ok, I think we need to let that simmer for a bit before we can make a decision
20:29:32 <xgerman> #action everybody does some research
20:29:45 <sbalukoff> Haha
20:30:26 * blogan simmers
20:30:31 <xgerman> #topic Brief progress reports
20:30:54 <bana_k> #link https://github.com/openstack/heat-specs/blob/master/specs/mitaka/lbaasv2-support.rst
20:30:59 <bana_k> got merged
20:31:09 <sbalukoff> #link https://review.openstack.org/#/c/234639/
20:31:14 <sbalukoff> Woot, bana!
20:31:16 <minwang2> #link https://review.openstack.org/#/c/226599/
20:31:18 <minwang2> get merged
20:31:26 <johnsom> I have mostly been working on slideware, reviews, etc.
20:31:31 <bana_k> :)
20:31:40 <bana_k> #link https://review.openstack.org/#/c/228598/7
20:31:40 <sbalukoff> The above link is the blueprint / spec for active-active mostly put together by the IBM research team in Haifa.
20:31:50 <bana_k> please review
20:31:51 <johnsom> I helped rebase some of the Octavia tempest patchsets with Min.
20:31:52 <minwang2> #link https://review.openstack.org/#/c/215359/
20:31:56 <minwang2> #link https://review.openstack.org/#/c/224929/
20:31:57 <rm_work> I SHOULD have time to really do reviews this week / next week
20:32:11 <sbalukoff> We are going to be discussing it in Tokyo. But it would help if people could start reviewing it now.
20:32:14 <minwang2> these 2 patches still need review, one is for add cert rotation, the other is doc update
20:32:17 <rm_work> so feel free to ping me in PMs with review links for Octavia and I'll get started
20:33:05 <xgerman> internal stuff has been crazy for me but I started work on an image for the lab
20:33:08 <rm_work> have been drowning in internal stuff for about a month now but i am finally out for a bit :P
20:33:18 <sbalukoff> I've mostly been working on feedback / refining the active-active blueprint / spec. and getting distracted by internal nonsense. Will be back on updating docs as of this afternoon.
20:33:29 <xgerman> nice
20:33:46 <sbalukoff> rm_work: Great!
20:33:54 <johnsom> I plan to get back to active/standby this week so I can create a demo
20:33:58 <rm_work> woo internal fires, destroying productivity since *always*
20:34:05 <sbalukoff> johnsom: Awesome!
20:34:12 <sbalukoff> rm_work: +1
20:34:16 <xgerman> rm_work same here
20:34:32 <rm_work> yep it took out a bunch of us recently
20:34:39 <sbalukoff> But! I'm feeling like this conference might not suck-- things seem to be coming together nicely for that!
20:35:12 <xgerman> +1
20:35:25 <xgerman> #topic Open Discussion
20:35:37 <xgerman> I think we are sort of sliding into that
20:35:55 <sbalukoff> Heh!
20:36:04 <johnsom> Reminder, Summit hands-on-lab hangout meeting in ~25 minutes.  https://plus.google.com/hangouts/_/hpe.com/summit
20:36:05 <sbalukoff> So-- lab planning session / hangout right after this meeting, eh!
20:36:10 <sbalukoff> XD
20:36:11 <xgerman> yep
20:36:36 <xgerman> also should we meet next week or just skip the summit week?
20:36:36 <rm_work> ah ok
20:36:57 <rm_work> how long do we think the lab planning will take?
20:36:58 <blogan> ihar was having some issues last night with the minimal gate job
20:37:00 <rm_work> is that going to be 1h+?
20:37:00 <johnsom> I'm up for meeting next week and skipping summit week
20:37:19 <sbalukoff> It's not a bad idea to have a touch-base next week. We should not meet during summit week.
20:37:23 <sballe> hi sorry for being late
20:37:25 <johnsom> blogan Yes, nova had a bad patch that caused amps to not boot
20:37:30 <rm_work> ok I might be 10m late but if someone can email me the hangout link i can catch it soon
20:37:44 <blogan> johnsom: thats what it looked like from the bug reports, but just making sure that was the real issue
20:37:48 <rm_work> oh nm i'll email it to myself
20:37:49 <sbalukoff> sballe: That's OK, we've delegated all review work for the next two weeks to you.
20:37:49 <xgerman> ok, we will meet next week and skip the summit week!
20:37:53 <sbalukoff> Since you're leaving us and all.
20:38:18 <xgerman> nah, mystery left HP as well
20:38:21 <xgerman> mestery
20:38:26 <dougwig> I'm leaving for Japan next Wednesday.  So I'll be out. :)
20:38:26 <johnsom> blogan last I heard the nova patch was reverted and it resolved the issue.
20:38:58 <blogan> johnsom: yeah thats what i've gathered as well, sounds like we know about the same :)
20:39:07 <johnsom> Yep
20:40:08 <xgerman> dougwig: Nice!!
20:41:23 <sballe> sbalukoff: perfect re: reviews
20:41:23 <xgerman> I think we covered everyhting
20:42:08 <sballe> sbalukoff: I'll miss you guys. You are a fun bunch and we have been working together for a long time
20:42:10 <sbalukoff> I figure next week will probably be a very short meeting in any case.
20:42:28 <sbalukoff> sballe: I'm sure our paths will cross again. And yes-- I'll miss you too!
20:42:38 <TrevorV> You're saying this one was long sbalukoff ????
20:42:39 <TrevorV> :D
20:42:46 <sballe> lol
20:42:55 <minwang2> i hope that we can make a decision about the sceanrio test plan before the end of the meeting today
20:42:56 <sbalukoff> TrevorV: It is when I haven't had lunch yet. XD
20:43:15 <TrevorV> minwang2, today?  I thought we just decided to postpone that
20:43:20 <xgerman> +1
20:43:20 <sbalukoff> minwang2: I don't think we will. We all need to do more research.
20:43:25 <minwang2> ok
20:44:53 <sbalukoff> I think that's it? Or does anyone have anything else?
20:45:11 <xgerman> #endmeeting