20:00:12 <xgerman> #startmeeting Octavia
20:00:12 <openstack> Meeting started Wed Nov 18 20:00:12 2015 UTC and is due to finish in 60 minutes. The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:16 <openstack> The meeting name has been set to 'octavia'
20:00:23 <johnsom> o/
20:00:24 <TrevorV> o/
20:00:24 <blallau> Hi,
20:00:28 <bana_k> hi
20:00:35 <sbalukoff> Howdy!
20:00:48 <xgerman> #chair blogan
20:00:49 <fnaval> o/
20:00:49 <openstack> Current chairs: blogan xgerman
20:01:00 <madhu_ak> hi
20:01:39 <TrevorV> blogan is finishing up a one on one
20:01:46 <blogan> hello!
20:01:47 <xgerman> #link https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-11-18
20:01:54 <xgerman> #topic Announcements
20:01:55 <johnsom> xgerman is on it. eight seconds after the hour
20:02:11 <minwang2> o/o
20:02:36 <johnsom> Active/Standby patch is ready for review. Thank you to the folks that have already done so.
20:02:39 <johnsom> #link https://review.openstack.org/#/c/206252/
20:02:39 <xgerman> so blogan + I are stepping down from the sub team lead
20:03:01 <sbalukoff> Sweet.
20:03:12 <fnaval> congrats
20:03:21 <fnaval> or not?
20:03:27 <xgerman> yeah, so we propose to hold elections in two weeks — so everybody can think about if he likes to run
20:03:45 <sbalukoff> Ok.
20:03:47 <TrevorV> I was lost on context here. You meant for Octavia PTL elections
20:03:47 <TrevorV> Got it
20:03:48 <blallau> :(
20:04:08 <johnsom> I will throw my hat in the ring
20:04:11 <blogan> STL
20:04:24 <xgerman> (yeah, whoever runs now has two weeks for campaigning)
20:04:30 <johnsom> STTL?
20:04:33 <sbalukoff> I'll probably throw my name in as well.
20:04:43 <blogan> we should totally mention this on the ML, to give people the chance to throw their hats in too
20:04:49 <sbalukoff> Yep.
20:04:52 <xgerman> +1
20:04:55 <johnsom> +1
20:04:55 <blallau> +1
20:05:27 <blogan> how is the voting going to take place?
20:05:42 <xgerman> pound vote?
20:05:47 <blogan> no
20:06:10 <blogan> its gotta be better than an irc vote
20:06:21 <xgerman> ok, so we should use the voting server?
20:06:22 <fnaval> +1
20:06:24 <johnsom> I think that is how we did it last time, but I think there is an openstack system for it
20:07:25 <blogan> i wasn't a fan of it last time either
20:07:54 <johnsom> http://civs.cs.cornell.edu/ is the usual OpenStack way I think
20:07:58 <xgerman> well, propose something… we can send out ballots by mail ;-)
20:08:05 <sbalukoff> Heh!
20:08:05 <dougwig> it's also usually just atc's from the project.
20:08:15 <TrevorV> Strawpoll?
20:08:18 <sbalukoff> dougwig: +1
20:08:28 <dougwig> we have some flexibility, since we're technically all under armax's tyrant thumb anyway. :)
20:08:44 <armax> dougwig: what did my thumb do this time?
20:08:45 <johnsom> Ha, write it on the back of an octavia sticker and mail it in
20:08:59 <dougwig> armax: just taking your name in vein. we all love you.
20:09:02 <dougwig> vain
20:09:14 <blogan> if we can do the cornell voting thing, that would be really good
20:09:25 <dougwig> we can.
20:09:36 <armax> dougwig: someone tells me that we all waiting for the release to be over :)
20:09:41 <blogan> alright do you knwo the logistics of it?
20:09:47 <dougwig> blogan: i'll set it up, yes.
20:09:55 <blogan> dougwig: alright!
20:10:03 <xgerman> #action dougwig to set up voting
20:10:17 <sbalukoff> Yay!
20:10:31 <xgerman> #topic Midcycle
20:10:43 <xgerman> #link https://etherpad.openstack.org/p/lbaas-mitaka-midcycle
20:10:49 <dougwig> the date is the january range.
20:10:54 <xgerman> so I talked with FwaaS and they are pok to colocate
20:11:09 <dougwig> only open question is where. since we did seattle last time, i'd like to see us cycle to san antonio, but i'm fine with wherever.
20:11:19 <blogan> dougwig: boise?
20:11:42 <sbalukoff> I'd go for Boise.
20:11:48 <dougwig> that's open, but i figure we lose both rax and hp extras with that option.
20:12:16 <xgerman> yep, our budget is nowadays constraint. The printers printing money belong to another company now
20:12:23 <blogan> lol
20:12:35 <blogan> well fiddlesticks
20:12:44 <sbalukoff> I'm honestly OK with whereever as well.
20:12:44 <xgerman> also we were able to book the big conference room in our building
20:13:21 <sbalukoff> I think we're looking at moving offices in that time frame-- so I'm reluctant to say whether Blue Box is going to be in a position to host in Seattle.
20:13:32 <blogan> xgerman: did you book both halves?
20:13:38 <sbalukoff> Heh!
20:13:49 <xgerman> blogan barclay did!!
20:13:54 <xgerman> braclac
20:13:56 <blogan> didnt he last time?
20:14:05 <xgerman> yeah, he did
20:14:14 <xgerman> but I think this time we are getting it
20:14:23 <barclaac> The admins are going to hate me. Got both halves
20:14:32 <blogan> lol
20:14:37 <barclaac> If we want to break for a working session we can even split them up
20:14:58 <johnsom> barclaac as long as we don't have to have people working on storage cabinets again
20:15:08 <sbalukoff> Heh!
20:15:14 <barclaac> see - just haters everywhere
20:15:57 <blogan> well i'm still all for boise, 2nd choice woudl be san antonio for same reasons as dougwig
20:16:02 <dougwig> ok, so if we cycle, it's texas or boise. if we declare seattle the official lbaas city, we can just do that every time. :) my suggestion is texas, since we get more rax folks involved. but i'm open.
20:16:29 <xgerman> don’t forget FWaaS - they are ok with both
20:16:43 <blogan> kevinbenton wanted san antonio i've heard
20:16:44 <xgerman> they did’t like Boise though...
20:16:46 <blogan> ;)
20:16:50 <barclaac> But aren't we coming to Texas at the summit anyway?
20:16:54 <dougwig> kevinbenton hates the cold.
20:17:07 <blogan> barclaac: but didnt we do seattle the last 2 times?
20:17:07 <sbalukoff> Well... Boise in January... I guess you could go skiing.
20:17:08 <xgerman> barclaac +1
20:17:09 <barclaac> It's not cold, just really wet :-P
20:17:25 <sbalukoff> No, it can be cold. Especially if you're used to Texas temps.
20:17:35 <TrevorV> Lets go everywhere there is snow. I want snow.
20:17:49 <TrevorV> I'll probably not be able to go, but snow at a possibility makes me happy
20:18:02 <dougwig> alaska!
20:18:04 <barclaac> Personally I'd vote for Hawaii but my boss will kill me over the travel budget.
20:18:05 <TrevorV> Done
20:18:10 <TrevorV> +1 dougshelley66
20:18:12 <TrevorV> dougwig
20:18:13 <sbalukoff> +1 on Hawai'i.
20:18:14 <TrevorV> Dammit
20:18:23 <johnsom> TrevorV we will buy you some shaved ice from the trucks....
20:18:29 <TrevorV> ... not the same thing
20:18:35 <sbalukoff> (Just got back from there-- I'd be happy to return. :) )
20:18:48 <fnaval> hot tub snow
20:19:01 <johnsom> Maui it is! My boss voted for it
20:19:06 <sbalukoff> Woot!
20:19:35 <barclaac> See - johnsom wants to get me killed
20:19:51 <sbalukoff> That's how promotion happens in the HP empire, right?
20:20:00 <barclaac> Don't give him ideas
20:20:22 <xgerman> well, so how do we decide? Vote in the ether pad, dougwig flips a coin...
20:20:32 <johnsom> sbalukoff Does one of the locations help you to get more of the new IBM people getting involved attend?
20:21:01 <sbalukoff> Most of them are either in San Jose or Israel. So, I don't think it makes much of a difference, actually.
20:21:28 <sbalukoff> Honestly-- I think dougwig is probably right: we should shoot for more RAXers there, and do it in San Antonio.
20:23:42 <sbalukoff> RAXers: How many, realistically, could make it if it's in Boise vs. San Antonio?
20:23:45 <blogan> well we need to decide quickly, how bout we let the ehterpad stew a few more days and then come to a final decision
20:24:01 <xgerman> ok, sounds good
20:24:07 <blogan> by end of this week would be great thoguh
20:24:11 <markvan> btw, some of the ibm folks are in MN
20:24:12 <sbalukoff> (I'm biased toward Boise as I grew up there and would take the opportunity to visit with family while I'm there...)
20:24:14 <blogan> before the thanksgiving week
20:24:48 <blogan> does boise have electricity?
20:24:48 <sbalukoff> markvan: Oh? Cool. I didn't know that.
20:24:56 <xgerman> nice.
20:25:27 <markvan> sbalukoff: yup, quite a large group of openstack folks here
20:25:27 <johnsom> They do, but they turn it off at 7pm
20:25:28 <xgerman> #topic How the CI is failing us
20:25:34 <sbalukoff> blogan: Yes, but it's provided by potatoes, and the chemical reaction slows down in the winter time, so we might be a bit short on supply then.
20:26:25 <johnsom> I think we have no scenario tests running actual code right now. This concerns me
20:26:44 <johnsom> We have had a couple of patches get in that were broken...
20:26:48 <blogan> yeah did that tox change ever get reverted? sorry been out a couple of days
20:26:52 * johnsom eyes some folks at the table
20:26:55 <xgerman> yep + we see several bugs which a good CI could have caught
20:26:55 <ptoohill> :/
20:26:56 <blogan> dougwig, armax ^
20:27:21 <fnaval> 242697 and 215359 needs to be reviewed as well
20:27:40 <fnaval> there is a large review up for a scenario test
20:27:47 <armax> blogan: I think tox is still busted
20:27:55 <blogan> so 2 problems i think that have caused this are 1) tox bug that happened last week caused some patches to basically skip tests so that the gate coudl clear up 2) scenario tests needt o be voting
20:27:56 <armax> blogan: as far as I can tell
20:28:09 <minwang2> fnaval thanks for pointing it out
20:28:11 <xgerman> and worse as a core I now need to be a human CI and install a devstack with that patch, run a scenario test manual, etc.
20:28:18 <blogan> okay we'll have to work around it now
20:29:14 <xgerman> is there an ETA for when the CI will work again
20:29:14 <blogan> xgerman: i agree, so we're going to have to rework the tox stuff and test run to actually run the tests bc of the tox bug
20:29:15 <xgerman> ?
20:30:18 <sbalukoff> Eew.
20:30:26 <blogan> whenever tox fixes their bug which if it hasn't been fixed yet i wouldn't wait
20:32:06 <xgerman> ok, so with M1 looming I am not sure if we have too many cycles to attack that
20:32:16 <xgerman> or let M1 slide on some stuff and fix the CI?
20:32:27 <blogan> might be a simple fix, not sure
20:32:47 <blogan> i have an idea, i might be able to get to it tonight, but if someone else wants to tackle it by all means
20:33:06 <xgerman> well, then we stay focused on M1...
20:33:31 <xgerman> #action to revisit the CI situation after M1
20:33:43 <xgerman> #topic Brief progress reports
20:34:09 <evgenyf> Hi folks, I've spoted some bugs in cert managers and TLS functionality in plugin and oushed 2 change-sets, will appreciate your review
20:34:23 <sbalukoff> Hawai'i is awesome. That is my report. Oh-- and I'm getting caught up and should have more interesting things to say next week.
20:34:37 <johnsom> As mentioned in announcements, active/standby is good for reviews. I will be created a dependent patch to update the failover flow so I don't contribute more to the size of that patch.
20:34:46 <sbalukoff> evgenyf: Can you link reviews here?
20:35:05 <evgenyf> https://review.openstack.org/#/c/243218/1, https://review.openstack.org/#/c/244201/
20:35:17 <sbalukoff> Danke!
20:35:39 <johnsom> Should make it for the M1 goal we had.
20:35:53 <evgenyf> sorry for no adding it in meeting's agenda, thought it will start in half an hour, I'm still on summer time..
20:36:57 <TrevorV> #link https://review.openstack.org/#/c/243218/1
20:37:05 <TrevorV> #link https://review.openstack.org/#/c/244201/
20:37:08 <sbalukoff> johnsom: Cool.
20:37:10 <TrevorV> I got you evgenyf :D
20:37:47 <johnsom> Speaking of these, I see the third party CI's are failing on them and others. Do we need to poke people to take a look at those?
20:37:56 <evgenyf> TrevorV: thanks
20:38:38 <evgenyf> Johnsom: I will handle Radware's
20:38:51 <xgerman> thanks
20:38:56 <xgerman> and if A10...
20:39:14 <minwang2> the following patches need review:
20:39:18 <minwang2> #link https://review.openstack.org/#/c/215359
20:39:38 <minwang2> #link https://review.openstack.org/#/c/242697/
20:40:00 <minwang2> #link https://review.openstack.org/#/c/244859/
20:41:17 <johnsom> evgenyf Thanks!
20:42:41 <johnsom> BTW, when testing the active/standby don't forget to grab the dependent taskflow fix. It is merged, but not yet released. I hope it will go out next week
20:43:25 <sbalukoff> johnsom: Aah! Thanks for the heads-up.
20:44:02 <blogan> does this fix taskflow by removing it? :)
20:44:15 <sbalukoff> Haha
20:44:22 <johnsom> No, but it helps us remove a bunch of extra code
20:44:29 <blogan> i had to
20:44:43 <johnsom> not really
20:44:45 <xgerman> #link https://review.openstack.org/#/c/242277/
20:44:50 * johnsom grins
20:44:50 <xgerman> Anchor and such
20:44:56 <xgerman> but let’s move on
20:45:03 <xgerman> #topic Open Discussion
20:45:35 <sbalukoff> Question for y'all: What vacations / holidays do y'all have coming up for the end of the year?
20:45:50 <sbalukoff> (Since this is a pretty typical time to burn through that, eh.)
20:45:56 <xgerman> I will be gone 12/12->end of year
20:46:02 <blogan> i have a lot
20:46:15 <sbalukoff> I'm gone from 12/17->EOY
20:46:15 <johnsom> Along the taskflow and removing code lines, harlowja as kind enough to fix a bug we opened in the conditional flows.
20:46:46 <blogan> harlowja is definitely very helpful and kind
20:46:50 <johnsom> This should allow us to merge the flows into one flow in a few cases so revert works better.
20:46:54 <sbalukoff> So, in other words... if you want to get something merged soon, you've got about 2 weeks. Let's definitely get the Active/Standby stuff merged before then.
20:47:01 <TrevorV> My last active day in December is the 20th
20:47:04 <johnsom> The guy is awesome
20:47:26 <xgerman> also don;’t forget right after that Piet has another UI review
20:47:30 <xgerman> #link https://bluejeans.com/454453749/browser
20:47:34 <harlowja> ha
20:47:48 <johnsom> I am out next week, then around the holiday in December
20:47:49 <TrevorV> I meant the 18th... was looking at the wrong month... RIP
20:47:50 <sbalukoff> xgerman: Ah yes-- thanks for the reminder, eh!
20:48:13 <blogan> consider me off every day after next week, but i really wont be
20:48:22 <xgerman> well, I should have Internet on vacation so might be able to do one or the other review
20:48:24 <blallau> @johnsom can you link Taskflow bug on launchpad?
20:48:45 <xgerman> blogan for you vacation means that you have time to work on Octavia :-)
20:48:51 <sbalukoff> Haha!
20:49:00 <blogan> xgerman: sadly thats waht i am thinking
20:49:34 <johnsom> blallu I think it was, someone else actually opened the issue. I will check
20:49:51 <blallau> thank you ;)
20:50:38 <johnsom> It was not linked, but is now
20:50:45 <blallau> Great
20:51:13 <xgerman> sbalukoff those Active-Active friends of yours… any update?
20:51:46 <sbalukoff> xgerman: Nothing to share yet. I'm also not yet up-to-date on that since returning from Hawai'i, though, either.
20:52:07 <xgerman> oh, ok.. was curious
20:52:12 <sbalukoff> I will poke them to get that spec updated per the recommendations from the design summit.
20:52:25 <xgerman> sounds good
20:52:44 <xgerman> I think we can give everybody 8 minutes before the next meeting...
20:52:52 <sbalukoff> Sounds good!
20:52:56 <xgerman> #endmeeting