19:59:31 <xgerman> #startmeeting octavia
19:59:31 <openstack> Meeting started Wed Dec  2 19:59:31 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:35 <openstack> The meeting name has been set to 'octavia'
19:59:37 <johnsom> o/
19:59:37 <blallau> Hi,
19:59:38 <rm_work> o/
19:59:38 <blogan> hi
19:59:43 <xgerman> #chair blogan
19:59:44 <openstack> Current chairs: blogan xgerman
19:59:49 <bana_k> hi
19:59:54 <rm_work> I am back from being kinda-mostly-away for a month
19:59:59 <xgerman> #topic Announcements
20:00:22 <eranra> Hi
20:00:22 <xgerman> bana_k I have some question for you in Open Discussion so don’t leave early :-)
20:00:28 <ajmiller> hi
20:00:35 <bana_k> xgerman : sure
20:00:42 <johnsom> Welcome back rm_work.  No more raw chicken for you
20:00:42 <xgerman> Midcycle in San Antonio, TX - January 12-15
20:00:53 <rm_work> heh, maybe just a little bit? :P
20:00:56 <xgerman> #link https://etherpad.openstack.org/p/lbaas-mitaka-midcycle
20:01:00 <minwang2> o/
20:01:07 <dougw2> please rsvp on that etherpad, all.
20:01:13 <xgerman> +1
20:01:27 <xgerman> and please offer a good remote option for people who are budget constraint
20:01:34 <blogan> dougw2 = dougwig?
20:01:47 <xgerman> yep, irccloud is down
20:01:55 <xgerman> I had to fire up alocal client
20:01:56 <rm_work> Yeah I don't know how well my camera-on-a-trashcan thing worked last time?
20:01:57 <TrevorV> o/
20:01:58 <rm_work> was that  ... OK?
20:02:00 <dougw2> blogan: yes, irccloud is hosed today
20:02:15 <xgerman> hope they give us our money back
20:02:31 <rm_work> if they actually let us in the actual CEC this time we should have videoconferencing?
20:02:32 <dougw2> freenode got ddos'ed, so i don't think it's irccloud's fault.
20:02:42 <rm_work> and Vidyo is more friendly for external access I think than our old system
20:02:48 <xgerman> cool
20:02:56 <xgerman> also we are collocated with FwaaS
20:03:03 <rm_work> we'll have to check it out, but hopefully will have a better plan in place
20:03:12 <xgerman> cool
20:03:29 <xgerman> next announcement:
20:03:33 <xgerman> GSLB Midcycle in Seattle - January 20-22?
20:03:38 <rm_work> worst case i put my webcam up high again
20:03:55 <johnsom> Yes, Kosmos Jan 20-22 Seattle
20:04:12 <xgerman> mugsie wanted Seattle your RAX DNS guys must have roughed him up in San Antonio
20:04:15 <rm_work> I'm still really interested in finding out what Kosmos is doing and how that's moving along, but still don't have time <_<
20:04:49 <xgerman> next Elections for Sub-Project-PTL ongoing
20:04:50 <johnsom> rm_work You haven't missed much yet.
20:05:05 <blogan> your dns guys are mostly in Austin
20:05:13 <dougw2> anyone with a commit in the last two cycles should've gotten an email ballot. if not, ping me privately.
20:05:15 <blogan> i mean our
20:06:35 <xgerman> that explains it - they probably brainwashed him :-)
20:06:58 <xgerman> next Backwards compat for libraries and clients.
20:07:06 <xgerman> #link https://review.openstack.org/#/c/226157/
20:07:27 <xgerman> release manager johnsom take note: process change for closing bugs when patches merge
20:07:35 <xgerman> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/080288.html
20:07:44 <johnsom> Yeah, I saw that
20:07:51 <xgerman> the next one is really important
20:07:53 <xgerman> Release Notes for *aaS Projects
20:08:01 <xgerman> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/081105.html
20:08:26 <xgerman> so they want us to put our release notes closer to the code. Not sure how diligent we were with the release notes for M1
20:08:36 <xgerman> I think that got cut today
20:08:45 <dougw2> it was a wiki before. if you've never seen it, this will not affect you.  :)
20:08:55 <blogan> pretty sure we werent diligent
20:09:01 <xgerman> yep, I don;t think we have been very diligent
20:09:08 <rm_work> erk
20:09:26 <johnsom> I manually wrote the octavia release notes as we didn't have a previous release to reference
20:09:39 <xgerman> well, let’s improve on that one ;-)
20:10:01 <xgerman> and lastly Evolving the stadium concept
20:10:10 <xgerman> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/080865.html
20:10:13 <johnsom> The tools assumed a previous release.  Plus we aren't being good with launchpad.  So this is probably good for us.
20:10:43 <dougw2> i encourage folks to read and comment on that stadium thread. or if you're not comfortable with the ML, ping one of us in channel or privately.
20:11:59 <xgerman> to sum it up LBaaS and/or Octavia might become their own OpenStack project...
20:12:30 <xgerman> so if you have an opinion one way or the other please comment
20:12:31 <dougw2> well… to sum it up, armax is asking whether the stadium is too big, too small, or just right. it sort of feels "too big". the exact effects of that are under discussion.
20:12:51 <rm_work> agree
20:12:56 <blogan> too big for one PTL
20:12:58 <rm_work> seems a bit too big
20:13:02 <blogan> bc most have their own core teams
20:13:06 <dougw2> i don't think *any* stadium project is ready to be it's own TC project at the moment.
20:13:24 <xgerman> well, I am sure we have enough manpower
20:13:57 <xgerman> but Neutron is a cozy place ;-)
20:14:03 <johnsom> Yeah, the overhead could be high for some projects.  Maybe the advanced services become a "stadium"
20:15:01 <xgerman> and then we have neutron as a sub-project ;-)
20:15:04 <dougw2> i'd rather see each of the three survive on their own merits, in the case of adv.services.  just IMO.
20:15:13 * johnsom looks for the panic on dougw2's face
20:15:14 <blogan> same for me
20:16:24 <rm_work> So LBaaS and Octavia would BOTH fall under one?
20:16:36 <dougw2> rm_work: i believe so, in some fashion.
20:16:37 <rm_work> or, that is part of the discussion I guess
20:16:43 <dougw2> rm_work: yep
20:16:48 <xgerman> yep, we would need to discuss and decide
20:16:53 <rm_work> seems fairly reasonable, the overlap is not 100% but it is significant
20:17:17 <xgerman> also I am a bit worried that we need to increase the TC when all those projects hit
20:17:34 <dougw2> that's the TC's problem to figure out.
20:17:46 <dougw2> plus, this won't all hit all of the sudden, unless we go insane.
20:17:52 <blogan> cross that bridge when it happens
20:18:44 <xgerman> yeah, ML for that one
20:18:53 <xgerman> #topic Brief progress reports
20:19:49 <johnsom> Active/Standby I have been iterating on comments.  Will post another update for open review in a few minutes.
20:19:57 <blogan> i'm starting on the get me a lb work
20:20:28 <johnsom> I have the failover flow updates for active/standby coded, but still have some work to do on it.
20:20:28 <blallau> great
20:20:51 <xgerman> blogan please coordinate with doug-fish
20:21:23 <blogan> i have a review up that includes a graphite dashboard that shows the neutron lbaas jobs history
20:21:25 <blogan> https://review.openstack.org/#/c/252178/
20:21:27 <xgerman> #link https://review.openstack.org/#/c/242277/ is stuck in merge conflict but I am hoping we will have that ready for review soon again
20:21:47 <blogan> nice to be able to see the job history and easy to see the failure rate
20:22:16 <xgerman> cool
20:22:36 <blogan> bc our jobs are failing intermittently bc of this bug
20:22:39 <blogan> https://bugs.launchpad.net/neutron/+bug/1504465
20:22:39 <openstack> Launchpad bug 1504465 in neutron "neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors failed to clean up loadbalancer" [Medium,In progress] - Assigned to Syed Ahsan Shamim Zaidi (ahsanmohsin04)
20:22:59 <dougw2> is it being actively worked on, or does it need to be reassigned?
20:23:15 <blogan> i do not knwo but i was giong to look into it anyway
20:23:19 <xgerman> also how do I see that dashboard? Link?
20:23:30 <dougw2> open the html file locally
20:23:31 <blogan> i'm going ot have to get a tiny url
20:23:33 <blogan> one sec
20:23:51 <xgerman> they are all rst
20:23:58 <blogan> but normally ou'd just build the docs
20:24:04 <xgerman> but yes, I can build it
20:24:24 <xgerman> was hoping for a cdentrally hosted one…
20:24:40 <xgerman> but who has a public cloud those days...
20:24:44 <blogan> welp this allows one to be easily built, at least link to the graphs
20:24:47 <dougw2> blogan: you now own that bug.
20:25:00 <blogan> dougw2: hate you
20:25:06 <johnsom> Just click on the docs gate
20:25:28 <rm_work> octavia.io does central hosting for building docs...
20:25:29 <blogan> lol
20:25:36 <blogan> i have never clicked on that
20:25:45 <blogan> that is much easier
20:25:46 <rm_work> not 100% sure what you're talking about but we could also host more stuff there :P
20:25:48 <xgerman> brilliant
20:25:58 <rm_work> but yeah once built it renders via that link yes :P
20:26:00 <dougw2> that site has been down 100% of the times i've tried to use it.
20:26:05 <rm_work> dougw2: really?
20:26:11 <dougw2> yep. i gave up.
20:26:17 <xgerman> fanatical support, eh?
20:26:19 <rm_work> try using it now
20:26:32 <rm_work> it's been up for at least most of the month, was down for a few days due to a reqs issue
20:26:52 <rm_work> it'll move you to like... 33% :P
20:27:17 <xgerman> ok, anyhting else progressing?
20:27:27 <rm_work> i have mostly been away or focused on internal stuff or various upstream fixes that don't fall into a specific category -- but am behind on reviews by a lot and plan to get through at least some today/tomorrow
20:27:28 <xgerman> event streamer?
20:27:30 <dougw2> my current success rate allows me to apply any reply from doesdouglikeit.com to your site.
20:27:41 <rm_work> I am reviewing EventStreamer NOW
20:27:50 <xgerman> ok, cool
20:27:52 <blogan> event streamer, i put some comments in nothing major
20:27:57 <rm_work> I think it needs a little more love
20:28:00 <rm_work> but just minor stuff
20:28:03 <blogan> crc32_znc: is welcome to respond
20:28:08 <rm_work> very close, yeah
20:28:20 <xgerman> also blogan you said our gate is now better
20:28:42 <xgerman> so I cut back on my human CI work :-)
20:28:57 <rm_work> oh I think https://review.openstack.org/#/c/216140/ really could be merged, although I am not sure if the current test suites actually hit that code
20:29:13 <rm_work> do they run through TLS stuff? anyone know before I go digging?
20:29:20 <xgerman> no
20:29:26 <xgerman> no TLS scenarios run/exist
20:29:31 <rm_work> bleh
20:29:49 <xgerman> yeah, fnaval said he would work on it…
20:29:53 <johnsom> Yeah, we got bit on that one with the initial octavia release, TLS was broken
20:29:58 <rm_work> yes
20:30:10 <fnaval> yep - on my list of things to do
20:30:18 <rm_work> so, would love to merge this, but i understand if people are hesitant
20:30:31 <xgerman> well, we just need to test which takes time
20:30:48 <johnsom> Same here, just hasn't bubbled up yet
20:30:57 <xgerman> maybe mwang2 has cycles...
20:31:15 <rm_work> yeah even for me, I can say "it worked fine" but that was a ton of patches ago, dunno if current master broke it, it has sat for a while
20:31:19 <xgerman> speaking of which: dougw2 who approved Octavia backports
20:31:31 <xgerman> approves
20:31:36 <dougw2> that'd be the neutron-stable-maint team.
20:31:46 <dougw2> i think, let me check our gerrit ACLs
20:32:07 <dougw2> yep.
20:32:16 <xgerman> thanks — now as we have a release we need to keep backporting bugfixes and people really want TL:S to work
20:32:23 <rm_work> yes
20:32:36 <rm_work> having working TLS (since it was one of our big features) would be good :P
20:32:59 <xgerman> well, we are a few +2s/+A away in Liberty
20:33:00 <blogan> we have working tls passthrough
20:33:09 <rm_work> heh
20:33:10 <dougw2> don't expect that team to do the backports. we should be cherry-picking what we want back into liberty, within the definitions of acceptable backports.
20:33:20 <xgerman> we did the backports
20:33:23 <dougw2> ok
20:33:31 <dougw2> if they're not looking at them, just ping them on IRC.
20:33:45 <dougw2> mestery and ihrachys are pretty fast on those usually.
20:33:54 <xgerman> they might not check Octavia
20:34:18 <johnsom> Is there a process for those with the cores?  Like we need to +1 it before they look at them?
20:34:43 <rm_work> a few of us did already
20:34:51 <dougw2> no, since it's mechanical. just asked in neutron channel.
20:34:54 <xgerman> #action xgerman ping neutron-stable-maint team for approving Octavia backports
20:35:05 <johnsom> Yeah, just curious
20:35:40 <xgerman> bana_k what’s the status of the LBaaS V2 heat template?
20:36:03 <xgerman> any place we can check?
20:36:08 <bana_k> markvan is working on it.
20:36:22 <xgerman> ETA?
20:36:38 <xgerman> will it hit Mitaka? M2?
20:36:54 <bana_k> I have to check with them for that.
20:37:07 <markvan> hi, the new LBaaS v2 heat resources are our for review
20:37:10 <xgerman> ok, please do - and let me know if I need to start looking for people to help
20:37:18 <dougw2> can you link the review here?
20:37:25 <xgerman> markvan great!!
20:37:47 <markvan> #link https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/lbaasv2-suport,n,z
20:38:03 <xgerman> thanks
20:38:32 <xgerman> lastly, LBaaS V2 horizon panel is making progress. I roped ajmiller in to write a devstack plugin :-)
20:38:50 <dougw2> markvan: ty
20:39:02 <ajmiller> xgerman:  Yup - have a skeleton patch up, working on it as I have time today.
20:39:10 <ihrachys> dougw2: I use the Kyle's dashboard for stable stuff https://github.com/openstack/gerrit-dash-creator/blob/master/dashboards/neutron-subprojects-stable.dash
20:39:26 <ajmiller> Might get a somewhat functioning version up later today.
20:39:27 <ihrachys> since the project is in the list, should eventually work.
20:39:46 <xgerman> awesome!!
20:40:12 <ihrachys> that said, we have other stuff to care, so it does not occur overnight
20:40:44 <dougw2> ihrachys: ty
20:40:54 <xgerman> thanks
20:42:10 <blogan> oh want to add one more thing
20:42:55 <blogan> since scenario tests are running the real octavia drivers, but its not voting, reviewers should not approve if the scenario job fails
20:43:32 <blogan> most likely its one of those intermittent failures and a recheck will pass it, but it might catch an actual regression
20:43:35 <rm_work> which one is this?
20:43:42 <rm_work> gate-neutron-lbaasv2-dsvm-scenario
20:43:43 <rm_work> ?
20:43:46 <blogan> yes
20:43:48 <rm_work> ok
20:43:48 <dougw2> and please don't recheck spam. if you don't have the time or knowledge to debug, flag someone.
20:43:49 <blogan> its non-voting right now
20:43:50 <rm_work> good to know
20:44:01 <blogan> i'd like to get it stable enough to make it voting but its failure rate is higher than wanted
20:44:02 <dougw2> we need to fix the errors, not spam them in.
20:44:09 <rm_work> ^^
20:44:16 <xgerman> dougw2 +1
20:44:35 <johnsom> +1
20:44:48 <blogan> lets spam fixes in!
20:44:54 <xgerman> #topic Open Discussion
20:44:57 <minwang2> also i feel it is a good habbit to check HP-Octavia-Sonar-CI to make sure we have unit tests
20:45:08 <xgerman> minwang2 +1
20:45:10 <blogan> good idea minwang2
20:45:26 <johnsom> Yep, it is handy for that
20:45:32 <minwang2> #link https://review.openstack.org/#/c/251479/
20:45:39 <xgerman> about that Sonar system — with our public cloud shutting down...
20:46:01 <blogan> lol
20:46:03 <minwang2> this patch and its dependent patches need review, it is octavia  backport for TLS
20:46:13 <xgerman> minwang2 we discussed that earlier
20:46:27 <minwang2> yeah, just put the link here :)
20:46:30 <johnsom> Yeah, right now we don't have a landing place for the sonar gate.
20:46:44 <xgerman> though we unaerthed some Azure credit
20:46:54 <johnsom> I have pretty detailed docs and would sign up to install it somewhere.
20:48:12 <xgerman> we don’t need to solve it today…
20:48:38 <xgerman> and I am hopinf that a company who actually manufactures servers can spare one or twp
20:49:19 <dougw2> i'll run it, but i'll mock you OPERATORS mercilessly.
20:50:05 <johnsom> Grin
20:50:07 <rm_work> well, we're eventually going to have a CI for rackspace's stuff
20:50:13 <rm_work> I imagine it could also do Sonar?
20:50:22 <rm_work> but that's down the road a bit
20:50:31 <blogan> only if we can rename it to RAX-SONAR-GATE
20:50:39 <xgerman> deal
20:50:41 <blogan> wait we can't use rax
20:50:45 <blogan> has to be RACKS
20:50:47 <blogan> lol
20:51:11 <rm_work> >_>
20:51:17 <xgerman> yeah, we shut down 1/31
20:51:32 <johnsom> I think that is perfectly fair.  You can call it TOWING-SONAR-GATE if you want
20:51:36 <xgerman> (will also take your server with it dougwig2)
20:52:33 <johnsom> I would like to target early January for that.  So if we can make a call on where it goes by then it would be great.
20:52:43 <blogan> i was joking, i dont care what its called, well has to have sonar in the name
20:52:46 <johnsom> Then I will work with whoever wants it on the details.
20:53:17 <rm_work> k, i'm sure we can spin up a machine
20:53:20 <blogan> maybe a christmas cloud server gift?
20:53:22 <rm_work> how big is the machine now
20:53:36 <dougw2> i'll want to call it hp-welfare-gate
20:53:41 <blogan> lol
20:53:43 <johnsom> 4CPU/8GB
20:53:46 <rm_work> the meeting is effectively over? I think we can take this to main channel
20:54:12 <dougw2> move to adjourn
20:54:13 <rm_work> unless someone has anything else
20:54:27 <xgerman> #endmeeting