20:00:02 <johnsom> #startmeeting Octavia
20:00:03 <openstack> Meeting started Wed Oct 19 20:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:07 <openstack> The meeting name has been set to 'octavia'
20:00:10 <sbalukoff> Hello folks!
20:00:13 <johnsom> Hi there
20:00:33 <johnsom> It could be a light turnout today as some folks have said they can't make it
20:00:43 <johnsom> #topic Announcements
20:00:51 <nmagnezi> hi all
20:01:03 <nmagnezi> o/
20:01:21 <johnsom> We have a design summit session, add any topics comments to the etherpad
20:01:28 <johnsom> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/global-search?t=Neutron%3A+LBaaS+retrospective+and+next+steps
20:01:44 <perelman> anyone is here?
20:01:50 <johnsom> Also, we had some gate breakage yesterday
20:02:01 <johnsom> #link  https://review.openstack.org/#/c/345818/
20:02:27 <johnsom> Infra is dropping projects from the "projects" list for devstack.  They started with diskimage-builder
20:02:38 <sbalukoff> He!
20:02:39 <johnsom> This is to save cloning repos I guess.
20:02:40 <sbalukoff> heh!
20:02:54 <nmagnezi> johnsom, sorry for that question but what is the meaning of this? the fact that they drop it from the list
20:02:57 <sbalukoff> Yeah; would have been nice if they checked that we were using it first.
20:03:04 <johnsom> Anyway, I put a quick fix in yesterday for our gates, but it doesn't help folks adding us via the plugin
20:03:22 <dougwig> it makes the underlying image build quicker, and the devstack jobs have to do more cloning from the mirrors.
20:03:46 <johnsom> nmagnezi It means when we do a git clone of diskimage-builder during our devstack setup we get an error saying it's not an OpenStack project.
20:04:08 <johnsom> So, this is the start.  I guess over time they are going to pull more out.
20:04:20 <nmagnezi> got it
20:04:33 <johnsom> I am going to do some tests and probably update the patch for out devstack plugin.
20:04:48 <johnsom> Just an FYI item in case someone was having trouble.
20:04:59 <johnsom> #topic Brief progress reports / bugs needing review
20:05:20 <dougwig> i18n/deb queries are out, waiting for replies.
20:05:32 <johnsom> dougwig I think these need your blessing: https://review.openstack.org/388834 https://review.openstack.org/386245
20:05:39 <sbalukoff> There are a number of CRs in neutron-lbaas in particular that I put a +2 on a couple weeks ago that haven't seen any reviews.
20:05:59 <johnsom> One is our functional job for Octavia, the other is the merge the jobs into one API test
20:06:22 <perelman> I also have some strange problem in my change for distributor image creation that I wanted to ask you about
20:06:24 <johnsom> Ok, I will try to take a pass there soon
20:06:28 <dougwig> sbalukoff: ok, will look
20:07:09 <johnsom> Mostly I have been focused on getting the gate stuff straightened out.  Our grafana dashboard is up now:
20:07:10 <sbalukoff> Dustin and I have been working on C10k optimizations for amphorae. We were able to get a test environment to reliably scale to 180k connections to a single amphora.
20:07:25 <johnsom> #link http://grafana.openstack.org/dashboard/db/octavia-failure-rates
20:07:39 <sbalukoff> And there will be 1 or 2 more patches related to that. (The only one not up for review is a documentation patch I'm working on talking about "high performance Octavia")
20:07:40 <johnsom> sbalukoff That is pretty darn cool.
20:07:49 <johnsom> More than I thought we would handle with one amp
20:08:06 <sbalukoff> Well, we had to beef up the amphora's RAM. XD
20:08:28 <sbalukoff> On that note-- I now have a good use case for why we might want amphorae to survive a reboot.
20:08:36 <johnsom> perelman We can address the image questions in open discussion if that is ok
20:08:51 <sbalukoff> Because resizing an amphora in place ends up looking a lot like a reboot.
20:09:00 <johnsom> sbalukoff Ugh, you are killing me.  You just convinced me to give up on that.....
20:09:04 <perelman> while building distributor image we try to clone ovs (git clone https://github.com/openvswitch/ovs.git /opt/ovs-install)
20:09:22 <sbalukoff> johnsom: Well, yes-- because nobody could come up with a good use case on that. But... now we have one. :P
20:09:29 <perelman> and it fails on gerrit tests with - connection timeout to server
20:09:37 <sbalukoff> Granted, there are other ways to go about it if you want single instances to scale.
20:10:02 <sbalukoff> But... you know me: I am prone to change my position on something when new information comes to light. :P
20:10:49 * johnsom coughs multi-processes of haproxy
20:10:58 <sbalukoff> Haha!
20:10:59 <perelman> sorry, i type too slowly and while typing dont see your requests :(
20:11:17 <sbalukoff> Well, yes-- I saw the light on that too and changed my position. Now... somebody just needs to do the work. :P
20:12:08 <johnsom> Sigh, yes.  So, any thoughts on the cert stuff in light of the reboot need?
20:12:35 <sbalukoff> Well... a couple.
20:12:47 <johnsom> Is it a graceful reboot ?
20:13:08 <sbalukoff> It would be great if the amphora could send a signal to the controller (one of its various components) that it needs certs if it doesn't find them. And this would trigger a push to the amphora.
20:13:28 <sbalukoff> We might be able to piggy-back that on to the existing health check.
20:13:49 <johnsom> Yeah, I don't really want to open another port, etc.
20:13:52 <johnsom> Hmm
20:14:25 <johnsom> Ok, any other progress to talk about?
20:14:29 <sbalukoff> Just a flag that says "I have all the certs I need" or not.
20:14:57 <johnsom> #topic Open Discussion
20:15:04 <perelman> hi
20:15:13 <perelman> so lets return to my question
20:15:26 <johnsom> perelman Hi.  I hope my comments have made sense on the act/act patches.
20:15:37 <johnsom> So this clone is in the element?
20:15:41 <perelman> in patch for building distributor image #link: https://review.openstack.org/#/c/327137/33/elements/openvswitch-octavia/install.d/77-run_setup_install
20:15:57 <perelman> we run command git clone https://github.com/openvswitch/ovs.git /opt/ovs-install
20:16:12 <perelman> and fail with connection to server timeout
20:16:14 <johnsom> Yeah, that probably isn't going to work.
20:16:28 <perelman> in our local machines it passes fast
20:16:33 <johnsom> It will need to be in here: https://review.openstack.org/#/c/327137/33/elements/distributor-agent/source-repository-distributor-agent
20:17:25 <johnsom> Take a look at the docs here:
20:17:27 <johnsom> #link https://github.com/openstack/diskimage-builder/tree/master/elements/source-repositories
20:17:42 <nmagnezi> when you finish with perelman's topic i would like to raise something
20:17:57 <perelman> johnsom, I am trying to go over all the comments but in the last week we had holidays and also some deadline in other project, so only tomorrow i return to A/A with full gas :(
20:18:13 <johnsom> Cool.
20:18:14 <perelman> thank you very much for the reviews!
20:18:29 <johnsom> Darn, I forgot a topic.  Meeting schedule for the next two weeks.
20:18:49 <johnsom> Most of us will be at the summit next week, so I expect to cancel that meeting.
20:18:53 <sbalukoff> We can do it after open discussion.
20:19:06 <sbalukoff> Yep, that seems reasonable-- we'll be meeting in person, eh!
20:19:16 <johnsom> The week after I am vacationing in Barcelona, so we can cancel it as well or someone else can host.
20:19:40 <perelman> ok, I will see the document
20:19:45 <sbalukoff> I'm also vacationing the following week.
20:20:14 <johnsom> Most folks are...  It sounds like we should cancel that one as well.
20:20:20 <johnsom> I will send a note to the mailing list.
20:20:28 <sbalukoff> Sounds good!
20:20:41 <nmagnezi> so the next meeting is in 3 weeks?
20:20:57 <johnsom> perelman Give that a try, if not, leave me a message in the IRC channel and I will have a look
20:21:14 <johnsom> nmagnezi Yes, November 9th.
20:21:23 <nmagnezi> ack
20:21:34 <johnsom> perelman nmagnezi are either of you coming to the summit?
20:21:39 <perelman> johnson, OK, thank you very much!
20:22:08 <johnsom> nmagnezi I think you had a topic
20:22:16 <perelman> no, i think i cant.. we have some urgent deadline
20:22:19 <nmagnezi> johnsom, not, I can't travel this time
20:22:31 <nmagnezi> johnsom, yes
20:22:40 <nmagnezi> so, the another topic for the open discussion topic i would like to raise are two patches that wait for a second +2 (sbalukoff mentioned earlier that some patches are pending reviews for a couple of weeks now): https://review.openstack.org/#/c/299998/ https://review.openstack.org/#/c/344658/
20:22:52 <perelman> but i will try to connect if there will be possibility to connect to some of your meetings there
20:22:53 <johnsom> #agreed Next meeting will be November 9th
20:22:59 <perelman> will be glad to do it
20:23:55 <sbalukoff> I think those are going to be fairly impromptu.
20:24:01 <johnsom> Ok.
20:24:14 <johnsom> Yeah, we don't have talk session this time.
20:25:32 <johnsom> nmagnezi Ok.  I think Doug said he was going to have a look.  I will also try to review those, but I have a list of reviews I'm still working on.
20:25:51 <sbalukoff> It occurred to Dustin and I that giving a #vbrownbag on high-performance Octavia would have been great, but apparently we're also too late for that deadline.
20:26:00 <sbalukoff> So... I guess we can just talk about it in person and share our notes.
20:26:58 <nmagnezi> johnsom, thanks. sorry just wanted to raise this one more time so it might get merged before the summit break
20:27:03 <johnsom> Yep.  I plan to be in the design summit area most of the time, so opportunity for us to chat/work together.
20:27:20 <sbalukoff> Woot!
20:27:25 <sbalukoff> I'm looking forward to it!
20:27:47 <johnsom> Yep.  Any other topics for today?
20:27:59 <nmagnezi> sbalukoff, do you eventually stick around? :)
20:28:14 <sbalukoff> nmagnezi: Er...? Today?
20:28:22 <sbalukoff> I'm going to be intermittently available today.
20:28:40 <nmagnezi> sbalukoff, no, in Octavia in general. asking because of your announcement  the other day
20:29:09 <nmagnezi> johnsom, seems like there are no additional topics
20:29:32 <sbalukoff> If you're talking about me being paid to work on neutron-lbaas / octavia long term...  Well, they've not told me to stop working on it yet. And based on more recent developments there's a very, very slim chance I might still be working on Octavia in three weeks. But it's slim enough that I didn't want to raise anyone's hopes (or fears).
20:29:47 <sbalukoff> So for now? I'll do what I can. Until they tell me to stop.
20:30:08 <johnsom> We appreciate the help!
20:30:20 <sbalukoff> I care a lot about these projects, because I've been working with y'all on them from their inception. And I think they're actually pretty good. :D
20:31:10 <johnsom> Ok, that sounds like it for today.  Thanks!  Safe travel
20:31:18 <johnsom> #endmeeting