17:01:46 <johnsom> #startmeeting Octavia
17:01:47 <openstack> Meeting started Wed Jul 19 17:01:46 2017 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:49 <xgerman_> o/
17:01:51 <openstack> The meeting name has been set to 'octavia'
17:01:54 <pksingh> Pradeep
17:02:01 <johnsom> Hi folks!
17:02:04 <sanfern> Hi
17:02:10 <jniesz> Hi
17:02:24 <johnsom> #topic Announcements
17:02:35 <johnsom> PTL elections are coming up
17:02:41 <johnsom> #link https://governance.openstack.org/election/
17:03:17 <johnsom> Please consider running for Octavia PTL.  The link above has information on criteria, etc.
17:03:52 <johnsom> I cannot say at this time whether I will run for another release....
17:04:00 <jniesz> :(
17:04:06 <xgerman_> :-(
17:04:14 <johnsom> Plus, it's always good to have new folks involved.
17:04:18 <sanfern> :(
17:04:23 <pksingh> johnsom: u are awesome :)
17:04:29 <xgerman_> +1
17:04:34 <johnsom> Yeah, I'm not sure if my employer will want me to run again
17:04:38 <sanfern> +1
17:04:44 <jniesz> +1
17:05:01 <xgerman_> hopefully we don’t go the way of designate
17:05:05 <johnsom> Thanks folks!  grin
17:05:30 <johnsom> Yeah, I have faith in our community (couldn't do it without your support)
17:05:41 <pksingh> xgerman_: what happened with designate?
17:06:11 <pksingh> may be not important
17:06:33 <xgerman_> they imploded because of lack of participants/leadership
17:06:40 <johnsom> Also, the PTG is September 11-15th.  I have an Octavia room reserved Wednesday through Friday, though I will be there all week.
17:06:44 <pksingh> xgerman_: ohh
17:06:50 <johnsom> #link https://www.openstack.org/ptg
17:07:51 <johnsom> The next summit is in Sydney, Australia November 6-8.  I am not planning to attend this one.
17:07:58 <johnsom> #link https://www.openstack.org/summit/
17:08:04 <xgerman_> rm_work and I submitted a talk
17:08:17 <johnsom> Yes, I think some folks are planning to attend.
17:08:31 <xgerman_> well, I wouldn’t call that planning
17:08:55 <johnsom> Well, I'm pretty sure at least one other person is....
17:09:01 <xgerman_> but if somebody has budget and the talk is approved we can add people
17:09:28 <johnsom> Yeah, our talks are usually a community collaboration.
17:09:41 <johnsom> Which I think is cool.
17:10:09 <johnsom> Final announcement I have: Feature freeze and Pike-3 milestone is next week, July 24th!!!!
17:10:28 <johnsom> #link https://releases.openstack.org/pike/schedule.html
17:11:12 <johnsom> Next week we will be locking down the features for Pike.  Please plan accordingly.  If you have something critical to get in, please add it to the priority bug list and let me know.
17:11:22 <johnsom> #link https://etherpad.openstack.org/p/Octavia-Pike-priority-patches
17:11:41 <johnsom> Any other announcements I am forgetting about?
17:12:27 <johnsom> #topic Brief progress reports / bugs needing review
17:12:36 <xgerman_> https://review.openstack.org/#/c/418530/ - needs review
17:12:39 <nmagnezi> johnsom, just joined in. I think you'll get our votes even if you won't run.
17:12:43 <johnsom> Ok, so I just mentioned a reminder about the priority bug list.
17:12:50 <xgerman_> yep added
17:13:11 <johnsom> Cool
17:13:21 <xgerman_> but we should probably discuss if/how much we swotch to V2 API
17:13:26 <xgerman_> later
17:13:28 <johnsom> nmagnezi also wanted input on:
17:13:34 <johnsom> #link https://bugs.launchpad.net/octavia/+bug/1705259
17:13:35 <openstack> Launchpad bug 1705259 in octavia "Octavia health-manager and worker should work better with any given interface_driver " [Undecided,New] - Assigned to Nir Magnezi (nmagnezi)
17:13:47 <johnsom> Ok
17:14:01 <nmagnezi> yup, please have a look and comment i'd like to work on that one
17:14:21 <johnsom> Recently I have started to pick up the python-openstacksdk patches that the folks from Intel started
17:14:33 <johnsom> #link https://review.openstack.org/#/c/454410/
17:14:40 <johnsom> #link https://review.openstack.org/#/c/451574/
17:15:12 <johnsom> #link https://review.openstack.org/449264
17:15:27 <johnsom> This is a python library for OpenStack that will include Octavia.
17:15:39 <johnsom> I plan to use it for the octavia-dashboard
17:16:34 <johnsom> I think I can get most of API done this week.
17:16:55 <johnsom> Any other progress updates or bugs to note?
17:17:39 <johnsom> #topic Proposed mascot
17:17:54 <johnsom> The foundation has come back with a proposed mascot rendering
17:18:01 <johnsom> #link https://usercontent.irccloud-cdn.com/file/KdpSnmb0/OctaviaMascot.jpg
17:18:24 <johnsom> I think rm_work had some comments/feedback.  Any other thoughts from the team?
17:18:26 <nmagnezi> looks nice!
17:18:29 <rm_mobile> o/
17:18:30 <xgerman_> +1
17:18:33 <xgerman_> ship it
17:18:42 <nmagnezi> +1
17:18:45 <nmagnezi> looks good
17:18:46 <rm_mobile> I did have some feedback
17:18:48 <pksingh> it looks nice
17:18:51 <rm_mobile> Can you link it again?
17:18:59 <nmagnezi> rm_mobile, https://usercontent.irccloud-cdn.com/file/KdpSnmb0/OctaviaMascot.jpg
17:19:07 <sanfern> looks good
17:19:07 <rm_mobile> I thought it looked really busy
17:19:16 <rm_mobile> And why wasn't it 8 feathers
17:19:33 <rm_mobile> That'd help with the busyness
17:19:34 <pksingh> its our national birs
17:19:37 <pksingh> bird
17:19:39 <rm_mobile> And make it a pun
17:19:58 <johnsom> Nice
17:19:58 <pksingh> great :)
17:20:06 <rm_mobile> Oct-avia
17:20:11 <johnsom> So, proposing dropping the two bottom feathers?
17:20:21 <xgerman_> sounds good
17:20:32 <sanfern> +1
17:20:41 <rm_mobile> They could do that or resize them all
17:20:54 <pksingh> rm_mobile: avia?
17:21:09 <rm_mobile> I actually was hoping for the resize but both work
17:21:18 <rm_mobile> Pksingh "oct"
17:21:25 <rm_mobile> Means 8 :P
17:21:32 <johnsom> What do others think about dropping the two bottom feathers to make it eight (octa)?
17:22:07 <rm_mobile> Just dropping those two might make it look awkward because of the lines
17:22:13 <pksingh> then we can increase the width of feathers little bit, to look it full
17:22:13 <johnsom> Personally I'm fine with it as-is, but looking for feedback
17:22:19 <nmagnezi> if that's important for Adam I'd vote in favor of it :P
17:22:53 <johnsom> To give context, the foundation is putting them here:
17:22:54 <xgerman_> yeah, for me it’s more important we get a mascot/sticker after what happened the last time ;-)
17:22:57 <johnsom> #link https://www.openstack.org/software/project-navigator/
17:23:22 <johnsom> They will also make up stickers for the summit/PTG
17:23:41 <xgerman_> I already reserved a space on my laptop ;-)
17:24:01 * nmagnezi needs a mascot shipped :D
17:24:29 <johnsom> nmagnezi We can probably make that happen
17:24:34 <xgerman_> +1
17:24:37 <sanfern> please ship to us ;)
17:24:45 <nmagnezi> that would be really nice :-)
17:25:30 <johnsom> We can figure out a way to get any active contributor a sticker
17:25:33 <rm_mobile> Yeah just note how simple most are
17:25:45 <rm_mobile> On that page
17:25:48 <johnsom> Ok, so should we vote on this?  More discussion?
17:25:59 <rm_mobile> To many lines makes them look really bad as a low res icon
17:26:47 <johnsom> When I zoom it small in chrome the dark and light sections show up pretty well actually
17:26:59 <rm_mobile> Yeah it's close
17:27:22 <johnsom> https://usercontent.irccloud-cdn.com/file/FwOSBaQh/image.png
17:27:39 <rm_mobile> Eugh
17:27:56 <rm_mobile> Yeah less plz
17:28:07 <jniesz> i think less feathers would help that
17:28:49 <rm_mobile> 8!
17:29:25 <johnsom> #startvote Should we change the proposed mascot? Yes, No
17:29:26 <openstack> Begin voting on: Should we change the proposed mascot? Valid vote options are Yes, No.
17:29:27 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:29:39 <johnsom> Just to keep our voting heritage alive....
17:29:45 <xgerman_> ol
17:29:51 <rm_mobile> #vote yes
17:30:03 <johnsom> #vote No
17:30:04 <rm_mobile> #vote Yes
17:30:20 <pksingh> #vote No
17:30:26 <jniesz> #vote yes
17:30:33 <sanfern> #vote yes
17:30:42 <nmagnezi> #vote yes
17:31:24 <johnsom> Ok, going once...
17:31:32 <johnsom> going twice....
17:31:42 <johnsom> #endvote
17:31:43 <openstack> Voted on "Should we change the proposed mascot?" Results are
17:31:44 <openstack> Yes (4): sanfern, nmagnezi, rm_mobile, jniesz
17:31:45 <openstack> No (2): johnsom, pksingh
17:32:10 <rm_mobile> 8 feathers wins the day! Huzzah
17:32:18 <johnsom> Ok, so help me with instructions for the artist.  We want eight feathers, how do we do that?
17:32:33 <rm_mobile> Reduce the number of feathers by 2
17:32:36 <rm_mobile> :P
17:32:40 * johnsom glares
17:32:51 <rm_mobile> Ideally scale the others around to match the current layout
17:32:53 <jniesz> reduce by 2 resize the rest
17:33:31 <johnsom> So we still want two dropped features, just remove two, resize and some white space between feathers?
17:33:59 <johnsom> Help me, to help you, help the artist....  grin
17:34:11 <rm_mobile> Err I don't know about white space
17:34:18 <rm_mobile> Just drop two and resize imo
17:34:29 <johnsom> So, you are thinking making the feathers bigger?
17:34:33 <jniesz> yea, no whitespace
17:34:34 <rm_mobile> Yes
17:34:44 <johnsom> Ok
17:35:15 <johnsom> Everyone good with that?  Additional comments?
17:35:37 <johnsom> Don't make me call another vote...  grin
17:36:03 <johnsom> All right, moving on
17:36:11 <johnsom> #topic Discuss L3 active-active spec confusion (xgerman)
17:36:58 <johnsom> xgerman and I were talking this week about the active/active patch he is working on and the distributor driver
17:37:12 <johnsom> I think there is some confusion about the L3 spec
17:37:43 <johnsom> Specifically, what actions the L3 act/act distrubutor driver will take against the top of rack switch?
17:38:04 <xgerman_> and what part the bgp speaker plays
17:38:20 <jniesz> the ToR will be the bgp peer
17:38:20 <johnsom> What are the mechanics if an amphora needs to be removed from rotation?  (distributor-> ToR switch?)
17:38:37 <johnsom> And what exactly the BGP speaker will be sending out.
17:38:48 <johnsom> xgerman_ Does that capture the questions?
17:38:55 <jniesz> the bgp speaker will essentially be sending out route announcements
17:39:02 <jniesz> to the bgp peer of the ToR
17:39:41 <xgerman_> ok, johnsom thought the speaker would just annoucne and cold be configured when starting an amp and didn’t need to be reconfigured
17:40:22 <jniesz> we would want the ability to cleanly withdraw the route as well
17:40:28 <jniesz> so when we remove it from the distributor
17:40:35 <jniesz> it will pull the route
17:40:44 <jniesz> otherwise have to wait for timeout
17:40:53 <jniesz> which is dictated by the hold time
17:41:05 <johnsom> So, give us a little detail on how that would work.  Is that a distributor driver call to ToR?
17:41:19 <jniesz> no calls directly to the ToR
17:41:30 <jniesz> all the calls would go through the bgp speaker on the amphora
17:41:57 <johnsom> Ok, so to remove an amphora, it needs to stop speaking.  Correct?
17:42:20 <jniesz> to remove it would have to withdraw the /32 route and then terminate the peering session
17:42:42 <jniesz> that is for shutdown
17:42:49 <johnsom> Because essentially, in your model the "distributor" is the ToR doing the ECMP right?
17:43:15 <jniesz> the ToR is just bgp neighbor that is taking the route and injecting it into the L3 fabric
17:43:23 <jniesz> the neighbor could be a route reflector as well
17:43:31 <jniesz> doesn't have to be the ToR
17:43:36 <jniesz> in our model it will be ToR
17:43:57 <jniesz> but the design should work with different network topologies based on L3 fabric
17:44:36 <jniesz> when the amphora boots up we can automatically create the peer session
17:44:41 <johnsom> So, to setup the ECMP hashing, your distributor driver would talk to what?
17:44:44 <jniesz> and then announce the route when everything is ready
17:45:15 <jniesz> for the ECMP hashing, we would need multiple amphora launched
17:45:30 <johnsom> Or are you planning to just accept any multi-advertised route as an ECMP hashed
17:45:30 <jniesz> and they would inject the same anycast VIP route with different next-hops
17:46:14 <jniesz> each amphora injects the same route with different next hop
17:46:24 <jniesz> ECMP happens when you have 2+
17:46:39 <jniesz> as the network then has multiple best paths of equal eight
17:46:41 <jniesz> weight
17:47:21 * johnsom Thinks he had this all wrong and German was on the right path.
17:47:39 <johnsom> I think we need to step back and re-think the distributor driver.
17:47:49 <xgerman_> well, we still should note that in the spec
17:47:59 <xgerman_> so others can read & understand
17:48:18 <johnsom> jniesz Can we update the spec to call out who is talking to what components for each of the actions?  I think that would help clarify.
17:48:36 <johnsom> +1 Yeah, that was what I was typing.
17:48:37 <xgerman_> it can also just be an example and we can go from there
17:48:56 <jniesz> yes, it would be an example, as a different operator might have different devices
17:48:58 <johnsom> Bonus points for a lifecycle
17:48:59 <jniesz> that they BGP peer with
17:49:05 <johnsom> Right
17:49:18 <xgerman_> yes, but it would help us to understand ;-)
17:49:57 <jniesz> ok, I can add some details in the spec with our example
17:50:03 <johnsom> Thanks!
17:50:29 <xgerman_> I still feel we need to whiteboard ACTIVE-ACTIVE and talk that through at the PTG
17:50:32 <jniesz> also for the distributor driver talk if you want to discuss after on a call I can set up
17:50:53 <johnsom> ok, so now the discussion is really about how we abstract the act/act to support the "service vm distributor", "appliance distributor", and 'L3 fabric distributor" models.
17:51:03 <xgerman_> indeed
17:51:20 <xgerman_> and where we put the abstraction: flows for each or hide it in the driver
17:51:52 <jniesz> yea, I remember the flow question came up
17:52:26 <johnsom> I can't do a call today, I have some other meetings, but yeah, whiteboard and/or proposals would be good.
17:52:42 <johnsom> I need to think about that abstraction a bit.
17:53:16 <jniesz> they are pretty different, as some you just call api from driver, others you have to orchestrate the service vm distributor
17:53:17 <xgerman_> same here and we probably should loop in rm_work to see if it fits "our architecture”
17:53:35 <johnsom> Right
17:54:15 <johnsom> #action Think about how we abstract the act/act to support the "service vm distributor", "appliance distributor", and 'L3 fabric distributor" models.
17:54:26 <johnsom> #topic Open discussion
17:54:37 <johnsom> Any other topics for the last 5-6 minutes today?
17:54:46 <xgerman_> My main things is how much do we want to switch to V2 API?
17:54:53 <pksingh> https://review.openstack.org/#/c/484325/
17:55:04 <xgerman_> Are we planning to change the default in devstack. etc.
17:55:45 <xgerman_> unrelated I asked infra and they can build  diskiamges…
17:56:17 <johnsom> Hmmm, so changing the service "octavia" to not require neutron-lbaas?
17:56:33 <xgerman_> and making the proxy default driver in Neutron
17:56:48 <johnsom> We need to merge that  first...
17:56:53 <xgerman_> indeed
17:56:54 <johnsom> (needs some reviews)
17:57:20 <xgerman_> but depending on what we decide that might inform priorities
17:57:27 <johnsom> Yeah
17:57:50 <johnsom> It might be a bit late to pull that switch on other projects.  I'm thinking heat for example
17:58:16 <xgerman_> well, I think we can punt that until next week…if we do proxy it shoudl eb transparent
17:58:26 <johnsom> I would propose making sure the proxy gets into Pike, then at the start of queens making the switch
17:58:53 <xgerman_> yeah, just wanted us to have a decision… works for me
17:59:15 <johnsom> Ok, let's do that.
17:59:27 <johnsom> pksingh
17:59:41 <pksingh> johnsom: i replied to your comments
17:59:44 <johnsom> Reading your comments.   I will comment there as we are now out of time
17:59:52 <pksingh> johnsom: sure, thanks :)
17:59:55 <johnsom> Other please chime in
18:00:09 <johnsom> Ok, thanks folks!
18:00:15 <xgerman_> thanks
18:00:20 <johnsom> #endmeeting