17:00:04 <johnsom> #startmeeting Octavia
17:00:05 <openstack> Meeting started Wed Oct  4 17:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <openstack> The meeting name has been set to 'octavia'
17:00:43 <johnsom> Hi folks!
17:00:56 <johnsom> Another fine day in OpenStack land...
17:01:03 <jniesz> Hi
17:01:10 <longstaff> Hi
17:01:23 <johnsom> #topic Announcements
17:01:34 <xgerman_> o/
17:01:41 <tongl> hi
17:01:59 <johnsom> In case you missed the fun, Infra enabled Zuul V3 for a few days but it did not go well.
17:02:18 <johnsom> I think the issues for use were minor or solvable, but some other teams had bigger problems.
17:02:38 <johnsom> So, they have now reverted back to Zuul v2 so that teams can get patches merging again.
17:03:05 <johnsom> So, back to the old normal for now.  The gates should be passing again.
17:03:28 <johnsom> If you see anything questionable, post in the channel and we can take a look/help
17:03:30 <tongl> It seems they will rolling-forward again to v3 in a few weeks.
17:03:41 <tongl> hope in that time, it will be more stable
17:03:48 <johnsom> Yeah, I know they are going to give it another go, just not sure when
17:04:17 <johnsom> Also of note, the OpenStack newton release is going EOL.
17:04:38 <johnsom> Technically it would be this week, but given the issues it has been slightly delayed to 10/18.
17:05:08 <johnsom> I plan to check today if we need to cut one last release for backports and/or clean out any proposed patches against stable/newton.
17:05:37 <johnsom> Any other announcements / questions about that stuff?
17:06:44 <johnsom> #topic Meeting time revisit
17:06:54 <johnsom> #link https://doodle.com/poll/p65x9xxkec52ecaw
17:07:26 <tongl> it is a tie
17:07:41 <johnsom> So, this time slot does not work for some active octavia contributors.  I put up another doodle so we could have another round of voting
17:08:29 <johnsom> Only two timeslots were proposed and yes, it came out to a tie.
17:09:24 <xgerman_> mmh, coin-flip?
17:10:30 <johnsom> Well, the later time means a core can make it and I think two of the folks that can only make the earlier meeting time are going to transition off octavia.
17:11:18 <jniesz> yes, we can go with the later time
17:11:25 <johnsom> So that makes me lean towards adopting the later time slot.
17:11:34 <johnsom> Thoughts / comments?
17:11:56 <johnsom> This is so hard as we have people all over the world working on the project, which is a good thing, but...
17:12:24 <xgerman_> we can always go crazy and do one week late and the other early…
17:12:32 <johnsom> We could also consider alternating times, but I tend to not like it as it really splits the team and makes decisions / votes hard.
17:13:16 <xgerman_> yeah, when Neutron did that it always confused me
17:13:34 <johnsom> Yeah, me too, I end up missing some of those.
17:14:15 <johnsom> We are usually around in the channel in the mornings, so we also kind of have office hours covering those time slots.
17:14:28 <xgerman_> +1
17:15:14 <johnsom> Unless I hear more discussion/comments I think I will break the tie and work towards setting up the later time slot.
17:15:31 <tongl> +1 for latter
17:15:32 <jniesz> +1
17:15:42 <johnsom> I will also move the meeting to our channel to make it easier to get meeting bot
17:15:43 <longstaff> +1
17:16:09 <johnsom> Ok
17:16:27 <johnsom> #agreed Breaking the meeting time tie to select the later time.
17:16:46 <johnsom> I will do the leg work and send out an e-mail to the dev list
17:17:04 <johnsom> #topic Brief progress reports / bugs needing review
17:17:45 <johnsom> How are things going?  I know I took some time during the Zuul outage to do a bit of performance investigation in addition to reviews.
17:18:03 <jniesz> I am interested in updates regarding provider spec, as that is required for our flavor implementation
17:18:15 <johnsom> My lowly workstation under vmware workstation could do ~10,000 connections per second in HTTP mode.
17:18:53 <johnsom> It was CPU bound.  I think the NIC driver was a contributing factor as well as conntrack on the host.
17:19:36 <johnsom> longstaff Do you have an update on the provider spec?  I know you folks have started work on it as I have answered some questions.
17:19:51 <johnsom> It would be nice to get a draft posted
17:20:03 <longstaff> We are making good progress and plan to have the initiall draft posted later tomorrow
17:20:10 <johnsom> Nice
17:20:23 <johnsom> Any areas we should discuss?
17:21:08 <longstaff> Not at this point -- we're still reviewing a few things interanlly
17:21:14 <johnsom> Ok
17:21:51 <johnsom> FYI, I plan to pivot to working on the act/act patches.  I started that yesterday.
17:22:25 <johnsom> Any other progress updates / patches to discuss?
17:22:49 <johnsom> #topic Open Discussion
17:22:57 <johnsom> Ok, how about other topics for the day?
17:23:53 <johnsom> Well, ok. I will give you back some time for patch reviews.
17:24:12 <johnsom> Thanks folks
17:24:22 <johnsom> #endmeeting