16:00:10 <gthiemonge> #startmeeting Octavia
16:00:10 <opendevmeet> Meeting started Wed May 25 16:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is gthiemonge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <opendevmeet> The meeting name has been set to 'octavia'
16:00:15 <gthiemonge> Hi!
16:00:18 <johnsom> o/
16:00:21 <spencerharmon> hello!
16:00:21 <tweining> hi
16:00:53 <gthiemonge> #topic Announcements
16:01:01 <gthiemonge> * PTG October 2022
16:01:23 <gthiemonge> it was announced this week, the next PTG will be in-person!
16:01:43 <gthiemonge> October 17-20th in Columbus, Ohio
16:02:35 <gthiemonge> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-May/028601.html
16:03:09 <gthiemonge> any other announcemnts?
16:03:23 <gthiemonge> also:
16:03:27 <gthiemonge> #link https://openinfra.dev/ptg/
16:04:19 <gthiemonge> #topic Brief progress reports / bugs needing review
16:05:02 <gthiemonge> I was focused on downstream tasks, but I have proposed a fix for the graceful shutdown of the driver-agent:
16:05:10 <gthiemonge> #link https://review.opendev.org/c/openstack/octavia/+/843248
16:05:12 <tweining> it seems we've been lazy wrt. to reviews lately
16:06:27 <gthiemonge> there were 2 issues with the driver-agent: systemctl stop killed the driver-agent after a 5min timeout, and there were a lot of leaked processes after each restart of the service
16:10:22 <gthiemonge> #topic Open Discussion
16:10:30 <gthiemonge> anything else folkss?
16:10:46 <tweining> maybe a stupid question about the PTG: does in-person mean that only people who a physically there can participate in discussions? (ie. no virtual meetings anymore)
16:11:00 <spencerharmon> No changes on my end, but if there are any questions/comments on notifications patch, please lmk. :)
16:11:07 <spencerharmon> #link  https://review.opendev.org/c/openstack/octavia/+/831051
16:11:23 <gthiemonge> I think they will provide a solution for people in remote
16:11:27 <gthiemonge> they did it in the past
16:12:19 <gthiemonge> spencerharmon: yeah I still need to review it :/
16:12:35 <gthiemonge> I'm off for a few days but I'm going to take a look when I'm back
16:13:09 <gthiemonge> spencerharmon: maybe a quick question
16:13:20 <spencerharmon> Not a rush. Just hoping to get it in for next release.
16:13:51 <gthiemonge> spencerharmon: IIRC at the PTG we discuss adding ".begin" events (that would match the .end events)
16:13:59 <gthiemonge> "discussed"
16:14:51 <gthiemonge> do you plan to add it?
16:15:29 <spencerharmon> That's right. I don't need them in my use case. I'd be happy to add them, but I think it could be a long process of deciding exactly which notifications should exist. My hope is that this pattern is simple enough that folks wanting new notification types can add them easily in future patches. If you'd like those before merging, I'll be happy to create them.
16:17:11 <gthiemonge> ok, that's a fair point
16:17:31 <spencerharmon> I'd like these ones at a minimum for triggering a service we use to make recordsets in designate. I don't object to any other notification types, though. :)
16:18:07 <gthiemonge> yeah I see
16:18:18 <gthiemonge> I don't know if other folks have an opinion on it
16:18:26 <gthiemonge> anywys, I will review it
16:18:45 <tweining> #action gthiemonge review notifications change ;)
16:18:56 <spencerharmon> :D
16:19:36 <gthiemonge> is it on my TODO lsit now?
16:21:19 <gthiemonge> Ok, anything else?
16:22:02 <gthiemonge> ack
16:22:07 <gthiemonge> Thanks everyone!
16:22:08 <tweining> it would be cool if the bot would send a reminder in the next meeting
16:22:17 <gthiemonge> #endmeeting