19:59:49 <dendrobates> #startmeeting
19:59:50 <openstack> Meeting started Fri Sep  3 19:59:49 2010 UTC.  The chair is dendrobates. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:01 <dendrobates> #topic Blueprints
20:00:31 <dendrobates> Hi everyone. Thanks for coming
20:00:51 <dendrobates> We have extended the deadline for blueprint submission until Tuesday Sept 7th
20:01:02 <dendrobates> We will use today's time to discuss blueprints and answer any questions anyone might have.
20:01:08 <dendrobates> First the basics.
20:01:22 <dendrobates> The reason we need blueprints and specifications is because we need to plan for the release and track features
20:01:28 <dendrobates> In future releases:
20:01:35 <dendrobates> blueprints will be drafted before each summit
20:01:42 <dendrobates> the drafter will propose his blueprint for discussion at the summit.
20:01:52 <dendrobates> if approved the drafter will lead the discussion of the proposed feature at the summit.
20:01:59 <dendrobates> After the discussion a specification will be drafted
20:02:06 <dendrobates> the blueprint will then be used to track the state of the feature through the development cycle.
20:02:21 <dendrobates> You can see the list of blueprints created at https://blueprints.launchpad.net/openstack
20:02:32 <dendrobates> You can see the list of specifications on the wiki at http://wiki.openstack.org/CategorySpec
20:02:47 <dendrobates> Some of the blueprints link back to etherpad instead of the wiki.  Initially we thought his was ok, but they are not easily searchable or aggregatable.
20:02:58 <dendrobates> If you put your spec in etherpad, don't worry.  If you don;t get to it, I will move it to the wiki and update launchpad for you.
20:03:14 <dendrobates> We will continue to use etherpad at summits for collaborative editing.
20:03:30 <jaypipes> k
20:03:36 <dendrobates> Are there any specific questions about blueprints and specs?
20:03:51 <pjz> someone file a feature request for the wiki re: collaborative editing :)
20:04:13 <soren> dendrobates: Is the deadline also for specs?
20:04:17 <soren> dendrobates: Or just blueprints?
20:04:28 <soren> dendrobates: I.e. do we have to finish specs before Tuesday?
20:04:29 <dendrobates> soren: specs too
20:04:33 <soren> Gotcha.
20:04:41 * soren sharpens his pencil
20:05:05 <ewanmellor> Does the Xen spec have to say any more than "support Xen"?
20:05:10 <dendrobates> I don;t expect much, just a basic outline of what you intend to do
20:05:15 <ewanmellor> Because I don't think I'll get much further than that by Tuesday.
20:05:40 <dendrobates> ewanmellor: I understand.  We will fill in the rest as we are able
20:05:51 <ewanmellor> OK
20:06:12 <ewanmellor> Do we have any plans around HVM domains (i.e. Windows)?
20:06:30 <dendrobates> there is a template on the wiki for creating a spec.  http://wiki.openstack.org/SpecTemplate
20:06:34 <soren> ewanmellor: I have half a plan.
20:07:02 <ewanmellor> soren: Do you have a blueprint for your half-plan?  And is it planned for Austin?
20:07:06 <dendrobates> ewanmellor: not for this release, probably the next one.
20:07:21 <soren> ewanmellor: The plan only popped up in my head a few hours ago, so no.
20:07:47 <soren> ewanmellor: The Ubuntu guys got it working quite nicely, apparantly, with Eucalyptus. In a way that should be pretty easy to implement in Nova.
20:07:50 <jbryce> #link http://wiki.openstack.org/SpecTemplate - template on the wiki for creating a spec
20:08:10 <ewanmellor> The basic parameter setting for Xen is easy, once we know where the parameter comes from on the template side, and once we have boot-whole-disks.
20:08:24 <ewanmellor> If you have a doc on the API that Eucalyptus used, that would be great.
20:08:48 <ewanmellor> I was thinking of doing something horrible like kernel_id=hvm because I don't see any other place to put the parameter.
20:08:57 <soren> ewanmellor: The guys who did it for Eucalyptus promised he'd write some docs for it. I can't speak for when he'll have it done.
20:09:20 <dendrobates> ewanmellor: one thing that I have been asked, that you should include in your spec is scope.  is this just for xenserver, or is open source xen supported by your work?
20:09:21 <soren> ewanmellor: Let's take this discussion elsewhere :)
20:09:39 <vishy> ewanmellor: there is a branch for whole disk booting by justinsb that i think is just waiting on some formatting changes
20:09:52 <soren> ewanmellor: I'm happy to discuss it in #openstack, if you want.
20:10:05 <soren> ...so we can move on here.
20:10:25 <vishy> soren: sounds good, i'll participate there as well
20:10:26 <ewanmellor> dendrobates: Plain open-source Xen (Xen as seen in SUSE Linux, for example) is not covered.  The toolstack there is different.
20:10:34 <vishy> \win 3
20:10:38 <soren> That's the part I expect to work on.
20:10:46 <soren> I won't bother with
20:10:52 <soren> Xen server since Ewan seems on top of that.
20:11:05 <ewanmellor> dendrobates: The Xen Cloud Platform uses the same toolstack as XenServer, and is open-source (on Xen.org).
20:11:11 <dendrobates> That is what I thought, we should be able to get opensource xen support through libvirt, iiuc
20:11:17 <soren> dendrobates: Precisely.
20:12:20 <ewanmellor> XenAPI is the name that we use to distinguish the toolstack on XenServer (commercial) and Xen Cloud Platform (OSS), versus the toolstack in other Xen-based platforms.
20:12:29 <dendrobates> I will put any updates about blueprints on http://wiki.openstack.org/Blueprints
20:12:51 <ewanmellor> soren: Yes, will move the HVM discussion to #openstack.
20:13:02 <dendrobates> I assume most people saw my email about blueprint naming conventions today
20:13:28 <vishy> dendrobates: yes, i just changed all of the anso ones to start with austin-
20:13:41 <dendrobates> vishy: thanks
20:14:08 <dendrobates> We are trying to come up with a list of targeted features for Austin
20:14:19 <dendrobates> a lot pf people are asking for that.
20:14:55 <dendrobates> then we can get people to stop writing articles saying we are dropping an API, or not supporting Xen :)
20:15:21 <dendrobates> So...
20:15:41 <dendrobates> Is there anyone here that would like help creating a blueprint?
20:16:39 <littleidea> seems straight forward
20:17:32 <dendrobates> we will have very low standards for specs this release.  This is our first time and we will not be fascist.
20:17:45 <dendrobates> WE will work with anyone that submits one.
20:17:54 <dendrobates> and bring it up to snuff
20:18:26 <letterj> dendrobates: Were you going to start a blueprint on the testing/qa process?
20:18:43 <dendrobates> I am.
20:19:00 <soren> \o/
20:19:03 <dendrobates> I am working on acquiring some test equipment as well
20:19:09 <letterj> Do you want a separate one for Nova and Swift?
20:19:36 <dendrobates> letterj: probably, I hadn;t thought about it too much yet.
20:20:07 <dendrobates> I would love a testing genie to appear out of nowhere to hepl me.
20:20:10 <littleidea> dendrobates: How will OpenStack handle blueprints that are planned for Austin, but don't get completed?
20:20:49 <dendrobates> we will re target them to the next release and discuss whether to continue work or not at the summit
20:21:38 <dendrobates> littleidea: btw, thanks for the blog post.
20:21:56 <littleidea> dendrobates: my pleasure
20:22:36 <littleidea> What is 'Call for volunteers' on the agenda?
20:22:58 <dendrobates> my hint about testing was one of them
20:23:07 <littleidea> Call for testing genie
20:23:29 <dendrobates> I am not a tester, we will need test plans.
20:23:49 <dendrobates> We also need to start beefing up the developer docs.
20:24:00 <dendrobates> #topic call for volunteers.
20:24:08 <creiht> where's the beef?
20:24:28 <letterj> I will help with the Swift testing
20:25:03 <jbryce> the good news on the docs front is that annegentle is going to be full time as a tech writer starting next week. she's going to need help from others, but will be able to help us get organized
20:25:34 <dendrobates> jbryce: I am VERY excited to have her start
20:25:34 <littleidea> w00t, I plan to help annegentle
20:25:56 <annegentle> woo! that's the plan - community doc ftw
20:25:58 <dendrobates> soren: we could use better docs on using UML
20:26:17 <soren> dendrobates: Yup.
20:26:18 <dendrobates> can it be used on the rackspace cloud or ec2?
20:26:27 <dendrobates> I would love a guide for that.
20:26:41 <dendrobates> We need better docs to help new devs ramp up.
20:27:13 <dendrobates> So my call for volunteers, is mostly centered around docs and testing
20:27:32 <dendrobates> but we also will need to get a bug triaging team ramped up.
20:27:56 <dendrobates> Maybe I should start by documenting what we need.
20:28:35 <creiht> I've been pretty deep in the swift docs, so I imagine I would continue to help with that
20:28:52 <dendrobates> creiht: great
20:28:53 <littleidea> I'll volunteer to help with docs and cloudscaling will test between the freeze and release.
20:28:54 <xtoddx> dendrobates: yea, seeing a test plan will help.  we may be hitting some of that stuff already, and we just need to document and share the results
20:29:17 <soren> dendrobates: Yes, it can be use on the rackspace cloud.
20:29:19 <dendrobates> xtoddx: do you guys have a formal test plan at nebula?
20:29:50 <xtoddx> we have developers do due dilligance and pass it off to QA, and I don't know what the QA process is, exactly
20:30:10 <dendrobates> ok, we need someone to get openstack running in UML on the rackspace cloud and document it
20:30:24 <dendrobates> anyone from Rackspace want to take that.
20:30:32 <soren> I can do it.
20:30:44 <dendrobates> if anyone outside of RS want to do it, I'll get you free resources to do it.
20:30:49 <soren> I'm doing the work anyway, I just need to write it down somewhere.
20:31:08 <dendrobates> I would rather have someone that is not you do it\
20:31:12 <soren> Heheh :)
20:31:28 <dendrobates> there are things you assume, becuase you did the work
20:31:35 <soren> I can live with that. :)
20:32:00 <littleidea> dendrobates, soren: how much time do you think it would take?
20:32:43 <littleidea> or maybe if soren does a first pass documenting and then I can try to make it work and fill in anything with annegentle
20:33:19 <dendrobates> #action soren to take first pass at uml guide, assisted by littleidea and annegentle
20:33:30 <annegentle> sounds good
20:33:41 <dendrobates> weeeeeeeeee
20:34:12 <dendrobates> ok next topic
20:34:20 <dendrobates> #topic meeting time.
20:34:41 <dendrobates> in the email I sent I suggested a meeting time
20:35:20 <dendrobates> http://goo.gl/WHj2
20:35:37 <dendrobates> 20:00 UTC
20:36:02 <dendrobates> it is very difficult to find a time that will be good for everyone around the world.
20:36:25 <jbryce> dendrobates: would that be on tuesdays going forward? (the link says friday)
20:36:46 <dendrobates> god I suck
20:36:50 <dendrobates> I suggest our Tuesday release meeting be moved one hour later to 21:00
20:36:50 <dendrobates> UTC, which is 10:00 for most of Europe and 6:00 AM Wednesday morning in
20:36:50 <dendrobates> Japan.
20:37:02 <dendrobates> That is my suggestion.
20:37:15 <dendrobates> I pasted in the wrong time and link
20:37:17 <dendrobates> sorry
20:37:36 <littleidea> so next tuesday, 21:00 UTC
20:37:41 <dendrobates> yes.
20:37:42 <vishy> dendro: that is fine with me
20:37:50 <ewanmellor> dendrobates: Can we have a procedure for getting stuff discussed if you can't make the release meeting?  I will have devs in Bangalore working on this, and that's 1.30am for them.
20:37:54 <dendrobates> It is pretty late in europe and early in asia
20:39:00 <soren> 2100 UTC is 11 PM for most of Europe, really.
20:39:05 <soren> ...which is ok.
20:39:07 <soren> I'm just saying.
20:39:14 <soren> Well, until DST passes.
20:39:15 <littleidea> timezones aren't going away anytime soon
20:39:15 <dendrobates> yes, you can add it to the agenda noting that you cannot attend we will try to discuss it post the minutes, you can then  use the mailing list to continue the discussion
20:39:22 <dendrobates> is that satisfactory
20:39:33 <dendrobates> or, we can rotate the meeting times
20:39:48 <ewanmellor> dendrobates: That procedure sounds fine.
20:39:55 <dendrobates> ok
20:40:16 <ewanmellor> dendrobates: If you had two meetings, one in the US morning, and one in the US afternoon/evening, do you manage to cover everyone?
20:41:11 <dendrobates> ewanmellor I think so.  do you mean each week have 2 meetings?
20:41:18 <ewanmellor> Not that I'm trying to double your workload ;-)
20:41:44 <ewanmellor> Yes, that's what I meant.  I'm fine with my Bangalore team missing out, but it would be good to be able to include the people from Japan.
20:41:59 <dendrobates> I don't mind the long day.  my conrecn is that the 2 groups will never connect.
20:42:35 <ewanmellor> At 6am Japanese time, they might never connect anyway.
20:42:37 <dendrobates> yeah I'm pretty sure none of them got up at 6am on Sat to come.
20:42:47 <dendrobates> er 5am today
20:43:13 <littleidea> I think two meetings gets really awkward to manage and gets phased out.
20:43:37 <dendrobates> can we keep next weeks at 21:00 utc and start a mailing list discussion on meeting times?
20:44:02 <soren> So we'll have another meeting two working days from now? I'm cool with it, I'm just checking.
20:44:17 <dendrobates> yes
20:44:27 <ewanmellor> dendrobates: Fine by me.  There's no way that you can get everyone in one meeting.  You may as well use your Benevolent Dictator status here.
20:44:40 <dendrobates> done.
20:44:52 <dendrobates> I will post the next meeting on the wiki.
20:44:52 <ewanmellor> We did, after all, put devs in Bangalore precisely _because_ we wanted round-the-clock work!
20:45:54 <dendrobates> I'm going to be around for the next few hours to help people with blueprints if any one needs help.
20:46:01 <littleidea> is there something else to decide?
20:46:11 <littleidea> dendrobates: cool, might hit you up then
20:46:29 <dendrobates> Thanks for coming everyone.
20:46:52 <dendrobates> #endmeeting