21:05:12 <dendrobates> #startmeeting
21:05:13 <openstack> Meeting started Tue Sep 7 21:05:12 2010 UTC. The chair is dendrobates. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:05:21 <dendrobates> Thank you for coming everyone.
21:05:35 <dendrobates> We had a meeting only a few days ago, ut I wanted to have this one, since we extended the blueprint deadline. The agenda is on the wiki, I encourage other to add items if there are things they want to discuss.
21:05:45 <dendrobates> #link http://wiki.openstack.org/Meetings
21:05:56 <dendrobates> #topic blueprints
21:06:04 <dendrobates> The current list of Blueprints targeted for Austin are here:
21:06:13 <dendrobates> #link https://blueprints.edge.launchpad.net/nova/austin
21:06:34 <dendrobates> This does not include swift, but they only have a couple.
21:06:59 <dendrobates> If your blueprint is not listed but you think it should be, please contact me ASAP
21:07:19 <dendrobates> There is one blueprint that is suggesting some major networking changes: Extend the network control API
21:07:29 <dendrobates> #link https://blueprints.edge.launchpad.net/nova/+spec/austin-extend-network-model
21:07:46 <adjohn> That is from over here and @romain_lenglet
21:07:52 <dendrobates> I've asked for feedback from the openstack-core team.
21:08:07 <dendrobates> adjohn: do you guys have any code yet?
21:08:14 <littleidea> dendrobates: I added this one https://blueprints.edge.launchpad.net/nova/+spec/austin-stats-utilization
21:08:57 <dendrobates> littleidea: must have just missed it. I'll look at it.
21:09:05 <adjohn> @dendrobates coming soon
21:09:32 <littleidea> I just added it. I was trying to make a spec, but instead I messed up the wiki.
21:09:45 <dendrobates> adjohn: have you seen the other networking changes that vishy made?
21:10:04 <dendrobates> adjohn: I want to be sure you are working with the newest code.
21:11:04 <dendrobates> Does anyone have any questions about austin-extend-network-model, or should we move it to the mailing list?
21:11:06 <romain_lenglet> dendrobates: ok, we'll start from this branch
21:11:31 <dendrobates> adjohn: I recommend pushing code ASAP, even if is is just a skeleton
21:11:45 <dendrobates> that will help others get an idea of your changes.
21:11:55 <adjohn> dendrobates: got it
21:12:30 <dendrobates> soren: did you see the question abour your austin-xen blueprint?
21:12:48 <soren> dendrobates: I didn't, no.
21:12:59 <dendrobates> you added ewanmellor's branches
21:13:11 <soren> I.... did?
21:13:16 <dendrobates> so I was not sure if it was for xenserver or all xen
21:13:31 <dendrobates> well they were there, unless I am crazy
21:13:33 <soren> I really don't think I did.
21:13:38 <soren> Ewan must have done that himself.
21:13:44 <ewanmellor> Nope!
21:13:48 <ewanmellor> I was confused too ;-)
21:13:49 <soren> O_o
21:14:10 <ewanmellor> Anyway, I made an austin-xenapi, just to avoid any further confusion.
21:14:20 <dendrobates> so you meant that to be opensourc xen, right?
21:14:27 <ewanmellor> We can use austin-xen for non-XenServer Xen support, if that's what you intend.
21:14:31 <soren> dendrobates: Me? Yes.
21:14:54 <dendrobates> ok, I'll remove the branches from it.
21:14:55 <ewanmellor> soren: Do you intend to support other Xen's through libvirt, or some other means?
21:15:22 <soren> ewanmellor: libvirt.
21:15:30 <soren> That's how I roll.
21:15:56 <ewanmellor> OK, so should we call this blueprint austin-xen-libvirt or something, to distinguish it from austin-xenapi?
21:16:19 <dendrobates> I'll fix it up
21:16:22 <dendrobates> soren: I deferred your puppet blueprint
21:16:48 <dendrobates> I don't believe there is any way in hell you could finish every bp you submitted
21:16:50 <soren> dendrobates: I can tell.
21:16:55 <soren> dendrobates: I've got a plan :)
21:17:01 <soren> dendrobates: But no worries.
21:17:06 <soren> dendrobates: I'll do it while you're not looking.
21:17:08 <ewanmellor> soren: Is there anything even to do? Doesn't it "just work" if you use libvirt today?
21:17:09 <soren> :p
21:17:27 <soren> ewanmellor: It's really meant as a "make sure that it already works" sort of blueprint.
21:17:33 <dendrobates> ok, if you have a plan fine, but the other things are more critical, and I know you and your "plans" pretty well.
21:17:35 <dendrobates> :)
21:17:49 <soren> ewanmellor: I do think, though, that it needs a tiny, tiny bit of template tweaking.
21:18:06 <soren> dendrobates: Gotcha.
21:18:07 <ewanmellor> soren: OK, that makes sense.
21:18:38 <dendrobates> ewanmellor: all the work may be in ubuntu's version of libvirt
21:18:52 <soren> Well...
21:18:59 <soren> Ubuntu doesn't even have a dom0.
21:19:08 <soren> (Clever as they are)
21:19:12 <soren> :)
21:19:23 <dendrobates> soren: true, but that doesn;t stop rackspace from using it with xen
21:19:31 <soren> But yeah, there might be libvirt work involved. That's fine.
21:19:41 <soren> dendrobates: Good point.
21:19:46 <dendrobates> soren: zul has agreed to hepl if you need it.
21:19:58 * soren hugs zul
21:20:23 <dendrobates> any other blueprint questions or discussions people want to have?
21:20:36 <dendrobates> 3
21:20:36 <ewanmellor> What's the plan with Redis?
21:20:43 <ewanmellor> Will we still have Redis in Austin?
21:20:54 <gundlach> afaik, yes -- i rely on it to get the new API working
21:20:59 <dendrobates> afaik, yes
21:21:01 <xtoddx> ~vishvananda/nova/orm_deux should be live
21:21:05 <xtoddx> vishy, care to chime in?
21:21:05 <gundlach> and don't plan on figuring anything else out by october :)
21:21:37 <dendrobates> yeah, but for all practical purposes, Redis will still be required this release
21:21:57 <dendrobates> right vishy?
21:21:58 <ewanmellor> Do we expect to remove it soon?
21:22:00 * soren didn't realise the orm_deux branch was a Redisectomy?
21:22:14 <dendrobates> it is not, it is an abstraction
21:22:26 <soren> Ok, that's what I thought.
21:22:33 <xtoddx> right, but no redis backend has been written yet, only sqlalchemy
21:23:12 <xtoddx> gundlach will have to re-jigger all the stuff that used nova.compute.model to use nova.db, regardless
21:23:38 <dendrobates> even if it hits, I don;t think everything can be reworked in time, Austin+1 i'd say.
21:23:57 <xtoddx> what day is the freeze?
21:24:04 <dendrobates> 9/30/10
21:24:06 <soren> Sep 30.
21:24:23 * soren will never get used to middle-endian dates.
21:24:38 <dendrobates> 30/9/10
21:24:42 <gundlach> 10/9/30
21:24:46 <soren> 2010-09-30.
21:24:49 <soren> Deal.
21:24:52 <ewanmellor> What's the name of Austin + 1?
21:24:52 <dendrobates> ha
21:25:08 <dendrobates> ewanmellor: probably san antonio
21:25:16 <ewanmellor> Is Austin going to be OpenStack 1.0?
21:25:22 * soren was hoping for something beginning with 'b'
21:25:32 <vishy> sorry guys was afk
21:25:33 <eday> xtoddx, vishy: don't you plan on having the orm branch land soon? if so, that means it's going to be austin
21:25:37 <gundlach> dendrobates: oh, come, we *surely* must do alphabetical :)
21:25:46 <dendrobates> gundlach: sorry out of my hands
21:25:51 <vishy> would be great if the orm branch landed soon
21:25:56 <gundlach> http://en.wikipedia.org/wiki/List_of_cities_in_Texas
21:26:02 <soren> ewanmellor: Probably Nova 1.0, but Swift already had a 1.0.
21:26:08 <zul> dudes name it after south park characters :)
21:26:14 <vishy> and with that branch the only thing requiring redis is fake ldap
21:26:37 <eday> vishy: ok, so for most purposes, redis will be gone in austin
21:26:37 <xtoddx> Bangs, TX
21:26:54 <ewanmellor> xtoddx: I bet she does!
21:26:54 <dendrobates> vishy: but there are other branches out there that are using redis, like gundlach's
21:26:56 <gundlach> fyi i'm using the central redis store to map RS API image ids to Glance image URLs
21:27:05 <vishy> eday: yes, if someone wants to rewrite fakelap using mysql then we could ditch it completely
21:27:19 <gundlach> if someone else can lend a hand turning that into a local store for the API cluster to use, i'm fine with that
21:27:32 <vishy> dedrobates: I wasn't aware that gundlach was using redis
21:27:50 <gundlach> vishy: i kind of fell into it when i realized we'd need a persistent mapping for IDs and redis was lying around.
21:27:53 <dendrobates> vishy: when do you plan on this being merged?
21:27:54 <eday> I think we need to land the ORM branch sooner than later, before merge conflicts become even more of a nightmare :)
21:28:26 <xtoddx> vish, can we work on landing orm this week?
21:28:31 <vishy> dendrobates: as soon as possible...there will be some inevitable cleanup, i think i may have broken xen a bit
21:28:56 <ewanmellor> dendrobates: I
21:29:11 <dendrobates> ewanmellor: you
21:29:32 <ewanmellor> dendrobates: (Sorry about that) It make sense to line up version numbers, doesn't it? Nova and Swift 1.1?
21:29:45 <soren> ewanmellor: I thought about that, but..
21:29:47 <xtoddx> ewanmellor: #agree
21:30:24 <soren> ewanmellor: It's not unimaginable that other thigsn will come under the OpenSTack umbrella in the future, and they might already have a versioning scheme in place that conflicts.
21:30:35 <ttx> naming scheme kinda forces not to have a development summit twice in the same town ?
21:30:41 <soren> ewanmellor: So we might be able to do it now, but at some point, it's going to fall apart (or so I hypethicise)
21:30:45 <dendrobates> ewanmellor: possibly, but I don't want to put a 1.0 release on nova yet.
21:30:46 <soren> hypothecise.
21:30:56 <soren> Or whichever way it's meant to be spelled.
21:31:02 <dendrobates> ttx: that is the goal
21:31:15 <soren> ttx: Sounds familiar? :)
21:31:18 <vishy> gundlach: I can help you move stuff over to orm...it is pretty straightforward
21:31:19 <dendrobates> ok, back on topic
21:31:30 <soren> dendrobates: You're not shooting for Nova 1.0?
21:31:34 <ttx> soren: now you must just pick towns alphabetically :P
21:31:37 <vishy> i thought it was just alph by town
21:31:39 <dendrobates> any more blueprint questions?
21:31:47 <vishy> boston release next?
21:31:51 <gundlach> vishy: ty, i'll talk w/ you offline
21:32:28 <soren> vishy: Bahamas City.
21:32:29 <dendrobates> San Antonio is in Bexar county if you want to cheat a bit.
21:32:46 <dendrobates> #topic Release
21:33:00 <dendrobates> are there any questions about the Austin release?
21:33:05 <soren> Yes.
21:33:07 <soren>
21:31 < soren> dendrobates: You're not shooting for Nova 1.0?
21:33:29 <dendrobates> soren: no
21:33:35 <soren> Hm.
21:33:36 <soren> Ok.
21:34:27 <ewanmellor> What is the license on OpenStack documentation?
21:34:42 <ewanmellor> Will we (Citrix) be able to repurpose OpenStack docs, for example?
21:34:56 <dendrobates> I will be working to get everything documented with our new community tech writer/leader annegentle
21:35:07 <dendrobates> creative commons probably
21:35:12 <dendrobates> will that work?
21:35:36 <ewanmellor> I was looking at the Swift Deployment Guide and thinking how good it was and how I'd just want to cut huge sections into a page with a Citrix logo at the top, and ship it ;-)
21:35:42 <eday> dendrobates: well, there are different CC versions, some allowing for commercial uses
21:35:43 <dendrobates> I havent asked anyone in RS legal yet, but we've already used CC for other things.
21:35:52 <ewanmellor> Would that be morally acceptable to the community?
21:36:02 <dendrobates> I would not want to restrict usage in anyway.
21:36:05 <notmyname> dendrobates: how does that fit with python docs generated from the code which is apache?
21:36:11 <dendrobates> hmm
21:36:18 <dendrobates> damn good question
21:36:35 <dendrobates> I don't know ianal
21:37:09 <dendrobates> #action find out what license to use for docs]
21:37:10 <eday> could just use apache lic for docs too, keep it simple (whether it's code-generated or not)
21:37:31 <xtoddx> by-sa would maybe be acceptable?
21:37:32 <dendrobates> #action find out how APL2 affects docs in code
21:38:01 <dendrobates> that might be best, but I am not ready to commit without more knowledge
21:38:21 <dendrobates> Anne isn't with us today or she might know
21:38:30 <dendrobates> I will find out
21:38:44 <dendrobates> are there any questions about the Austin release?
21:38:47 <ewanmellor> #link http://www.apache.org/dev/apply-license.html
21:38:58 <ewanmellor> ASF policy is to apply the Apache license to docs, too.
21:39:13 <dendrobates> ewanmellor: thanks
21:39:29 <ewanmellor> (Not that we have to do the same, just that they've obviously decided that it's legally sensible.)
21:39:50 <dendrobates> it does sound easy, I'll take it up with the lawyers
21:40:22 <dendrobates> #topic OpenStack-Clients project group
21:40:41 <dendrobates> The LP admins created a project group for the clients. I will be populating it with the client projects and teams asap
21:41:25 <dendrobates> it let's them control their own group without our interference, the clients are pretty separate anyway.
21:41:44 <dendrobates> questions?
21:41:52 <notmyname> these are things like the mobile apps and CP?
21:41:59 <dendrobates> yep
21:42:19 <dendrobates> mostly written by mike mayo
21:42:33 <xtoddx> does clients mean libraries for other languages, or just end-user applications?
21:42:36 <dendrobates> i any thing was server side we would still keep it in openstack
21:42:43 <dendrobates> end user apps
21:42:57 <dendrobates> although....
21:43:00 <xtoddx> is there a place for client libraries for ruby, java, etc to grow up at?\
21:43:05 <notmyname> not sure if this is the time or place, but will there be any level of effort to include 3rd party devs (like CyberDuck or wordpress extensions [in the case of swift])?
21:43:08 <littleidea> what about projects to implement different lang bindings?
21:43:25 <gundlach> xtoddx: the javascript library already exists, as part of the GroundControl browser extension
21:44:07 <dendrobates> We could put them all under clients, or keep them with openstack if they are tied to our release cycle.
21:44:25 <xtoddx> its a sign of maturity to have many language bindings, so i think we need to give them a place to exist and be loved
21:44:30 <dendrobates> or they could not have anything to do with us officially
21:44:37 <xtoddx> tying them to our release cycle sounds smart
21:44:53 <notmyname> they may be tied to a release cycle (new features, etc), but they probably need a faster release cycle than the main projects
21:44:56 <xtoddx> with tiny-number upgrades for any changes specific to their code
21:45:09 <littleidea> #agreed love <3
21:45:12 <dendrobates> then let's do that until someone bitches and reconsider it then.
21:45:17 <xtoddx> #agreed
21:45:22 <notmyname> do that == ??
21:45:32 <notmyname> keep in openstack?
21:45:40 <dendrobates> what xtoddx said: keep them with openstack\
21:46:32 <notmyname> is that openstack/swift-python, openstack/swift-php or openstack/swift/<language>
21:46:52 <notmyname> or even openstack/bindings/<language>
21:46:53 <dendrobates> under each project
21:47:07 <dendrobates> so you only dl what you actually need
21:47:23 <dendrobates> I would assume different devs
21:48:04 <dendrobates> let's take this to the mailing list.
21:48:25 <dendrobates> but we've resolved to keep them in openstack
21:48:36 <dendrobates> #topic
21:48:43 <dendrobates> #topic meeting time
21:49:05 <dendrobates> I was thinking about rotating the times
21:49:37 <dendrobates> one week we would be very lat for our friends in Japan, and the next early for Europe
21:50:09 <dendrobates> I can see no way to please everyone all the time.
21:50:16 <littleidea> I think rotating times tends to dissipate energy.
21:50:35 <dendrobates> I feel that way to, but have no better suggestions
21:50:56 <dendrobates> how does this time work for those in Japan?
21:51:04 <dendrobates> Europe?
21:51:04 <romain_lenglet> it's ok
21:51:07 <adjohn> 6am is a bit early for us I think, and the other guys like NTT may not be able to make it that early it seems?
21:51:20 <ddumitriu> it's not terrible, but i'm an early riser
21:51:28 <littleidea> maybe it's always in a certain time the 1st week, a different time 2nd... and when there are more than 4 in a month we double up on one
21:51:30 <ddumitriu> most of the Japanese are not
21:51:37 <soren> dendrobates: It's kinda late, but manageable.
21:51:46 <littleidea> but something that has a predictable cadence
21:52:06 <notmyname> meet every 170 hours? (168 hours in a week)
21:52:21 * soren slaps notmyname
21:52:21 <dendrobates> littleidea: so tie the time to the week of the month
21:52:32 <littleidea> dendrobates: just an idea
21:52:54 <littleidea> looking for a compromise that keeps some regularity
21:53:26 <adjohn> We can ask the others we know in the Japan community about the meeting times, but I guess for the 3 of us from Japan here now the current time is ok
21:54:06 <dendrobates> I'll send a suggestion to the ML for a perm rotation, but we need to schedule next weeks.
21:54:10 <soren> It's worth noting that if we find a time that is on the edge of being acceptable to someone, that will probably require us to move it every time /anyone/ goes to/from DST.
21:54:20 <dendrobates> I think Tuesday is a good day
21:54:35 <dendrobates> any disagreement
21:54:42 <soren> Nope. Tuesday is good.
21:54:45 <dendrobates> or wednesday in Japan
21:54:49 <adjohn> fine here
21:55:21 <dendrobates> same time next week or 1 hour later?
21:55:56 <soren> http://www.timeanddate.com/worldclock/meetingtime.html?day=7&month=9&year=2010&p1=195&p2=248&p3=64&p4=137
21:56:17 <dendrobates> for some reason it is easier for me to ask to stay up till 1am than to expect people up at 6am
21:56:18 <ewanmellor> The Englishman here votes for no later than the current time!
21:56:40 <dendrobates> That's one vote
21:56:46 <dendrobates> anyone else.
21:56:55 <dendrobates> I prefer this time as well
21:56:56 <soren> I prefer now over one hour later.
21:57:04 <adjohn> I prefer this time rather than one our later
21:57:06 <soren> That would put it at midnight for me.
21:57:19 <dendrobates> adjohn: really! wow
21:57:21 <romain_lenglet> +1 for keeping this time
21:57:22 <soren> ...and I have to get up early Wednesday.
21:57:27 <dendrobates> ok done
21:57:42 <dendrobates> same time next week
21:57:53 <adjohn> dendrobates: one our later means i have to commute to work before the meeting, or some of us will show up late as they have a long commute after the meeting
21:58:08 <adjohn> s/our/hour
21:58:12 <dendrobates> send anything else to the ml or #openstack
21:58:27 <dendrobates> adjohn: I forgot, some people go to work.
21:58:41 <dendrobates> I just walk downstairs
21:58:47 <dendrobates> #endmeeting