21:02:14 <dendrobates> #startmeeting
21:02:15 <openstack> Meeting started Tue Sep 21 21:02:14 2010 UTC. The chair is dendrobates. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:24 <dendrobates> The agenda is here:
21:02:31 <dendrobates> #link http://wiki.openstack.org/Meetings
21:02:54 <dendrobates> sirp1: just in time.
21:02:58 <dendrobates> #topic Glance Status
21:03:29 <sirp1> so, ill start by giving a quick background in case you guys aren't familar
21:04:04 <sirp1> glance is the overarching project for two components: the a) caching image proxy (nicknamed Teller) and b) the image registry (nicknamed Parallax)
21:04:31 <soren> o/
21:05:36 <sirp1> right now not much exists for either; a minimal framework to get started was just merged in (still needs gundlach's recomendations taken into account)
21:05:50 <sirp1> and _0x44 is working on the Swift Backend
21:06:41 <jaypipes> sirp1: is it reasonable to expect Glance for Austin? Could additional resources be useful to you?
21:06:59 <sirp1> no work started yet on parallax, but for the austin release that should be pretty trivial, we just need to expose a registry (possibly backed using the ORM merge from nova) and exposed through a wsgi we service
21:07:14 <dendrobates> FF == 9 days
21:07:30 <dendrobates> for the record.
21:07:41 <sirp1> jaypipes: additional resources would be much appreciated as im pretty swamped on RS internal stuff right now (and for the forseesable future)
21:08:39 <jaypipes> sirp1: I'm about 70% complete on the NoSQL driver for the new datastore backend. Should be finished tomorrow. I can help.
21:09:04 <dendrobates> jaypipes: awesome.
21:09:06 <sirp1> jaypipes: excellent
21:09:21 <dendrobates> I know that chmouel was looking for something as well.
21:09:27 <dendrobates> maybe he can help.
21:09:36 <jaypipes> sirp1: I'll work with you offline on some reasonable blueprints to get done by Austin for Glance.
21:09:41 <sirp1> the goals of glance for austin were pretty modest, so i think we could still get it in, but more resources will be needed
21:09:47 <jaypipes> k
21:09:56 <sirp1> jaypipes: good deal
21:10:13 <sirp1> #done glance update
21:10:16 <dendrobates> ok, I think that covers that
21:10:28 <dendrobates> #topic Blueprint status
21:10:39 <dendrobates> I would like each person who is assigned a blueprint to give us a quick update.
21:10:45 <dendrobates> We will be doing this in every future release meeting.
21:10:55 <dendrobates> The object is to know status, not put you on the spot.
21:11:00 <gundlach> link to blueprint list?
21:11:01 <dendrobates> If the status has not changed since the last meeting feel free just to say, "no change"
21:11:18 <pvo> https://blueprints.launchpad.net/nova ?
21:11:20 <dendrobates> Here is the list:
21:11:29 <dendrobates> #link https://blueprints.launchpad.net/nova/austin
21:11:41 <pvo> ah, that one is better
21:11:49 <creiht> dendrobates: it is likely that we will have to drop large file support for the austin release in swift
21:11:54 <dendrobates> In the future I will make sure to include swift.
21:11:58 <jaypipes> #info jaypipes 70% complete on https://blueprints.launchpad.net/nova/+spec/austin-nosql-datastore-adapter
21:11:59 <soren> Hm... It seems completed blueprints vanish off that list.
21:12:00 <gundlach> i can go next, since openstack-api is second. it's assigned to todd but i think i kind of took it over
21:12:12 <dendrobates> creiht: ok, good to know.
21:12:30 <creiht> dendrobates: otherwise everything else on swift is on track
21:12:35 <gundlach> #info getting worried about api. getting EC2 off of Tornado took way longer than expected, mostly due to merge headaches.
21:13:01 <gundlach> it's off now, but all of Servers remains to be done, and cerberus has been too swamped w/ RS stuff to attack that yet
21:13:16 <gundlach> if anybody (eday?) would like to split Servers up w/ me & cerberus it would be great
21:13:28 <dendrobates> eday: how about it?
21:13:43 <_cerberus_> There is *some* progress on the servers API, but not as much as I'd like.
21:13:46 * gundlach wasn't clear: "all of Servers remains" means that the RS API /servers endpoint doesn't exist yet
21:13:53 <eday> dendrobates, gundlach: Yeah, I'm helping with some API cleanup right now, and can help with those other bits
21:14:16 <soren> I may be able to grab some of it. I've never done REST API's before, though.
21:14:29 <dendrobates> gundlach: with the extra help, is API at risk?
21:14:49 <gundlach> soren, the frontend can be taken care of -- it's the mapping of e.g. reboot() function to whatever the backned bits of Nova are required to actually reboot -- that kind of thing
21:15:07 <gundlach> dendrobates: lemme pass that to cerberus, since he has a better feeling for the scope of servers. cerberus?
21:15:12 <dendrobates> pvo: any chance of freeing up RS resources to push toward FF?
21:15:13 <gundlach> you had mentioned changes-since maybe needing to drop?
21:15:25 <soren> gundlach: That part I feel pretty confident about.
21:15:33 <pvo> dendrobates: I'm working on that right now
21:15:50 <gundlach> soren: great, then potentially let's add you to the 4-way meeting where cerberus eday you and i split up tasks :)
21:15:54 <eday> gundlach, soren, _cerberus_: I'm guessing between the four of us we can crank it out pretty quickly
21:15:55 <dendrobates> cererus isn't here
21:16:05 <dendrobates> there he is
21:16:05 <_cerberus_> eday: Most likely
21:16:33 <gundlach> _cerberus_: with the extra help, is the API at risk in your opinion? anything you think will still need to be dropped?
21:16:35 <dendrobates> soren: what is the status of your 25 other blueprints, do you have time?
21:16:47 <_cerberus_> I don't believe anything is necessarily at risk, no
21:16:48 <soren> dendrobates: Done.
21:16:53 <soren> dendrobates: So yes.
21:16:54 <soren> :)
21:16:56 <_cerberus_> We've made good progress so far
21:17:06 <_cerberus_> Extra help is always appreciated
21:17:08 <gundlach> cool. i'll email you/soren/eday to start talking about splitting up tasks
21:17:13 <soren> dendrobates: Well, the last three are still awaiting review, but otherwise done.
21:17:27 <dendrobates> are any of the anso guys here?
21:17:28 <soren> dendrobates: Last three branches, that is. Not blueprints, obviously.
21:17:50 <jaypipes> OK, so some action items out of this? grr, that sounds so very Deloitte and Touche.
21:18:09 <jaypipes> dendrobates: no, I pinged vishy to join us on the main chan.
21:18:19 <dendrobates> #action soren to be added to gundlach's 4way
21:18:30 <jaypipes> hmm, that doesn't sounds quite right ;)
21:18:37 <soren> It doesn't, no.
21:18:45 * gundlach pointedly ignores the innuendo
21:18:45 <soren> And now it's recorded for eternity.
21:19:01 <jaypipes> #action jaypipes, sirp1 tackle blueprints for Austin's Glance. Split up between 2.
21:19:12 <soren> Oh, well. I'm sure there's worse stuff out there about me.
21:19:15 <gundlach> #action gundlach to FU w/ cerberus eday soren to get tasks split up
21:19:56 <dendrobates> the anso guys sent some update privately that I have not had time to summarize
21:20:23 <dendrobates> due to an extended debate with swardley on twitter :(
21:20:44 <dendrobates> I will send, or get them to send updates to the list.
21:20:55 <dendrobates> in the future, if you cannot attend, please send me a quick status by email
21:20:56 <jaypipes> dendrobates: be a lover, not a fighter. ;)
21:21:13 <dendrobates> Also, it would be very helpful if you would go into launchpad and update the status, before each meeting, if necessary
21:21:36 <dendrobates> jaypipes: it is very difficult to argue in 140 char
21:21:54 <jaypipes> dendrobates: :)
21:21:57 <dendrobates> #topic Bexar Design Summit prep
21:22:06 <dendrobates> At the upcoming design summit we will be discussing and specing out work for two 3 month releases.
21:22:24 <jaypipes> dendrobates: I sent out a reminder to update blueprints/bugs to the ML. Would be best if you did that on Mondays I think.
21:22:25 <dendrobates> I need everyone to be thinking of what they want in openstack in ~April 2011.
21:22:50 <dendrobates> jaypipes: I know. It's on my list
21:22:59 <dendrobates> We need blueprints created for each feature so we can schedule sessions to discuss them.
21:22:59 <jaypipes> sparkycollier, spectorclan: any update on summit stuff?
21:23:10 <dendrobates> We are trying to document the process.
21:23:16 <dendrobates> #link http://wiki.openstack.org/Process
21:23:24 <dendrobates> jaypipes: ther will be soon
21:23:26 <jaypipes> dendrobates: I'm happy to put blueprints together.
21:23:39 <spectorclan> jaypipes: i am meeting with folks on Thursday to finalize much of plan external to agenda
21:23:49 <dendrobates> We will be doing this summit differently than the first one. The sessions will be smaller and more technical.
21:23:56 <jaypipes> spectorclan: ++ cool.
21:23:59 <dendrobates> We will have multiple sessions running simultaneously.
21:24:13 <dendrobates> So you will need to pick the ones that interest you. Launchpad will let you register interest in a blueprint or make yourself mandatory.
21:24:13 <jaypipes> #agreed
21:24:15 <spectorclan> jaypipes: party just for developers Thursday night is a go!
21:24:21 <jaypipes> spectorclan: :)
21:24:24 <soren> :(
21:24:30 * soren leaves Thursday morning
21:24:33 <dendrobates> It will be very helpful if you make use of this, it will help us schedule the sessions.
21:24:44 <spectorclan> soren: we do have a party first night for everyone
21:24:45 <jaypipes> soren: then just get drunk on the plane. :P
21:24:48 <dendrobates> soren: has too many weddings to attend
21:24:58 <soren> I'll get drunk Wednesday night. You can all watch.
21:25:03 <dendrobates> We need to have a basic idea of what we will be producing over the next six months.
21:25:14 <zul> soren: been there done that
21:25:14 <dendrobates> It is not necessary to target a specific release yet, we can prioritize the list after the summit discussions.
21:25:21 <soren> zul: :)
21:25:27 <dendrobates> Blueprints are not limited to features, we can have tracks to discuss community, governance, documentation, process.
21:25:43 <dendrobates> Basically anything we need to talk about as a group.
21:25:52 <jaypipes> ++
21:25:56 <dendrobates> any questions?
21:26:31 <dendrobates> ok
21:26:43 <dendrobates> this may be our first quick meeting
21:26:46 <vishy> hey all: sorry i'm late
21:26:57 <dendrobates> np
21:27:03 <vishy> we had a mandatory building emergency meeting
21:27:08 <jaypipes> vishy: no worries.
21:27:27 <dendrobates> can you give us updates on the anso blueprints?
21:27:31 <jaypipes> vishy: I thought you guys lived on the international space station? :P
21:27:52 <dendrobates> #topic Blueprint II
21:28:10 <dendrobates> or the ones you are working on, at least?
21:28:31 <dendrobates> are any at risk for not making feature freeze?
21:29:21 <dendrobates> vishy: ?
21:29:38 <pvo> reevacuated
21:30:07 <dendrobates> so vishy is only listed on the orm refactor which is done.
21:30:21 <dendrobates> We'll move on.
21:30:35 <dendrobates> #topic Feature freeze
21:30:42 <pvo> dendrobates: did you see anything about the other anso blueprints?
21:30:56 <pvo> I only saw rescue, guest agent and ajaxterm
21:31:05 <vishy> dendrobates: i can update
21:31:08 <dendrobates> there were some emails today
21:31:17 <pvo> I didn't know if you saw anything for migrations and snapshots
21:31:19 <dendrobates> #topic Blueprint II
21:31:19 <vishy> anotherjesse is nearby
21:31:39 <vishy> nothing pushed for migrations and snapshotting yet
21:31:40 <dendrobates> pvo I did, but did not read completely yet.
21:32:01 <pvo> thannks vishy
21:32:41 <dendrobates> vishy: does it look like migrations and snapshotting will make it by FF?
21:32:56 <vishy> dendrobates: yes that is the plan
21:33:28 <dendrobates> ok
21:33:33 <dendrobates> #topic Feature freeze
21:33:44 <dendrobates> Feature freeze is coming up quick. Just 9 days away and counting.
21:33:54 <dendrobates> Please don't wait to merge your code until then. The more time we have for review the better.
21:34:23 <dendrobates> By next Tuesday, if I haven't seen any merge request, do not be surprised to find your blueprint retargeted to the next release.
21:34:23 <gundlach> could you define feature freeze for me again vs post-freeze-bug-fixing?
21:34:32 <dendrobates> yes
21:34:50 <dendrobates> the features have to be merged, but can be buggy
21:34:54 <gundlach> e.g. if some aspect of servers is stubbed out but not complete, does that get axed?
21:35:00 <dendrobates> bugs will be fixed and testing will be done
21:35:04 <dendrobates> after FF
21:35:19 <dendrobates> we will have a final freeze close to the release
21:35:21 <gundlach> ok so in good faith we should assume FF represents code that is finished. we may find bugs, but we shouldn't *know* about missing functionality.
21:35:54 <dendrobates> yes, but soren has experience getting around freezes, so I'd talk to him.
21:36:00 <gundlach> heh ok
21:36:04 <gundlach> hopefully we won't need to :)
21:36:44 <dendrobates> it depends, if a blueprint is marked as essential, we might consider pushing the date if we can;t complete it.
21:36:46 <soren> Heheh :)
21:36:51 * soren whistles innocently
21:36:53 <dendrobates> the release date that is
21:37:00 <dendrobates> , but that would be major.
21:37:10 <gundlach> kthx
21:37:26 <dendrobates> If you have any questions or concerns please contact me.
21:37:47 <dendrobates> any other release questions?
21:38:11 <dendrobates> #topic Meeting time
21:38:21 <dendrobates> Anyone want to complain?
21:38:28 <jaypipes> nope.
21:38:45 * zul looks around for ninjas
21:38:46 <spectorclan> dendrobates:is this a fixed time every week?
21:38:51 <dendrobates> yes
21:38:57 <dendrobates> unless it isn;t
21:39:00 <soren> I wouldn't mind if it were a bit earlier, but it's ok.
21:39:02 <adjohn> good over here
21:39:21 <dendrobates> spectorclan: we will reconsider it as necessary
21:39:21 <zul> my wife and my kid wouldnt mind if it was a bit earlier as well
21:39:34 <romain_lenglet> it's a good time for us in Tokyo
21:39:54 <adjohn> any earlier would be pretty rough
21:40:01 <dendrobates> #topic any other business?
21:40:11 <dendrobates> anything anyone wants to talk about?
21:40:22 <dendrobates> this is the first time we have finished early
21:40:33 <creiht> lets not make it the last time :)
21:40:52 <dendrobates> I will always try
21:41:07 <dendrobates> 5
21:41:08 <dendrobates> 4
21:41:09 <dendrobates> 3
21:41:10 <dendrobates> 2
21:41:11 <dendrobates> 1
21:41:16 <dendrobates> #endmeeting