21:01:26 <dendrobates> #startmeeting
21:01:26 <spectorclan> hello
21:01:27 <openstack> Meeting started Tue Dec 21 21:01:26 2010 UTC.  The chair is dendrobates. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:49 <dendrobates> #topic Actions from previous meeting
21:02:08 * dendrobates mtaylor to bring down the openstack-discuss group
21:02:26 <dendrobates> It still seems to exist so I am assuming it was not done.
21:02:52 <dendrobates> #action dendrobates to contact mtaylor about deleting openstack-discuss
21:03:37 <dendrobates> #topic Current release stage
21:03:55 <dendrobates> #link http://wiki.openstack.org/ReleaseCycle
21:04:08 <dendrobates> We are in the implementation phase
21:04:19 <dendrobates> two weeks until merge proposal freeze
21:04:46 <dendrobates> We need to try to clear the queue
21:05:03 <dendrobates> specifically  --
21:05:14 <dendrobates> https://code.launchpad.net/~armando-migliaccio/nova/xenapi-unittests/+merge/43796
21:05:21 <dendrobates> #link https://code.launchpad.net/~armando-migliaccio/nova/xenapi-unittests/+merge/43796
21:05:44 <dendrobates> there are several merges that are dependent on it.
21:06:05 <dendrobates> Can someone volunteer to review it?
21:06:56 <dendrobates> how about someone from ozone?   You guys need that to hit
21:07:38 <dendrobates> hello
21:08:03 <dendrobates> ok, we'l l ping people offline
21:08:37 <dendrobates> Please look at the merge queue though.  https://code.launchpad.net/nova/+activereviews
21:08:54 <dendrobates> We really need to clear it.
21:09:17 <vishy> dendrobates: We (anso) don't have a xen testbed set up so it is a bit tough for us to review those
21:09:46 * vishy has 7 (soon to be 8) outstanding branches as well
21:09:52 <soren> The point of that branch is that you don't need a Xen setup to test it.
21:10:01 <eday> vishy: stop working so hard
21:10:04 <vishy> that was (eight) not 8)
21:10:17 <vishy> eday: :p
21:10:38 <dendrobates> #topic Release status
21:10:39 <vishy> soren: fair, I'll look it over and run tests for sure
21:11:11 <dendrobates> It seems that all the essential blueprints for all projects have now hit.
21:11:39 <dendrobates> So now we will be watching the high priority bps
21:12:05 <dendrobates> ttx gave me a bunch of stats, but I didn't take notes.
21:13:06 <dendrobates> if you haven;t linked a branch to your blueprint yet, please do.  It is very helpful and it keeps us from bugging you yoo much
21:13:52 <dendrobates> also ttx said there were some devs that had branches they hadn;t push to a public archive yet
21:14:07 <dendrobates> Please push early and push often.
21:14:46 <dendrobates> anything else on the release status?
21:15:24 <dendrobates> #topic open discussion
21:16:01 <dendrobates> anyone have anything they would like to discuss?
21:16:04 <alekibango> service-provider-readiness should be ok  for bexar,right?
21:16:05 <devcamcar> we're on track to have the django dashboard released for bexar
21:16:21 <dendrobates> devcamcar: awesome
21:16:45 <soren> \o/
21:16:48 <armandomi> is there a branch for that?
21:16:57 <dendrobates> devcamcar: is that all approved by tptb?
21:17:04 <alekibango> armandomi: will be before the end of the year :)
21:17:16 <devcamcar> yes, all the work that remains is on the devs, which is how we like it :)
21:17:21 <armandomi> sweet!
21:17:40 <dendrobates> alekibango: push it as soon as you can
21:18:04 <dendrobates> I assume most of you have seen the proposals I have been spewing to the mailing list
21:18:08 <alekibango> i will  now start working on my blueprint intensively
21:18:35 <dendrobates> The feedback has been good, thanks
21:18:39 <alekibango> but i would love someone to help me with infrastructure. i will mail the list tomorrow or so
21:19:20 <dendrobates> anything else?
21:19:35 <alekibango> what is status of trunk ppa packages?
21:19:38 <alekibango> are they working now?
21:19:59 <alekibango> we all imho need some good functional tests
21:20:04 <alekibango> to be really sure it all works
21:20:06 <dendrobates> I haven;t checked, they were broken because they were missing the python-cheetah dep
21:20:16 <soren> I fixed them.
21:20:26 <alekibango> soren: thanks a lot will try them tomorrw
21:20:48 <alekibango> ... with functional tests we need also a tool for testing nova health
21:20:58 <alekibango> which can be used against installed systems
21:21:04 <dendrobates> soren are the ppa's built from the same packaging branch used for ubuntu?
21:21:11 <alekibango> and which might inform user on potential problems found
21:21:18 <soren> dendrobates: Yes.
21:21:28 <dendrobates> ok
21:21:39 <dendrobates> anything else....
21:21:54 <soren> dendrobates: So you fixed the build, really.
21:22:14 <soren> dendrobates: I fixed the resulting packages' deps.
21:22:23 <dendrobates> ah
21:22:36 <dendrobates> I knew I tried to fix the build.
21:22:49 <dendrobates> I didn't check to see if it worked
21:23:29 <dendrobates> ok if there is nothing else.....
21:23:42 <alekibango> dendrobates: imho what dendro said to me should be towards you, push as early as u can...
21:23:53 <alekibango> s/dendrobates/devcamcar/
21:23:56 <alekibango> :D
21:24:07 <dendrobates> #endmeeting