21:01:18 <ttx> #startmeeting
21:01:19 <openstack> Meeting started Tue Jan 11 21:01:18 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:37 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:44 <ttx> Today's agenda is at:
21:01:49 <ttx> #link http://wiki.openstack.org/Meetings
21:02:07 <ttx> #topic Current release stage: Implementation
21:02:19 <ttx> #info We are 2 days away from FeatureFreeze (Jan 13) !
21:02:31 <ttx> By the end of the day Thursday we'll try to have all feature branches merged.
21:02:50 <ttx> The idea is to switch as early as we can to testing/bugfixing mode, which is difficult to do if we continue to merge new features and disruptive changes.
21:03:11 <ttx> #info Feature branches that are not merged in time should be kept for the next development window (Cactus, opening February 4), or you can file a FeatureFreeze exception request to try to sneak in Bexar.
21:03:28 <ttx> The exception process described at http://wiki.openstack.org/FeatureFreeze is a bit inconvenient, I propose we simplify it:
21:03:44 <ttx> (current) create bug justifying exception, subscribe me to it, link bug to BMP, wait for me to ACK the exception in the bug
21:03:57 <ttx> We could get rid of the bug creation and do everything in the BMP (branch merge proposal):
21:04:13 <ttx> (proposed) justify the exception in a BMP comment, and add me to the reviewers, wait for me to approve the BMP
21:04:27 <ttx> The drawback being, if people delete the BMP, we lose the history of approval.
21:04:39 <ttx> Which solution do you prefer ? Please vote "current" or "proposed"
21:05:04 <soren> Proposed is fine with me. I have e-mail trail of everything anyway. Muahhaha.
21:05:34 <ttx> anyone else caring either way ?
21:05:44 <dragondm> proposed. sounds simpler. simple is good.
21:05:44 <annegentle> proposed is ok if you can help me keep up for the release notes :)
21:05:45 <pvo> proposed works... once its merged, does the history matter?
21:05:50 <dabo> proposed looks much more direct
21:06:02 <ttx> proposed is more obvious, yes.
21:06:19 <ttx> ok, I'll change it in the wiki
21:06:42 <ttx> #action ttx to document simplified exception procedure in wiki
21:06:56 <ttx> Note that Bexar-targeted features, or branches that do not affect so much the existing code are much more likely to get an exception granted.
21:07:09 <ttx> Questions ?
21:07:20 <ttx> (I accept bribes in all kinds of currency)
21:08:08 <ttx> ok, moving on...
21:08:14 <ttx> #topic Release status
21:08:19 <ttx> #link http://wiki.openstack.org/releasestatus/
21:08:26 <ttx> All remaining "High" specs are in good shape and on track for merging, yay
21:08:41 <ttx> "Medium" specs that may not make it without attention:
21:08:58 <ttx> * bexar-migration-live, ipv6-support and sheepdog-support branches need some review love, see below
21:09:10 <ttx> * image-service-use-glance-clients is not proposed yet
21:09:22 <ttx> jaypipes: still planning to propose a merge for that, or should we defer ?
21:09:45 <ttx> ah, we don't have a jaypipes around. Will sync with him
21:09:45 <sirp-> jaypipes, ttx: xs-snaps prop right now does some of that (perhaps all of it)
21:10:01 <ttx> sirp-: a-ha.
21:10:03 <sirp-> image service is using glance.client now
21:10:32 <ttx> sirp-: thanks, I'll sync with jaypipes to confirm that covers everything/enough
21:10:44 <ttx> * snapshot-instance is not started
21:10:49 <ttx> vishy: should we defer it to cactus ?
21:12:00 <ttx> Hm, I'll sync with him offline.
21:12:10 <ttx> #topic Review/merging status
21:12:25 <ttx> I posted a status this morning... glance and swift seem to be on track, nova needs some attention:
21:12:32 <ttx> Unreviewed branches:
21:12:39 <ttx> https://code.launchpad.net/~nii/nova/nova-deployment-tool/+merge/45335
21:12:42 <ttx> https://code.launchpad.net/~vishvananda/nova/cow/+merge/45293
21:12:55 <ttx> Targeted features that are late in the review/fix process:
21:13:02 <ttx> https://code.launchpad.net/~ntt-pf-lab/nova/ipv6-support/+merge/45228
21:13:06 <ttx> https://code.launchpad.net/~nttdata/nova/live-migration/+merge/44940
21:13:11 <ttx> https://code.launchpad.net/~morita-kazutaka/nova/sheepdog/+merge/45093
21:13:23 <ttx> Please give them all some review love !
21:13:49 <ttx> #topic Open discussion
21:13:50 <pvo> <3
21:14:05 <ttx> Anything on anyone's mind ?
21:14:22 <pvo> ttx: what is your confidence for bexar as of today?
21:14:44 <pvo> and is there anything that need critical attention besides the merges?
21:14:45 <ttx> Feature-wise, I think we are already in good shape compared to the defined plan
21:15:00 <ttx> two issues:
21:15:03 <vishy> ttx: yes defer
21:15:12 <ttx> - the plan might not reflect what we wanted to have
21:15:26 <ttx> - the current state of trunk is barely testable
21:16:11 <pvo> not sure what we can do about #1... but #2 seems fixable.
21:16:11 <ttx> So I think we really need to switch into test/qa/bugfix gear in order to find and fix the issues before release
21:16:37 <pvo> ttx: we're planning a bug sprint in SAT the week of the 24th
21:16:41 <ttx> About #1, nothing we can do right now. But we'll need to doublecheck the plan for Cactus
21:16:50 <pvo> ttx: agreed there
21:17:59 <ttx> So critical attention is in the merges right now, since the current state of trunk doesn't encourage me to accept late branches
21:19:04 <ttx> so let's break it badly, but early :)
21:19:33 <ttx> also the current state of trunk highlights the need for Jay's smoketesting on merges magic
21:19:45 <tr3buchet> why the lack of confidence regarding trunk? (just curious)
21:20:19 <ttx> vishy said that its state prevented them from testing merges correctly
21:20:47 <ttx> it should be unstable, but not to the point of preventing further merging at crunch time
21:21:48 <ttx> tr3buchet: I still think we will fix all issues, but the state it's been in seem to show we don't do enough automated tests
21:21:58 <soren> +1
21:22:46 <tr3buchet> i understand
21:22:51 <tr3buchet> makes perfect sense
21:22:57 <dragondm> what's our coverage?
21:23:20 <sandywalsh> +1
21:23:37 <ttx> 69% lines, according to Hudson ?
21:23:48 <ttx> http://hudson.openstack.org/job/nova-coverage/
21:23:56 <ttx> (for Nova)
21:24:11 <dragondm> ah. we have a separate job for it. I see
21:24:32 <dragondm> I was looking at the regulat Nova job, and not seein g it
21:25:17 <ttx> I hope we'll be able to prioritize jaypipes's hudson-smoketesting at high prio for Cactus and get something done in that area
21:25:37 <dragondm> good
21:25:39 <soren> I'd love to spend more time on automated testing.
21:26:15 <ttx> soren: I am game as well. After one cycle I should spend less time setting up my release tools
21:26:45 <ttx> ok, let's wrap up, unless someone has anythign else to discuss ?
21:27:35 <ttx> alrighty then
21:27:38 <ttx> #endmeeting