21:00:48 <ttx> #startmeeting
21:00:49 <openstack> Meeting started Tue Jan 18 21:00:48 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:58 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:05 <ttx> Today's (long) agenda is at:
21:01:08 <soren> o/
21:01:09 <ttx> #link http://wiki.openstack.org/Meetings
21:01:21 <ttx> #topic Actions from previous meeting
21:01:32 <ttx> * ttx to document simplified exception procedure in wiki: DONE
21:01:44 <ttx> #topic Current release stage: QA
21:02:01 <ttx> #info We are now passed FeatureFreeze and well into QA stage. The goal is to test, find and fix as many bugs as we can before GammaFreeze.
21:02:20 <ttx> After GammaFreeze the idea is to restrict bugfixing to release-critical issues only, in order to avoid introducing regressions... a known bug being better than an unknown regression
21:02:38 <ttx> That said, on the release schedule, GammaFreeze is EOD on Tuesday, January 25. I wonder if we shouldn't push that back to EOD Thursday, January 27.
21:02:54 <ttx> Given the number of new things that landed in this release, maximizing random bugfix time sounds like a good idea for Nova...
21:03:08 <ttx> 3 business days between GammaFreeze and RCFreeze should be enough to spot and fix regressions.
21:03:15 <ttx> Thoughts ?
21:03:27 <jaypipes> hopefully...
21:03:32 <dendrobates> only if we stop new merges
21:03:54 <ttx> dendrobates: new merges ?
21:04:01 <devcamcar> would be nice to have til 27th for gamma
21:04:28 <devcamcar> how are we supposed to fix bugs if we can merge? :)
21:04:34 <dendrobates> ttx: there are still some outstanding questions that we are going to discuss later in the meeting.
21:04:51 <dendrobates> ttx: I just mean we need to decide today and not draw anything out
21:05:09 <ttx> ok, maybe revisit that question at the end of the meeting then.
21:05:23 <ttx> Moving on
21:05:26 <ttx> #topic Release status
21:05:35 <ttx> #link http://wiki.openstack.org/releasestatus/
21:05:46 <ttx> We still have 2 feature branches in the FeatureFreezeException track:
21:05:53 <ttx> https://code.launchpad.net/~citrix-openstack/nova/xenapi-glance-2/+merge/45977
21:06:05 <ttx> jaypipes: could you give us a quick summary of the situation ?
21:06:17 <jaypipes> sure..
21:06:27 <ttx> or maybe ewan
21:06:45 <ewanmellor> right here
21:06:53 <ttx> ewanmellor: could you give us a quick summary of the situation ?
21:07:15 <jaypipes> xenapi-glance-2 was delayed because of Glance packaging issues. that has been fixed, but there were other bugs in Glance that showed up. the one right now that is a showstopper is appparent large file upload limitations...
21:07:38 <jaypipes> So, while citrix' code is fine, glance has bugs that may be showstoppers for merging that code in.
21:08:20 <ttx> jaypipes: and we are still a few days away from getting those ironed out, right
21:08:31 <ewanmellor> We've worked around those problems by registering images by URL rather than by upload
21:08:39 <jaypipes> ttx: and since I'm currently the only one working on glance bugs, it's a little tough to predict if I can get them all fixed in time .
21:08:54 <jaypipes> ewanmellor: sure, but that's a limitation for sure..
21:08:59 <ttx> So from a release management perspective, I want us to stop merging new code asap...
21:09:08 <ttx> But it's up to the nova-core team to determine if it's ready to go in or not.
21:09:31 <jaypipes> ttx: like I said, it's not the xenapi-glance-2 code that's buggy, it's glance...
21:09:32 <ewanmellor> There's no reason to block the Nova half of the code because of a bug in Glance.
21:09:51 <ewanmellor> jaypipes: Thanks ;-)
21:10:03 <ttx> jaypipes: so should we merge the code ?
21:10:11 <ttx> the code is fine, the feature is not, IIUC
21:10:13 <devcamcar> ewanmellor: agree, lets merge the branch and let the glance bug be a glance bug
21:10:17 <jaypipes> ttx: that is true, actually, there are 2 workarounds... one for glance (use x-image-meta-location) and one is just use nova-objectstore...
21:10:19 <ewanmellor> I can get someone to help with the Glance bugs.
21:10:54 <jaypipes> ttx: I don't want to make the final call, because it's my bugs that are the issue...
21:11:05 * jaypipes hides sheepishly...
21:11:07 <ttx> any other nova-core dev wanting to chime in ?
21:11:22 <jaypipes> ttx: devcamcar says proceed...
21:11:23 <soren> jaypipes: Are the glance problems likely to be resolved any time soon?
21:11:33 <jaypipes> soren: hopefully, yes.
21:11:44 <dendrobates> I say merge it
21:11:47 <soren> +1
21:11:50 <devcamcar> +1
21:11:51 <jaypipes> soren: there were, like 6 bugs, and I've fixed all but 1 of them..
21:11:52 <xtoddx> are we talking about merging a branch we can't test?
21:11:59 <jaypipes> xtoddx: no.
21:12:09 <xtoddx> then merge
21:12:20 <jaypipes> xtoddx: it has unit tests and has functional testing ability (with the workarounds mentioned above)
21:12:20 <ttx> ok, then please one of you set the branch to approved now :)
21:12:33 <jaypipes> devcamcar: go for it.
21:12:46 <creiht> jaypipes: If the only problem is the large file uploading one, that should be fixable
21:13:02 <ttx> second feature branch left:
21:13:05 <ttx> https://code.launchpad.net/~termie/nova/db_migration/+merge/46073
21:13:09 <jaypipes> ttx: I'll try to get that remaining bug resolved, and in the unlikely event I cannot resolve it, we'll make a note in the release about the workarounds.
21:13:16 <ttx> termie: could you give us a quick summary of the situation, though I guess that will quickly bring us to the next topic...
21:13:22 <ttx> jaypipes: works for me
21:13:31 <jaypipes> creiht: yeah, that's the only bug left.
21:13:36 <termie> the branch is essentially done, it has just been being updated to track trunk changes to db schema
21:13:51 <termie> the latest tracking brought me to the changes introduced by live_migration
21:14:06 <termie> which is up for some debate and the db_migration branch is stalled on it
21:14:26 <soren> Can you explain how db_migration is stuck because of it? It's not entirely clear to me.
21:14:35 <jaypipes> no debate in my mind... I've voted for a reversion of live-migration and a merge of db-migration...
21:14:39 <termie> largely in that the schema changes it suggests do not appear to be completely thought out
21:15:24 <ttx> ok, let's switch to the next topic then
21:15:29 <ttx> #topic Live-Migration patch
21:15:37 <ttx> vishy/termie: floor is yours.
21:15:51 <termie> sure, some discussion has already happened over on https://code.launchpad.net/~termie/nova/revert_live_migration/+merge/46660
21:16:10 <vishy> basically there are a number of issues with the patch
21:16:11 <ttx> termie: wouldn't it be simpler at this point to just fix the remaining issues ?
21:16:12 <termie> the gist of it is that i think the code review of the live_migration branch failed to identify issues
21:16:26 <vishy> there are two options: keep the merge in and fix the issues
21:16:29 <termie> ttx: not nearly so simple as reverting the patch, no
21:16:38 <termie> ttx: there are no tests in the patch
21:16:44 <vishy> or revert the merge and let the original author fix the issues
21:17:09 <ttx> termie: "revert+fix+rereview" is not simpler than "fix"
21:17:18 <termie> ttx: yes it is when there are no tests
21:17:30 <termie> ttx: and we are only talking about revert here
21:17:36 <soren> termie: I can't help but wonder why you didn't raise these issues while this patch was being reviewed?
21:17:45 <termie> soren: i didn't review the patch
21:17:52 <termie> soren: i don't believe i am expected to review them all?
21:18:02 <soren> Are you in nova-core?
21:18:05 <jaypipes> OK guys, let's cool it.
21:18:06 <vishy> I think we have failed as a team in terms of reviewing
21:18:06 <ttx> termie: if we revert it, that means we push it back to Cactus. We can't wait for another review cycle.
21:18:10 <dragondm> couldn't we implement some test-coverage requirement hook/test in hudson??
21:18:17 <jaypipes> A number of us were on vacations, let's be more reasonable here..
21:18:19 <termie> ttx: i think it should be pushed back to after bexar, yes
21:18:35 <ttx> termie: I'm fine with that, just explaining what "reverting" exactly means
21:18:49 <dendrobates> vishy: I agree we have failed
21:18:58 <eday> dragondm: we already have coverage checks, we're just not enforcing anything. but, yes, we could
21:19:05 <soren> dragondm: Current trunk would fail such a test, probably.
21:19:15 <vishy> we need to have a discussion about nova-core and reviews.  We proposed to the community that they could submit patches before BMPF and that we would help them prepare for FF
21:19:26 <vishy> we clearly did not do that well for this patch
21:19:42 <vishy> and most of the external patches were probably under-reviewed
21:20:02 <jaypipes> agreed, for this specific patch. most other patches had a lot of review, however (xenapi-glance-2, for instance..)
21:20:03 <vishy> soren and I hit most of them, but we did it too late and too quickly imo
21:20:40 <jaypipes> vishy: sorry, what did you mean by "external patches"?
21:20:56 <termie> jaypipes: i think he means patches not coming from core team members
21:21:03 <vishy> jaypipes: patches done by non- nova-core members
21:21:03 <jaypipes> ah, k.
21:21:07 <termie> jaypipes: we tend to talk about our own patches amongst ourselves more
21:21:25 <devcamcar> yea i did notice a number of patches that weren't reviewed by nova-core but were still approved
21:21:30 <soren> vishy: At some point, I did switch into "alright, I think this is `good enough`, we can fix the remaining issues after the freeze" sort of mode.
21:21:37 <devcamcar> is there some way to enforce that?
21:21:42 <soren> vishy: Perhaps not entirely consciously.
21:21:44 <jaypipes> I think some non-core patches were very heavily reviewed (all of the citrix ones at least). the reason is because we were able to go through 5-6 cycles for each of the patches..
21:21:58 <ttx> In the end it's a chief architect / nova-core decision. Is it good enough ? I just set the deadline.
21:22:08 <vishy> soren: me too
21:22:09 <soren> devcamcar: Whuh?
21:22:19 <soren> devcamcar: Example?
21:22:20 <jaypipes> devcamcar: that's not possible AFAIK...
21:22:32 <ttx> devcamcar: only nova-core can approve
21:22:49 <vishy> it is possible if someone from nova-core doesn't wait for the second approval
21:22:50 <devcamcar> i could have sworn i saw a few, maybe i'm wrong
21:23:05 <dendrobates> adding to nova core and having more people doing reviews would be helpful
21:23:07 <jaypipes> vishy: yes, that is true.
21:23:16 <sandywalsh_> dendrobates, +1
21:23:19 <soren> To me, being in nova-core means you *must* do reviews.
21:23:28 <ttx> soren: +1
21:23:31 <vishy> +1
21:23:33 <ttx> nova-core is a duty, not a right
21:23:38 <soren> Membership in nova-core is..
21:23:41 <soren> right, precisely.
21:24:14 <dendrobates> soren: I am working on a definition of core dev for the wiki
21:24:21 <vishy> people that don't have time to review sould remove themselves from nova-core so we know how many active reviewers we have
21:24:21 <jaypipes> Guys, I think we should keep some perspective here... granted, this live-migration patch was a mess, but overall, we reviewed dozens of patches in the last week or so...
21:24:21 <dendrobates> should be published tonight
21:24:39 <soren> vishy: Fully agreed.
21:24:47 <termie> if nova-core means must then require sizeof(nova-core) approvals
21:24:47 <vishy> jaypipes: true...its the big ones that no one wants to touch
21:25:00 <creiht> We should ask lp to have a popup when you hit the approve button to confirm that all unit tests were run and that they did indeed read the code
21:25:04 <creiht> ;)
21:25:24 <termie> creiht: we should ask lp to have line-by-line code review
21:25:31 <jaypipes> vishy: not necessarily :) I reviewed some pretty big ones...but just did not get around to live-migrations for some reason..
21:25:39 <vishy> in any case we can go on about fixes to the process, but we need to take action on this particular patch, so what should we do?
21:25:47 <soren> termie: No, we shouldn't. I don't want to use a web UI to do code review.
21:25:56 <soren> Fix the patch.
21:26:07 <soren> IMO
21:26:23 <devcamcar> it can be tough to review the larger patches solo
21:26:26 <jaypipes> is this a vote then? revert vs. fix patch?
21:26:29 <termie> revert
21:26:35 <jaypipes> revert
21:26:39 <devcamcar> it would be valuable to have a way to review virtually as a group
21:26:43 <vishy> i feel that it was our (nova-core's) failure and to show good faith to the community we should fix it ourselves.
21:26:54 <termie> devcamcar: standard line-by-line code review handles group interaction well
21:27:06 <vishy> fix
21:27:10 <dendrobates> fix, basically because we messed up.
21:27:21 <devcamcar> termie:  yes it does but lp doesn't do it =x
21:27:25 <devcamcar> revert
21:27:37 <xtoddx> revert, and fix in a branch ourselves?
21:27:49 <soren> Just to be clear: Revert means revert the patch and refuse the feature for bexar?
21:27:51 <xtoddx> definitely revert though
21:28:02 <ttx> xtoddx: there is no time left for that option
21:28:09 <ttx> (revert+fix)
21:28:11 <devcamcar> just playing devil's advocate - why is it our job to fix as opposed to authors
21:28:12 <xtoddx> ttx: for cactus then
21:28:18 <jaypipes> soren: yes
21:28:20 <soren> devcamcar: We approved it.
21:28:21 <ttx> xtoddx: ack
21:28:37 <dendrobates> we shoudn;t have merged it, but once we did, we all own it.
21:28:40 <ttx> soren: yes
21:28:41 <soren> If people hated the patch so much, they should have said something. Really.
21:28:47 <vishy> devcamcar: and we didn't review it in a timely manner as outlined for the process for getting stuff in.
21:28:58 <devcamcar> ok, change my vote to fix
21:29:21 <devcamcar> otherwise its not going in this release
21:29:34 <termie> soren: you should have reviewed it better, you can't blame that on somebody else
21:29:43 <ttx> I'm not nova-core, but I prefer to "fix", not because otherwise it won't make it into this release, but to be fair to the proposer
21:29:45 <soren> termie: I'm not.
21:29:52 <jaypipes> termie: it's not all on soren. we all played a role.
21:29:55 <soren> termie: How am I blaming anyone else?
21:29:57 <ttx> since he proposed well before the branchmergeproposalfreeze
21:30:07 <termie> soren: "if people hated the patch so much..." etc
21:30:20 <soren> termie: If I were proposing to revert, *then* I'd be a hypocrite.
21:30:24 <termie> soren: we depend on the people who review something to do it correctly
21:30:31 <termie> otherwise we _all_ have to look at eevery patch
21:30:47 <devcamcar> termie, soren: take it to pms
21:30:52 <vishy> termie: I'll take credit for being lazy with the review
21:31:05 <soren> Me too, for sure.
21:31:08 <ttx> I take my part in the blame -- I pushed for getting stuff merged
21:31:11 <xtoddx> we don't need to assess blame, we just need to move on
21:31:18 <jaypipes> xtoddx: ++
21:31:20 <ttx> (though I also pushed for getting stuff reviewed :)
21:31:25 <soren> I decided to let it in and fix things after the fact.
21:31:33 <ttx> it's about half/half votes
21:31:38 <soren> I figured it'd be faster, and the really tricky bits seemed ok.
21:31:41 <vishy> forget blame, I'm taking credit...laziness is an asset! :)
21:31:47 <dendrobates> I think we can agree to fix the process and not let this happen again.
21:31:47 <jaypipes> hehe
21:31:53 <creiht> at least it was pep8 compliant ;)
21:31:54 <ttx> sounds like it's time for some chief architect fiat
21:32:03 <jaypipes> creiht: had to go there, didn't ya? :P
21:32:04 <ttx> creiht: it wasn't until the last review
21:32:08 <ttx> :P
21:32:17 <creiht> >:)
21:32:18 <johnpur> who is volunteering to make the fix and get it reviewed if we vote for fix?
21:32:21 <xtoddx> we have a policy of piece-meal commits to keep size down, so approving a half-baked commit should be expected occasionally.
21:32:32 <dendrobates> ttx: what was the vote?
21:32:43 <termie> johnpur: looks like me
21:32:44 <ttx> "fix" vs. "revert and defer to cactus"
21:32:52 <termie> there are no tests though
21:32:56 <termie> so it can't be fixed
21:32:57 <johnpur> termie: how much time will this take?
21:33:11 <ttx> I don't tjhink it would just fall on termie
21:33:19 <dendrobates> soren: you should help to.
21:33:22 <johnpur> can we get tests from the original author
21:33:28 <vishy> masumotok can probably help
21:33:38 <vishy> johnpur: lets ping him for some tests
21:33:47 <termie> tests usually take longe rot write than the code, for the record
21:33:59 <johnpur> termie: a sad fact!
21:34:01 <vishy> meanwhile we can clean up formatting issues and such
21:34:08 <masumotok> how much time ca I have to add the test?
21:34:29 <johnpur> ttx: how long can we reasonably take?
21:34:43 <xtoddx> lets aim for landing the fix before gamma freeze?
21:34:44 <ttx> johnpur: depends on how much that blocks db-migration
21:34:51 <ttx> I want db-migration in
21:34:54 <soren> Me too.
21:35:01 <johnpur> me too
21:35:05 <ttx> since its 1k lines still needing to hit trunk
21:35:14 <termie> ttx: they are self-contained lines
21:36:01 <vishy> masumotok: hi, didn't know you were here
21:36:02 <termie> ttx: so it doesn't affect much by waiting, i'd like it in too but we will have to change that code again once the new changes happen
21:36:27 <termie> so either i update it to fit with current and then make another branch after this fixes branch goes in
21:36:29 <jaypipes> isn't gamma freeze in 8 days? can we get tests in next 2 days and reviews in an additional day?
21:36:32 <ttx> OK. Let's give the db-migration branch until the end of the week
21:36:43 <johnpur> ttx: agree
21:36:47 <xtoddx> do we want to aim for tests from masumotok by end of week, leaving the weekend and until tuesday to land fixes to that branch and migrations before gamma freeze?
21:36:56 <ttx> since it was expected to be the last branch anyway, by design
21:37:00 <termie> masumotok: i am happy enough to work wiht you to write tests, i don't think this will be a very easy thing to test
21:37:18 <jaypipes> xtoddx: that's pushing it a bit thin IMHO.
21:37:18 <termie> masumotok: but i have worked with testing a lot so maybe can offer assistance
21:37:24 <dendrobates> down to the wire again :(
21:37:43 <johnpur> dendrobates: that's how we roll!
21:37:47 <xtoddx> jaypipes: then lets make a post-gamma exception and get it in before release candidate freeze?
21:37:55 <ttx> xtoddx: no way
21:38:06 <xtoddx> we want both features, what the other option?
21:38:16 <jaypipes> xtoddx: no, I was suggesting the other way :) reviews complete by end of week, tests done by Thursday.
21:38:18 <ttx> I think we have enough time
21:38:32 <dendrobates> if the tests don;t arrive at that late date, what would we do?
21:38:40 <dendrobates> revert right before release
21:38:42 <dendrobates> ?
21:39:02 <jaypipes> masumotok: think you can get your team to get tests done by Thursday end of day UTC?
21:39:03 <ttx> dendrobates: the end of this week is not right before release
21:39:11 <termie> i would say revert now if matsumotok is on board and he can just work on cleaning the branch up more
21:39:19 <masumotok> jaypipes: yes
21:39:21 <dendrobates> ttx: I meant post gamma
21:39:26 <johnpur> dendrobates: let's make sure that doesn't happen.... sounds like there is a lot of help ready to write the tests
21:39:31 <eday> I'm thinking we revert and merge db migration today. if we can get it fixed up before freeze, it makes it, if not, it's not a big revert at the last minute
21:39:39 <ttx> dendrobates: no way I'll let that overflow to next week, lest postgamma
21:39:42 <termie> eday: +1
21:39:58 <jaypipes> termie: I'm on the fence with this one...
21:40:22 <dendrobates> eday: that is starting to seem more sane to me
21:40:24 <jaypipes> eday: that was termie's original suggestion, and what I voted for originally...
21:40:35 <vishy> eday: I'm ok with that proposal if masumotok is ok with it
21:40:37 <eday> jaypipes: yup
21:40:38 <johnpur> jaypipes: time to get off the fence, let's decide
21:40:52 <dendrobates> I think we are waiting for masumotok
21:40:56 <ttx> I feel comfortable merging db-migration late... but not so much merging live-migration late
21:41:09 <dendrobates> ttx: why?>
21:41:13 <jaypipes> johnpur: revert live-migrations, merge db-migrations, masumotok to make tests by thursday, nova-core to get reviewed by end of this week.
21:41:29 <masumotok> End of the thursday I submit the test code, do I?
21:41:39 <masumotok> UTC
21:41:39 <ttx> because db-migration is relatively self-contained
21:41:57 <jaypipes> masumotok: yes, along with the rest of the patch, which we'll revert to get the db-migrations patch in.
21:42:11 <masumotok> jaypipes: that is fine.
21:42:21 <dendrobates> ok, done.
21:42:26 <jaypipes> masumotok: and you have nova-core to assist with you in the tests as you need it.
21:42:46 <dendrobates> not really, who is going to handle reverting?
21:42:58 <jaypipes> dendrobates: it's already proposed by termie..
21:42:59 <ttx> dendrobates: termie has a branch up for it
21:42:59 <termie> dendrobates: already submitted the merge prop
21:43:01 <xtoddx> dendrobates: termie has a branch
21:43:07 <ttx> 4x
21:43:09 <dendrobates> easy then
21:43:12 <jaypipes> heh
21:43:12 <soren> ttx: Can you post a summary of this discussion?
21:43:17 <soren> ttx: On that bpm?
21:43:19 <johnpur> all: nice conclusion
21:43:21 <soren> bmp, even.
21:43:22 <ttx> soren: I will. Tomorrow
21:43:33 <xtoddx> haha, i read that as "eday then"  which was quite the non-sequitur.
21:43:39 <ttx> #action ttx to summarize the decision on live-migration
21:43:45 <dendrobates> ttx: what, you can't work all night?
21:43:56 <ttx> dendrobates: that depends how much more you can pay me
21:44:08 <ttx> #topic D release naming
21:44:24 <ttx> OK, funnier discussion now.
21:44:27 <ttx> As we move closer to Bexar release, we need to discuss the name of the "D" release.
21:44:33 <ttx> I summed up the rules of the game at:
21:44:38 <ttx> #link http://wiki.openstack.org/ReleaseNaming
21:44:50 <ttx> There aren't so many cities and counties in California starting with a D, but some people added new ones
21:44:56 <ttx> Please dump your preference on the channel for a highly scientific popularity contest !
21:45:02 <dendrobates> diablo!!!!!
21:45:05 <ttx> Sounds like it boils down to dublin vs. Diablo
21:45:07 <zul> diablo
21:45:09 <jaypipes> Denver.
21:45:10 <xtoddx> I like Dublin.  Mostly because of Dr Pepper
21:45:11 <ttx> Dublin !
21:45:16 <glenc> Dunsmuir
21:45:19 <termie> i think danville is pretty funny
21:45:22 <termie> as a california native
21:45:23 <kpepple> Downieville (http://en.wikipedia.org/wiki/Downieville,_California)
21:45:43 <sandywalsh_> diablo
21:45:44 <ttx> stephenspector asked me to vote "Diablo" for him
21:45:47 <soren> Diablo sounds awesome.
21:45:50 <_cerberus_> Diablo
21:45:53 <pvo> diablo
21:45:57 * jaypipes was joking... diablo sounds good to me.
21:45:59 <xtoddx> Dublin does double duty as a tx city and a ca city
21:46:08 <diegoparrilla> Diablo, no doubt
21:46:16 * creiht like Dublin
21:46:18 <termie> easier to drink beer from dublin to celebrate, also
21:46:19 * vishy votes for Dorris
21:46:25 <jaypipes> diegoparrilla: ah, hola. :)
21:46:25 <eday> so we are ok with diablo but not corpus-christi? :)
21:46:38 <soren> Yes. :)
21:46:39 <ttx> eday :)
21:46:43 <creiht> and don't forget dublin sugar dr pepper :)
21:46:44 <soren> Absolutely.
21:46:45 <dabo> Diablo has more non-city meaning than Dublin
21:46:49 * sandywalsh_ looks for the lightning clouds
21:46:50 <jaypipes> corpus christi isn't in California. :P
21:47:01 <termie> diablo just makes me think of the video game
21:47:01 <dabo> Hard to explain it's supposed to be a city reference
21:47:05 * creiht thinks diablo is a dumb name for a release
21:47:13 <termie> clicking on pale yellow artifacts
21:47:18 * dabo votes for Dublin
21:47:18 <eday> jaypipes: for the C release we shot it down due to religious implications
21:47:31 <eday> diablo++
21:47:32 <jaypipes> eday: yes, I know. :) I was pulling your chain.
21:47:34 <ttx> so let's count
21:47:46 <zul> diablo is not religious? ;)
21:47:47 <soren> eday: What's that? diablp?
21:47:49 <dabo> eday: Diablo should go for the same reason
21:47:53 <creiht> How about... wait for it... 1.0? :)
21:48:07 <creiht> dabo++
21:48:08 * jaypipes kickbans creiht.
21:48:10 <diegoparrilla> jaypipes: hi!
21:48:11 <xtoddx> creiht: pffft.  thats so 1990s
21:48:12 <creiht> :)
21:48:23 <xtoddx> creiht: did you just vote to name it dabo?
21:48:23 <dabo> creiht: 1.0 doesn't start with 'D'
21:48:29 <creiht> lol
21:48:35 <creiht> doh1.0
21:48:36 <creiht> !
21:48:37 <dabo> Yeah, let's call it dabo!! :)
21:48:37 <termie> http://www.google.com/imgres?imgurl=http://www.stanleysteamers.com/vapor-trails/saca-danville/danville1-x.JPG&imgrefurl=http://www.stanleysteamers.com/danville.htm&usg=__SDFY1sLWIcd9U-QADxdsJFF8cuo=&h=571&w=947&sz=82&hl=en&start=0&sig2=0R-fcWbp2eE9pJorsEjH6A&zoom=1&tbnid=tiE6zFbS-8gg9M:&tbnh=120&tbnw=199&ei=pwo2TZm7CJPWtQOStvC1BQ&prev=/images%3Fq%3Ddanville%26um%3D1%26hl%3Den%26safe%3Doff%26sa%3DN%26biw%3D1156%26bih%3D930%26tbs%3Disch:1
21:48:45 <vishy> deuce?
21:48:51 <ttx> so it looks like it's Diablo vs. Dublin
21:48:58 <vishy> we'll create a new city
21:49:06 <ttx> with Diablo leading a bit, but having strong advocates against it
21:49:12 <johnpur> Drytown
21:49:14 <jaypipes> Dublin then is my vote...since it's more identifiable as a city..
21:49:29 <sandywalsh_> Dumas (dumbass)
21:49:31 <annegentle> Danville LOL. Just got it. I'm slow.
21:49:32 * creiht thinks it is funy that you drop Corpus Christi for religious reasons, but don't for diablo
21:49:34 * vishy still thinks Dorris is incredible
21:49:36 <creiht> sandywalsh_: ++
21:49:38 <dabo> jaypipes: ...even if most won't know it's in CA
21:50:01 <pvo> ttx: surveymonkey?
21:50:16 <soren> http://www.googlefight.com/index.php?lang=en_GB&word1=diablo&word2=dublin
21:50:19 <soren> :(
21:50:24 <ttx> pvo: yeah, that dodn't exactly turned out to be the global consensus I hoped :)
21:50:46 <eday> I say DIablo, and during the diablo summit, we take a field trip and hike mt diablo
21:50:57 <soren> Of course we want the one with the *fewest* google hits for better ranking. :)
21:51:01 <johnpur> Death Valley?
21:51:09 <creiht> release del diablo
21:51:12 <ttx> johnpur: rha
21:51:23 <dabo> johnpur: yeah, that's the vibe we want!
21:51:55 <vishy> soren: http://www.googlefight.com/index.php?lang=en_GB&word1=diablo&word2=dorris
21:51:56 <xtoddx> johnpur: i like it, its edgy
21:51:57 <sandywalsh_> Dumas is just down the road from Cactus actually
21:52:14 <ttx> dendrobates: do you have enough momentum for Diablo to decide it, or should we move to a more scientific voting technique ?
21:52:26 <pvo> science. meh
21:52:37 <dendrobates> I say put up a voting
21:52:43 <pvo> yea, I do too
21:52:53 <ttx> ok, I'll condorcet it
21:52:57 <dendrobates> let everyone vote, not just those on IRC now.
21:53:13 <termie> http://www.google.com/imgres?imgurl=http://www.cccprc.org/puppies/images/group/bowling_0106b.jpg&imgrefurl=http://www.cccprc.org/puppies/group-pictures.html&usg=__7KQUKlmiJU3PJ5yeT1eKvI8o_YA=&h=300&w=450&sz=42&hl=en&start=25&sig2=AfHh8A3S53s-EjiV7Y660g&zoom=1&tbnid=7cEhJQUS1fIdBM:&tbnh=141&tbnw=196&ei=wgs2TaT7NYz0swPav7DiBQ&prev=/images%3Fq%3Ddanville,%2Bca%26um%3D1%26hl%3Den%26safe%3Doff%26biw%3D1156%26bih%3D930%26tbs%3Disch:10,631&um=
21:53:26 <termie> how can you vote against puppies?
21:53:27 <eday> shoudl we really spend more time on this? setting up a vote and whatnot? dendrobates, just pick one :)
21:53:30 <ttx> #action ttx to turn his failed IRC attempt to a real vote
21:53:39 <ttx> eday++
21:53:41 <sandywalsh_> so, top three choices are Diablo, Death Valley and Dublin?
21:53:50 <creiht> anyone but diablo
21:53:51 <creiht> :)
21:54:00 <annegentle> Danville, Dumas, Death Valley, Dublin?
21:54:35 <devcamcar> vote = dublin
21:54:41 <termie> i can hook us up with some danville locals if we want to celebrate in danville
21:54:44 <ttx> ok, dendrobates said "put up a vote", I'll do that unless someone else feels up to it
21:55:04 <ewanmellor> Please not Death Valley.  Two-word release names are really irritating.
21:55:10 <ttx> #topic open discussion
21:55:13 <creiht> So is it still in question on weather or not diablo is in the running?
21:55:20 <ttx> ewanmellor: rules of the game say "single word, 10 char max"
21:55:23 <eday> dendrobates: dublin or diablo, pick one :)
21:55:34 <dendrobates> damn, lay off!
21:55:38 <creiht> lol
21:55:41 <eday> haha
21:55:52 * notmyname votes dublin
21:56:01 <creiht> dublin
21:56:10 <xtoddx> yea, more dublin momentum, keep it coming!
21:56:11 * ttx makes mental note: Never discuss release naming on IRC again
21:56:19 <dendrobates> corpus christie was not officially rejected, so I see no reason that diablo should be
21:56:23 <eday> funny thing is, ultimately, no one really cares ;)
21:56:26 <ewanmellor> ttx: lol
21:56:27 <xtoddx> tts: you should know how the internet works by now
21:56:29 <jk0> eday: ++
21:56:30 <ttx> eday: exactly
21:56:32 <dendrobates> true
21:56:34 <johnpur> Darwin?
21:56:42 <xtoddx> johnpur: to apple
21:56:43 <johnpur> lol
21:57:00 <jaypipes> eday: exactly. the only release anyone ever cares about is the one that isn't released yet...
21:57:02 <ttx> "Downey" seems a bit dangerous for a production release
21:57:18 <creiht> Disney?
21:57:19 <sandywalsh_> hah
21:57:19 <creiht> :)
21:57:19 <xtoddx> ttx: it'll probably develop a drug habbit
21:57:29 <johnpur> ooooh.... Dulzura?
21:57:36 <ttx> "The Disneyland release"
21:57:38 * jaypipes picked a bad week to stop sniffing glue.
21:57:41 * eday goes back to real work
21:57:48 <ttx> #endmeeting