21:01:13 <ttx> #startmeeting
21:01:14 <openstack> Meeting started Tue Jan 25 21:01:13 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:19 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:26 <ttx> Today's agenda is at:
21:01:32 <ttx> #link http://wiki.openstack.org/Meetings
21:01:38 <ttx> #topic Actions from previous meeting
21:01:46 <ttx> * ttx to summarize the decision on live-migration: DONE
21:01:56 <ttx> Note that NTT Data finally decided to defer to merging early in Cactus.
21:02:05 <ttx> * ttx to turn his failed IRC attempt to a real vote
21:02:24 <ttx> That was done, the poll ended one hour ago. And the winner is...
21:02:26 <ttx> Diablo!
21:02:40 <ttx> By a fair margin. Results at the bottom of https://launchpad.net/~openstack/+poll/d-release-naming
21:03:27 <pvo> ha
21:03:29 <ttx> Good fight put up by Dublin and Dorris fans
21:03:44 <ttx> #topic Current release stage: QA
21:04:00 <ttx> #info We are now deep into QA stage. We need to test, find and fix and merge as many bugs as we can before GammaFreeze.
21:04:16 <ttx> #info GammaFreeze is at EOD Thursday, at that point we'll restrict merging to release-critical issues only
21:04:35 <ttx> Release-critical issues are bugs that we estimate we can't release with. It's usually all "critical" bugs, and most "High" bugs.
21:04:49 <ttx> That said, sometimes we include other less-important issues that would be a problem if we released with them
21:05:07 <ttx> Example: "Use Glance instead of KRM json to Relate Images": if we don't fix that wishlist item, we need to document use of the KRM json... which we want to drop asap.
21:05:42 <ttx> To ask for a bug to be added to the RC buglist, you should comment on the corresponding bugs and explain why we can't release without the bugfix and why it can't break something else.
21:05:57 <ttx> Prefixing bug subject by "[RC]" and/or pinging me (or a member of the corresponding "Drivers" team) should do the trick.
21:06:02 <ttx> Questions ?
21:06:53 <ttx> ok, moving on...
21:07:03 <ttx> #topic Release status
21:07:16 <ttx> We stopped merging full feature branches, so the table at http://wiki.openstack.org/releasestatus/ is final
21:07:32 <ttx> I think we retrospectively created blueprints for significant stuff that was merged, let me know if we missed anything.
21:07:48 <ttx> We may still have "default behavior" changes that need FFe, but I'd like to have them in ASAP. That includes:
21:07:58 <ttx> * https://code.launchpad.net/~rconradharris/nova/kernel_ramdisk_glance/+merge/47170
21:08:05 <ttx> * https://code.launchpad.net/~vishvananda/nova/friendly-db/+merge/46797
21:08:14 <ttx> Please review them in priority.
21:08:41 <ttx> I've started working on RC buglists. After a small discussion with creiht, they are now using milestones instead of series, now:
21:08:51 <ttx> #link https://bugs.launchpad.net/nova/+milestone/bexar-rc
21:08:56 <ttx> #link https://bugs.launchpad.net/swift/+milestone/1.2.0
21:09:15 <ttx> #action ttx to sync with jaypipes wrt. glance milestones and RC buglists
21:09:32 <jaypipes> ttx: I'm here...
21:09:37 <ttx> jaypipes: will talk to you later, i'm a bit lost with your Glance milestones :)
21:09:41 <jaypipes> ttx: sorry, meeting with pvo and lauren as we speak..
21:09:53 <jaypipes> ttx: the milestones are necessary when you do a release...
21:10:37 <ttx> jaypipes: I'll ping you about Glance status, probably tomorrow morning
21:10:53 <ttx> Any question on release status ?
21:12:03 <ttx> I saw we uncovered a critical issue running on separate systems
21:12:10 <ttx> bug 707554
21:12:42 <ttx> I'll try to spend some cycles on that
21:12:49 <ttx> ok, moving on
21:12:58 <ttx> #topic Review of docs.openstack.org - progress report and review request
21:13:08 <ttx> Unfortunately annegentle is sick, I'm copypasting for her:
21:13:16 <ttx> annegentle> I am sick and can't talk at the meeting about the ongoing work for docs.openstack.org. I did want to pass along two URLs for people who want to take a look at the plans and work-in-progress.
21:13:22 <ttx> annegentle> How to for editing documentation:
21:13:26 <ttx> #link http://wiki.openstack.org/Documentation/HowTo
21:13:31 <ttx> annegentle> The PDF (rough draft, still working on output and source)
21:13:37 <ttx> #link http://bazaar.launchpad.net/~annegentle/openstack-devel/working/view/head:/doc/build/target/docbkx/pdf/os-book.pdf
21:13:44 <ttx> annegentle> Again I apologize - I will keep everyone updated on the mailing list once the site itself is ready for review.
21:14:33 <dendrobates> get well soon anne, if you read through the logs:)
21:14:44 <ttx> #topic Cactus preparation
21:14:50 * ttx hands the mike to dendrobates
21:14:58 <dendrobates> The themes for Cactus are stability and testing.
21:15:15 <ttx> yay
21:15:33 <dendrobates> our goal for cactus is to merge any major changes asap and spend most of the cycle fixing things up
21:16:04 <dendrobates> with that in mind, we need all proposed blueprints for cactus in by bexar release
21:16:35 <ttx> dendrobates: maybe we should move FeatureFreeze a bit up in the schedule ?
21:16:46 <dendrobates> ttx: good idea
21:17:08 <ttx> dendrobates: we'll finalize the Cactus schedule next week.
21:17:30 <dendrobates> So please let us know about any blueprints asap
21:17:56 <dendrobates> we will also be a bit tougher about what we accept for the release
21:18:06 <ttx> dendrobates: what about the "deferred" blueprints from http://wiki.openstack.org/releasestatus/ ?
21:18:10 <dendrobates> so please do not take it personally if we defer your feature
21:18:38 <dendrobates> ttx: it depends on how far they are along.  We will want to merge them asap in the cycle
21:18:53 <ttx> so their assignee repropose them for Cactus at some point
21:19:00 <dendrobates> if code exists and they just missed they will almost certainly go in
21:19:01 <ttx> should repropose*
21:19:10 <dendrobates> yes
21:19:15 <ttx> ok
21:19:46 <pvo> we're going to need to add some more BPs to fill out our feature set
21:19:53 <dendrobates> any questions?
21:19:58 <pvo> I'll work with ttx and dendrobates on which ones should go in
21:20:23 <dendrobates> comments?
21:20:51 <soren> Sounds good to me.
21:21:03 * ttx likes more testing.
21:21:17 <dendrobates> ok, I'm done
21:21:25 <ttx> #topic Open discussion
21:21:41 <dendrobates> ttx: actually I added a topic at the last minute
21:21:46 <ttx> arh
21:21:51 * ttx refreshes
21:21:57 <henrichrubin> this blueprint is pretty much complete, https://blueprints.launchpad.net/nova/+spec/frontend-heterogenous-architecture-support, just needs testing module.
21:22:17 <ttx> #topic New process for becoming core dev
21:22:26 <ttx> dendrobates: floor is yours again
21:22:44 <dendrobates> the core dev proposal was approved and we can now start adding core devs
21:22:55 <dendrobates> #link http://wiki.openstack.org/Governance/Approved/CoreDevProcess
21:23:08 <dendrobates> it's pretty simple
21:23:22 * vishy slides in late
21:23:29 <dendrobates> just send an email to the list asking to become a core dev
21:23:48 <dendrobates> and the existing core devs will vote lazy consensus style
21:24:29 <dendrobates> I have a wiki page describing the responsibilities of a core dev that I will be putting up soon
21:24:41 <dendrobates> and I will send an email to the list about the process.
21:24:49 <dendrobates> #end
21:25:06 <ttx> dendrobates: do you plan to have a process for removing coredevs, or should they just step down considerately ?
21:25:19 <dendrobates> right now the later.
21:25:20 <ttx> (like, when they don't have time to do reviews anymore)
21:25:37 <dendrobates> we so have a plan to make all team memberships expire after a year
21:25:49 <dendrobates> but you just need to click a link to renew
21:26:12 <dendrobates> that will clean up people that drop off the face of the earth
21:26:12 <ttx> I think it's important to have -core team that is representative of active reviewers (as opposed to past active reviewers)
21:26:23 <dendrobates> agreed
21:26:35 <dendrobates> although inactivity does no actual harm
21:27:04 <ttx> ok, back to...
21:27:09 <ttx> #topic Open discussion again
21:27:19 <ttx> anything else ? comments questions ?
21:27:32 <devcamcar> hey all, i'd like to talk about the openstack django dashboard briefly
21:27:41 <devcamcar> its up, but i haven't formally announced it to the mailing list yet
21:27:47 <devcamcar> because it still needs a bit of content loving
21:27:50 <ttx> devcamcar: screenshots!
21:28:17 <devcamcar> ttx: i will provide some non home page screenshots today
21:28:30 <devcamcar> i'm hoping to find a few people that can help provide content for the home page
21:28:38 <devcamcar> both design and copy
21:28:54 <ttx> devcamcar: tutorial on setting it up!
21:29:00 <kpepple> devcamcar: is it fully operational ? ( I get errors when clicking on the images link within a project)
21:29:57 <devcamcar> it is fully operational
21:30:04 <devcamcar> it is the same backend code that nasa is using for the nebula dashboard
21:30:15 <devcamcar> so if you are running into specific issues find my on irc and i can help you troubleshoot
21:30:17 * ttx notes that his list of things to test is growing at an insane rate
21:30:31 <devcamcar> installation directions are provided in the READMEs in the lp repos
21:30:51 <devcamcar> located at http://launchpad.net/openstack-dashboard
21:31:40 <dendrobates> soren ttx and I will be at fosdem in Brussels next week if anyone want to grab a beer or test the release with us.
21:31:45 <devcamcar> (http://bazaar.launchpad.net/~devcamcar/openstack-dashboard/trunk/view/head:/README)
21:32:18 <ttx> dendrobates: I know Daviey should be there over the weekend
21:32:55 <ttx> ok, let's wrap up
21:33:05 <ttx> #endmeeting