21:01:37 <ttx> #startmeeting
21:01:38 <openstack> Meeting started Tue Feb 15 21:01:37 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:38 <soren> o/
21:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:50 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:57 <ttx> Today's agenda is at:
21:02:01 <ttx> #link http://wiki.openstack.org/Meetings
21:02:15 <ttx> No actions from last week meeting
21:02:24 <ttx> #topic Current release stage: Development
21:02:35 <ttx> We are now well into the development stage.
21:02:48 <ttx> Merge proposals are starting to pile up, so -core people don't forget to spend some time on reviews
21:03:03 <ttx> We now almost have the final Cactus plans up on http://wiki.openstack.org/releasestatus/
21:03:16 <ttx> (btw this page now displays branch links so you can easily look up work in progress)
21:03:32 <ttx> Note that these "plans" are for tracking purposes, it should never prevent you from coding, we can always catch up later.
21:03:43 <ttx> I think Glance is complete, Nova is almost done, Swift is still todo
21:03:44 <annegentle> ttx: woo for branch links
21:04:00 <ttx> creiht: do you think we can get Swift plans done by next week ?
21:04:18 <ttx> annegentle: thanks. I had to fix Launchpad so that they would work.
21:04:18 <johnpur> ttx: how are we tracking items for the stability goals?
21:04:55 <dendrobates> right now we I don't think we are, but we need bp's for them
21:05:07 <ttx> johnpur: stability is not really a feature... so it's more about having a testing effort to uncover the bugs then track bug fixing
21:05:12 * soren has no clue what to write in such a blueprint.
21:05:25 <dendrobates> it depends
21:05:35 <dendrobates> some of what soren is doing is bug hunting
21:05:39 <johnpur> we need to get this in a measurable form
21:05:48 <justinsb> Do we have integration tests?  That would work...
21:05:51 <dendrobates> but Jay plans on doing some autoomated testing work and that can be a bp
21:06:06 * soren has some automated testing going
21:06:12 <ttx> sometimes there is an area of improvement that can also make up a blueprint. For example "resilience to instance failure"
21:06:27 <dendrobates> soren: that all needs bp's then
21:06:45 <dendrobates> at least so you and jaypipes don;t do the samer work
21:06:59 <ttx> johnpur: so you have some efforts that can be tracked as BPs, for the rest it's about measuring progress in bug fixing
21:07:04 <johnpur> who should own the whole "stability/resiliancy/testing/qa" effort?
21:07:09 <soren> Hmm... Yeah.
21:07:26 <johnpur> we need good descriptions of the objectives and plans to meet them
21:07:42 <johnpur> or else we will be no better than we have been in the past
21:07:45 <soren> Someone who has access to a bunch of hardware would be a good person to be on top of this.
21:08:03 <johnpur> rackspace is putting up 188 hosts
21:08:28 <soren> That's what I hear. I just don't think they'll turn up on my doorstep :)
21:08:34 <johnpur> lol
21:08:41 <dprince> Are these test we plan on running on every build?
21:08:42 <soren> Or so I hope.
21:09:04 <johnpur> jaypipes: what is your plan?
21:09:56 <ttx> johnpur: so far it's been a shared effort, but I understand the need for a vision on this, with objectives and measurable results
21:10:57 <ttx> johnpur: maybe we can start a public discussion on the vision part, see if some natural leader emerges for this ?
21:11:09 <johnpur> ttx: sounds like a good idea
21:11:09 <dendrobates> My opinion is that jaypipes should lead the efforts
21:11:22 <dendrobates> he seems to be missing today
21:11:22 <johnpur> jaypipes is doing some of this now
21:11:41 <ttx> #action ttx and johnpur to ensure the stability goals are defined and properly tracked
21:11:54 <ttx> johnpur: i'll be in touch with you about it.
21:12:00 <johnpur> awesome!
21:12:09 <ttx> dendrobates: you wanted to talk about some of the Nova blueprints ?
21:12:21 <dendrobates> sure
21:12:21 <ttx> johnpur: I probably can't lead it, but I can definitely facilitate it.
21:12:55 <dendrobates> everything has been reviewed and approved unless you have heard from me
21:13:09 <dendrobates> with the exception of a few bps that I have questions about
21:13:20 <dendrobates> or that seem like duplicate efforts
21:13:28 <ewanmellor> dendrobates: I see the "No spec link" warning triangle on http://wiki.openstack.org/releasestatus/.  Does this mean that you aren't approving blueprints if they don't have a spec link?
21:13:57 <dendrobates> in general that is the case.  I made at least one exception
21:14:27 <dendrobates> where the work was an extension of an existing feature
21:14:50 <ewanmellor> I note that xenapi-vlan-network-manager has a lot of text in the whiteboard, rather than a separate spec page.
21:15:32 <dendrobates> ewanmellor: there were a couple like that, IMHO that is equivalent
21:15:45 <jaypipes> johnpur, dendrobates: sorry, stepped away for a sec.
21:16:00 <johnpur> pvo: or other RAX cloud guys... looking at the 51 BP's, does this encompass everything RAX needs to start preparing to transition to Nova?
21:16:09 <ttx> ewanmellor, dendrobates: once the spec is approved, the warning goes away.
21:16:37 <dendrobates> also some specs are not set 'pending approval'
21:16:52 <dendrobates> so I assumed those are not ready.
21:17:03 <troytoma_> johnpur: that is everything we know about
21:17:11 <ewanmellor> dendrobates: Oh, makes sense.  I shall chase ours in the morning then.
21:17:15 <dendrobates> I also set one bp back to drafting for more info
21:17:19 <johnpur> trotoma_: thx!
21:17:27 <ttx> dendrobates: some of those "non-pending-approval" already have branches proposed
21:17:42 <ttx> so it's probably an oversight
21:17:55 <jaypipes> re: testing, I've had a few conversations with termie, but nothing solid yet. haven't had a chance to focus on the CI testing yet, sorry.
21:17:55 <dendrobates> ttx: ok, I'll look at them asap
21:18:10 * ttx votes to duplicate jaypipes
21:18:18 <dendrobates> btw, it's awesome that so many people are attaching branches to their bps
21:18:23 <johnpur> dendrobates: are we targeting to diablo now?
21:18:51 <dendrobates> johnpur: not yet, but I think we need to get that started asap
21:19:00 <johnpur> me too...
21:19:01 <ttx> #action ttx to create the diablo series
21:19:21 <ttx> ok, anything more on the cactus plans front ?
21:19:35 <dendrobates> not from me.
21:19:57 <ttx> ok, moving on...
21:20:02 <ttx> #topic Nova 2011.1.1
21:20:20 <ttx> For those who missed last week meeting, we'll have a 2011.1.1 update for Nova Bexar so that we include missing files in the released tarballs (bugs 714678 and 714679).
21:20:25 <ttx> #link https://bugs.launchpad.net/nova/+milestone/2011.1.1
21:20:37 <ttx> That said we have a number of other bugfixes that are candidates for inclusion in 2011.1.1
21:20:42 <ttx> #link https://bugs.launchpad.net/nova/+bugs?field.tag=bexar-post-release
21:20:55 <ttx> From bug comments I've identified two candidates, anything else you want to be considered ?
21:21:14 <ttx> I'd like us to discuss which should be included. I'd rather have a limited list of showstopper fixes, so that we limit the risk of regression
21:21:31 <ttx> Also I'd like the fixes to be committed in Cactus before they are shipped in 2011.1.1, so the more we add the more we delay 2011.1.1
21:21:47 <ewanmellor> The eventlet ones that Soren worked on looked serious.
21:21:53 <ewanmellor> And easy to fix
21:22:09 <dendrobates> +1 on that
21:22:09 <ttx> soren do you think we should ship the fix for that one ?
21:22:41 <ewanmellor> https://bugs.launchpad.net/nova/+bug/718390
21:22:43 <soren> Jm...
21:22:44 <soren> Hm..
21:22:54 <soren> I'm not sure.
21:23:02 <ewanmellor> https://bugs.launchpad.net/nova/+bug/716427
21:23:04 <soren> It depends on a patched eventlet.
21:23:10 <ewanmellor> Those two are the ones I was thinking of.
21:23:26 <soren> The RPC one, sure.
21:23:41 * ttx adds tags to both so that we discuss them
21:23:42 <soren> The eventlet one...
21:24:01 <jaypipes> sorry guys, in a few conversations now...
21:24:03 <soren> No, I don't think I want that one backported.
21:24:25 <ttx> Candidate list updated at https://bugs.launchpad.net/nova/+bugs?field.tag=bexar-post-release
21:24:34 <soren> It requires a version of eventlet that is not only different than the one required by what we released with bexar, but is not even available from upstream yet.
21:24:39 <ttx> let's go through them one by one
21:24:39 <soren> Not even in their VCS.
21:24:51 <soren> Without that part, Nova won't work at all.
21:25:00 <ttx> bug 718390
21:25:14 <soren> No uvirtbot?
21:25:26 <soren> bug 718390
21:25:31 <uvirtbot> Launchpad bug 718390 in nova "Filedescriptor leak and zombie processes" [High,Fix committed] https://launchpad.net/bugs/718390
21:25:34 <soren> There we go.
21:25:45 <ttx> soren: so you -1 that one ?
21:25:58 <soren> Yes.
21:26:10 <dendrobates> I think that takes it out of the running
21:26:18 <ttx> bug 713430
21:26:19 <uvirtbot> Launchpad bug 713430 in nova "Restart of nova-volume with volumes in wrong state: global name 'volume_ref' is not defined" [High,Fix committed] https://launchpad.net/bugs/713430
21:26:27 <ttx> +1
21:26:37 <soren> +1 for sure
21:27:13 <ttx> vishy left with the split but I know he wanted that one in
21:27:16 <Ryan_Lane> can bug 714889 also be added for bexar-post-release?
21:27:16 <uvirtbot> Launchpad bug 714889 in nova "GetConsoleOutput in EC2 api requires InstanceId.1, when it should use InstanceId" [Undecided,Fix committed] https://launchpad.net/bugs/714889
21:27:33 <ttx> Ryan_Lane: adding to the list for consideration
21:27:40 <Ryan_Lane> thanks
21:28:01 <ttx> done
21:28:07 <ttx> bug 718675
21:28:08 <uvirtbot> Launchpad bug 718675 in nova "Can't create db with PostgreSQL backend" [Medium,In progress] https://launchpad.net/bugs/718675
21:28:12 <ttx> +0
21:28:22 <ttx> jaypipes: you proposed this one ?
21:29:05 <dendrobates> -1
21:29:17 <dendrobates> there is a workaround, don't use postgres
21:29:23 <soren> heh
21:29:38 <ttx> bug 714889
21:29:38 <uvirtbot> Launchpad bug 714889 in nova "GetConsoleOutput in EC2 api requires InstanceId.1, when it should use InstanceId" [Undecided,Fix committed] https://launchpad.net/bugs/714889
21:30:28 <soren> Again?
21:30:33 <soren> Oh.
21:30:34 <soren> Heh
21:30:48 <ttx> This one sounds rather limited to me, hardly a showstopper ?
21:30:58 <ttx> Ryan_Lane: rationale for inclusion ?
21:31:20 <Ryan_Lane> I can't pull console output in my web interface, and i'd like to not have to patch :)
21:31:41 <dendrobates> ttx: however the fix is not risky
21:31:59 <soren> Yeah, it looks pretty safe to me.
21:32:04 <ttx> dendrobates: then +1 it :)
21:32:04 <dendrobates> +1 it affects Ryan and is trivial
21:32:10 <Ryan_Lane> thanks
21:32:34 <ttx> bug 716427
21:32:35 <uvirtbot> Launchpad bug 716427 in nova "RPC concurrency problem" [Undecided,Fix committed] https://launchpad.net/bugs/716427
21:32:55 <dendrobates> +1
21:32:58 <ttx> I think we +1d it in previous discussion
21:33:23 <johnpur> agree +1
21:33:26 <ttx> OK, I'll summarize the results and post it to ML for people that missed the meeting
21:33:44 <jaypipes> ttx: no, not that I know of.
21:34:03 <ttx> #action ttx to target bugs to 2011.1.1 and post proposed list of fixes for last-minute comments
21:34:19 <ttx> jaypipes: ISTR you commented in that direction on the BMP
21:34:20 <soren> What's the plan for testing this point release?
21:34:40 <johnpur> ttx: once we release 2011.1.1 do we start discussing 1.2?
21:34:52 <ttx> johnpur: I don't think so.
21:34:57 <soren> I sure hope we won't do a 1.2.
21:35:18 <johnpur> we won't know if we don't look at the bugs?
21:35:39 <ttx> johnpur: did the POC rule a point release policy yet ?
21:36:02 <johnpur> ttx: good q for any of the poc members on today?
21:36:05 <soren> johnpur: I don't think we'd even be evaluating this list of bugs if it hadn't been for the one about a bunch of stuff missing from the tarball.
21:36:20 <ttx> Last time I asked the decision was that Nova was too fast-moving to warrant point releases
21:36:31 <ttx> soren: exactlty
21:36:32 <johnpur> soren: the question is whether we should
21:36:55 <ttx> johnpur: I'd say, not for Bexar, but we need the policy decided before we release Cactus
21:37:08 <dendrobates> I like the way kvm did it.
21:37:08 <soren> The way I see it, the bugs would have to be rather devastating to warrant a fresh tarball.
21:37:15 <johnpur> gets back to the stability questions, are we keeping trunk runnable now?
21:37:33 <dendrobates> they let the distros handle backporting bugs until things slowed down
21:37:34 <soren> If/when we decide to do a point release to address the devastating bug, we can include a few other simple/important fixes.
21:37:37 <ewanmellor> The POC has another meeting this Thursday.  Last week's overran.
21:37:47 <soren> ...but I don't think we should plan to do one.
21:38:02 <ttx> let's defer to the POC on that question.
21:38:48 <ttx> #action POC to rule on point release policy for the different projects
21:39:19 <ttx> #topic Open discussion
21:39:37 <Ryan_Lane> siebrand from translate wiki heard the openstack talk at fosdem and is really excited about the project (and wikimedia's involvement), and was wondering if you guys would like translation support through translate wiki.
21:39:42 <ewanmellor> POC wanted to go back to Ubuntu et al and see if that was something that they were happy with doing (doing our point-release dirty work for us)
21:40:17 <Ryan_Lane> translate wiki does localization for mediawiki, and a number of other projects, and the translations are done by an army of volunteers
21:40:26 <Ryan_Lane> they support a couple hundred languages well
21:40:32 <berendt> how is the status about the rewrite/extension of nova-manage
21:40:41 <Ryan_Lane> (mediawiki has at least some support for over 300 languages, for instance)
21:40:45 <berendt> how is the status about adding/extending schedulers
21:40:52 <dendrobates> Ryan_Lane: for docs, not code right?
21:40:56 <Ryan_Lane> code
21:41:01 <dendrobates> ah
21:41:39 <Ryan_Lane> he's also fairly good at helping with ways to better support localization in code
21:42:12 <ttx> Ryan_Lane: we used Rosetta so far with surprisingly good results, and jaypipes/mtaylor just finalized automated that, I'd hate to change translation communities now :)
21:42:29 <berendt> how is the status about replacing rabbitmq with something other (i forgot with what, somebody noted  a python-framework)
21:42:49 <soren> I doubt we'll replace rabbit.
21:42:49 <Ryan_Lane> ok. will let him know :)
21:42:50 <dendrobates> but we'll keep it in mind if we have problems and we might need document and wiki translations
21:42:55 <berendt> how is the status about supporting more databases, oracle for example
21:43:21 <soren> berendt: We support whatever sqlalchemy supports.
21:43:33 <ttx> Note that the live migration branch is back for review, so please give it a look.
21:43:34 <soren> berendt: (that includes Oracle)
21:43:39 <ttx> Let's try not to repeat the same mistakes :)
21:43:52 <dendrobates> soren: but that does not mean that is is tested
21:44:05 <soren> dendrobates: Indeed.
21:44:06 <johnpur> ttx: please! Let's jump on this early.
21:44:12 <ttx> termie: ^
21:44:45 <berendt> dendrobates: at the moment only MySQL is tested, right?
21:44:52 <ttx> dendrobates: as was pretty apparent when someone tried to use Bexar with postgres
21:45:02 <ttx> berendt: and sqlite.
21:45:37 <berendt> ttx: I don't think that sqlite is a option for a productive environment..
21:45:52 <soren> Not at all.
21:45:53 <dendrobates> berendt: you might be surprised
21:46:26 <johnpur> swift uses sqlite extensively
21:46:46 <ttx> soren: about the plan for testing the point release, I thought we could do SRU-like test cases to validate that the bug is fixed
21:46:57 <berendt> but status to nova-manage and the scheduler is more important to me at the moment
21:47:58 <ttx> soren: using some 2011.1.1~rc
21:48:17 <soren> ttx: That *might* work.
21:48:33 <johnpur> ttx: can we not use the tilde?
21:48:49 <soren> ttx: I'm just worried about regressions. These are not discrete packages.
21:49:09 <ttx> johnpur: that was a metaphoric tilde.
21:49:28 <johnpur> lol, I just don't want a repeat of tilde-gate!
21:50:40 <ttx> soren: I'll give it a thought. Will be difficult to gather lots of resources on testing that post-release
21:50:56 <soren> ttx: Yes, it will.
21:50:59 <ttx> so i'd rather be conservative in what we accept to land
21:51:08 <soren> That's part of my reservation about point releases.
21:52:04 <ttx> ok, time to wrap up, let's continue the open discussion on #openstack if needed
21:52:21 <ttx> #endmeeting