21:00:42 <jbryce> #startmeeting
21:00:43 <openstack> Meeting started Thu Feb 17 21:00:42 2011 UTC.  The chair is jbryce. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:45 * creiht bows
21:00:45 <vishy> jesse and I only have 1/2 hour as well
21:00:52 <vishy> so lets go quick :)
21:01:05 <jbryce> fine with me...agenda is here: http://wiki.openstack.org/Governance/POC
21:01:39 <jbryce> #topic Image format proposal
21:02:19 <jbryce> after the meeting last week, john circulated some additional comments and clarification on the image format proposal. did you all see that thread?
21:02:29 <dendrobates> yep
21:02:31 <vishy> yes
21:03:08 <jbryce> it seems like ewan got his questions answered and the initial scope of the image interchange format is narrowed to interop between openstack clouds
21:03:34 <jbryce> are there any other outstanding questions or concerns on that proposal?
21:03:41 <vishy> no it lgtm
21:03:49 <dendrobates> me too
21:04:14 <jbryce> ok...let's take a vote on approving it
21:04:31 * creiht doesn't vote as I have no background in this area
21:04:40 <dendrobates> +1
21:04:57 <soren> +1
21:04:59 <jesse_> +1
21:05:04 * soren is here, too :)
21:05:27 <jbryce> +1
21:05:42 <jbryce> vishy, jmckenty: any desire to vote?
21:06:16 <vishy> +1
21:06:22 <vishy> oh sorry thought my lgtm counted
21:06:24 <vishy> :)
21:06:25 <jbryce> ewanmellor: hi ewan...we were just voting on the image format proposal now that john circulated the updated comments
21:06:25 <ewanmellor> Sorry I'm late -- my last call overran.
21:06:31 <ewanmellor> +2
21:06:34 <ewanmellor> Ha
21:06:40 <ewanmellor> That was meant to be a +1 ;-)
21:06:50 <ewanmellor> But now it looks like I'm _really_ in favour!
21:06:55 <dendrobates> btw, there had been some licensing concerns about vhd.  RS legal and outside FOSS legal has looked at it and said we are fine
21:07:06 <jbryce> #agreed ImageFormat proposal approved with 6 approves
21:07:23 <ewanmellor> Good -- Citrix is already shipping open-source VHD code, so it would be a shame if that wasn't legal!
21:07:35 <jbryce> all right...moving on
21:07:37 <jbryce> #topic versioning and minor releases
21:08:51 <jbryce> #info proposal floated last week was that all projects should line up for the major releases on a fixed time schedule but that individual projects would have the flexibility to do an intermediate release if the core team felt it was needed. the release manager would facilitate the process and work to ensure quality
21:09:18 <jbryce> this seems to be the general approach that we are following currently with the one-off for bexar in nova
21:09:35 <vishy> I'm ok with that, we definitely need a .1 release in nova, there are some pretty nasty bugs
21:09:40 <jesse_> I like this approach - what does swift thing?
21:09:42 <jesse_> think
21:09:51 <creiht> jesse_: it was my idea :)
21:09:59 <creiht> +1 for me
21:10:06 <jesse_> sorry, was on a plane last week ...
21:10:19 <creiht> we will likely want to do a 1.2.1 release in the near future
21:11:18 <jesse_> +1
21:11:24 <jbryce> i'm ok with the proposal to give projects the flexibility to do what they need to, but i think it would be good to flesh out some sort of additional plan that makes it a little more clear how we work with downstream distributors
21:12:55 <jbryce> so creiht, jesse_, vishy are all on board--do the rest of you have any thoughts on it?
21:13:03 <jesse_> jbryce: is this something that we can say for the next two releases
21:13:05 <dendrobates> we need a plan to support releases
21:13:14 <dendrobates> creating releases is easy
21:13:31 <creiht> dendrobates: yeah that is the next step once we decide that we are going to have point releases
21:13:35 <jesse_> jbryce: and re-evaluate post-diablo
21:13:43 <creiht> dendrobates: I think that should be up to the individual projects as well
21:14:28 <dendrobates> maybe, but is there is a combined integrated release, people expect the same support period
21:14:41 <jbryce> creiht: i think it would be nice for there to be some consistency at that level across openstack projects. if i'm a user, i would prefer to have at least a general idea of what to expect in terms of ongoing support and patching across all the projects
21:15:35 <jbryce> especially in terms of timing...if swift eols every 6 months and nova every 18 months and i'm using them both, that would be a pain
21:15:43 <creiht> In my view the point releases would be bug fix/security fixes only
21:15:45 <creiht> not features
21:16:09 <creiht> jbryce: ahh good point
21:16:28 <soren> creiht: Certainly.
21:16:36 <dendrobates> I agree, but for how long are you going to release bug fixes for a major release?  that is where we need to standardize
21:16:53 <soren> I can see why there might be some divergence here.
21:17:08 <soren> Swift is way more mature than Nova. Doing bug fix releases further back makes more sense for Swift.
21:17:08 <creiht> What I was thinking for swift is that we would support the last released version
21:17:21 <soren> ...or not :)
21:17:23 <soren> Ok :)
21:17:24 <creiht> heh
21:17:31 <jbryce> haha
21:17:38 <jbryce> 3 month eol cycle
21:17:39 <creiht> I don't see many more big number releases for swift down the road
21:18:10 <creiht> We are even stretching to call cactus a 1.3 release for swift
21:18:14 * soren puts that in a Quotes file.
21:18:18 <creiht> lol
21:18:28 <soren> I *know* that will come in handy some day :)
21:18:46 <jbryce> so...i kind of like jesse_'s idea where we say for the next two release cycles we leave it up to the projects and during that time, come up with a unified plan that will be the default across projects
21:19:13 <jesse_> around that time is when distros will start playing a major role
21:19:16 <creiht> agreed
21:19:28 <dendrobates> I really like the way kvm handled supporting releases when they started out
21:19:40 <creiht> I expect this to change down the road as all the projects mature more, and as more projects are brought in
21:19:50 <jesse_> dendrobates: how was that?
21:19:50 <dendrobates> they made the distros do any packporting, until the rate of change slowed
21:20:19 <creiht> If nothing else, the backporting/point releases makes it easier for us to manage swift releases to RS
21:20:19 <dendrobates> soren did kvm backporting for ubuntu until the started maintaining a stable branch
21:21:45 <jbryce> we don't have very broad distribution support right now
21:22:00 <soren> Nor did kvm :)
21:22:40 <dendrobates> we will soon, both fedora and ubuntu
21:22:55 <soren> And Debian.
21:23:07 <creiht> When that happens, we can re-evaluate :)
21:23:17 <jbryce> we seem to already have quite a few users who are not consuming it through a distro
21:23:20 <jesse_> creiht: +1
21:23:41 <jesse_> as openstack + distro story matures we shoudl re-evalute
21:24:32 <dendrobates> and then once the rate of feature change slows we should reevaluate again
21:24:40 <jesse_> sounds good
21:24:41 <jbryce> ok
21:24:44 <jbryce> #info revised proposal is to allow project core teams to decide to do point releases, facilitated by the release manager up to the diablo release
21:25:39 <jbryce> #info follow up with a unified release plan that takes into accounts division of upstream/downstream labor and support time frames
21:26:12 <jbryce> can we vote on the revised proposal?
21:26:26 <ewanmellor> +1
21:26:26 <creiht> +1
21:26:28 <soren> sure
21:26:29 <soren> +
21:26:31 <soren> +1
21:26:47 <dendrobates> +1
21:26:48 <jesse_> +1
21:26:56 <jbryce> +1
21:27:10 <jbryce> #agree revised proposal agreed to with 6 approves
21:27:28 <jbryce> #action jbryce to document and add to wiki
21:27:56 <jbryce> so we've only got a couple of minutes before several have to leave...do we want to postpone the other items and meet again next week?
21:28:20 <dendrobates> +1
21:28:57 <creiht> sure
21:28:59 <creiht> +1
21:29:20 <jbryce> i'm sure jesse and vish agree since they have to leave. = )
21:29:26 <creiht> hehe
21:29:49 <jesse_> +1
21:30:14 <jesse_> although we might be able to keep going with 2 meetings at once
21:30:37 <jbryce> soren, ewanmellor: do you guys want us to try to alternate meeting times to something that's more normal for you?
21:31:08 <ewanmellor> I'll be in Santa Clara next week.
21:31:44 <soren> jbryce: Possibly.
21:32:17 <soren> jbryce: I've tried that a number of times, but it usually just ends up being at dinner time which is way worse than late evening.
21:32:57 <jbryce> soren: are you utc+1?
21:33:15 <soren> jbryce: At the moment, yes.
21:33:24 <soren> For another month and a half.
21:33:35 <soren> -ish.
21:33:56 <ewanmellor> soren: Where are you going?
21:34:07 <soren> Nowhere.
21:34:13 <soren> The Earth is.
21:34:42 <soren> (DST change)
21:34:51 <ewanmellor> :-)
21:35:06 <jbryce> well...i'm open to whatever as far as the time. i think you two have the biggest offset, so let us know if you want to alternate and make jesse, vish and josh wake up early for a change.
21:35:37 * jbryce offended jmckenty and he left
21:36:12 <jbryce> for now, we'll plan on same time next thursday. i'll send out a note and the leftover agenda items.
21:36:17 <creiht> k
21:36:36 <jbryce> thanks guys!
21:36:38 <jbryce> #endmeeting