21:10:44 <jbryce> #startmeeting
21:10:45 <openstack> Meeting started Thu Feb 24 21:10:44 2011 UTC.  The chair is jbryce. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:10:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:11:13 <jbryce> agenda located at http://wiki.openstack.org/Governance/POC
21:11:58 <jbryce> #topic Google Summer of Code
21:12:19 <vishy> I liked termie's suggestion, which was to skip GSoC this year
21:12:21 <jbryce> #info Ewan wanted us to discuss participation (or non-participation) in GSOC
21:12:34 <vishy> I don't think we have anyone with enough time to mentor atm
21:12:37 <jbryce> i believe that was dendrobates preference as well
21:12:56 <anotherjesse> I agree .. I'd love to participate
21:12:58 <anotherjesse> but timing
21:13:11 <dendrobates> yes, and that half-assing it would be detrimental
21:13:30 <vishy> me too, i think it would be really fun but I am stretched too thin
21:13:51 <jbryce> ok. so it sounds like our recommendation is to skip it this year.
21:14:05 <Interrante> Skip is my preference
21:14:07 <dendrobates> +1
21:14:11 <anotherjesse> +1
21:14:20 <Interrante> +1
21:14:26 <vishy> +1
21:14:49 <jbryce> #agreed Skip participation (with our regrets) in Google Summer of Code this year due to lack of resources availability
21:15:03 <tr3buchet> +1
21:15:03 <jbryce> #topic Incubation/new project process
21:16:05 <jbryce> we had a proposal a couple of weeks ago to open up the new project/incubation process to a more organic, community driven method
21:16:20 <anotherjesse> jbryce: is there a summary of the proposal?
21:16:22 <dendrobates> I think we need criteria for inclusion, at least
21:16:51 <vishy> we can start with just a wiki page for related projects
21:17:17 <anotherjesse> dendrobates: the projects naming can't be "openstack FOO" until done with incubation
21:17:18 <vishy> then draft a incubation proposal process
21:17:56 <anotherjesse> dendrobates: what criteria would you propose?
21:18:02 <dendrobates> I mean what is the scope of openstack.    What is appropriate to be part of openstack at all.
21:18:25 <anotherjesse> dendrobates: something being in incubation needs to not imply that it is "part of openstack"
21:18:43 <dendrobates> but it does imply that it could be
21:18:46 <anotherjesse> it is more "affiliated with openstack" and a statement from the incubated project that they want to be part eventually
21:18:56 <jbryce> vishy: anyone could do a wiki already. i think people who are looking at including their projects are looking for that incubation process
21:18:59 <anotherjesse> but they have to earn it
21:19:33 <anotherjesse> dendrobates: I kinda like the idea of how plugins happen to rails/django/...
21:19:49 <jbryce> the other part we had discussed was a userscripts.org style directory that would give some indication about the quality/popularity of the projects
21:20:18 <anotherjesse> having a large community and when projects get enough momentum/support they can be migrated into core
21:20:23 <dendrobates> I don't think popularity is a good measure
21:20:30 <Interrante> +1. On django style approach
21:20:55 <dendrobates> I'm not familar with how django does it
21:21:50 <anotherjesse> dendrobates: http://www.djangopackages.com/
21:22:24 <dendrobates> my other concern is about killing a healthy ecosystem by choosing one member to be official.
21:22:38 <anotherjesse> dendrobates: right - that is my concern as well
21:23:13 <anotherjesse> dendrobates: my hope is that our process is more of a community process
21:23:30 <anotherjesse> where people decide that using X + Y + Core is a good deploy of openstack
21:23:45 <dendrobates> anotherjesse: I agree, but I think we need to publish some guidelines
21:24:27 <anotherjesse> dendrobates: part of the idea is that things need to live in the community for a period (3+ months?) and get community adoption before it is decided to be added to core
21:25:04 <anotherjesse> we can separate the discussion about the requirements for incubation and becoming an official part of openstack
21:25:31 <dendrobates> agreed
21:25:47 <jbryce> incubation isn't really incubation then, though. it's just a directory of related software.
21:26:42 <dendrobates> unless there is a path out, then it is incubation.
21:27:01 <jbryce> things are incubated to make it to an end state. and it involves actions along the way
21:27:08 <anotherjesse> the path exists, it is just not formal ;)
21:28:34 <dendrobates> maybe there are multiple paths, one to become part of core, and one to some other state, i.e. affiliated
21:29:12 <anotherjesse> the idea of having a directory of related pojects
21:29:27 <anotherjesse> is probably generally agreeable
21:29:43 <anotherjesse> and in the end probably becoming part of openstack == POC vote?
21:30:13 <jbryce> i don't think there's much to agreeing that we should have a listing of software related to openstack. anyone can do that--list in the wiki or otherwise. i think the difficult part is how do things move to being more officially "openstack" and that's what people want to have us give direction on
21:32:05 <vishy> i don't know if there is much "discussion" possible here
21:32:21 <vishy> someone needs to just come up with a basic proposal that we can straw-man against
21:32:52 <anotherjesse> the idea that in the end it is a POC vote - agreeable?
21:33:01 <anotherjesse> if so, we can figure out the middle :)
21:33:03 <dendrobates> anotherjesse: yes
21:33:05 <jbryce> haha
21:33:07 <vishy> agreed
21:33:10 <Interrante> Yes
21:33:55 <jbryce> #agreed A directory would be a useful way of exposing related projects
21:34:18 <jbryce> #agree to become an official openstack project requires a POC vote
21:34:52 <jbryce> #todo determine the process and criteria by which the POC would evaluate and vote on a project for inclusion
21:35:33 <jbryce> vishy: i did lay a strawman out back in october or whenever. do we want to start there or start from scratch?
21:35:58 <vishy> we can start there
21:36:20 <jbryce> ok...i'll send that around again and we can discuss how to improve
21:36:30 <jbryce> #topic Standards body activity
21:36:56 <anotherjesse> standards are good - let's go shopping!
21:37:00 <anotherjesse> err, hard
21:37:05 <dendrobates> I think the standards bodies are distractions
21:37:11 <jbryce> http://wiki.openstack.org/Governance/Proposed/StandardsCommittee
21:38:00 <jbryce> bret piatt has been talking with most of these standards bodies and put together a proposal to form a committee of people who wanted to participate in these on openstack's behalf (rather than him continuing to do it alone)
21:38:29 <vishy> proposal seems fine
21:38:41 <vishy> as long as i don't need to be on the comittee
21:38:43 <vishy> :)
21:38:44 <jbryce> haha
21:38:59 <jbryce> i'd propose it be volunteer driven
21:38:59 <anotherjesse> that's what speakphone + mute is for
21:39:08 <anotherjesse> jbryce: ya
21:40:36 <jbryce> ok
21:41:08 <jbryce> we've lost mark--that puts us down to only 4
21:41:23 <anotherjesse> jbryce: we should probably require that the members don't speak on behalf of openstack
21:41:35 <vishy> my battery is toast
21:41:41 <vishy> i'll look over jesse's shoulder
21:42:27 <dendrobates> I think the goal should be to follow the stds and report back to the community, while advocating for openstack
21:43:10 <anotherjesse> dendrobates: my only concern is that if it is any volunteer, they could mis-represent openstack
21:43:26 <dendrobates> anotherjesse: I agree
21:43:43 <jbryce> following and reporting back shouldn't present problems
21:43:53 <dendrobates> and those organizations tend to be very political
21:44:38 <anotherjesse> might be too corporate -- but we could have a statement on the website that "opinions from community members may not reflect those of openstack"
21:45:04 <jbryce> what if there's something that it would be good for openstack to be represented (not mis-represented on)
21:45:12 <dendrobates> well than what opinions do represent openstack?
21:46:03 <jbryce> perhaps the committee chair should be approved by the POC and be responsible for laying out the official positions/opinions that the members are supposed to propagate?
21:47:38 <dendrobates> since we all have different opinions I don't know what official openstack opinions are.
21:47:42 <jbryce> haha
21:48:06 <jbryce> ok. i'll toss this back to bret and see if he has a suggestion
21:48:08 <anotherjesse> dendrobates: I think that is healthy
21:48:10 <dendrobates> I think we need to avoid the appearance of openstack opinions == rackspace opinions
21:48:26 <dendrobates> anotherjesse: me too
21:48:45 <anotherjesse> dendrobates: just as long as an individual's opinion is not interpretted as the openstack standard
21:48:46 <dendrobates> I don't want fox news style talking points
21:48:50 <anotherjesse> heh
21:49:26 <jbryce> #topic next meeting time
21:50:15 <dendrobates> same bat time, sams bat channel?
21:50:19 <jbryce> we're missing several, so we'll probably move this to the mailing list, but i'm traveling next thursday. so we can go ahead and let someone else chair, move to a different day next week, or skip
21:50:51 <anotherjesse> 13 days from now? (a wednesday)
21:51:16 <Interrante> 13 good for me
21:51:33 <anotherjesse> Mar 7th
21:51:47 <anotherjesse> err, Mar 9th
21:52:13 <jbryce> if we push that far, any reason not to just do it on thursday the 10th in our regular time?
21:52:42 <dendrobates> nope, wfm
21:52:54 <anotherjesse> 1pm PDT is hard for vish & I
21:53:01 <anotherjesse> if we did it an hour earlier it would work better
21:53:17 <anotherjesse> (vish & I have sprint planning at 1:30pm PDT)
21:53:18 <dendrobates> probably better for ewan and soren too
21:53:39 <jbryce> fine with me. i'll send a note out to the list
21:53:47 <anotherjesse> jbryce: email about noon PDT thursday march 10th
21:53:49 <anotherjesse> cool
21:53:58 <Interrante> Good for me
21:53:58 <jbryce> anyone have anything else?
21:54:31 <anotherjesse> nope
21:54:46 <jbryce> thanks for the time
21:54:48 <jbryce> #endmeeting