21:00:47 <ttx> #startmeeting
21:00:48 <openstack> Meeting started Tue Mar 8 21:00:47 2011 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:00 <ttx> Welcome everyone to our weekly team meeting...
21:01:11 <ttx> Today's agenda is at:
21:01:16 <ttx> #link http://wiki.openstack.org/Meetings
21:01:26 * ttx checks for late additions
21:01:33 <sirp_> howdy
21:01:37 <jaypipes> yo.
21:01:41 <ttx> #topic Actions from previous meeting
21:01:50 <ttx> * pvo to readjust prios for xs-resize and xs-migration: DONE
21:02:06 <ttx> #topic Current release stage: Development
21:02:19 <ttx> We are 9 days from BranchMergeProposalFreeze (March 17).
21:02:35 <ttx> Your branches should be proposed by then, so that we have the time to properly review and merge them before FeatureFreeze (March 24).
21:02:55 <ttx> That only affects "feature" branches, not bugfix branches.
21:03:22 <ttx> Any questions on that stage ?
21:04:00 <jaypipes> not from me.
21:04:04 <ttx> ok, moving on.
21:04:15 <ttx> #topic Cactus Release status
21:04:22 <ttx> Please check:
21:04:27 <ttx> #link http://wiki.openstack.org/releasestatus/
21:04:43 <ttx> Note that we have a few significant Nova BMPs (branch merge proposals) coming up that are not reflected in the plan:
21:04:55 <ttx> openstack-api-volumes, authn_and_authz, constraint-scheduler...
21:05:04 <ttx> I guess that brings up a question.
21:05:20 <ttx> We have lots of planned features that won't get delivered due to lack of resources...
21:05:37 <ttx> And ~100 open bugs in a release focused on stability... and yet we have unplanned features proposed for landing.
21:05:47 <ttx> Are we (as a project) doing something wrong ?
21:05:54 <jaypipes> and lots of branches proposed for things that *aren't* in the proposed release...
21:06:03 <ttx> Is it difficult to predict every three months the features we'll want to land during the short feature merge window we have ?
21:06:18 <ttx> Is it a consequence of not having a design summit at the start of the cycle, so we miss a catalyst ?
21:06:35 <jaypipes> ttx: no, frankly, I think people are just working on whatever they want to regardless of whether it's in the release plan for Cactus or not. Sorry if I'm being blunt here.
21:06:41 <ttx> Or is it that we are lazy to wait/defer them to the next cycle ?
21:06:42 <justinsb> I think you're addressing the #1 problem, which is not having a decision maker on each project
21:06:51 <dendrobates> I think we are suffering from different groups having different priorities
21:06:58 <jaypipes> yes
21:07:05 <jaypipes> on both dendrobates and justinsb
21:07:08 <pvo> dendrobates: ++
21:07:22 <soren> Yeah. There's a clear disconnect between the priorities set on the blueprints and the actual priorities of the various development teams.
21:07:38 <dendrobates> I don't mean on blueprints
21:07:48 <soren> Well, that's relevant, too.
21:07:57 <soren> Since that's what is publically "known".
21:07:58 <ttx> dendrobates: how do you see us fixing this ? Having a plan is quite essential to communicating what we are doing outside the project
21:08:03 <soren> Where "known" really means "thought".
21:08:37 <jaypipes> ttx: there *is* a plan. it's been a plan since the summit. it's that a number of folks aren't particularly interested in that plan.
21:08:46 <soren> I suppose it's a question whether the priorities of blueprints should be definitive or descriptive.
21:08:49 <dendrobates> we need to enforce it
21:08:51 <ttx> otherwise our Nova releases look like a collection of loosely-coupled merges that happened to land during that month
21:08:59 <jaypipes> ttx: yep.
21:09:00 <dendrobates> we need the will and the power to enforce it plan
21:09:22 <dendrobates> 'the' plan
21:09:36 <ttx> we need the will to act as a united project, that takes strong leadership, and meritocracy should help
21:09:57 <jaypipes> justinsb: as an example, I'd like to see some of your branches go through, but I'm having a tough time seeing how any of them fit into the declared release plan for Cactus.
21:10:10 <justinsb> jaypipes: Well, they bring testing of the APIs
21:10:19 <jaypipes> justinsb: yes, the one does.
21:10:25 <ttx> soren: so far priorities on the blueprints mean how much nagging I apply to get updated status
21:10:32 <jaypipes> justinsb: but it's not clear how many of the others fit.
21:10:47 <justinsb> jaypipes: Let's discuss the details off each branch offline
21:10:57 <jaypipes> justinsb: and I'm not just picking on you, please don't back away. the same can be said of the authn/authz brnach proposed.
21:11:00 <dendrobates> we should focus in the future
21:11:13 <dendrobates> what do we need to do to not have these problems
21:11:44 <jaypipes> dendrobates: well, is the root cause bad planning or bad execution?
21:11:49 <justinsb> I think all we need is someone who is responsible for delivering the project's goals. That's the project technical lead, in my book. We need them yesterday, (or 9 months ago) IMHO
21:11:50 <ttx> ok, I guess the next summit will be essential for that. With the new PTLs and all that
21:12:00 <ttx> jaypipes: I'd say both
21:12:10 <ttx> with the same root cause
21:12:31 <soren> justinsb: I just don't see how that will work. It's not like they can actually manage the people working on stuff.
21:12:33 <dendrobates> without the authority to enforce the goals the ptl's will be ineffective
21:12:38 <jaypipes> justinsb: we've had that, however, there have been a number of political issues that have prevented that person from actually pushing forward a direction for Nova.
21:13:15 <justinsb> jaypipes: Who has it been, and what were the issues?
21:13:27 <jaypipes> justinsb: dendrobates was the chief architect.
21:13:31 <dendrobates> justinsb: it was me.
21:13:45 <dendrobates> butg I have not been acting in that role for some time
21:13:59 <justinsb> Are there lessons to be learned from this experience for the PTL role?
21:14:31 <dendrobates> probably not
21:14:48 <pvo> should we figure these out at a summit?
21:14:50 <jaypipes> justinsb: at this point, we have a number of teams (internal Rackers, OpenStack Rackers, Anso, NTT, etc) that are all basically doing their own thing. There isn't any technical lead that is pushing a concerted agenda, and I'm not sure that if there was one, that the teams would really care to follow a direction.
21:14:50 <dendrobates> but I am extremely worried about the 6 month term for ptl
21:15:07 <devcamcar> you know, i think something as simple as a weekly report to mailing list about current priorities, progress of blueprints, etc. would go a long way
21:15:24 <jaypipes> devcamcar: that would be great.
21:15:36 <devcamcar> just to keep everyone focused
21:15:38 <sirp_> devcamcar: ++
21:15:46 <alekibango> devcamcar: ++
21:15:47 <pvo> devcamcar: spectorclan_ was doing something like this for a short time
21:15:49 <jaypipes> devcamcar: but sorry, that's really what blueprints and bug statuses are for.
21:15:56 <dendrobates> pvo: yes, I think we should have a long discussion at the summit
21:16:02 <ttx> devcamcar: I can certainly do that. That duplicates a bit the info I'm giving at the meeting
21:16:06 <ttx> anyway, we won't solve it now. For cactus we'll have to rely on nova-core to filter the proposals
21:16:09 <spectorclan_> I can do something more project specific to what I have been doing
21:16:29 <devcamcar> pvo: yea spectorclan_ was doing the higher level number of commits and stuff, and that is good info. i think something a bit more specific to developers within the project, just something to push priorities in front of eyeballs
21:16:29 <ttx> food for thought. definitely something to raise while we can pay people beers.
21:16:42 <spectorclan_> OK, will look into it with ttx
21:16:47 <eday> also, we may need to rethink our methods. obviously a 6 month summit + 3 month blueprint proposal/approves are not able to encapsulate what people are doing. before trying to enforce the current system, we may need to rethink the system
21:16:47 <devcamcar> sweet
21:17:06 <dendrobates> eday: +1
21:17:10 <dragondm> true
21:17:17 <eday> also, afaik, swift/glance seem to be fine, it's really just nova
21:17:25 <ttx> #action ttx and spectorclan_ to look at providing weekly focus ML post
21:17:31 <jaypipes> eday: there's 10 times as many people working on Nova... to be fair.
21:17:32 <alekibango> eday: +1
21:17:35 <devcamcar> jaypipes: i'm not saying we create a bunch of overhead, just basically a report of current status of the blueprints, just the text thats already there in a prioritized list
21:17:41 <devcamcar> that goes to the list
21:17:43 <dragondm> probably because nova has such a wide scope
21:17:46 <eday> jaypipes: yup, which is part of the thing we need to address :)
21:18:01 <ttx> eday: also glance and swift do not suffer from the "multiple groups" syndrome
21:18:05 <jaypipes> devcamcar: you mean http://wiki.openstack.org/releasestatus/?
21:18:20 <eday> jaypipes: in other words, out system doesn't scale to a project of nova's size
21:18:33 <jaypipes> devcamcar: my point being is that if people are just working on whatever, completely outside of blueprints and bug reports, it's almost impossible to tell what's going on.
21:18:47 <devcamcar> jaypipes: it could be as simple as that, if it were pushed to the list once a week
21:18:58 <dendrobates> we need to discuss all of this at the summit
21:19:14 <devcamcar> jaypipes: true, but at least this way we can reinforce the priorities so people are more aware that they're outside scope
21:19:14 <eday> dendrobates: ++, nothing will be solved in IRC
21:19:18 <ttx> ok, let's close it for now
21:19:40 <justinsb> It's an open source project: people will scratch their own itch
21:19:43 <justinsb> You don't have to merge it
21:19:43 <alekibango> scalable development of scalable cloud system :) .... thats endless fight against ever increasing entropy!
21:19:52 <ttx> Like I said, we'll rely on nova-core to DTRT
21:19:54 <justinsb> But anyone can fork if they don't like the direction you're taking the project in
21:20:09 <jaypipes> dendrobates: sure, at the summit, but in the meantime we've now got a backlog of reviews for branches that aren't in the release plan and don't have any blueprints tied to them. Specifically what are reviewers to do?
21:20:13 <alekibango> justinsb: people would love to have common standard. forking is bad
21:20:31 <justinsb> Forking is bad, which is why it's important to get the direction right and have a good leader that aligns everyone
21:20:34 <dendrobates> jaypipes: so we need criteria for rejecting merges?
21:20:49 <ttx> jaypipes: I would prioritize reviews of planned stuff over unplanned stuff
21:20:58 <jaypipes> dendrobates: no, we need someone to say "sorry this is not in Cactus. Deferred to Diablo." Period.
21:21:21 <dragondm> IMHO, all merges need a bp or bug associated.
21:21:25 <dendrobates> the first step is to reject the merge
21:21:26 <glenc> +1
21:21:28 <ttx> jaypipes: I can enforce that once we hit the freezes... before that, must be nova-core
21:21:37 <devcamcar> i think it would be helpful for the core teams to meet on irc once a week for discussing branches and whether they meet criteria
21:21:39 <devcamcar> something more granular
21:21:40 <jaypipes> and I'm not talking about justinsb's branches alone here... there's lots of stuff. and some of justinsb branches ARE in plan...
21:22:22 <justinsb> jaypipes: I'm fine for the constraint scheduler to target diablo
21:22:40 <eday> or perhaps we just need to break on of justinsb's hands to slow his hacking/mps down :)
21:23:13 <justinsb> eday: :-)
21:23:21 <dendrobates> we need to figure out where the decision can and should be made
21:23:27 <jaypipes> as a practical example of what has happened because of the chaos: we now are in a situation where masumotok_'s team's live migration patches have received less attention that they deserve, and it looks like we are heading down the same path we hit in January...
21:23:28 <dendrobates> at review time is not ideal
21:23:57 <ttx> jaypipes: right, extraneous BMPs just dilute our focus
21:24:25 <ttx> jaypipes: I think it's acceptable for nova-core to reject unplanned stuff
21:24:28 * jaypipes acknowledges justinsb has a freakish hacking pace indeed.
21:24:49 <ttx> jaypipes: I'll ecrtainly not grant any release exception to unplanned stuff
21:25:05 <dragondm> we also need more reviewers.
21:25:14 <jaypipes> ttx: it's more the delay/chaos it creates for the planned stuff that has become an issue.
21:25:18 <dendrobates> it should be rejected and sent to another another queue to decide if it should be included in the release
21:25:26 <jaypipes> dragondm: or we need all nova-core reviewers to be reviweing ;)
21:25:45 <jaypipes> soren: whatever happened to that review days thing?
21:26:08 <ttx> we won't solve it now. I'd raise a thread about review focus for nova-core dudes that tackles that issue
21:26:09 <dragondm> yes. reviewers == *active* reviewers.
21:26:23 <soren> jaypipes: It started yesterday.
21:26:26 <ttx> jaypipes: feeling up to it ?
21:26:31 <soren> jaypipes: It took a while to get people to respond.
21:26:56 <jaypipes> ttx: sure
21:27:03 <soren> jaypipes: I failed to announce it, though. :(
21:27:14 <jaypipes> ttx: though I hate to keep coming across as the slavedriver...
21:27:14 <pvo> soren: consider it announced! ;P
21:27:21 <soren> jaypipes: But that's only because I suck.
21:27:21 <ttx> #action jaypipes to raise a ML thread about review focus for nova-core
21:27:40 <ttx> jaypipes: you prefer to leave te stick with me :P
21:27:43 <devcamcar> soren: what does "it started yesterday" mean? :)
21:27:44 <ttx> ok, we need to move on
21:27:47 <alekibango> soren: btw i would rather make quota for weekly reviews for core members. like 4 reviews for week or something like that...
21:28:04 <ttx> Completion rate, based on the current data:
21:28:06 <jaypipes> ttx: no, I'll do it.
21:28:09 <soren> devcamcar: It means that it was my review day yesterday. It's someone else today.
21:28:13 <ttx> Essential specs:
21:28:18 <ttx> Glance: 3 completed, 1 proposed
21:28:20 <soren> devcamcar: http://wiki.openstack.org/Nova/ReviewDays
21:28:23 <ttx> Nova: 1 in progress
21:28:35 <ttx> Tushar: how far cactus-flatmanager-ipv6-support is from being proposed ?
21:28:52 <ttx> High specs:
21:28:56 <ttx> Glance: 1 proposed, 1 deferred
21:29:00 <ttx> Nova: 4 implemented, 2 started, 2 in jeopardy, 1 not started and 1 deferred
21:29:06 <ttx> Other specs:
21:29:11 <ttx> 12 implemented, 6 proposed, 9 in progress, 10 not started and 1 deferred
21:29:28 <ttx> Given the number of "not started", I suspect there are a few specs we already know we won't be able to deliver in time...
21:29:41 <ttx> Does anyone want to raise a flag about a spec not likely to be completed in time ?
21:29:50 <cynb> yes
21:30:03 <dendrobates> let's start deferring them, if they are not going to make it
21:30:05 <ttx> (one that isn't already marked Slow Progress / Deferred on http://wiki.openstack.org/releasestatus/)
21:30:13 <jaypipes> cynb: which one?
21:30:16 <ttx> dendrobates: done already
21:30:22 <cynb> error codes...
21:30:30 <cynb> system usage records
21:30:37 <cynb> xs-guest-agent
21:30:42 <cynb> xs-ovs
21:30:57 <ttx> cynb: in jeopardy, or already deferred ?
21:31:00 <cynb> bexar-distributed scheduler (already deferred)
21:31:24 <cynb> deferred - correct me if i'm wrong
21:31:36 <jaypipes> dragondm: ^^
21:31:43 <ttx> xs-ovs still ahd a chance, according to antonym today
21:31:47 <jaypipes> dragondm: system usage records to be deferred? ok with that?
21:31:52 <dragondm> yup.
21:31:54 <ttx> hence the "slow progress" status
21:32:14 <jaypipes> ttx: defer on system usage records.
21:32:32 <ttx> #action ttx to update status on cynb's deferred spec list if nobody beats him to it
21:33:08 <justinsb> I'll take on the distributed scheduler if you want
21:33:09 <ttx> #action ttx to sync with Tushar on cactus-flatmanager-ipv6-support status
21:33:19 <ericrw> I'm preparing to suggest a merge of my execvp patch (bug: 726359). I should have it ready by freeze, but it touches a lot of stuff and I want to make sure it is well tested before it goes into a release.
21:33:41 <soren> Looking forward to it!
21:33:49 <ttx> ericrw: cool
21:33:54 <ttx> On the Nova stabilization effort:
21:33:57 <eday> justinsb: it needs the zone dependencies too, which may not be ready in time
21:33:59 <ttx> Last week we had 36 bugs opened and 29 fixes committed
21:34:04 <ttx> This week we had 16 bugs opened and 10 fixes committed
21:34:15 <ttx> That's a big drop, maybe the proximity of BMPFreeze made people concentrate on feature work...
21:34:39 <justinsb> eday: Well, I could take that one on as well, but I think zones3 looks good
21:34:45 * jaypipes notes last week he had a 3 day jury trial. this week he doesn't. big drop in jury trials.
21:35:19 <dendrobates> jaypipes: did they find you guilty?
21:35:21 <eday> justinsb: sandy and dabo are actively working on them, so might ask them if they need help
21:35:38 <jaypipes> dendrobates: nah, got off by reason of insanity ;)
21:35:42 <ttx> eday, justinsb: I think the problem is more that other stuff needs to land first
21:35:55 <eday> ttx: yeah
21:36:03 <dabo> eday: it's really in flux right now. Much depends on the multi-cluster/zones stuff, and the possible adoption of a central db
21:36:05 <ttx> eday, justinsb: not really that they need help or resources
21:36:25 <ewanmellor> ttx: Regarding xs-ovs you said "waiting on OVS support from Citrix". What does that mean?
21:36:27 <jaypipes> cynb: re: the error codes one, did you know Naveed had a branch proposed for merging? https://code.launchpad.net/~ironcamel/nova/http-error-codes/+merge/52492
21:36:43 <westmaas_> I think those are different error codes.
21:36:48 <jaypipes> ah.
21:36:54 <Tushar> ttx:I have almost finished implementation of flatManager for IPV6. Most probably I will propose my branch for merge early next week.
21:36:56 <jaypipes> westmaas_: wanna ping Naveed on that? ;)
21:37:07 <ttx> ewanmellor: antonym told me he was in contact with Citrix to get OVS support in XenServer, and that was needed to implement this psec
21:37:16 <ttx> ewanmellor: I don't really know more than that.
21:37:19 <antonym> ewanmellor: we ran into some issues with the beta drop from citrix that we're working through, we can start coding the script up but we're trying to get ovs working so we can actually test out functionality
21:37:21 <westmaas_> haha I can. I know what Naveed's are, I will check in with cynb right after this :)
21:37:39 <ttx> Tushar: ok, thanks
21:37:40 <jaypipes> westmaas_: cheers mate
21:38:19 <ttx> ok, moving on to the next topic in 15 seconds
21:38:37 <ttx> #topic Elections coming up
21:38:42 <ttx> spectorclan: floor is yours
21:38:51 <spectorclan_> Nomination Process at http://www.openstack.org/blog/2011/03/openstack-governance-nominations-and-election-process/; open until March 18 at Midnight CST
21:38:52 <ewanmellor> ttx, antonym: Will follow up on this offline.
21:39:09 <antonym> ewanmellor: sure thing
21:39:12 <spectorclan_> If you want to be nominated or self-nominated, contact me or post yourself at http://etherpad.openstack.org/Spring2011-Elections
21:39:22 <spectorclan_> We already have 2 people listed for SWIFT
21:39:44 <spectorclan_> I will also be posting the election process later this week as there are rules for who can vote for each of the positions
21:40:03 <ttx> spectorclan: will we know who owns the 4 RS-nominated seats on the PPB before or after voting ?
21:40:23 <spectorclan_> Will find that our for you; as of now I do not know
21:40:45 <soren> What happens if the PTL elected is already on the PPB?
21:40:49 <dendrobates> spectorclan: the voting needs to be completely transparent and the results available immediately after the voting ends
21:41:02 <spectorclan_> All voting will be done in public via the tool that ttx suggested
21:41:15 <pvo> spectorclan_: what tool is that?
21:41:18 <ttx> That's http://www.cs.cornell.edu/andru/civs.html
21:41:20 <soren> CIVS, probably.
21:41:22 <dendrobates> spectorclan: there are still options
21:41:27 <spectorclan_> yes
21:41:35 <dendrobates> and it was not done correctly last time
21:41:45 * jaypipes hopes he spelled vishy's name right ...
21:41:56 <ttx> spectorclan: you just need to pick "results goes to everyone, not a selected group"
21:42:18 <spectorclan_> My plan is to make sure there are no issues and everyone is pleased with process. That is why I am posting all process stuff ahead of time for comment and changes
21:42:21 <spectorclan_> Thanks ttx, will do
21:42:30 <dendrobates> soren: it is an obvious fail, the ptl needed to be elected first
21:42:35 <jaypipes> spectorclan: appreciated. thx :)
21:42:40 <ttx> spectorclan: that's the default choice
21:42:46 <spectorclan_> I am open to all suggestions on tools and process
21:42:56 <soren> dendrobates: Yeah. Failing that though, I wonder what the resolution process is.
21:43:02 <ttx> soren: the case is already described in the governance
21:43:07 <soren> ttx: orly?
21:43:26 <ttx> soren: PTL gets on PPB, next PPB winner gets a seat
21:43:43 <spectorclan_> I will explain that issue in the Election Process blog post
21:43:48 <soren> ttx: Ah. Neat.
21:44:06 <dendrobates> spectorclan: please send it to the mailing list
21:44:11 <justinsb> Surely the real debate is on who gets a vote, not on the tool we use. The former will determine the outcome, after all...
21:44:21 <dendrobates> spectorclan: you will find that you miss a large part of the community with blog posts
21:44:22 <ttx> justinsb: hopefully.
21:44:33 <spectorclan_> dendrobates: ok, will do that next time, thanks
21:44:47 <ttx> spectorclan: anything else you wanted to mention ?
21:44:48 <pvo> justinsb: it is just as much about the transparency of the elections as the candidates
21:44:55 <spectorclan_> Yes,,,
21:45:06 <spectorclan_> Design Summit Registration site expected this week; waiting...
21:45:14 <spectorclan_> on the Rackspace event team to get all the credit card processing in order
21:45:43 <spectorclan_> Developer party is looking like Dave and Buster's but we are still waiting for other places to get back to us
21:45:44 <justinsb> pvo: Why is one-vote-per-company less valid than one-vote-per-committer ? :-)
21:46:32 <spectorclan_> ttx: that's enough from me for the day; I hope
21:46:41 <pvo> justinsb: ?? not what I was saying at all....
21:47:02 <ttx> #topic Open discussion
21:47:09 <justinsb> pvo: It's just that everything else is a bit of a red herring! But maybe I misunderstood your point!
21:47:31 <dendrobates> I've got something
21:47:47 <dendrobates> This is my last meeting as a rackspace employee
21:48:12 <dendrobates> I resigned rackspace and accepted a position at cisco
21:48:24 <jaypipes> congrats, dendrobates. well, on the new job part...
21:48:24 <dendrobates> I will still be working on openstack
21:48:41 <spectorclan_> Congrats!
21:48:55 <dendrobates> even more so
21:49:21 <dendrobates> I no longer have the conflict of interest of working at rackspace
21:49:36 <ewanmellor> dendrobates: Congrats! Will you still be chief benevolent dictator?
21:49:48 <dendrobates> so, if I think we RS is doing something wrong, I am free to speak
21:49:54 <ttx> ewanmellor: that position no longer exists in the new governance
21:50:04 <ttx> ewanmellor: a bit dissolved into PTLs.
21:50:05 <dendrobates> ewanmellor: I'll still be aroundm, you guys will decide my role
21:50:38 <dendrobates> I'll do my review days though
21:51:03 <dendrobates> cisco is building an openstack dev team, btw
21:51:40 <tr3buchet> interesting
21:52:04 <dendrobates> ha
21:52:18 <dendrobates> I'm not trolling for rackers. :)
21:53:15 <eday> For folks not following the ML, burrow (queue service) is switching to Python (from Erlang). C/C++ will be used when optimizations are needed. See ML thread for details.
21:53:43 <ttx> anything else, anyone ?
21:54:01 <dendrobates> eday: woohoo
21:54:06 <devcamcar> also for folks using openstack-dashboard / django-nova, the django-nova repo has been decommissioned and both projects are rolled up into the openstack-dashboard repo. the components are still separate but this makes administration much easier
21:54:19 <ttx> devcamcar: +1
21:55:09 <ttx> ok, let's close this one
21:55:25 <ttx> #endmeeting