21:02:13 <ttx> #startmeeting
21:02:14 <openstack> Meeting started Tue May  3 21:02:13 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:25 <ttx> Welcome everyone to our weekly OpenStack team meeting...
21:02:33 <ttx> Today's agenda:
21:02:40 <ttx> #link http://wiki.openstack.org/Meetings
21:03:02 <ttx> #topic Current release stage: Design
21:03:16 <ttx> We are just a few days after the design summit, and still digesting all the sessions...
21:03:30 <ttx> The PTLs are working on the Diablo plans.
21:03:49 <ttx> The idea is to have blueprints for the significant features we want to have in Diablo, in order to track them.
21:03:53 <ttx> jaypipes: o/
21:04:04 <jaypipes> ttx: sorry for tardiness...
21:04:07 <ttx> Vish already sent an email to Nova devs for missing assignees.
21:04:21 <ttx> By next week we should have a more precise plan.
21:04:31 <ttx> #topic Default release schedule
21:04:48 <ttx> I talked to Vish on Friday and we came up with a default release schedule
21:05:01 <ttx> #link http://wiki.openstack.org/DiabloReleaseSchedule
21:05:15 <sandywalsh> o/
21:05:19 <ttx> One milestone every 4 weeks, with some extra time for the first, to account for BP work and design summit digestion
21:05:33 <ttx> Last milestone is skipped since we have a coordinated release instead
21:05:55 <ttx> We might add an extra gamma-like milestone towards the end...
21:06:08 <ttx> Unless they have a good reason not to, projects should try to stick to that default schedule
21:06:19 <ttx> Questions ? Remarks ?
21:06:47 <soren> Um.
21:06:49 <NelsonN> When will be possibl;e to start submitting code?
21:06:57 <carlp_> Sounds good, looks like we should get some rapid iterative development with this.
21:07:04 <ttx> NelsonN: it's already possible.
21:07:10 <ttx> Since April 14.
21:07:21 <NelsonN> ok great
21:07:31 <soren> ttx: I don't see any freezes or anything on that release schedule.
21:07:46 <soren> ttx: Do we not do freezes? Just random snapshots of trunk on those days?
21:08:04 <ttx> soren: depends on the project. Whenever I have more precision from PTLs I'll add it
21:08:36 <vishy> soen: the plan we discussed was for the first milestone to do a QA branch a couple of days before
21:08:38 <ttx> But we probably won't freeze. Just branch out a QA thing.
21:09:06 <vishy> until automated testing is complete enough that we feel comfortable just tagging the latest stable build
21:09:13 <vishy> soren: ^^
21:09:41 <soren> Ok.
21:09:53 <ttx> soren: the schedule will get more precise over time. I wanted to set the milestones dates early.
21:10:17 <ttx> Ok, let's move on then
21:10:21 <ttx> #topic Bits from the PTLs: Nova
21:10:30 <ttx> vishy: anything to announce ?
21:10:41 <ttx> others: any question for the Nova PTL ?
21:11:24 <ttx> vishy: I suspect you're waiting on answers and assignees on your recent ML post ?
21:11:34 <jaypipes> vishy: excellent post to ML about decisions. thanks for doing that.
21:11:42 <vishy> ttx: no announcements
21:11:53 <vishy> ttx: more emails and blueprints coming soon :)
21:11:59 <ttx> eh.
21:12:09 <vishy> ttx: i didn't request specific assignees in that post
21:12:09 <ttx> #topic Bits from the PTLs: Glance
21:12:26 <jaypipes> We're assigning blueprints currently to D1 and D2 milestones. https://launchpad.net/glance/+milestone/diablo-1
21:12:26 <ttx> vishy: ok, only BPs so far.
21:12:46 <jaypipes> Expect to see some emails about Glance BPs and milestones in a few hours.
21:13:23 <ttx> jaypipes, vishy: are we standardizing milesones names ? diablo-1 ? diablo1-20110602 ?
21:13:28 <jaypipes> And a ML post about new images API stuff coming in D1.
21:13:39 <jaypipes> ttx: doesn't matter to me...
21:13:53 <pvo> dX seems to make sense.
21:13:58 <jaypipes> ttx: I think it's easier to say D1 than D1-20110602 ;)
21:14:11 <ttx> jaypipes: I agree, but Vish wanted to add te date in it...
21:14:21 <glenc> it also doesn't look as silly if you slip it by a few days
21:14:24 <pvo> the milestones already have a date field that is required.
21:14:34 <jaypipes> ++ to pvo and glenc
21:14:42 <ttx> vishy: ok with that ?
21:14:47 <vishy> yes
21:14:56 <vishy> as long as the date exists somewhere easy to find
21:15:01 <vishy> i don't think it needs to be in the name
21:15:03 <ttx> https://launchpad.net/glance/diablo
21:15:06 <jaypipes> vishy: it's attached to the milestone...
21:15:09 <ttx> or on the release schedule.
21:15:14 <vishy> that is fine with me
21:15:20 <ttx> ok, thx
21:15:25 <ttx> anything else on Glance ?
21:15:49 <jaypipes> ttx: eh, not right now... I have some stuff to talk about re: Keystone, though...
21:16:05 <jaypipes> KnightHacker: that you, Khaled?
21:16:28 <jaypipes> whois confirms...
21:16:33 <KnightHacker> jaypipes: Yes.
21:16:33 <anotherjesse> jaypipes: have you had a chance to play with tests for keystone?
21:16:40 <jaypipes> anotherjesse: yes.
21:16:56 <jaypipes> anotherjesse, ttx, KnightHacker: can I propose a topic for later on for Keystone?
21:17:03 <anotherjesse> ++
21:17:04 <ttx> sure
21:17:10 <KnightHacker> sure
21:17:11 <ttx> #topic Bits from the PTLs: Swift
21:17:20 <ttx> notmyname: something on your mind ?
21:17:34 <notmyname> I don't have anything yet. just been working a little on the github account
21:17:40 <notmyname> nothing for swift yet
21:17:46 <ttx> Any question for notmyname ?
21:18:30 <ttx> ok then...
21:18:33 <notmyname> wait
21:18:34 <ttx> #topic Feedback from the design summit
21:18:36 <ttx> ah
21:18:38 <notmyname> heh
21:18:49 <ttx> notmyname: fire
21:19:04 <notmyname> well, since you were talking milestones with the other projects, our milestones will be (I think) version numbers
21:19:09 <notmyname> like 1.3.X
21:19:34 <notmyname> just FYI
21:19:44 <ttx> hmm... and you turn 1.3.8 into 1.4.0 ? sounds weird to me
21:20:05 <vishy> notmyname: are you doing 4 week milestones as well?  Or is it a "when it is ready" point release?
21:20:26 <notmyname> I think it will be more of a "when it's ready", but we will target something roughly monthly
21:20:35 <notmyname> ttx: I'm not sure that diablo == 1.4.0
21:20:48 <ttx> notmyname: oh, I see.
21:21:08 <notmyname> I'd like to discuss more with the other devs on that, but we aren't making fundamental changes to the architecture at this point
21:21:18 <notmyname> at least, not until pluggable rings are imported :-)
21:21:19 <jaypipes> notmyname: so you're saying that instead of milestones named D1, you'll have milestones named, say, "1.3.6"?
21:21:28 <notmyname> jaypipes: yes
21:21:36 <jaypipes> notmyname: k, understood...
21:22:01 <ttx> notmyname: ok, keep us posted on further progress.
21:22:05 <notmyname> will do
21:22:13 <ttx> really moving to next topic now
21:22:19 <ttx> #topic Feedback from the design summit
21:22:33 <ttx> For those who were present but missed the postmortem session at the end...
21:22:44 <ttx> Anything on your mind ? What went well, what went wrong ?
21:23:01 <zns> Is there a summary somewhere of the postmortem?
21:23:05 <jlm^> Shouldn't have multiple differing copies of agenda.
21:23:06 <pvo> mobile scheduling tool was nice.
21:23:12 <anotherjesse> ttx: it might be nice to have a clearer separation of the summit and conference part
21:23:22 <ttx> anotherjesse: We might place the design summit *before* the conference next time
21:23:23 <anotherjesse> it can be confusing to folks to have them overlap
21:23:47 <spectorclan_> anotherjesse: we plan to market as independent events next time
21:23:52 <ttx> anotherjesse: I'm fully with you. The business people like to have it overlap though, so make sure you give then that feedback
21:23:57 <dabo> sometimes seating and/or people made it hard to hear the discussion
21:24:12 <ttx> dabo: I'd blame rooms, that were too large for our need
21:24:22 <bblair48> Hard to call them design discussions with 150 people in the room.
21:24:27 <notmyname> +1 to mobile scheduling
21:24:29 <anotherjesse> I think the unconference sessions were nice - would have liked to have a day just for those topics
21:24:30 <zns> More whiteboards
21:24:39 <anotherjesse> (that folks want to talk about - not overlapping with summit)
21:24:42 <dabo> +1 on whiteboards
21:24:44 <jaypipes> zns: ++
21:24:48 <glenc> ++
21:24:55 <spectorclan_> Got it on the whiteboards
21:24:58 * jaypipes would like smaller rooms
21:24:59 <anotherjesse> maybe we overlap the unconference and conference -- not the summit & conference :)
21:25:11 * ttx would like projectors and screens up until the end
21:25:29 <spectorclan_> ttx: that was a scheduling issue on our end, we thought 3:30 would be it. my mistake
21:25:34 <jaypipes> if the design summit were first, then last DS day mixed with first conference day, then decisions made in the DS could be explained to business folks better..
21:25:50 <spectorclan_> jaypipes: that is what I proposed today
21:25:54 <ttx> jaypipes: yes, that's the rationale.
21:26:01 <spectorclan_> design summit (M-W) Conf (W-R)
21:26:07 <jlm^> Organizing which sessions -- can this happen on the open list?  There were "by invite" sessions.
21:26:11 <ewindisch> having a mobile site was nice, but finding it was relatively difficult.
21:26:24 <jaypipes> jlm^: which ones were " by invite"?
21:26:39 <anotherjesse> the pre-conference naas ones?
21:26:39 <dabo> no overlapping teenybopper events next time!
21:26:48 <zns> Mobile sucked on BlackBerry. (I know BlackBerry sucks, but gotta support em… for a couple more years at least).
21:26:49 <ttx> dabo: +1
21:26:49 <jaypipes> dabo: lol
21:26:50 <jlm^> The networking ones before Thu.
21:27:02 <spectorclan_> zns:we are aware of the blackberry issue
21:27:19 <zns> Or provide iPhones ;-)
21:27:22 <spectorclan_> did everyone take the online survey?
21:27:33 <zns> No. Link to survey?
21:27:35 <jaypipes> jlm^: no design summit discussion should have been "by invite"
21:27:55 <jlm^> I missed (didn't hear about) the Mon one, someone forwarded me a msg about the Tue one.
21:28:00 <ttx> jlm^: I think those weren't by invite, they were only "organized at the very last moment"
21:28:02 <spectorclan_> http://www.surveymonkey.com/s/XH8NW5Y
21:28:29 <ttx> jlm^: but we'll make sure to avoid that next time...
21:28:32 <spectorclan_> I am not aware of the NAAS stuff on Monday - do we know who planned it?
21:28:39 <troytoman> jlm^: sorry. we just pulled together the authors of the various naas blueprints. not meant to be invite only
21:28:44 <jlm^> The organizing msgs didn't go to an open list, they went to a list of invitees.
21:29:00 <ttx> spectorclan: Erik Carlin, I think
21:29:16 <spectorclan_> ok. I will make sure all things come thru me so I can keep track
21:29:22 <spectorclan_> and make sure the items are public
21:29:26 <ttx> any other quick feedback before we switch to Keystone ?
21:29:30 <jlm^> Also, they weren't on the schedules.
21:29:46 <ttx> jlm^: they weren't part of the design summit.
21:29:58 <ttx> jlm^: until Thursday...
21:30:10 <spectorclan_> BTW, looks like Boston in first week of October - starting my search this week for an event location; open to all ideas
21:30:40 <zns> Everything in October should be in Munich...
21:30:41 <vishy> spectorclan_: +1 for summit in Hawaii
21:30:45 <jk0> what happened to Europe?
21:30:50 <anotherjesse> vishy: +1 for hawaii
21:30:51 <salv-orlando> I thought the design summit was coming to Europe :-)
21:30:52 <ttx> jk0: +1
21:30:52 <spectorclan_> vishy: Hawaii is not a state so no can do
21:30:52 <dendrobates> boston is horrible.  We should not make all the Japanese devs travel here again.
21:31:05 <pvo> what?
21:31:09 <spectorclan_> jk0: Europe or Asia is target for 2012 Fall event
21:31:26 <dendrobates> spectorclan: why?
21:31:36 <spectorclan_> Not enough time to plan an event in Europe this year
21:31:49 <spectorclan_> Event team at Rackspace wants more time to put it together
21:32:13 <spectorclan_> I am looking to setup mini summits in Japan this year for developers and possibly europe as well
21:32:16 <notmyname> all I ask is that the date and place be firm as soon as possible for those of us who will try to plan travel around it. airfare and hotels will be cheaper the sooner they are booked
21:32:32 <dendrobates> I call BS on that.  six months is more than enough time.
21:32:33 <spectorclan_> notmyname: the plan is to finalize the location and dates this month.
21:32:55 <pvo> spectorclan_: pssst. Hawaii is a state.
21:32:57 <spectorclan_> dendrobates: they are part of the decision process for helping to plan and finance the event
21:32:59 <alekibango> ttx: ... a bit late comment to release schedules:  i would love shorter iterations, like in agile programming -- backed by lots of automated tests
21:33:07 <ttx> ok, we'll move the rest of this discussion to open discussion
21:33:09 <comstud> just curious: which entity is responsible for making the decision?
21:33:15 <comstud> (of where, when, etc)
21:33:16 <dendrobates> do we need someone other than Rackspace to put it on?
21:33:18 <ttx> alekibango: whenever we have automated tests up to snuff maybe
21:33:20 <anotherjesse> spectorclan_: hawaii became a state recently - 1959
21:33:32 <spectorclan_> I just saw on Fox they are not a state???
21:33:33 <dabo> just ask the donald
21:33:40 <comstud> I was going to comment on the Hawaii thing, too, but I assume this was a joke
21:33:41 <ttx> Don't ask Fox anything.
21:33:44 <alekibango> ttx: i think i can help with this if someone will put few computers and configs in
21:33:44 <comstud> :)
21:33:58 <spectorclan_> Event location discussion - we can have another talk later on this and the thinking of the current plan
21:34:00 <termie> there are conference facilities in hawaii, this is not an unusual activity for them
21:34:01 <ttx> alekibango: it's being worked on. It's the key to everything
21:34:07 <alekibango> i agree
21:34:07 <spectorclan_> Hawaii is VERY EXPENSIVE
21:34:12 <alekibango> bugs are really tough
21:34:25 <alekibango> even for old hackers
21:34:29 <ttx> -- STOP -- please complain about location in 10min
21:34:30 <vishy> spectorclan_: true, but it is cheaper for the japanese...
21:34:31 <NelsonN> Vegas?
21:34:36 <vishy> ttx; ok
21:34:38 <ttx> #topic Keystone
21:34:58 <ttx> want to squeeze the keystone topic requested before we fire location ideas
21:35:01 <anotherjesse> Jay - want to give an update on testing?
21:35:10 <ttx> jaypipes: your topic
21:35:14 <jaypipes> zns, KnightHacker: OK, so I was wondering if you guys would be opposed to replacing bottle with how Nova/Glance/Swift do WSGI app loading?
21:35:29 <KnightHacker> I think that makes sense.
21:35:40 <zns> Not at all. Intending to. In fact, there is a nobottle branch. Just haven't got to it yet.
21:35:42 <KnightHacker> We only used bottle because it was a little faster for us to prototype things
21:36:04 <jaypipes> ok, no worries... will the nobottle branch be merged any time soon?
21:36:33 * jaypipes was trying to write integration tests with Glance and found it odd that identity.py used a different load process than echo/echo/echo.py ;)
21:36:47 <KnightHacker> This branch was created a while back and it'll probably need to be re-created.
21:36:57 <KnightHacker> I mean, we can make that a priority I guess.
21:37:13 <anotherjesse> KnightHacker: should we just convert it over with a new branch?
21:37:21 <KnightHacker> I don't think that it is a big deal.
21:37:23 <zns> No date. I don't know the state of the branch. Might be too far back. We are meeting internally at Rackspace tomorrow to plan what to code next. We can bring nobottle up.
21:37:24 <jaypipes> KnightHacker, zns: would be cool to make that a priority. just because that would make starting/stopping servers in integration tests much easier/more standardized...
21:37:27 <KnightHacker> Yes.
21:37:46 <jaypipes> KnightHacker, zns: ok, sounds good. can you invite me to that meeting?
21:38:02 <zns> Sure!
21:38:08 <ttx> #action KnightHacker zns to get the nobottle branch merged asap
21:38:22 <ttx> jaypipes: anything else ?
21:38:27 <jaypipes> awesome. ok, that's all I wanted to bring up right now. thx.
21:38:37 <zns> Gorrit.
21:38:44 <ttx> #topic Open discussion
21:38:54 <ttx> FWIW I'm taking a few days vacation starting tomorrow, and I'm at a conference next week. Should read email though.
21:39:01 <ttx> OK, location again
21:39:20 <jaypipes> anything but Santa Clara is fine by me :)
21:39:21 <ttx> I think we should choose a place that has some relatively-local openstack developers
21:39:21 <jk0> +1 for somewhere other than Boston
21:39:27 <dendrobates> in 20 minutes we will be having a meeting to discuss the Network project
21:39:36 <comstud> jay, lol
21:39:37 <ttx> Europe or Japan makes sense... Hawaii or Boston less so
21:39:44 <salv-orlando> dendrobates: on this channel?
21:39:46 <dendrobates> basically logistics stuff
21:39:50 <dendrobates> salv-orlando: yes
21:39:53 <termie> hawaii was a compromise on japan
21:39:53 <ttx> though I won't oppose Hawaii. Or Reunion Island.
21:39:54 <sandywalsh> Nova Scotia ;)
21:40:06 <sandywalsh> (hell no)
21:40:07 <vishy> I have another discussion topic to bring up when the location argument is done
21:40:07 <dendrobates> We need to get the LP stuff setup and organize teams
21:40:11 <soren> Bahamas!
21:40:33 <comstud> +1 :)
21:40:36 <spectorclan_> vishy: go ahead with your discussion - I will send an email on Deve mailing list
21:40:39 <glenc> Iceland - very inexpensive these days
21:40:55 <vishy> so forums.openstack.org
21:41:05 <soren> Ah, that thing.
21:41:07 <vishy> seems a little odd to me
21:41:15 <ttx> vishy: don't tell me
21:41:18 <termie> i'd like it gone
21:41:18 <dendrobates> that it is already up?
21:41:25 <glenc> yup
21:41:28 <vishy> the overwhelming majority on the list seemed to be a stackexchange style site
21:41:38 <vishy> yet we have forums instead
21:41:40 <spectorclan_> jordan rinke put it up and asked me to blog and promote
21:41:43 <ttx> vishy: JordanRinke got fed up by the discussion less than 24 hours after starting it and "just made it"
21:41:51 <antonym> would it make sense to split the lists and irc channels by projects?  they seem to be getting pretty busy
21:41:59 <alekibango> i think more documentation and complete config examples should be written on sane nova network architectures...  like few examples here:  http://stackops.org/display/documentation/Standard+Multinode+deployment       Having more and well documented examples with explanation is what is really missing in nova manuals.  But it needs help of those people who really understand nova well.
21:42:20 <notmyname> antonym: +1
21:42:31 <dendrobates> forums are a lot of work if you don't want them to suck
21:42:47 <vishy> ttx: I got that, but if it is under openstack.org it seems "official" and i don't think there was consensus on forums being the right idea, seems like it should at least go through the PPB...
21:42:51 <dendrobates> antonym: I suggest we just move off the noisy projects
21:43:08 <jlm^> antonym: Agreed.  The unified ML is too overloaded.
21:43:09 <dendrobates> once you get busy enough you get your own list
21:43:26 <jamesurquhart> dendrobates: +1
21:43:29 <ttx> vishy: fully agree
21:43:29 <dendrobates> we don't want to completely fragment
21:43:39 <antonym> well #openstack is a big question and answer room in addition to development, if we seperated dev for nova and swift, it might make a little more sense
21:43:59 <vishy> maybe we just put it on the PPB agenda as part of our figure out the various things that the ppb should be in charge of
21:44:05 <pvo> vishy: I agree that it would give the impression that its fully supported and staffed.
21:44:07 <alekibango> +1
21:44:07 <soren> vishy: +1. I think that's really more of an issue that anything else.
21:44:21 <alekibango> +1 for separation of irc
21:44:44 <soren> vishy: Forums being what we want or not, the fact that it just magically appeared in the openstack.org namespace is problement.
21:44:47 <soren> ERr..
21:45:01 <soren> problematic. "problement"?!?
21:45:08 <vishy> soren: agreed, this is just what we discussed at the ppb last week.  I'll put it on the agenda
21:45:09 <soren> butter fingers.
21:45:27 <zns> French
21:45:36 <soren> I don't speak French.
21:45:51 <zns> You just did!
21:45:52 <soren> Not on purpose, at least.
21:46:45 <ttx> ok, anything else ?
21:46:51 <antonym> i have #openstack-swift and #openstack-nova reg'd from when i set the channels up a while back if we did want to seperate those out
21:47:21 <dendrobates> antonym: how about just #openstack-devel
21:47:33 <jlm^> Now that we have more projects, it makes sense.
21:47:40 <antonym> is there a ton of nova and swift talk that overlaps?
21:47:47 <jaypipes> not really...
21:47:59 <ttx> I haven't witnessed that much overlap
21:48:01 <dendrobates> I like seeing all the swift stuff, though
21:48:18 <dendrobates> but perhaps it's just me.
21:48:20 * jaypipes would prefer a single channel and mailing list still... I still don't see it being a huge issue.
21:48:21 <antonym> you can sit in all the channels for that :)
21:48:24 <jlm^> If you like seeing Swift, sign up for it.  :)
21:49:03 <ttx> antonym: could you prepare a plan, we'll had a topic for the next week meeting and discuss it
21:49:14 <ttx> I don't want to rush anything in that area
21:49:27 <ttx> or maybe raise a thread to take options
21:49:43 <ttx> Back to preferred topic: What happened of Brussels ?
21:49:46 <notmyname> from the swift perspective, it's hard to keep up with questions that are asked if they aren't specifically addressed to a swift dev. the other stuff (generally nova stuff) tends to drown it out
21:49:53 <antonym> ttx: sure, i can make a mailin list topic if that's cool
21:50:21 <ttx> antonym: yes, with a basic proposal, should spawn a bit of discussion
21:50:28 <antonym> sounds good
21:50:45 <ttx> #action antonym to raise a thread about IRC separation on the ML
21:51:11 <ttx> OK, any other topic ?
21:52:23 <ttx> I guess not.
21:52:33 <ttx> #endmeeting