21:01:56 <ttx> #startmeeting
21:01:57 <openstack> Meeting started Tue May 10 21:01:56 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:14 <ttx> Welcome everyone to our weekly OpenStack team meeting...
21:02:21 <ttx> Agenda:
21:02:33 <ttx> #link http://wiki.openstack.org/Meetings
21:03:01 <ttx> #topic Actions from previous meeting
21:03:07 <ttx> * KnightHacker, zns to get the nobottle branch merged asap
21:03:13 <ttx> any news on that front ?
21:04:02 <jaypipes> ttx: I'm subscribed to the GitHub repo and there's been no progress on nobottle.
21:04:17 <ttx> hmm. I guess we should carry on then
21:04:27 <jaypipes> ttx: we had a 2 hour sprint planning with the Keystone team last wednesday and they are still assigning roles, responsibility etc
21:04:34 <ttx> #action  KnightHacker, zns to get the nobottle branch merged asap
21:04:49 <ttx> * antonym to raise a thread about IRC separation on the ML
21:05:01 <ttx> I've seen that raised, did we reach a conclusion on that thread yet ?
21:05:26 <eday> yeah, there was a decision email at the end, I think
21:05:48 <pvo> the thread was to keep them the same for now?
21:05:48 <eday> adding -dev
21:05:51 <ttx> between vacation and UDS I'll admit not having followed every thread lately
21:06:09 <soren> *cough* slacker *cough*
21:06:21 * soren is no better, though. :)
21:06:24 <ttx> soren: so you finally finished that beer, I see
21:06:39 <kpepple> i thought we agreed to add -dev also
21:06:46 <soren> ttx: I have no idea what you're talking about.
21:06:48 <eday> kpepple: yup
21:06:49 <soren> :p
21:06:52 <ttx> ok, anyone disagreeing on that ?
21:07:05 <ttx> I don't really care either way.
21:07:11 <eday> should probably join it :)
21:07:19 <soren> The idea of making the split a per-topic one was dropped?
21:07:28 <jaypipes> I believe so.
21:07:31 <soren> ok
21:07:32 <eday> soren: correct
21:07:50 <ttx> #action antonym to make agreed channel split happen
21:08:09 <ttx> #topic General release status
21:08:10 <eday> channel is there, everyone join and lets close the action item :)
21:08:30 <ttx> eday: he needs to post an email to officialize it on the ML
21:08:31 <pvo> seconded
21:08:38 <antonym> ttx: will do, it's pretty much done
21:09:12 <ttx> Under the new release management rules, we are in open development stage, so the coordinated release requirements at this point are quite basic
21:09:27 <ttx> Once the Diablo plans are mostly finalized, I'll switch to tracking mode
21:09:52 <ttx> The idea being to track what features land and give the PTLs an idea of how well their plan is actually executed
21:10:11 <ttx> Starting next week I'll also have a deeper look into how I could adapt the release status page to the new world order
21:10:27 <ttx> Questions before we switch to per-project status ?
21:11:10 <ttx> ok then
21:11:12 <ttx> #topic Nova status
21:11:25 <ttx> The Diablo plan is at: https://blueprints.launchpad.net/nova/diablo
21:11:34 <vishy> I've been going through the blueprints and prioritizing and targetting
21:11:37 <ttx> vishy: I'd say it's still being worked on ?
21:11:52 <vishy> I think I've got all of the major ones targetted
21:12:11 <ttx> I admit that I haven't had a chance to look into it that much...
21:12:22 <vishy> i need to find some people to assign a couple of the essential ones to
21:12:46 <ttx> yes, I'd prefer if all the >Low actually have assignees
21:12:48 <vishy> but it is going well (slower than i expected, there were/are a whole bunch of obsolete/hanging bps
21:13:27 <ttx> vishy: targeting to diablo should give you a good list at https://blueprints.launchpad.net/nova/diablo
21:13:40 <ttx> without needing to deprecate all the old stuff
21:13:48 <ttx> though cleaning up cannot hurt :)
21:14:12 <ttx> The first milestone, diablo-1, is scheduled for June 2
21:14:27 <ttx> That means cutting the milestone release branch in 3 weeks.
21:14:42 <ttx> Looking at https://launchpad.net/nova/+milestone/diablo-1 we have 19 blueprints targeted...
21:15:07 <ttx> ...which sounds a bit optimistic to me, but we'll see :)
21:15:12 <dabo> The distributed scheduler merge prop should be landing in about 2 weeks. It will be a fairly large and disruptive change, so will that interfere with diablo-1?
21:15:31 <vishy> ttx: yes I may be moving a few of those
21:15:46 <ttx> dabo: I don't think so, it's good if it actually lands in an early milestone...
21:15:48 <vishy> I'd like to get distributed scheduler and multinic in asap
21:16:03 <johnpur> vishy: agree, do it asap
21:16:04 <ttx> +1
21:16:19 <jaypipes> vishy: FYI, Glance's diablo-2 milestone is where I'm targeting keystone integration, if you want to align on that...
21:16:22 <dabo> cool - I'll keep everyone informed as to its progress
21:16:52 <vishy> jaypipes: cool, I think we're trying to get super ghetto version in in diablo-1, but our complete integration won't be until diablo-4
21:17:07 <vishy> we're going to go through a few iterations...
21:17:17 <jaypipes> vishy: yup, cool.
21:17:22 <ttx> vishy: anything else you wanted to mention ?
21:17:51 <westmaas> what should we do if we think things will move from milestone 1 to 2?
21:18:08 <westmaas> announce in these meetings, update the bp? both?
21:18:17 <jaypipes> westmaas: both.
21:18:28 <jaypipes> westmaas: and if it involves other teams, post something to the ML.
21:18:32 <westmaas> alrighty
21:18:36 <johnpur> notmyname: is swift aligning around keystone integration at the end of june?
21:19:01 <notmyname> if you would like us to :-)
21:19:03 <vishy> ttx: nope
21:19:03 <ttx> johnpur: maybe we can talk about that when we switch topic to swift
21:19:08 <jaypipes> westmaas: at least, that's what I'll be doing ;)
21:19:19 <johnpur> ttx: ok
21:19:25 <ttx> Other questions for the Nova PTL ?
21:19:29 <westmaas> jaypipes: just looking for someone to copy :)
21:19:33 <jaypipes> :)
21:19:52 <jaypipes> ttx: I do, actually
21:20:07 <ttx> fire.
21:20:37 <jaypipes> ttx, vishy: so, although I didn't get through a whole lot of reviews in my review day yesterday, I did notice a HUGE number of pending merge requests... perhaps we can send an email to the ML targeting a number of the high priority ones to review?
21:20:51 <vishy> jaypipes: good idea
21:21:02 <jaypipes> vishy: something like ttx's freeze emails.
21:21:43 <jaypipes> vishy: in particular, I note that the NTT volume branch blueprints are in needs code review status...
21:22:13 <jaypipes> vishy: ec2 volume stuff...
21:22:28 <_0x44> Are all of those merge requests still expecting to be merged? When I did my review day I saw quite a few that seemed abandoned pre-summit waiting for summit decisions but were never updated.
21:22:36 <ttx> yes and due to TZ differences the comment.fix iterations take a bit longer with japanese branch merge proposals
21:22:44 <vishy> ok I'll take a look at the merge list and fire out an email with important ones?
21:23:10 <vishy> and request that people update their branches or put them to wip if they aren't ready
21:23:12 <ttx> _0x44: the abandoned ones should no longer be in "needs review" status
21:23:13 <jaypipes> _0x44: it's a shared responsibility of the reviewer and PTL to follow up with folks about stagnating merge proposals...and get stuff into Work in Progress if it is being updated.
21:23:49 <pvo> vishy: that would help. Quite a few branches are a couple of weeks old
21:24:02 <jaypipes> vishy: yep, that sounds good. lemme know if you want assistance at all.
21:24:32 <ttx> ideally the branch review listing page would match the priorities
21:24:49 <ttx> haven't updated it though
21:24:58 <comstud> i made a merge prop today for a bugfix that's kinda important to get in for xenserver
21:25:04 <comstud> not sure the bug was prioritized, however
21:25:22 <ttx> will have a fresh look at it next week so that it's useful again
21:25:40 <jaypipes> I'd like to see https://bugs.launchpad.net/nova/+bug/771512 prioritized to Critical...
21:25:41 <uvirtbot> Launchpad bug 771512 in nova "Timeout from API with 50 Simultaneous Builds" [High,Triaged]
21:25:51 <antonym> jaypipes: +1
21:26:02 <jaypipes> anyone know the folks at Linden and might be able to raise a fire?
21:26:23 <ttx> jaypipes: any reason why you can't do that yourself ?
21:26:25 <comstud> jay: that's going in progress after this meeting
21:26:29 <ttx> (raising to critical)
21:26:31 <comstud> (771512)
21:26:32 <jaypipes> the reason I'd like to set it to Critical is because once mtaylor gets going with CI, that bug will cause major havoc.
21:26:41 <pvo> jaypipes: its causing havoc for our testing now.
21:26:49 <jaypipes> pvo: well, yes, I know :)
21:26:50 <comstud> it's next on my list
21:26:53 <antonym> yep :)
21:26:56 <pvo> ;p
21:26:58 <mtaylor> that's fine - cause all the havoc you want :)
21:26:59 * comstud steals it right now
21:27:00 <jaypipes> ok, super :)
21:27:09 <ttx> mtaylor: o/
21:27:31 <ttx> ok, can we switch to glance status now ?
21:27:38 <jaypipes> I'm ready.
21:28:07 <ttx> #topic Glance status
21:28:14 <ttx> The Glance Diablo plans are at: https://blueprints.launchpad.net/glance/diablo
21:28:25 <jaypipes> Here's the milestone we are focused on: https://launchpad.net/glance/+milestone/diablo-1
21:28:43 <jaypipes> For the next 3 weeks, we are focusing on API improvements that will make glenc happy :)
21:28:48 <ttx> sounds god to me
21:28:51 <ttx> good even
21:28:56 <glenc> :D happy glenc is happy
21:29:05 <ttx> jaypipes: other announcements, comments ?
21:29:14 <jaypipes> I've already talked with soren about coordination for packaging, but vishy, we need to discuss affects on nova integration
21:29:43 <jaypipes> vishy: mostly around the upgrade path for existing nova/glance installations. We can take it offline later on.
21:29:49 <vishy> ok
21:30:01 <ttx> Any question for Jay ?
21:30:24 <jaypipes> vishy: and if you have a chance, pls take a look at https://code.launchpad.net/~jaypipes/glance/api-version/+merge/60130
21:31:11 <jaypipes> ttx: good to move on I think.
21:31:14 <ttx> #topic Swift status
21:31:28 <ttx> notmyname: did you have time to sort out your versioning scheme and milestone plan ?
21:31:35 <johnpur> jaypipes: you are scheduled out only to diablo-2?
21:31:58 <notmyname> not yet, but there won't be much change from our current 1.X.Y
21:32:23 <ttx> ok, was wondering:
21:32:29 <ttx> We currently have a 1.4 "series", with no blueprints attached.
21:32:45 <ttx> We could have a "diablo" series instead, with milestones that happen to have whatever version number you want...
21:32:56 <jaypipes> johnpur: stuff to be discussed with usharesoft going into d3 and beyond... more to come.
21:32:57 <johnpur> ttx: we talked about syncing version nomenclature?
21:33:01 <ttx> though that doesn't make a lot of sense branch-wise, I guess
21:33:15 <notmyname> the blueprints https://blueprints.launchpad.net/swift are what we have
21:33:30 <notmyname> but no, they aren't targeted to a diablo release
21:33:38 <ttx> johnpur: not yet... so far Swift wanted their own versioning
21:33:45 <johnpur> jaypipes: cool. was wondering about the image conversion stuff that isn't showing up.
21:33:48 <ttx> notmyname: right, I'm trying to get a "diablo" picture
21:34:00 <ttx> and "1.4" might just not be synonymous
21:34:19 <ttx> since you might decide other values for "X" above... IIUC
21:34:30 <notmyname> we've been doing some internal planning here, but there isn't anything for "diablo" yet
21:34:41 <notmyname> and agreed about 1.4 not necessarily == 1.4
21:34:54 <ttx> notmyname: ok, I guess we'll wait a bit more then :)
21:35:00 <johnpur> notmyname, ttx: can we talk about getting a common version scheme? maybe outside of this meeting... it is a pain to do queries against non-normalized version strings.
21:35:34 <ttx> johnpur: we need to have a way to query what falls into the "diablo" timeframe and will become part of openstack 2011.3
21:35:44 <johnpur> notmyname: what is your plan to support keystone?
21:35:57 <johnpur> ttx: yes!
21:36:14 <ttx> johnpur: that might not imply forcing Swift to adopt the same version numbers for milestones
21:36:32 <notmyname> johnpur: yes, all that's needed to do is some wsgi middleware
21:36:35 <ttx> johnpur: agreed that we can discuss that offline
21:36:52 <jaypipes> notmyname: I think johnpur was asking about a general timeframe :)
21:37:06 <johnpur> jaypipes: :)
21:37:33 <jaypipes> notmyname: nova is trying for end of this month, glance is trying for end of july to integrate with keystone, as an FYI.
21:37:51 <notmyname> we don't know what needs to be done yet. we can be done when we see what keystone requires
21:37:57 <jaypipes> notmyname: sorry, I meant end of june, not july...
21:39:01 <jaypipes> notmyname: ok, however I think some things will come down to what *you* require from keystone, which is why communication with the keystone folks will be important. just a though, not trying to harrass you :)
21:39:24 <notmyname> gholt and ziad have been talking about it
21:39:30 <ttx> notmyname: any other announcements or comments ?
21:39:30 <jaypipes> ok, coolio.
21:39:39 <notmyname> ttx: nope
21:39:41 <ttx> Questions for the Swift team ?
21:40:16 <ttx> ok then...
21:40:20 <ttx> #topic Open discussion
21:40:41 <ttx> In case you missed the press, news from UDS here is that Ubuntu Server is switching their default solution for Ubuntu Cloud Infrastructure from Eucalyptus to OpenStack.
21:40:50 <pvo> nice
21:40:52 <notmyname> yay
21:40:58 <spectorclan_> congrats!
21:41:02 <glenc> sweet
21:41:04 <vishy> \o/
21:41:16 <ttx> Not really a surpise, but still, good news
21:41:27 <jaypipes> hmm, I guess we should fix that 50 concurrent clients bug then ;P
21:41:36 <pvo> ha. nah.
21:41:40 <jaypipes> :)
21:42:01 <soren> jaypipes: I'm quite close on that, by the way.
21:42:14 <jaypipes> soren: pls communicate with comstud :)
21:42:37 <soren> jaypipes: Oh, he's working on it, too?
21:42:58 <jaypipes> soren: yep
21:42:58 <soren> I mean *I'm* commenting on the bug and stuff.  :)
21:44:17 <soren> comstud: Well if you've got it, fine. I'll just stop playing around.
21:44:31 <antonym> soren: yeah, saw the of the updates on the bug report
21:44:39 <vishy> first person to patch eventlet wins
21:44:41 <comstud> yeah, i just read all of the notes
21:44:45 <vishy> gogogogo
21:44:46 <comstud> I didn't realize it had been triaged so much
21:44:58 <comstud> I don't care who does it as long it gets addressed RSN
21:45:02 <comstud> i can take a look at patching eventlet
21:45:08 <soren> I have a pathc that fixes it for us, but not generally, so I'm not really happy with it.
21:45:20 <comstud> ahh
21:45:20 * vishy wants to see that patch
21:45:22 <comstud> yeah
21:45:23 <comstud> me too
21:45:24 <antonym> me too
21:45:25 <johnpur> redbo is an eventlet expert too
21:45:35 <antonym> i can give it a whirl in our environment
21:45:39 <jaypipes> vishy, notmyname: we still on to discuss commonalities in a few minutes on this channel?
21:45:43 <soren> It fixes it in the case whee we never really block for the full socket connect timeout at time, but that's not good enough for upstreaming.
21:45:46 <ttx> something else someone wants to mention before we close the meeting ?
21:45:52 <vishy> jaypipes: yes
21:45:53 <ttx> the PTLs need the room :)
21:46:03 <antonym> i mainly just want to get past 50 builds so i can get some other bugs to come crawling out :D
21:46:14 <jaypipes> ttx: others are welcome to linger as far as I'm concerned.
21:46:31 <ttx> oh right, just need to formally pass the bucket
21:47:32 <ttx> so let's just do it... now
21:47:38 <ttx> #endmeeting