21:02:40 <ttx> #startmeeting
21:02:41 <openstack> Meeting started Tue May 17 21:02:40 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:58 <ttx> Welcome everyone to our traditional weekly OpenStack meeting...
21:03:04 <ttx> Today's agenda:
21:03:08 <ttx> #link http://wiki.openstack.org/Meetings
21:03:18 <ttx> #topic Actions from previous meeting
21:03:30 <ttx> * KnightHacker, zns to get the nobottle branch merged asap
21:03:37 <ttx> (whatever that is) -- any news ?
21:04:26 <westmaas> don't think they are here, but looking at keystone there was an update that removed nobottle
21:04:44 <westmaas> (hardly official though)
21:04:57 <westmaas> er, that removed bottle, haha
21:05:11 <ttx> dunno if that unblocks whoever was blocked by this (jaypipes iirc)
21:05:32 <ttx> #action jaypipes to confirm the nobottle unblocking
21:05:41 <ttx> * antonym to make agreed channel split happen
21:05:48 <ttx> I think we can consider that one DONE, too
21:06:01 <ttx> is the split working well for everyone ?
21:06:23 <westmaas> I know vishy was asking about logging for this channel, not sure if that happened?
21:06:31 <notmyname> we may need to get some other bots moved
21:06:39 <vishy> (i was asking for dev, but yes)
21:06:45 <notmyname> uvirtbot?
21:06:58 <notmyname> cool. just happened
21:07:17 <vishy> westmass: http://eavesdrop.openstack.org/irclogs/
21:07:19 <soren> Just joined it to the channel and tested it.
21:07:27 <vishy> er westmaas: ^^
21:07:32 <ttx> looks like we are all set.
21:07:35 <primeministerp1> hi all
21:07:46 <ttx> #topic General release status
21:07:58 <ttx> I'm free from conferences now, so I can focus on the Diablo plans
21:08:10 <ttx> I refreshed http://wiki.openstack.org/releasestatus/ for Diablo
21:08:21 <ttx> But that still need to be rethought so that it's more milestone-oriented
21:08:46 <primeministerp1> hey all was wondering what the current direction of openstack on hyperv is?   Is there anyone or any group currently contributing?
21:08:46 <ttx> Also the http://wiki.openstack.org/reviewslist/ now takes the diablo plan into consideration
21:09:03 <ttx> primeministerp1: please wait for open discussion to raise random topics
21:09:11 <primeministerp1> whoops sorry
21:09:30 <ttx> #topic Nova status
21:09:45 <ttx> The Diablo plan is pretty well defined now at https://blueprints.launchpad.net/nova/diablo
21:09:59 <ttx> I have a few issues with it, just talked to vishy and we'll resolve them soon.
21:10:20 <ttx> There was also IMO too much work targeted at diablo-1 (which closes in two weeks), but I see now that a few specs were deferred
21:10:56 <ttx> so if you have specs targeted to diablo-1 in https://launchpad.net/nova/+milestone/diablo-1 that you know won't make it, please let him/me now
21:11:14 <ttx> Quick diablo-1/essential status update:
21:11:23 <ttx> westmaas (or someone else at Titan): progress on https://blueprints.launchpad.net/nova/+spec/integrate-nova-authn ?
21:12:18 <ttx> tr3buchet: https://blueprints.launchpad.net/nova/+spec/nova-multi-nic is marked on track, any comment ?
21:12:46 <westmaas> ttx: first step is pretty simple but no new code on it yet
21:12:56 <tr3buchet> ttx: on track!
21:13:06 <westmaas> ttx: but planning done and ready to go
21:13:17 <ttx> westmaas: ok :)
21:13:21 <ttx> tr3buchet: thanks !
21:13:43 <ttx> others: please check https://launchpad.net/nova/+milestone/diablo-1 and update status if needed
21:13:54 <ttx> vishy: anything you wanted to mention ?
21:14:15 <vishy> ttx: just request for the blueprints that don't have anyone assigned
21:14:21 <ttx> oh right
21:14:26 <vishy> ttx: but I think it would be best on the ml as well
21:14:50 <ttx> We have 3 essential blueprints without an assignee yet
21:15:14 <ttx> #action ttx to crosspost assignee search to ML
21:15:14 <vishy> (and 4 Highs)
21:15:22 <ttx> https://blueprints.launchpad.net/nova/+spec/admin-account-actions
21:15:27 <ttx> https://blueprints.launchpad.net/nova/+spec/ec2-id-compatibilty
21:15:53 <ttx> and https://blueprints.launchpad.net/nova/+spec/implement-volume-api (though vishy is trying to see if Justin would take it)
21:16:20 <ttx> does any group/individual claim any of those ?
21:17:03 <glenc> the admin account actions is targeted for diablo-4
21:17:58 <ttx> indeed, but having in the plan a feature that is essential means "we will delay diablo release to get that one in", so it should have an assignee that is committed to delivering it
21:18:13 <ttx> or it shouldn't be essential.
21:18:36 <westmaas> I suspect titan will do it, but titan or ozone will make sure it gets in.
21:18:46 <glenc> I concur
21:18:46 <westmaas> pvo: agree?
21:19:06 <troytoman> one of the rackspace teams will make sure we get this done
21:19:07 <ttx> westmaas: we could tentatively assign Totan, and feel free to reassign to Ozone :)
21:19:22 <westmaas> ttx: sounds good
21:19:35 <ttx> ok, will do
21:19:46 <ttx> Questions for the Nova PTL ?
21:20:21 <primeministerp1> open questions?
21:20:39 <ttx> primeministerp1: potentially :)
21:20:45 <primeministerp1> hehe, I'll shoot then
21:20:53 <Vek> primeministerp1: http://wiki.openstack.org/Meetings <-- meeting agenda, btw; we're in the "nova" part
21:21:07 <primeministerp1> great I have questions on nova on hyperv
21:21:15 <primeministerp1> we currently work in the novl/mfst interop lab
21:21:36 <primeministerp1> we have an immediate need to use openstack on hyperv and can probably substancial resources to qa
21:21:46 <primeministerp1> once we finish getting it up and running
21:22:00 <primeministerp1> is there anyone using openstack on hyperv in the real world?
21:22:48 <ttx> primeministerp1: those who contributed the code used to test it, but we coudl definitely use something more connected to the current code
21:22:50 <primeministerp1> is there anyone currently contributing ?
21:22:57 <primeministerp1> that being said
21:23:08 <primeministerp1> we would love to get hooked into the nightly build process for us to test
21:23:19 <ttx> mtaylor: ^
21:23:19 <primeministerp1> and help progress the hyperv code
21:23:21 <soren> mtaylor: Å
21:23:24 <soren> Whoops :)
21:23:27 <vishy> primeministerp1: yes we could really use someone taking over maintenence of hyperv
21:23:46 <vishy> because no one is really testing/using it in production afaik
21:23:56 <ttx> primeministerp1: and a nice test rig hooked up into our Jenkins QA
21:24:15 <soren> Heck, it doesn't even have to be nice!
21:24:29 <ttx> primeministerp1: you need to connect with mtaylor
21:24:50 <primeministerp1> we would love to take over maint but right now we don't have the dev resources
21:25:04 <primeministerp1> we can contribute machines running hyperv
21:25:09 <primeministerp1> and potentially about 100 of them
21:25:20 <primeministerp1> w/ san etc
21:25:24 <ttx> primeministerp1: knowing how it's broken would already help :)
21:25:42 <primeministerp1> well we almost have all the bits up and running now
21:25:54 <ttx> primeministerp1: we'll take that off-meeting, but your offer is definitely appreciated
21:26:08 <johnpur> ttx: i gave him my contact info
21:26:09 <primeministerp1> is it possible to have someone contact me directly?
21:26:12 <primeministerp1> great
21:26:27 <ttx> #topic Glance status
21:26:30 <notmyname> If there are no objections, can we do swift status next? I need to leave the meeting a little early
21:26:33 <soren> wait!
21:26:34 <ttx> oops
21:26:40 <notmyname> :-)
21:26:45 <soren> One more thing for nova. Should be quick, i think:
21:26:48 <ttx> ok, ok
21:27:00 <soren> While setting up the Jenkins magic for python-novaclient, I noticed that Jacobian has renamed his python-cloudservers (on which python-novaclient is based) to python-openstack.compute. What is the current story here? Is there any reason for divergence at this point?
21:27:29 <soren> jk0: ^ perhaps?
21:27:36 <ttx> soren: yep, noticed that as well, looking into it is in slot 45 of my ever-expanding todo list.
21:28:12 <soren> We need to deal with it *somehow*.
21:28:20 <ttx> soren: maybe push that to the ML for discussion
21:28:35 <soren> It's not entirely unlikely that the "nova" python namespace would be renamed "openstack.compute", and then we're screwed.
21:29:11 <jk0> soren: I'm not entirely up to speed on that
21:29:18 <soren> Ok.
21:29:32 <jk0> I'd say ML + getting Jacobian involved
21:29:36 <jk0> he's been very hard to get in touch with
21:29:46 <ttx> soren: ok, raise a thread, then people can research the problem and reply accordingly.
21:29:48 <sandywalsh> my understanding is he just added the url parameter for connecting to openstack. Our branch has lots of new OS API features in it
21:29:49 <soren> There seems to be little point in divergence. Keeping it close means it's guaranteed to be up-to-date. Keeping it external keeps us honest.
21:30:15 <soren> Ok.
21:30:17 <sandywalsh> that said, the more we mess with the client library it's becoming evident we should investigate a new one ... that one is pretty chatty
21:30:35 <sandywalsh> perhaps Titan has some ideas?
21:31:10 <ttx> sandywalsh, soren: sounds like a good ML thread. Can I switch to Glance^WSwift ?
21:31:16 <sandywalsh> yes
21:31:20 <soren> ttx: No objections from me.
21:31:47 <ttx> #action soren to raise a thread on the python-openstack.compute jacobian situation
21:31:55 <ttx> #topic Swift status
21:32:05 <ttx> The Swift plan is at https://blueprints.launchpad.net/swift/diablo
21:32:15 <ttx> The first milestone will be 1.4.0, on May 31
21:32:39 <ttx> with up-to-date plan @ https://launchpad.net/swift/+milestone/1.4.0
21:32:51 <ttx> notmyname: any other announcements or comments ?
21:33:04 <ttx> (plan looks good and on track, fwiw)
21:33:17 <notmyname> I think that's mostly it. 1.4.1 will be the next milestone, but the date is currently undefined
21:33:35 <ttx> Questions for the Swift team ?
21:33:39 <soren> Just one.
21:34:38 <soren> Just to make sure... 1.4.1's date not being defined suggests you're not doing time based releases :)  Do you have plans to do something differently for the final release of  2011.3?
21:35:09 <notmyname> is that the diablo release?
21:35:10 <ttx> 2011.3 will contain whatever the last milestone will be...
21:35:11 <soren> Or is that just going to be "whatever the most recent swift release happens to be"?
21:35:17 <notmyname> yes
21:35:24 <soren> Ok.
21:35:41 <soren> That's all.
21:35:44 <notmyname> actually, it will probably be 1.5.0 for ease of use
21:35:45 <ttx> though I'd welcome a more pre-defined plan that clearly shows it's time-based :)
21:35:57 <johnpur> ttx: agree
21:36:17 <creiht> ttx: release will only be when it is done done ;)
21:36:18 <ttx> johnpur: discussions ongoing, we'll (ab)use the PPB meeting for that
21:36:19 <soren> notmyname: That seems a bit silly to me.
21:36:41 <ttx> soren: the 1.5.0 name ?
21:36:49 <soren> notmyname: Yes.
21:36:57 <soren> notmyname: If you're actually bumping the version for the openstack release, why can't just just adopt the openstack versioning?
21:37:08 <alekibango> creiht: +1 :)
21:37:35 <creiht> soren: because the openstack version is a bit silly to me :)
21:37:48 <creiht> but I'm not on the swift team, so I don't speak officially for them :)
21:38:07 <soren> Then why don't we have the discussion instead of people inventing their own random policies?
21:38:10 <notmyname> soren: there is no final decision on what the diablo swift version number is
21:39:26 <notmyname> we are fine with either the last version number before the diablo date or bumping the minor version number
21:39:31 <soren> If you were doing 1.4 soon, 1.5 a month later, and just kept going with 1.X for eternity, that would make more sense. If you're actually following the same pattern as openstack, but just insist on a different number, that's just silly.
21:39:58 <soren> What could possibly be the purpose of that?
21:40:18 <ttx> last version number would work
21:40:18 <creiht> soren: how about we make are arguments and let them stand on their own, rather than being childish and calling things silly?
21:40:32 <soren> Having been involved in the release process a couple of times, there's plenty of stuff to be confusing without having to translate arbitrary version numbers into less arbitrary ones.
21:41:21 <ttx> soren: I plan to just use the last milestone. No buming
21:41:25 <ttx> bumping
21:41:37 <notmyname> sounds good to us
21:41:40 <soren> ttx: Are you the one who'd do the bumping?
21:41:53 <soren> I thought that was outside your realm of power :)
21:42:17 <ttx> soren: which bumping ? I just take the last released milestone and include it in the announcement
21:42:53 <soren> ttx: You said "no bumping". Which bumping were *you* referring to?
21:43:16 <notmyname> I think we're in agreement. no need to keep going with this
21:43:30 <soren> I was just about to say :)
21:43:49 <ttx> soren: I was referring to taking the last milestone and rename it to 1.5.0
21:43:53 <ttx> this is not needed
21:43:55 <notmyname> next version of swift is 1.4.0. next version of swift in diablo is the version of the last stable release before diablo
21:43:58 <notmyname> done
21:44:16 <alekibango> +1 notmyname
21:44:17 <ttx> though I still need to wrap my head around what we do if a critical bug kis found in that last milestone
21:44:29 <ttx> but that's the discussion for anither day
21:44:35 <ttx> another, even.
21:45:09 <ttx> ok to switch to Glance ?
21:45:58 <notmyname> I don't have anything else
21:45:59 <soren> go for it.
21:46:03 <ttx> #topic Glance status
21:46:17 <ttx> no jaypipes, is anyone representing Glance ?
21:46:30 <ttx> Current plan at https://blueprints.launchpad.net/glance/diablo looks good to me
21:46:42 <bcwaldon> I can probably answer questions
21:46:46 <ttx> First milestone is diablo-1 (Jun 2), 3 specs all at Review stage, also looks good
21:46:51 <alekibango> glance needs auth asap :)
21:46:58 <ttx> bcwaldon: announcements, comments ?
21:47:30 <bcwaldon> I don't have anything, everything is going great for diablo-1
21:47:38 <ttx> alekibango: auth is planned for diablo-2
21:47:46 <bcwaldon> yes, was just about to look that up
21:50:13 <ttx> Any other Glance question ?
21:50:41 <ttx> if not...
21:50:45 <ttx> #topic Open discussion
21:50:53 <ttx> anything/anyone ?
21:51:23 <johan___> is jenkins broken?
21:51:31 <alekibango> ttx: thanks -- it should be sooner :/
21:51:50 <dendrobates> I have something
21:52:13 <dendrobates> someone on the networking project raised the possibility of webex calls
21:52:27 <dendrobates> they would be open to all and recorded
21:52:35 <soren> I'm not entirely sure I know what a webex call is.
21:52:49 <dendrobates> how does everyone feel about that with regards to openness?
21:52:58 <dendrobates> conference call
21:53:15 <soren> Regular conference call with POTS dial in?
21:53:19 <ttx> dendrobates: you mean use webex calls as part of our toolkit ? or replace IRC meetings with webex calls ?
21:53:43 <dendrobates> basically if the network project used them
21:53:44 <alekibango> dendrobates: i think we could just use mumble... it is free software... unlike nonfree service
21:53:54 <glenc> webex also has shared  desktop and whiteboard features
21:54:01 <glenc> just FYI
21:54:10 <Tv> I'd like to talk about Melange (networking IP address etc discovery)
21:54:15 <ttx> webex is good when you have slides to share :)
21:54:19 <alekibango> ic
21:54:25 <alekibango> mumble is only voip
21:54:28 <alekibango> but very good
21:54:32 <ttx> though last time I used it it's a while ago, and it was windows-centric
21:54:43 <dendrobates> it's about the format more than the tool
21:55:01 <dendrobates> you can't easily search a recording
21:55:19 <soren> I think it's a step down compared to IRC.
21:55:21 <glenc> eh, there's a mac client
21:55:26 <alekibango> dendrobates: open to all means no registration required?
21:55:30 <salv-orlando> I like the desktop sharing idea, but I'll miss browsing the chat logs using CTRL+F
21:55:31 <soren> For exactly the searchability reasons.
21:55:37 <soren> ...but it's good enough, I think.
21:55:40 <glenc> You can set up meetings with no security - open to anyone
21:55:43 <dendrobates> alekibango: yes, just a phone number you can call
21:56:06 <alekibango> dendrobates: i like using my headset... :)
21:56:13 <alekibango> with software
21:56:17 <alekibango> phones are evil a lot
21:56:22 <jk0> can you mute everyone but the chair? I have a feeling we'd here a lot of breathing into the mics
21:56:30 <alekibango> jk0: i can in mumble
21:56:37 <ttx> dendrobates: I think it shouldn't replace IRC meetings. It could be used as an exceptional complement when higher bandwidth is needed
21:56:44 <alekibango> and it can take thousands people, rooms like irc
21:56:57 <dendrobates> ttx: thanks
21:56:57 <ttx> jk0: you can mute everyone but the speaker, yes
21:56:59 <Tv> Melange stuff, https://blueprints.launchpad.net/nova/+spec/melange-address-discovery   -- I'm looking for the right people to talk to about plugging into Nova to do a DHCP etc service that talks to the IPAM service for it's answers.
21:57:16 <alekibango> jk0: its possible to split people into active and pasive participants....
21:57:26 <jk0> fair enough :)
21:57:28 <alekibango> and move them all the time
21:57:29 <Tv> Code is easy, figuring out how to fit into Openstack architecture in a way that will be acceptable is harder..
21:57:34 <jk0> I think we've all been on those calls where people forget to mute themselves
21:57:43 <alekibango> jk0: if you will install the client, you can talk to me on my mumble server :)
21:58:12 <jk0> I'll have to check i tout
21:58:39 <ttx> Tv: looks like a duplicate for https://blueprints.launchpad.net/nova/+spec/implement-network-api
21:58:43 <ttx> vishy: ^
21:59:10 <ttx> Tv: or is one quantum-related and the other melange-related ?
21:59:22 <salv-orlando> We need to make sure that if we use a tool different from IRC, it will scale as well as IRC. I.e.: allows audio-video streaming for a number of people like the ones in this room
21:59:34 <danwent> we need to rework some of the nova blueprints now that we have a better idea of what quantum & melange need
21:59:36 <Tv> ttx: What I'm doing is supposed to be Melange-related, independent of Quantum
21:59:49 <Tv> ttx: but i'm still new enough to openstack internals that i may be confused ;)
21:59:55 <vishy> ttx: there has been discussion about keeping melange inside of nova for now
21:59:56 <danwent> ttx: that blueprint is probably more quantum related.
22:00:00 <troytoman> tv: it's related to the overall refactoring of networking
22:00:13 <ttx> vishy: oh, I see.
22:00:22 <Tv> yeah i want to work on the "just this one little thing" version, not the "rewrite everything" version ;)
22:00:33 <vishy> so the mlange plueprints are still in nova as well...
22:00:43 <ttx> We should close the meeting now, feel free to continue to chat on #openstack-dev
22:00:44 <Tv> basically, replace dnsmasq with something that uses a centralized database of address allocations
22:01:00 <Tv> and i'm looking for the right people to coordinate with, not knowing you bunch yet
22:01:13 <vishy> Tv: maybe troy
22:01:21 <ttx> #endmeeting